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The U.S. Army Corps of Engineers’ River Analysis System (HEC-RAS)
is software that allows you to perform one-dimensional steady and
unsteady flow river hydraulics calculations. The HEC-RAS software
supersedes the HEC-2 river hydraulics package, which was a one-
dimensional, steady flow water surface profiles program. The HEC-
RAS software is a significant advancement over HEC-2 in terms of
both hydraulic engineering and computer science. This software is a
product of the Corps’ Civil Works Hydrologic Engineering Research
and Development Program.

The first version of HEC-RAS (version 1.0) was released in July of
1995. Since that time there have been several releases of this
software package, including versions: 1.1; 1.2; 2.0; 2.1; 2.2; 2.21; and
now version 3.0 in January of 2001.

Version 3.0 of HEC-RAS is a major advancement over the previous
2.21 version. This new version (3.0) includes unsteady flow routing,
as well as split flow optimization for steady flow modeling.

The HEC-RAS software was developed at the Hydrologic Engineering
Center (HEC), which is a division of the Institute for Water Resources
(IWR), U.S. Army Corps of Engineers. The software was designed by
Mr. Gary W. Brunner, leader of the HEC-RAS development team. The
user interface and graphics were programmed by Mr. Mark R. Jensen.
The steady flow water surface profiles module was programmed by
Mr. Steven S. Piper. The unsteady flow equation solver was
developed by Dr. Robert L. Barkau. The routines that import HEC-2
and UNET data were developed by Ms. Joan Klipsch. The cross
section interpolation routines were developed by Mr. Alfredo Montalvo.
The routines for modeling ice cover and wide river ice jams were
developed by Mr. Steven F. Daly of the Cold Regions Research and
Engineering Laboratory (CRREL).

Many of the HEC staff made contributions in the development of this
software, including: Vern R. Bonner, Richard Hayes, John Peters, and
Michael Gee. Mr. Darryl Davis was the director during the
development of this software.

This manual was written by Mr. Gary W. Brunner.
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CHAPTER 1
Introduction

Welcome to the U.S. Army Corps of Engineers River Analysis System (HEC-
RAS) developed by the Hydrologic Engineering Center. This software allows
you to perform one-dimensional steady flow, unsteady flow calculations.
Sediment transport computations will be added in a future version.

The HEC-RAS modeling system was developed as a part of the Hydrologic
Engineering Center's "Next Generation" (NexGen) of hydrologic engineering
software. The NexGen project encompasses several aspects of hydrologic
engineering, including: rainfall-runoff analysis; river hydraulics; reservoir
system simulation; flood damage analysis; and real-time river forecasting for
reservoir operations.

This chapter discusses the general philosophy of HEC-RAS and gives a brief

overview of the capabilities of the modeling system. Documentation for
HEC-RAS is discussed, as well as an overview of this manual.

. Contents
»  General Philosophy of the Modeling System
» Qverview of Program Capabilities

= HEC-RAS Documentation

s Qverview of This Manual
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General Philosophy of the Modeling System

HEC-RAS is an integrated system of software, designed for interactive use in

a multi-tasking, multi-user network environment. The system is comprised of
a graphical user interface (GUI), separate hydraulic analysis components, data
storage and management capabilities, graphics and reporting facilities.

The HEC-RAS system will ultimately contain three one-dimensional
hydraulic analysis components for: (1) steady flow water surface profile
computations; (2) unsteady flow simulation; and (3) movable boundary
sediment transport computations. A key element is that all three components
will use a common geometric data representation and common geometric and
hydraulic computation routines. In addition to the three hydraulic analysis
components, the system contains several hydraulic design features that can be
invoked once the basic water surface profiles are computed.

The current version of HEC-RAS supports Steady and Unsteady flow water
surface profile calculations. New features and additional capabilities will be
added in future releases.

Overview of Program Capabilities

1-2

HEC-RAS is designed to perform one-dimensional hydraulic calculations for
a full network of natural and constructed channels. The following is a
description of the major capabilities of HEC-RAS.

User Interface

The user interacts with HEC-RAS through a graphical user interface (GUI).
The main focus in the design of the interface was to make it easy to use the
software, while still maintaining a high level of efficiency for the user. The
interface provides for the following functions:

* File management

* Data entry and editing

* Hydraulic analyses

» Tabulation and graphical displays of input and output data

* Reporting facilities

*  On-line help
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Hydraulic Analysis Components

Steady Flow Water Surface Profiles. This component of the modeling system
is intended for calculating water surface profiles for steady gradually varied
flow. The system can handle a full network of channels, a dendritic system,
or a single river reach. The steady flow component is capable of modeling
subcritical, supercritical, and mixed flow regime water surface profiles.

The basic computational procedure is based on the solution of the one-
dimensional energy equation. Energy losses are evaluated by friction
(Manning's equation) and contraction/expansion (coefficient multiplied by the
change in velocity head). The momentum equation is utilized in situations
where the water surface profile is rapidly varied. These situations include
mixed flow regime calculations (i.e., hydraulic jumps), hydraulics of bridges,
and evaluating profiles at river confluences (stream junctions).

The effects of various obstructions such as bridges, culverts, weirs, and
structures in the flood plain may be considered in the computations. The
steady flow system is designed for application in flood plain management and
flood insurance studies to evaluate floodway encroachments. Also,
capabilities are available for assessing the change in water surface profiles
due to channel improvements, and levees.

Special features of the steady flow component include: multiple plan
analyses; multiple profile computations; multiple bridge and/or culvert
opening analysis; and split flow optimization.

Unsteady Flow Simulation. This component of the HEC-RAS modeling
system is capable of simulating one-dimensional unsteady flow through a full
network of open channels. The unsteady flow equation solver was adapted
from Dr. Robert L. Barkau's UNET model (Barkau, 1992 and HEC, 1997).
This unsteady flow component was developed primarily for subcritical flow
regime calculations.

The hydraulic calculations for cross-sections, bridges, culverts, and other
hydraulic structures that were developed for the steady flow component were
incorporated into the unsteady flow module.

Sediment Transport/Movable Boundary Computations. This component of
the modeling system is intended for the simulation of one-dimensional
sediment transport/movable boundary calculations resulting from scour and
deposition over moderate time periods (typically years, although applications
to single flood events are possible).

The sediment transport potential is computed by grain size fraction, thereby
allowing the simulation of hydraulic sorting and armoring. Major features
will include the ability to model a full network of streams, channel dredging,
various levee and encroachment alternatives, and the use of several different
equations for the computation of sediment transport.
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The model will be designed to simulate long-term trends of scour and
deposition in a stream channel that might result from modifying the frequency
and duration of the water discharge and stage, or modifying the channel
geometry. This system can be used to evaluate deposition in reservoirs,
design channel contractions required to maintain navigation depths, predict
the influence of dredging on the rate of deposition, estimate maximum
possible scour during large flood events, and evaluate sedimentation in fixed
channels.

Data Storage and Management

Data storage is accomplished through the use of "flat" files (ASCII and
binary), as well as the HEC-DSS. User input data are stored in flat files under
separate categories of project, plan, geometry, steady flow, unsteady flow,
and sediment data. Output data is predominantly stored in separate binary
files. Data can be transferred between HEC-RAS and other programs by
utilizing the HEC-DSS.

Data management is accomplished through the user interface. The modeler is
requested to enter a single filename for the project being developed. Once the
project filename is entered, all other files are automatically created and
named by the interface as needed. The interface provides for renaming,
moving, and deletion of files on a project-by-project basis.

Graphics and Reporting

Graphics include X-Y plots of the river system schematic, cross-sections,
profiles, rating curves, hydrographs, and many other hydraulic variables. A
three-dimensional plot of multiple cross-sections is also provided. Tabular
output is available. Users can select from pre-defined tables or develop their
own customized tables. All graphical and tabular output can be displayed on
the screen, sent directly to a printer (or plotter), or passed through the
Windows Clipboard to other software, such as a word-processor or
spreadsheet.

Reporting facilities allow for printed output of input data as well as output
data. Reports can be customized as to the amount and type of information
desired.
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HEC-RAS Documentation

The HEC-RAS package includes several documents. Each document is
designed to help the modeler learn to use a particular aspect of the modeling
system. The documentation has been broken up into the following three

categories:

Documentation

User's Manual

Hydraulic Reference Manual

Applications Guide

Overview of This Manual

Description

This manual is a guide to using HEC-RAS.
The manual provides an introduction and
overview of the modeling system, installation
instructions, how to get started, a simple
example, detailed descriptions of each of the
major modeling components, and how to view
graphical and tabular output.

This manual describes the theory and data
requirements for the hydraulic calculations
performed by HEC-RAS. Equations are
presented along with the assumptions used in
their derivation. Discussions are provided on
how to estimate model parameters, as well as
guidelines on various modeling approaches.

This document contains a series of examples
that demonstrate various aspects of HEC-
RAS. Each example consists of a problem
statement, data requirements, general outline
of solution steps, displays of key input and
output screens, and discussions of important
modeling aspects.

This user's manual is the primary piece of documentation on how to use the
HEC-RAS system. The manual is organized as follows:

= Chapters 1-2 provide an introduction and overview of HEC-RAS, as well
as instructions on how to install the software.

»  Chapters 3-5 describe how to use the HEC-RAS software in a step-by-
step procedure, including a sample problem that the user can follow along
with. Understanding how this system works with projects is also

discussed.

1-5
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Chapters 6-8 explain in detail how to enter and edit data, and how to
perform the different types of analyses that are available.

Chapter 9 provides detailed discussions on how to view graphical and
tabular output, as well as how to develop user-defined tables.

Chapter 10 describes how to perform a floodway encroachment analysis.

Chapter 11 provides discussions on "Trouble Shooting" and
understanding the most common Errors, Warnings, and Notes.

Chapter 12 describes how to perform bridge scour computations from
within HEC-RAS.

Chapter 13 describes how to perform channel modifications within HEC-
RAS.

Chapter 14 explains how to utilize GIS/CADD data in HEC-RAS, as well
as how to export HEC-RAS results back to the GIS/CADD system.

Appendix A contains a list of references.

Appendix B contains a detailed description of the file forméts used for
importing and exporting GIS data to and from HEC-RAS.

Appendix C contains a description of all the output variables available
from the HEC-RAS program.
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CHAPTER 2

Installing HEC-RAS

You install HEC-RAS using the program SETUP.EXE. The Setup program
installs the software, sample applications, and the Help system.

This chapter discusses the hardware and system requirements needed to use
HEC-RAS, how to install the software, and how to uninstall the software.

Contents

» Hardware and Software Requirements
» Installation Procedure

= Uninstall Procedure

. Important

You cannot simply copy files from the distribution CD to your hard disk and
run HEC-RAS. You must use the Setup program, which decompresses and
installs the files to the appropriate directories.

2-1
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Hardware and Software Requirements

Before you install the HEC-RAS software, make sure that your computer has
at least the minimum required hardware and software. In order to get the
maximum performance from the HEC-RAS software, recommended
hardware and software is shown in parentheses. This version of HEC-RAS
will run on a microcomputer that has the following:

» Intel Based PC or compatible machine with Pentium processor or higher
(a Pentium II or higher is recommended).

» A hard disk with at least 20 megabytes of free space (40 megabytes or
more is recommended).

* A CD Rom drive (or CD-R, CD-RW, DVD).

* A minimum of 32 megabytes of RAM if using Windows 95, 98, ME or
48 megabytes if using Windows NT or 2000 (64 or more is
recommended).

= A mouse.

»  Color Video Display (Recommend running in Super VGA (1024x768) or
higher, and as large a monitor as possible).

»  MS Windows 95, 98, ME, NT 4.0, or 2000 (or later versions).

Installation Procedure

2-2

Installation of the HEC-RAS software is accomplished through the use of the
Setup program.

To install the software onto your hard disk do the following:

1. Insert the HEC-RAS CD into your CD drive.
2. The setup program should run automatically.
3. If the setup program does not run, use the windows explorer to start

the setup.exe program on the CD.
4. Follow the setup instructions on the screen.

The setup program automatically creates a program group called HEC. This
program group will be listed under the Programs menu, which is under the
Start menu. The HEC-RAS program icon will be contained within the HEC
program group. The user can create a shortcut icon by opening Windows
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Explorer and dragging the HEC-RAS executable onto the desktop. The
HEC-RAS executable can be found in the \hec\ras directory with the name
"RAS.EXE".

Uninstall Procedure

The HEC-RAS Setup program automatically registers the software with the
Windows operating system. To unistall the software, do the following:

» From the Start Menu select Settings and then Control Panel.
* From within the Control Panel folder select Add/Remove Programs.

» From the Tab marked as Install/Uninstall select the HEC-RAS
program from the list of installed software, then press the
Add/Remove button.

» Follow the uninstall directions on the screen and the software will be
removed from your hard disk. It is up to the user to remove the HEC-
RAS icon from the desktop.

2-3




Chapter 3 Working With HEC-RAS - An Qverview.

CHAPTER 3

Working With HEC-RAS - An Overview

HEC-RAS is an integrated package of hydraulic analysis programs, in which
the user interacts with the system through the use of a Graphical User
Interface (GUI). The system is capable of performing Steady and Unsteady
Flow water surface profile calculations, and will include Sediment Transport
and several hydraulic design computations in the future.

In HEC-RAS terminology, a Project is a set of data files associated with a
particular river system. The modeler can perform any or all of the various
types of analyses, included in the HEC-RAS package, as part of the project.
The data files for a project are categorized as follows: plan data, geometric
data, steady flow data, unsteady flow data, sediment data, and hydraulic
design data.

During the course of a study the modeler may want to formulate several

different Plans. Each plan represents a specific set of geometric data and
. flow data. Once the basic data are entered into the HEC-RAS, the modeler

can easily formulate new plans. After simulations are made for the various

plans, the results can be compared simultaneously in both tabular and
graphical form.

This chapter provides an overview of how a study is performed with the

HEC-RAS software. Special topics on how to import HEC-2 data,
reproducing HEC-2 results, and how to use on-line help are also covered.

Contents

= Starting HEC-RAS

» Steps in Developing a Hydraulic Model With HEC-RAS
s Importing HEC-2 Data

» Reproducing HEC-2 Results

» Getting and Using Help

3-1
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Starting HEC-RAS

When you run the HEC-RAS Setup program, you automatically get a new
program group called HEC and program icon called HEC-RAS. They
should appear in the start menu under the section called Programs. The user
also has the option of creating a shortcut on the desktop. If a shortcut is
created, the icon for HEC-RAS will look like the following:

HEC-RAS 3.0

Figure 3.1 The HEC-RAS Icon in Windows

To Start HEC-RAS from Windows:

=  Double-click on the HEC-RAS Icon. If you do not have an HEC-
RAS shortcut on the desktop, go to the Start menu and select
Programs, then select HEC, and then HEC-RAS.

When you first start HEC-RAS, you will see the main window as shown in
Figure 3.2 (except you will not have any project files listed on your main
window).

8% HEC-RAS - River Analysis System

Figure 3.2 The HEC-RAS Main Window

3-2
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Edit Dptions Help
Geometric Data... Program Setup Contents
Steady Flow Data... Default Parameters Using HEC-RAS Help
I.Insteady Flow Data... | Unit System...

About HEC-RAS S

Hile Run i

New Project... : EW

. e PSJ' Steady Flow Analysis... b s Sone
QOpen Project...  [Insteady Flow Analysis...

! : Water Surface Profiles...
Save Project Sediment Analysis... Canesll Profie Pl
Save Projectas... Hydraulic Design Functions... e
Rename Project... Rating Curves
Delete Project... X-Y-Z Perspective Plots...
Project Summary Stage and Flow Hydrographs
Tmport HEC-2 Data Hydraulic Property Plots
C;Iléport %‘IERC-RQS Deata... Detailed Output Tables
neraie Keport... Profile Table

Export GIS Data. .. Summary Fre. W, Not
Export to HEC-DSS... o v
Restore Data DSS Data
Exit
d:\hec\ras\data\buffalo.prj
d:\hec\ras\data\example.prj
d:\hec\ras\data\onebox.pr]

. . Figure 3.3 HEC-RAS Main Window Menu Bar Structure
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At the top of the HEC-RAS main window is a Menu bar (Figure 3.3) with the
following options:

File: This option is used for file management. Options available under the
File menu include: New Project; Open Project; Save Project; Save Project As;
Rename Project: Delete Project; Project Summary; Import HEC-2 Data;
Import HEC-RAS data; Generate Report; Export GIS Data; Export to HEC-
DSS; Restore Data; and Exit. In addition, the most recently opened projects
will be listed at the bottom of the File menu, which allows the user to quickly
open a project that was recently worked on.

Edit: This option is used for entering and editing data. Data are categorized
into four types: Geometric Data; Steady Flow Data; Unsteady Flow Data;
and Sediment Data. In the current version, Sediment Data is not active.

Run: This option is used to perform the hydraulic calculations. The options
under this menu item include: Steady Flow Analysis; Unsteady Flow
Analysis; Sediment Analysis; and Hydraulic Design Functions. In the current
version, Sediment Analysis is not available.

View: This option contains a set of tools that provide for graphical and
tabular displays of the model output. The View menu item currently
includes: Cross Sections; Water Surface Profiles; General Profile Plot; Rating
Curves; X-Y-Z Perspective Plots; Stage and Flow Hydrographs; Hydraulic
Properties Plots; Detailed Output Tables; Profile Summary Tables; and
Summary Err, Warn, Notes.

Options: This menu item allows the user to change Program Setup options;
set Default Parameters; establish the Default Units System (U.S. Customary
or Metric); and Convert Project Units (U.S. Customary to Metric, or Metric to
U.S. Customary).

Help: This option allows the user to get on-line help, as well as display the
current version information about HEC-RAS.

Also on the HEC-RAS main window is a Button bar (Figure 3.4). The Button
bar provides quick access to the most frequently used options under the HEC-
RAS menu bar. A description of each button is shown in Figure 3.4.



Chapter 3 Working With HEC-RAS - An Qverview.

XYZ Perspective Plot:

Unsteady Flow Data: Unsteady Flow Analysis: : .
Edit and/or enter Perform an unsteady flow View 3D multiple cross
unsteady flow data simulation section plot
Geometric Data: Cross Sections: Hydraulic Properties:
Edit and/or enter View cross Plots and tables of
geometric Data section plots hydraulic properties
Profile Summary Table:

General Profile Plot:
View computed
variables along the
channel

View summary output at

Open Project:
multiple locations by profile

Open an existing
project

View DSS: View

Rating Curve:

’ Sum Errs, Warn, Notes:
View computed ’ ’

Summary of Errors,

Save Project:
Save an existing
project

Steady Flow Data:
Edit and/or enter
steady flow data

rating curves

Profile Plot:
View water surface

profile plots

Hydraulic Design Functions:
Perform hydraulic design
computations

Steady Flow Analysis:
Perform a steady flow

simulation

Warnings, and Notes

Detailed Output Table:
View detailed output at cross-
sections, bridges, culverts, etc...

Stage and Flow Hydrographs:
Plot stage and flow hydrographs

Figure 3.4 HEC-RAS Main Window Button Bar
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Steps in Developing a Hydraulic Model with HEC-RAS

There are five main steps in creating a hydraulic model with HEC-RAS:
» Starting a new project

» Entering geometric data

* Entering flow data and boundary conditions

= Performing the hydraulic calculations

» Viewing and printing results

Starting a New Project

The first step in developing a hydraulic model with HEC-RAS is to establish
which directory you wish to work in and to enter a title for the new project.
To start a new project, go to the File menu on the main HEC-RAS window
and select New Project. This will bring up a New Project window as shown
in Figure 3.5.

New Project

——

e S R A

Dendiitic data set dendiit. prj
Multiple Opening Data Set K1B1C1.PRJ
Twin Circular Pipe Data Set MULTPIPE.PRJ
Single Bridge Data Set NORMALBT.PRJ
Three Reach - With Hydraulic Structures THREE.prj

Figure 3.5 New Project Window

As shown in Figure 3.5, you first select the drive and path that they want to

. r work in (to actually select a path you must double click the directory you

VVLO TeLT. 2 want in the directory box), next enter a project title and file name. The

project filename must have the extension ".prj", the user is not allowed to
change this. Once you have entered all the information, press the "OK"
button to have the information accepted. After the OK button is pressed, a
message box will appear with the title of the project and the directory that the
project is going to be placed in. If this information is correct, press the OK
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button. If the information is not correct, press the Cancel button and you will
be placed back into the New Project window.

Note: Before any Geometric data and Flow data are entered, the user
should select the Units System (English or Metric) that they would like to
work in. This step is accomplished by selecting Unit System from the
Options menu of the main HEC-RAS window.

Entering Geometric Data

The next step is to enter the necessary geometric data, which consist of
connectivity information for the stream system (River System Schematic),
cross-section data, and hydraulic structure data (bridges, culverts, weirs, etc.).
Geometric data are entered by selecting Geometric Data from the Edit menu
on the main HEC-RAS window. Once this option is selected, the geometric
data window will appear as show in Figure 3.6 (except yours will be blank
when you first bring this screen up for a new project).

Geomelric Data - t;a;e geomet

Sutter¥-8.8

[
N\ 1
4 97 ’
.
<N Lower Reach
Rig 98
Ry
\\

,

9.4

P
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The modeler develops the geometric data by first drawing in the river system
schematic. This is accomplished, on a reach-by-reach basis, by pressing the
River Reach button and then drawing in a reach from upstream to
downstream (in the positive flow direction). After the reach is drawn, the
user is prompted to enter a "River" and a "Reach" identifier. The River and
reach identifiers can be up to 16 characters in length. As reaches are
connected together, junctions are automatically formed by the interface. The
modeler is also prompted to enter an identifier for each junction. For more
information on developing the river system schematic, see Chapter 6
"Entering and Editing Geometric Data."

After the river system schematic is drawn, the modeler can start entering
cross-section and hydraulic structure data. Pressing the Cross Section button
causes the cross section editor to pop up. This editor is shown in Figure 3.7.
As shown, each cross section has a River name, Reach name, River Station,
and a Description. The River, Reach and River Station identifiers are used
to describe where the cross section is located in the river system. The "River
Station" identifier does not have to be the actual river station (miles or
kilometers) at which the cross section is located on the stream, but it does
have to be a numeric value (e.g., 1.1, 2, 3.5, etc.). The numeric value is used
to place cross sections in the appropriate order within a reach. Cross
sections are ordered within a reach from the highest river station
upstream to the lowest river station downstream.

Crass io D - base geometry Data

m Hach Lenaths

G

Coefficients

Figure 3.7 Cross Section Data editor
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The basic data required for each cross section are shown on the Cross Section
Data editor in Figure 3.7. Additional cross section features are available
under Options from the menu bar. These options include: adding, copying,
renaming and deleting cross sections; adjusting cross section elevations,
stations, and n or k-values; skew cross section; ineffective flow areas; levees;
blocked obstructions; adding a lid to a cross section; add ice cover; add a
rating curve; horizontal variation of n or k-values; and vertical variation of n
values.

Also, available from the Cross Section Data editor is the ability to plot any
cross section or reach profile. Edit features are available to cut, copy, paste,
insert, and delete data from the Cross Section X-Y Coordinates grid.

Once the cross-section data are entered, the modeler can then add any
hydraulic structures such as bridges, culverts, weirs and spillways. Data
editors, similar to the cross section data editor, are available for the various
types of hydraulic structures. If there are any stream junctions in the river
system, additional data are required for each junction. The Junction data
editor is available from the Geometric Data window.

Once geometric data are entered, the data should be saved to a file on the hard
disk. This is accomplished by selecting the Save Geometric Data As option
from the File menu on the Geometric Data editor. This option allows the user

. to enter a title for the geometric data. A filename is automatically established
for the geometric data, and then saved to the disk. Once a title is established,
geometric data can be saved periodically by selecting Save Geometric Data
from the File menu of the Geometric Data editor.

Entering Flow Data and Boundary Conditions

Once the geometric data are entered, the modeler can then enter either steady
flow or unsteady flow data. The type of flow data entered depends upon the
type of analyses to be performed. For the discussion in this chapter, it is
assumed that a steady flow analysis will be performed. The data entry form
for steady flow data is available under the Edit menu bar option on the HEC-
RAS main window.

An example of the steady flow data entry form is shown in Figure 3.8, which
B mssies is the Steady Flow Data Editor. As shown in Figure 3.8, steady flow data
consist of: the number of profiles to be computed; the flow data; and the river
&s system boundary conditions. At least one flow must be entered for every
Povrepanyeom B TIOMLe o b within the system. Additionally, flow can be changed at any location
within the river system. Flow values must be entered for all profiles.

Boundary conditions are required in order to perform the calculations. Ifa
subcritical flow analysis is going to be performed, then only the downstream
CUPE pa i AL = B boundary conditions are required. If a supercritical flow analysis is going to

. be performed, then only the upstream boundary conditions are required. If

the modeler is going to perform a mixed flow regime calculation, then both
upstream and downstream boundary conditions are required. The Boundary

SoneiTiea — DS
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Conditions data entry form can be brought up by pressing the Enter

Boundary Conditions button from the Steady Flow Data entry form.

Once all of the steady flow data and boundary conditions are entered, the
modeler should save the data to the hard disk. This can be accomplished by
selecting Save Flow Data As from the File option on the Steady Flow Data

menu bar. Flow data is saved in a separate file. The user is only required to
enter a title for the flow data, the filename is automatically assigned.

Figure 3.8 Steady Flow Data window

Performing the Hydraulic Computations

Once all of the geometric data and flow data are entered, the modeler can
begin to perform the hydraulic calculations. As stated previously, there are
three types of calculations that can be performed in the current version of
HEC-RAS: Steady Flow Analysis, Unsteady Flow Analysis, and Hydraulic
Design Functions. The modeler can select any of the available hydraulic
analyses from the Run menu bar option on the HEC-RAS main window. An
example of the Simulation Manager window is shown in Figure 3.9, which is
the Steady Flow Analysis window.
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Figure 3.9 Steady Flow Analysis window

As shown in Figure 3.9, the modeler puts together a Plan by selecting a
specific set of geometric data and flow data. A Plan can be put together by
selecting New Plan from the File menu bar option of the Steady Flow
Analysis window. Once a Plan Title and Short Identifier (Short ID) have
been entered, the modeler can select a Flow Regime for which the model will
perform calculations. Subcritical, Supercritical, or Mixed flow regime
calculations are available.

Additional features are available under the Options menu for: performing a
Floodway Encroachment Analysis; Setting locations for calculating flow
distribution output; conveyance calculation options; friction slope methods;
calculation tolerances; critical depth output; critical depth computation
method; split flow optimization; data checking; setting log file levels; and
viewing the log file output.

Once the modeler has selected a Plan and set all of the calculation options, the
steady flow calculations can be performed by pressing the Compute button at
the bottom of the Steady Flow Analysis window. When this button is
pressed, the HEC-RAS system packages up all the data for the selected plan
and writes it to a run file. The system then runs the steady flow model
(SNET) and passes it the name of the run file. This process is executed in a
separate window. Therefore, the modeler can work on other tasks while it is
executing.
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Viewing and Printing Results

Once the model has finished all of the computations, the modeler can begin
viewing the results. Several output features are available under the View
option from the main window. These options include: cross section plots;
profile plots; rating curve plots; X-Y-Z perspective plots; tabular output at
specific locations (Detailed Output Tables); tabular output for many locations
(Profile Summary Tables); and the summary of errors, warnings, and notes.

An example of a cross section plot is shown in Figure 3.10. The user can plot
any cross section by simply selecting the appropriate River, Reach and River
Station from the list boxes at the top of the plot. The user can also step
through the plots by using the up and down arrow buttons. Several plotting
features are available under the Options menu of the Cross Section plot.
These options include: zoom in; zoom out; full plot; pan; animate; selecting
which plans, profiles and variables to plot; velocity distribution; viewing
interpolated cross-sections; and control over the lines, symbols, labels,
scaling, and grid options.

Hard copy outputs of the graphics can be accomplished in two different ways.
Graphical plots can be sent directly from HEC-RAS to whichever printer or
plotter the user has defined under the Windows Print Manager. Graphical
plots can also be sent to the Windows clipboard. Once the plot is in the
clipboard it can then be pasted into other programs, such as a word processor.
Both of these options are available from the File menu on the various plot
windows.

An example of a profile plot is shown in Figure 3.11. All of the options
available in the cross section plot are also available in the profile plot.
Additionally, the user can select which specific reaches to plot when a
multiple-reach river system is being modeled.

An example of an X-Y-Z Perspective Plot is shown in Figure 3.12. The user
has the option of defining the starting and ending location for the extent of the
plot. The plot can be rotated left or right, and up or down, in order to get
different perspectives of the river reach. The computed water surface profiles
can be overlaid on top of the cross section data. The graphic can be sent to
the printer or plotter directly, or the plot can be sent through the Windows
Clipboard to other programs.
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Figure 3.11 Profile Plot
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X-¥-Z Perspective Plot
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Figure 3.12 X-Y-Z Perspective Plot of River Reach with a Bridge
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Tabular output is available in two different formats. The first type of tabular
output provides detailed hydraulic results at a specific cross section location
(Detailed Output Table). An example of this type of tabular output is shown
in Figure 3.13.

_Profile: 100 yr
(| el
0.100 0.040
A 100.00 100.00
1814.46 2473.60 342.47

0.004567 |{zarealsa 2473.60 342.47

___9000.00 ' 5748.43| 3068.15 .42 i
915.30 difi £99.71 45.00 | 17059 |
VeV ’ 2.32 8.96
354 7.61
850655 | 454027
702.56 50.80
1.00 1.92
2.33 17.22
216.87 42.90
79.60 6.44

Figure 3.13 Tabular Detailed Output

The second type of tabular output shows a limited number of hydraulic
variables for several cross sections and multiple profiles (Profile Summary
Tables). An example of this type of tabular output is shown in Figure 3.14.
There are several standard tables that are predefined and provided to the user
under the Tables menu from the profile output tables. Users can also define
their own tables by specifying what variables they would like to have in a
table. User specified table headings can be saved and then selected later as
one of the standard tables available to the project.

Tabular output can be sent directly to the printer or passed through the

clipboard in the same manner as the graphical output described previously.
This option is also available under the File menu on each of the table forms.
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1803.60| 1815.54 0.004567 2933.81
9000.00| 1800.70{ 1810.68| 1810.42| 1811.90| 0.007043 1888.44
9000.00{ 1794.40| 1804.64| 1803.69| 1805.08| 0.008639 2641.12

9000.00| 1788.70] 1799.04| 1793.31| 1800.25| 0.012377 2386.84| 1209.91

9500.00| 1784.30| 1794.12| 1793.83| 1795.13| 0.007246 2787.41| 117116
9500.00{ 1777.20] 1789.64{ 1788.87| 1790.94| 0.008716 2028.56] 522.19
9500.00{ 1774.50| 1784.29| 1784.29| 1786.35] 0.011143 1266.30)  332.38
9500.00{ 1768.50| 1777.26| 1776.81| 1778.26] 0.003176 2096.03| 595.63
9500.00] 1763.00] 1772.79] 177223 1773.48| 0.007974 2504.12|  734.61
9500.00 1759.40| 1767.85| 1765.75| 1763.14| 0.011973 1961.46|  653.51
9500.00] 1753.60{ 1761.54] 1760.03| 1762.10 0.003429 2322.20)  682.66

9500.00 1747.40| 1756.71] 1795.71] 1757.21| 0.010002 2403.93

Figure 3.14 Profile Output Table

Importing HEC-2 Data

An important feature of HEC-RAS is the ability to import HEC-2 data. This
feature makes it easy for a user to import existing HEC-2 data sets and start
using HEC-RAS immediately.

What You Should Know First

Before importing HEC-2 data, there are several things that you should be
aware of. First, not all of the options available in HEC-2 have been
incorporated into the current version of HEC-RAS. The following is a list of
HEC-2 options that are not available in the current version of HEC-RAS:

- Compute Manning’s n from high water marks (J1)
- Archive (AC)

- Free Format (FR)

- Storage Outflow for HEC-1 (J4)

HEC-2 data sets containing these options can still be imported, but these data
options will be ignored.
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Another important issue to be aware of is how the cross sections are
identified. In HEC-RAS, each cross section is identified with a River name,
Reach name, and a River Station. The river stationing must be in order from
highest river stationing upstream to lowest river stationing downstream.
When the user goes to import HEC-2 data, a pop up window will appear
(Figure 3.15), asking the user to select a method for identifying the river
stationing of the cross sections. If you select "Use HEC-2 Section ID's," the
program will use the first field of the X1 record for the river stationing of the
cross section. If you choose this method, you must be sure that the cross
sections in the HEC-2 file are numbered with highest river stationing
upstream, and that no two cross sections have the same river station identifier.
If these two requirements are not met, the program will not import the data
correctly. An alternative is to select "Use Sequential Counter." This method
simply assigns river stations as 1, 2, 3, etc. in the order in which the cross
sections are found in the HEC-2 file (still maintaining highest numbers
upstream and lowest numbers downstream.

HEE—2 Import Dpl:luns

Figure 3.15 Method for Identifying River Stations from HEC-2 Data

After the HEC-2 data is imported into HEC-RAS, you may need to make
some modifications to the data. HEC-RAS is a completely new program. As
HEC-RAS was being developed, we tried to improve the hydraulic
computations in every way we could. Some of these improvements have
made it necessary to get more information and/or different information from
the user for a specific type of computation. The following is a list of features
in which the data requirements for HEC-2 and HEC-RAS have changed, and
it may be necessary for the user to modify the data after it is imported:

- Special Bridge (SB)

- Special Culvert (SC)

- Normal Bridge (X2, BT)

- Encroachments and Floodway Determmatlon (X3, ET)
- Ineffective Flow Areas (X3)
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When bridge data are imported, the user must take special care to ensure that
the data are correctly representing the bridge. The bridge routines in HEC-
RAS are more detailed than HEC-2, and therefore you may have to modify
some data and/or enter some additional data. Whenever you import an HEC-
2 data set with bridge data, carefully review all the data for each bridge.
Chapter 6 of this user's manual describes the required data for bridges in
HEC-RAS. Appendix C of the HEC-RAS Hydraulic Reference Manual
contains a detailed discussion of the computational differences between
HEC-RAS and HEC-2. Some key differences between the bridge routines
of HEC-2 and HEC-RAS are as follows:

1. Special Bridge Data Sets

HEC-RAS does not use a trapezoidal approximation for low flow through the
bridge opening. The actual bridge opening is used in both the Yarnell method
and the momentum method. This could be a problem for HEC-2 special
bridge data sets that do not include low chord information on the BT data. If
you have a data set like this, you will need to modify the bridge deck
information after the data have been imported. This can be done from the
HEC-RAS Deck/Roadway editor.

The pressure flow equations in HEC-RAS use the actual bridge opening,
defined by the ground and the bridge data. In HEC-2, the user was required
to enter an area for pressure flow. If the actual bridge opening produces a
different area than what the user had entered in the HEC-2 data deck, the
program will get different results for pressure flow, and pressure and weir
flow answers.

Pier information from the SB record is incorporated as a single pier in the
HEC-RAS data set (this is how it was treated in HEC-2). Piers are treated as
separate pieces of data in HEC-RAS. For special bridges that have piers, you
may want to change the single pier to multiple piers, depending on what is
actually at the bridge. Pier information can be modified using the Pier editor.

2. Normal Bridge Data Sets

Because piers are treated as a separate piece of data in HEC-RAS, they must
not be included in the cross section data or the bridge deck. Since it is
common to include pier information as part of the cross section or bridge
deck in HEC-2, these data will need to be modified. For data sets that have
piers, you will need to remove the pier information from the cross section or
bridge deck, and then add the information back in using the Pier editor.
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HEC-RAS - River Analysis System

Steps for Importing HEC-2 Data

To import HEC-2 data, do the following:

1.

Start a new project by selecting New Project under the File menu
option on the HEC-RAS main window (Figure 3.16). When this
option is selected a window will appear allowing you to select the
drive and directory for the new project, then enter a project title and
filename. Press the OK button, and then a pop up window will appear
asking you to confirm the information.

Select the Import HEC-2 Data option under the File menu on the
main window (Figure 3.16). A pop up window will appear (Figure
3.17), which will allow you to select a drive, path, and filename for
the HEC-2 data file. In addition to the filenames being listed, the first
line of each HEC-2 data file is shown under the title field on the
window. Once you have selected the file you want, press the OK
button.

Figure 3.16 HEC-RAS Main Window With File Menu Options Shown

Once you have selected an HEC-2 file and pressed the OK button, a
pop up window will appear asking you to select a method for
identifying the river stationing of the cross sections (this was
discussed under the "What You Should Know First" section). Select
a method and press the Import HEC-2 button.
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MATOMAS E&ST MAIN DRAIN TO RIO J

S : e

TEST 3INTERPOLATED CROSS SECTIO
TEST 4 DIRECT SOLUTION OF MANNIN

TEST 5 SPECIAL AND NORMAL BRIDGE
TEST 5 SPECIAL AND NORMAL BRIDGE
TEST 6 NORMAL BRIDGE,.SUPERCRITIC

TEST 7 NORMAL BRIDGE ,CRITICALD

TEST 8 SPECIAL BRIDGE .METRIC UNI

TEST 9 SPECIAL BRIDGE,CLASS A AN ]
START AT SECTION TJC3.DAT

Figure 3.17 Window for Importing HEC-2 Data

4, If the HEC-2 data file contains any bridges or culverts, a note will
appear reminding you to look at the imported data of all of the bridges
and culverts to ensure the data is complete and correct.

The data are automatically saved in HEC-RAS format with default names and
titles. The user can change the titles at any time by using the Rename
feature, which is available from the File menu of the various data editors
(Geometric data, flow data, and plan data).

Reproducing HEC-2 Results

The HEC-RAS program is a completely new piece of software. None of the

hydraulic routines from HEC-2 were used in the HEC-RAS software. When
HEC-RAS was being developed, a significant effort was spent on improving

the computational capabilities over those in the HEC-2 program. Because of
this, there are computational differences between the two programs.

Appendix C, of the HEC-RAS Hydraulic Reference Manual, outlines in
detail the computational differences between the two programs. Please
review this closely!

When importing HEC-2 data, and attempting to reproduce the results of a
previous study, the following is a list of items that should be considered:
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1. First, is the data that you have imported good data? In other words,
did it come from a working HEC-2 model, and was that model
considered as being hydraulically sound. Are there an adequate
number of cross sections? And are there any mistakes in the cross
section data? Review the data closely, before you assume that it is
good!

2, The default method for calculating conveyance in HEC-RAS is
different from HEC-2. However, HEC-RAS has the ability to
compute conveyance with the HEC-2 methodology. If you are trying
to reproduce HEC-2 results, you may want to switch HEC-RAS to the
HEC-2 method of computing conveyance. To do this, from the
Steady Flow Analysis window select Options from the menu bar then
select Conveyance Calculations. When this is selected, a pop up
window will appear as shown in Figure 3.18. There are two options
available, the HEC-RAS default method (break in n-value method)
and the HEC-2 style method. Select the HEC-2 style method if you
are trying to reproduce HEC-2 results. For more information on the
differences in conveyance calculations, see Appendix C of the HEC-
RAS Hydraulic Reference manual.

__ HECRAS _

. ~ SelectMethod of Calculs!

Figure 3.18 HEC-RAS Conveyance Calculation Methods

3. The HEC-RAS bridge routines are more comprehensive than the
HEC-2 bridge routines, and therefore differences can occur at bridge
locations. First, review the bridge data closely and make sure it
accurately represents the bridge you are trying to model. If you feel it
is necessary to match the results of a previous study at the bridge,
then your only alternative is to adjust the coefficients that are being
used in the bridge modeling approach (i.e., pressure and weir flow
coefficients, low flow coefficients, contraction and expansion
coefficients, etc...). For detailed information on the differences
between the HEC-RAS and HEC-2 bridge routines, please review
Appendix C of the Hydraulic Reference manual.
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4. Sometimes differences can occur at locations where the programs

have defaulted to a critical depth solution. First you should ask
yourself if critical depth is an appropriate solution for this location. It
is a common problem for both programs to default to critical depth
when the cross sections are spaced too far apart. If you feel critical
depth is an appropriate solution, then in general the HEC-RAS answer
will be better than HEC-2. The critical depth routines in HEC-RAS
are much more comprehensive than HEC-2. HEC-RAS has tighter
error limits for locating critical depth, as well as the ability to find
multiple critical depths and detect which is the most appropriate.

5. Differences can also occur at locations where floodway
encroachments are being computed. The HEC-RAS floodway
encroachment routines have been improved over those available in
HEC-2. Also, the default at bridges in HEC-RAS is to perform the
encroachment analysis, while the default in HEC-2 was to not
encroach at bridges. For more details on differences between
encroachment routines, please review Appendix C of the HEC-RAS
Hydraulic Reference Manual.

6. After carefully reviewing items one through five above, if you still
have computational differences in the computed profiles, you may
need to modify Manning’s n values in order to reproduce the previous
study results. In general, this is not suggested. If you do decide to
modify the n values, try to keep them within a realistic range of what
is appropriate for the stream you are working on.

Getting and Using Help
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On-line help is available from within the HEC-RAS software. Help can be
accessed by selecting the Help menu option at the top of each window, or by
pressing the F1 function key.
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CHAPTER 4
Example Application

This chapter provides an example application of how to perform steady flow
water surface profile calculations with HEC-RAS. The user is taken through
a step-by-step procedure of how to enter data, perform calculations, and view
the results.

In order to get the most out of this chapter, you should perform each of the

steps on your own computer. Also, before you try the example application,
you should have read the first three chapters in this manual.

Contents
= Starting a New Project
* Entering Geometric Data
» Entering Steady Flow Data
. » Performing the Hydraulic Calculations
s Viewing Results
» Printing Graphics and Tables

= Exiting the Program
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Starting a New Project

To begin this example, let's first start the HEC-RAS program. Double click
the HEC-RAS icon in Windows. The main window should appear as shown
in Figure 4.1 (except yours will be blank the first time you start the program).

HEC-RAS - River Analysis System

Figure 4.1 HEC-RAS Main Window

The first step in developing an HEC-RAS application is to start a new project.
Go to the File menu on the main window and select New Project. The New
Project window should appear as shown in Figure 4.2 (except the title and file
name fields will be blank when it first comes up).

Stream Junction - Example 10 JUNCTION. prj
Looped Network - Example 8 LOOP.pri
Mixed Flow Project MIXED.PRJ
Mized Flow - Example 9 MIXFLOW . pri
Multiple Culverts - Example 4 MULTCULV.prj

Multiple Openings - Example 5 MULTOPEN. prj
Mapa Cr. Bridge Project - Example 7 NAPA. pri

Neil Nelson's Property Nelson.prj
Inline Weir and Gated Spillay - Ex 12 NIT.prj

Bridge Scour - Example 11

Figure 4.2 New Project Window

First set the drive (e.g., C:) and the directory that you would like to work in.
Next enter the project title and filename as shown in Figure 4.2. Once you
have entered the information, press the OK button to have the data accepted.
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Entering Geometric Data

The next step in developing a steady flow model with HEC-RAS is to enter
the geometric data. This is accomplished by selecting Geometric Data from
the Edit menu on the HEC-RAS main window. Once this option is selected
the geometric data window will appear, except yours will be blank when you
first bring it up (Figure 4.3).

Drawing the Schematic of the River System

In this example we are going to develop a two-river (three hydraulic reaches)
system as shown in Figure 4.3. Draw the river system schematic by
performing the following steps:

1 Click the River Reach button on the geometric data window.

2. Move the mouse pointer over to the drawing area and place the
. pointer at the location in which you would like to start drawing the
first reach.

3. Press the left mouse button once to start drawing the reach. Move the
mouse pointer and continue to press the left mouse button to add
. additional points to the line segment. To end the drawing of the
reach, double click the left mouse button and the last point of the
reach will be placed at the current mouse pointer location. All
reaches must be drawn from upstream to downstream (in the positive
flow direction), because the program assumes this to be true.

4. Once the reach is drawn, the interface will prompt you to enter an
identifier for the River name and the Reach name. The River
identifier can be up to 32 characters, while the reach name is limited
to 12 characters. In this example, there is one river named Fall River
and another one named Butte Cr. Fall river contains two hydraulic
reaches, which are labeled Upper Reach and Lower Reach. Butte
Cr. has been entered as a single hydraulic reach, and the reach name
is Tributary.

5. Repeat steps one through four for each reach. After you enter the
identifiers for Butte Cr., you will also be prompted to enter an
identifier for the junction. Junctions in HEC-RAS are locations
where two or more reaches join together or split apart.
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Once you have finished drawing in the river system, there are several options
available for editing the schematic. These options include: change name,
move object (objects are labels, junctions, and points in the reaches), add
points to a reach, remove points from a reach, delete a reach, and delete a
junction. The editing features are located under the Edit menu on the
Geometric Data window. Note: when you first draw your schematic there
will not be any tic marks representing cross sections as shown in Figure
4.3. The tic marks only show up after you have entered cross sections.

Geomefr:c Data - Base Geomelry Data

-

Q

—_
—_

\Upper Reach

N y
*"ij- 97
"N Lower Reach
i "&.\,:;—-x
i 96

Figure 4.3 Geometric Data Window with example river schematic

Entering Cross Section Data

The next step is to enter the cross section data. This is accomplished by
pressing the Cross Section button on the Geometric Data window (Figure
4.3). Once this button is pressed, the Cross Section Data editor will appear as
shown in Figure 4.4 (except yours should be blank). To enter cross section
data do the following:
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1. Select a River and a Reach to work with. For this example start with
the Fall River, Upper Reach.

2. Go to the Options menu and select Add a new Cross Section. An
input box will appear to prompt you to enter a river station identifier

for the new cross section. The identifier does not have to be the
actual river station, but it must be a numeric value. The numeric
value describes where this cross section is located in reference to all
the other cross sections within the reach. Cross sections are located
from upstream (highest river station) to downstream (lowest river
station). For this cross section enter a value of 10.0.

Cont \E:-: Coefficients

Figuré 4.4 Cross Section Data Editor with example data

3. Enter all of the data for this cross section as it is shown in Figure 4.4.

4, Once all the data are entered press the Apply Data button. This
button is used to tell the interface that you want the data to be
accepted into memory. This button does not save the data to your
hard disk, which can only be accomplished from the File menu on the
Geometric Data window.

5. Plot the cross section to visually inspect the data. This is
accomplished by pressing the Plot Cross Section option under the
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Elevation (ft)

Cross Sect]on

Plot menu on the Cross Section Data Editor. The cross section
should look the same as that shown in Figure 4.5.

In general, the five steps listed would be repeated for every cross section that
is entered. In order to reduce the amount of data entry for this example, the
current cross section will be copied and adjusted to represent other cross
sections within the river system.

Steady Flow Example from Chapter 4

Plan: Existing Conditions Run
Geom: Base Geometry Data Flow: 10, 2 and 1% chance events
Upstream Boundary of Fall River

95 1

90 1

08 F{': 038 :l- .05 F{

Lagend
p—S—
Ground

*
Bank Sta

150 200 250 300 350 400
Station (ft)

Figure 4.5 Cross Section Plot for river mile 10.0 of Fall Creek

The following steps should be followed to copy the current cross section:

1.

Go to the Options menu on the Cross Section Data Editor and select
Copy Current Cross Section. An input box will appear to prompt
you to select a river and a reach, and then enter a river station for the
new cross section. For this example, keep the river and reach as Fall
River and Upper Reach, then enter a new river station of 9.9. Press
the OK button and the new cross section will appear in the editor.

Change the cross section description to "River Mile 9.9 of Fall River."
Adjust all the elevations of the cross section by -0.5 feet. This is
accomplished by selecting the Adjust Elevations feature from the

Options menu on the Cross Section Data Editor.

Adjust the cross section stationing to reduce the overbanks by 10%.
This is accomplished by selecting the Adjust Stations feature from
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the Options menu on the Cross Section Data Editor, then select
Multiply by a Factor. When the input box appears for this option,
three data entry fields will be available to adjust the stationing of the
left overbank, channel, and the right overbank separately. Enter
values of 0.90 for the right and left overbanks, but leave the main
channel field blank. This will reduce the stationing of both overbanks
by 10%, but the main channel will not be changed.

S Downstream reach lengths remain the same for this cross section.
6. Press the Apply Data button.
7 Plot the cross section to visually inspect it.

These seven steps should be repeated to enter all the data for Fall River
(Upper and Lower Reach). The necessary adjustments are listed in Table 4.1.
Perform the cross section duplications in the order that they are listed in the
table. Make sure to change the description of each cross section, and also
press the Apply Data button after making the adjustments for each cross
section.

Table 4.1 Cross Section adjustments for duplicating sections

Cross Section Adjusted Adjusted Stationing Downstream Reach Lengths
Elevation
Reach River Left Channel [Right O.B.|Left O.B.| Channel [Right O.B.
Sta. 0.B.
Upper 9.8 -0.4 0.80 - 0.80 0.0 0.0 0.0
Lower 9.79 -0.1 1.20 1.20 1.20 |. 500 500 500
Lower 9.7 -0.5 1.20 1.20 1.20 500 500 500
Lower 9.6 -0.3 - - - 500 500 500
Lower 9.5 -0.2 - - - 0.0 0.0 0.0

This completes all the cross section data for Fall River (upper and Lower
reach). Now let's work on entering the data for the Butte Creek tributary. To
enter the first cross section in the Butte Creek tributary do the following:

1. Go to the River text box on the Cross Section Data Editor and select
the Butte Cr. river. The Reach of "Tributary" will automatically be
selected since it is the only reach in Butte Creek.

2; Select Add a new Cross Section from the Options menu. When the
popup box appears to prompt you to enter a new river station, enter a

value of 0.2.
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3 Enter all the data for this cross section as shown in Figure 4.6.

4. Once all the data are entered for this section, press the Apply Data
button.

5. Plot the cross section to inspect the data.

Figure 4.6 Cross Section Editor with river mile 0.2 of Butte Creek

There are two other cross sections that need to be developed for the Butte
Creek tributary. These two cross sections will be developed by duplicating
the cross section that you just entered, and then adjusting the elevations and
stationing. The necessary adjustments are listed in Table 4.2. Perform the
cross section adjustments in the order that they are listed in the table. Make
sure to change the description of each cross section and press the Apply Data
button after editing is complete.
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Table 4.2 Cross Section adjustments for Butte Creek sections

Cross Section Adjusted Adjusted Stationing Downstream Reach Lengths
Elevation
Reach |River Sta. Left Channel [Right O.B.|Left O.B.| Channel [Right O.B.
O.B.
Butte Cr. 0.1 -0.6 - - - 500 500 500
Butte Cr. 0.0 -0.3 - - - 0.0 0.0 0.0

Now that all of the cross section data are entered, save the data to a file before
continuing. Saving the data to a file is accomplished by selecting the "Save
Geometry Data As" option from the File menu on the Geometric Data
window. After selecting this option you will be prompted to enter a Title for
the geometric data. Enter "Base Geometry Data" for this example, then press
the OK button. A file name is automatically assigned to the geometry data
based on what you entered for the project filename.

Entering Junction Data

The next step is to enter the junction data. Junction data consist of a
description, and reach lengths across the junction. In this example there is
only one junction, which is labeled Sutter. To enter Junction data, press the
Junction button on the Geometric Data window. Enter the junction data as
shown in Figure 4.7.

5 T e

FFall and Butte Creek

[FlowC
Length across Junction | e
Fall River - Lower Reach engh(ffy | -
re bt B0 :-
50|

I

Figure 4.7 Junction Data Editor, with Sutter junction data

4-9




Chapter 4 Example Application

Reach lengths across the junction are entered in the junction editor, rather
than in the cross section data. This allows for the lengths across very
complicated confluences (i.e., flow splits) to be accommodated. In the cross
section data, the reach lengths for the last cross section of each reach should
be left blank or set to zero.

In this example the energy equation will be used to compute the water surface
profile through the junction. If the momentum equation is selected, then an
angle can be entered for one or more of the reaches flowing into or out of a
junction. The momentum equation is set up to account for the angle of the
flow entering the junction.

Once you have all of the data entered for the junction, apply the data and
close the window by pressing the OK button.

Saving the Geometry Data

At this point in the example, all of the geometric data has been entered.
Before we continue with the example, you should save the geometric data to
the hard disk. Since the data have already been saved once, you simply have
to select Save Geometry Data from the File menu on the Geometric Data
window. We can now go on to enter the Steady Flow data.

Entering Steady Flow Data

The next step in developing the required data to perform steady flow water
surface profile calculations is to enter the steady flow data. To bring up the
steady flow data editor, select Steady Flow Data from the Edit menu on the
HEC-RAS main window. The Steady Flow Data editor should appear as
shown in Figure 4.8.

The first piece of data to enter is the number of profiles to be calculated. For
this example, enter "3" as shown in Figure 4.8. The next step is to enter the
flow data. Flow data are entered from upstream to downstream for each
reach. At least one flow rate must be entered for every reach in the river
system. Once a flow value is entered at the upstream end of a reach, it is
assumed that the flow remains constant until another flow value is
encountered within the reach. Additional flow values can be entered at any
cross section location within a reach.
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Figure 4.8 Steady Flow Data Editor, with example problem data

In this example, flow data will be entered at the upstream end of each reach.
. An additional flow change location will be entered at river mile 9.6 of the Fall
River in the Lower Reach. To add an additional flow change location into the
table, first select the Fall River, Lower Reach from the Reach list box. Next,
select the desired river station location (9.6 in this example) from the River
Sta. list box. Finally, press the Add a Flow Change Location button. The
new flow location should appear in the table. Now enter all of the flow data
into the table as shown in Figure 4.8. Profile labels will automatically default
to "PF#1," "PF#2," etc. You can change these labels to whatever you want.
In this example they have been changed to "10 yr," "50 yr," and "100 yr," to
represent the statistical return period of each of the events being modeled.

The next step is to enter any required boundary conditions. To enter
boundary conditions, press the Enter Boundary Conditions button at the top
of the Steady Flow Data editor. The boundary conditions editor will appear
as shown in Figure 4.9, except yours will be blank the first time you open it.

Boundary conditions are necessary to establish the starting water surface at
the ends of the river system. A starting water surface is necessary in order for
the program to begin the calculations. In a subcritical flow regime, boundary
conditions are only required at the downstream ends of the river system. Ifa
supercritical flow regime is going to be calculated, boundary conditions are |
only necessary at the upstream ends of the river system. If a mixed flow
regime calculation is going to be made, then boundary conditions must be
entered at all open ends of the river system.
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steady Flow Boundary Conditions
hd

The boundary conditions editor contains a table listing every river and reach.
Each reach has an upstream and a downstream boundary condition.
Connections to junctions are considered internal boundary conditions.
Internal boundary conditions are automatically listed in the table, based on
how the river system is connected in the geometric data editor. The user is
only required to enter the necessary external boundary conditions.

In this example, it is assumed that the flow is subcritical throughout the river
system. Therefore, it is only necessary to enter a boundary condition at the
downstream end of the Fall River, Lower Reach. Boundary conditions are
entered by first selecting the cell in which you wish to enter a boundary
condition. Then the type of boundary condition is selected from the four
available types listed above the table. The four types of boundary conditions
are:

» Known water surface elevations
» Critical depth

* Normal depth

» Rating curve

For this example, use the normal depth boundary condition. Once you have
selected the cell for the downstream end of Fall River, Lower Reach, press
the Normal Depth button. A pop up box will appear requesting you to enter
an average energy slope at the downstream end of the Fall River. Enter a
value of 0.0004 (ft/ft) then press the Enter key. This completes all of the
necessary boundary condition data. Press the OK button on the Boundary
Conditions form to accept the data.
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. The last step in developing the steady flow data is to save the data to a file.
To save the data, select the Save Flow Data As option from the File menu on
the Steady Flow Data Editor. A pop up box will prompt you to enter a
description of the flow data. For this example, enter "10, 2, and 1% chance
events." Once the data are saved, you can close the Steady Flow Data Editor.

Performing the Hydraulic Calculations

Now that all of the data have been entered, we can calculate the steady water
surface profiles. To perform the simulations, go to the HEC-RAS main
window and select Steady Flow Analysis from the Simulate menu. The
Steady Flow Analysis window should appear as shown in Figure 4.10, except
yours will not have any plan titles yet.

teady Flow Analysis

Figure 4.10 Steady Flow Analysis Simulation Window

The first step is to put together a Plan. The Plan defines which geometry and
flow data are to be used, as well as providing a title and short identifier for the
run. To establish a plan, select New Plan from the File menu on the Steady
Flow Analysis window. Enter the plan title as "Existing Conditions Run" and
then press the OK button. You will then be prompted to enter a short
identifier. Enter a title of "Existing" in the Short ID box.

The next step is to select the desired flow regime for which the model will
perform calculations. For this example we will be performing Subcritical
flow calculations only. Make sure that Subcritical is the selected flow
regime. Additional job control features are available from the Options menu
bar, but none are required for this example. Once you have defined a plan
and set all the desired job control information, the plan information should be
saved. Saving the plan information is accomplished by selecting Save Plan
. from the File menu of the Steady Flow Analysis window.
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Now that everything has been set, the steady flow computations can be
performed by pressing the Compute button at the bottom of the Steady Flow
Simulation window. Once the compute button has been pressed, a separate
window will appear showing you the progress of the computations. Once the
computations have been completed, the computation window can be closed
by double clicking the upper left corner of the window. At this time the
Steady Flow Simulation window can also be closed.

Viewing Results

Once the model has finished all of the computations successfully, you can
begin viewing the results. Several output options are available from the View
menu bar on the HEC-RAS main window. These options include:

= Cross section plots

» Profile plots

» General Profile Plot

= Rating curves

» X-Y-Z Perspective Plots

= Detailed tabular output at a specific cross section (cross section table)

» Limited tabular output at many cross sections (profile table)

Let's begin by plotting a cross section. Select Cross Sections from the View
menu bar on the HEC-RAS main window. This will automatically bring up a
plot of the first cross section in Butte Cr., as shown in Figure 4.11. Any cross
section can be plotted by selecting the appropriate river, reach, and river
station from the list boxes at the top of the cross section plot window. The
user can also step through the plots by using the up and down arrow buttons.
Several plotting features are available from the Options menu bar on the
cross section plot window. These options include: zoom in; zoom out;
selecting which plans, profiles and variables to plot; and control over lines,
symbols, labels, scaling, and grid options.
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. Figure 4.11 Cross Section Plot for Example Application

Select different cross sections to plot and practice using some of the features
available under the Options menu bar.

Next let's plot a water surface profile. Select Water Surface Profiles from
the View menu bar on the HEC-RAS main window. This will automatically
bring up a water surface profile plot for the first reach, which is Butte Cr.in
our example. To plot more than one reach, select Reaches from the Options
menu bar on the profile plot. This option brings up a list of available rivers
and reaches from which to choose. Select the Upper and Lower reaches of
the Fall river. This should give you a profile plot as shown in Figure 4.12.
Plot the additional profiles that were computed and practice using the other
features available under the Options menu bar on the profile plot.
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Figure 4.12 Profile Plot for Example Application

Now let's plot a computed rating curve. Select Rating Curves from the View
menu on the HEC-RAS main window. A rating curve based on the computed
water surface profiles will appear for the first cross section in Butte Cr., as
shown in Figure 4.13. You can look at the computed rating curve for any
location by selecting the appropriate river, reach, and river station from the
list boxes at the top of the plot. Plotting options similar to the cross section
and profile plots are available for the rating curve plots. Plot rating curves for
various locations and practice using the available plotting options.
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Rating Curve
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. Figure 4.13 Computed Rating Curve for Example Application

Next look at an X-Y-Z Perspective Plot of the river system. From the View
menu bar on the HEC-RAS main window, select X-Y-Z Perspective Plots.
A multiple cross section perspective plot should appear on the screen. From
the Options menu, select Reaches. A pop up window will appear allowing
you to select which rivers and reaches you would like to have on the plot.
Press the Select All button and then the OK button. Also, under the Options
menu, select the Profiles option. Select profile two to be plotted from the
three available profiles. Once you have selected these options, and X-Y-Z
perspective plot should appear on the screen, similar to the one shown in
Figure 4.14. Try rotating the perspective view in different directions, and
select different reaches to look at.

Now let's look at some tabular output. Go to the View menu bar on the HEC-
RAS main window. There are two types of tables available, a cross section
specific table and a profile table. Select Cross Section Table to get the first
table to appear. The table should look like the one shown in Figure 4.15.
This table shows detailed hydraulic information at a single cross section.
Other cross sections can be viewed by selecting the appropriate reach and
river mile from the table.
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Now bring up the profile table. This table shows a limited number of
hydraulic variables for several cross sections. There are several types of
profile tables listed under the Tables menu bar of the profile table window.
Some of the tables are designed to provide specific information at hydraulic
structures (e.g., bridges and culverts), while others provide generic
information at all cross sections. An example of this type of table is shown in
Figure 4.16.
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Figure 4.14 X-Y-Z Perspective Plot of All Three River Reaches



Chapter 4 Example Application
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Printing Graphics and Tables
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All of the plots and tables can be sent directly to a printer/plotter or passed
through the Windows clipboard to another program (e.g., a word processor).
The printer or plotter that gets used is based on what you currently have
selected as the default printer for Windows. The user has the ability to
change many of the default printer settings (e.g., portrait to landscape) before
printing occurs.

Sending Graphics Directly to the Printer

To send a graphic to the printer/plotter, do the following:

1. Display the graphic of interest (cross section, profile, rating curve, or
river system schematic) on the screen.

2. Using the available options (scaling, labels, grid, etc.), modify the
plot to be what you would like printed out.

3. Select Print from the File menu of the displayed graphic. Once Print
is selected, a Printer Options window will appear, giving the user
the opportunity to change any of the default printer settings. Once
you have the print settings the way you want them, press the Print
button on the Printer Options window and the plot will
automatically be sent to the Windows Print Manager. From that point
the Windows Print Manager will control the printing.

Sending Graphics to the Windows Clipboard

To pass a graphic to the Windows clipboard and then to another program, do
the following:

L. Display the graphic of interest on the screen.

2. Using the available options, modify the plot to be what you want it to
look like.

3. Select Copy to Clipboard from the File menu of the displayed
graphic. The plot will automatically be sent to the Windows
clipboard.

4, Bring up the program that you want to pass the graphic into (e.g.,

word processor). Select Paste from the Edit menu of the receiving
program. Once the graphic is pasted in, it can be resized to the
desired dimensions.
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Sending Tables Directly to the Printer

To send a table to the printer, do the following:

1. Bring up the desired table from the tabular output section of the
program.
2: Select Print from the File menu of the displayed table. Once the

Print option is selected, a Printer Options window will appear. Set
any print options that are desired then press the Print button. This
will send the entire table to the Windows Print Manager. From this
point the Windows Print Manager will control the printing of the
table.

The profile type of table allows you to print a specific portion of the table,
rather than the whole thing. If you desire to only print a portion of the table,
do the following:

L. Display the desired profile type table on the screen.

2. Using the mouse, press down on the left mouse button and highlight
the area of the table that you would like to print. To get an entire row
or column, press down on the left mouse button while moving the
pointer across the desired row or column headings.

3. Select Print from the File menu of the displayed table. Only the

highlighted portion of the table and the row and column headings will
be sent to the Windows Print Manager.

Sending Tables to the Windows Clipboard

To pass a table to the Windows clipboard and then to another program, do the
following:

1. Display the desired table on the screen.
2.« Select Copy to Clipboard from the File menu of the displayed table.

3. Bring up the program that you want to pass the table into. Select
Paste from the Edit menu of the receiving program.

Portions of the profile table can be sent to the clipboard in the same manner
as sending them to the printer.

Practice sending graphics and tables to the printer and the clipboard with the
example data set that you currently have open.
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Exiting the Program
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Before you exit the HEC-RAS software, make sure you have saved all the
data. This can be accomplished easily by selecting Save Project from the
File menu on the HEC-RAS main window. Any data (geometric, flow, and
plan data) that have not been saved will automatically be saved for you.

To exit the HEC-RAS software, select Exit from the File menu of the HEC-
RAS main window. The program will prompt you to save the project if the
data have not been saved previously.
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CHAPTER 5
Working With Projects

To create a river hydraulics application with HEC-RAS, you work with
projects. A project is a collection of files that are used to build a model.
This chapter describes projects and how you build and manage them.

Contents

» Understanding Projects

= Elements of a Project

» Creating, Opening, Saving, Renaming, and Deleting Projects

= Project Options

Understanding Projects

. As you develop an application, the management of all the files that get
created is accomplished through the user interface. When a new project is
started, the user is requested to enter a title and filename for the project. All
other data are automatically stored by the user interface using the same name
as the project file, except for the three character extension. A project consists
of:
= One Project file (.PRJ) -
= One file for each Plan (.P01 to .P99)
* One Run file for each plan ((R01 to .R99)
» One Output file for each plan (.001 to .099)
» One file for each set of Geometry data (.GO1 to .G99) ;
= One file for each set of Steady Flow data (.FO1 to .F99)
= One file for each set of Unsteady Flow data (.U01 to .U99)

= One file for each set of Sediment data (.S01 to .S99)

» One file for each set of Hydraulic Design data (.HO1 to .H99)
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The Project File contains: the title of the project; the units system of the
project; a list of all the files that are associated with the project; and a list of
default variables that can be set from the interface. Also included in the
project file is a reference to the last plan that the user was working with. This
information is updated every time you save the project.

Elements of a Project
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The following sections describe the various types of files that can be included
in a project. All of these files are either created by the user interface or the
various computation engines. The modeler interacts with the data through theM!‘
user interface, and is not required to create or edit any of these files directly. |

Plan Files

Plan files have the extension .P01 to .P99. The "P" indicates a Plan file,
while the number represents the plan number. As plans are created, they are
numbered from 01 to 99. The plan file contains: a description and short
identifier for the plan; a list of files that are associated with the plan (e.g.,
geometry file and steady flow file); and a description of all the simulation
options that were set for the plan. The plan file is created automatically by
the interface each time the user selects New Plan or Save Plan As from the
simulation windows.

Run Files

Run files have the extension .R01 to .R99. The "R" indicates a Run file,
while the number represents an association to a particular plan file. A file
with an extension of .RO01 is the run file that corresponds to the plan file with
the extension .PO1. The run file contains all of the necessary data to perform
the computations that are requested by the associated plan file. For example,
if a steady flow analysis is requested, the run file will contain geometry data,
steady flow data, and all the necessary computational options that are
associated with the plan file. The run file contains the input to any of the
computational engines available in the HEC-RAS system. The run file is
automatically generated by the interface whenever the user presses the
Compute button on the Simulation windows. The run file is in an ASCII
format, but it is not self explanatory.
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Output Files

Output files have the extension .001 to .099. The "O" indicates an Output
file, while the number represents an association to a particular plan file. A
file with the extension .O12 is the output file that corresponds to the plan file
with an extension .P12. The output file contains all of the computed results
from the requested computational engine. For example, if a steady flow
analysis is requested, the output file will contain results from the steady flow
computational engine. The output files are in a binary file format and can
only be read from the user interface.

Geometry Files

Geometry files have the extension .G01 to .G99. The "G" indicates a
Geometry file, while the number corresponds to the order in which they were
saved for that particular project. Geometry files contain all of the geometric
data for the river system being analyzed. The geometric data consist of: cross
section information; hydraulic structures data (e.g., bridges and culverts);
coefficients; and modeling approach information. The geometry data are
stored in an ASCII format. The file contains key words to describe each
piece of data, and is for-the-most-part self explanatory. A geometry file is
created by the user interface whenever the modeler selects New Geometry
Data or Save Geometry Data As from the Geometric Data window.

Steady Flow Data Files

Steady flow data files have the extension .FO1 to .F99. The "F" represents
that it is a steady Flow data file, while the number corresponds to the order in
which they were saved for that particular project. Steady flow data files
contain: the number of profiles to be computed; flow data; and boundary
conditions for each reach. The steady flow data files are stored in an ASCII
format. The file contains key words to describe each piece of data, and is for-
the-most-part self explanatory. Steady flow data files are automatically
created by the user interface when the modeler selects New Flow Data or
Save Flow Data As from the Steady Flow Data window.

Unsteady Flow Data Files

Unsteady flow data files have the extension .U01 to .U99. The "U"
represents that it is an Unsteady flow data file, while the number corresponds
to the order in which they were saved for that particular project. Unsteady
flow data files contain: flow hydrographs at the upstream boundaries; starting
flow conditions; and downstream boundary conditions. The unsteady flow
data files are stored in an ASCII format. The file contains key words to
describe each piece of data, and is for-the-most-part self explanatory.
Unsteady flow data files are automatically created by the user interface when
the modeler selects New Flow Data or Save Flow Data As from the
Unsteady Flow Data window. Currently, the unsteady flow data option is not
available in HEC-RAS. This option will be included in a future version.
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Sediment Data Files

Sediment data files have the extension .S01 to .S99. The "S" represents that it
is a Sediment data file, while the number corresponds to the order in which
they were saved for that particular project. Sediment data files contain: flow
data; boundary conditions for each reach; and sediment data. The sediment
data files are stored in an ASCII format. The file contains key words to
describe each piece of data, and is for-the- most-part self explanatory.
Sediment data files are automatically created by the user interface when the
modeler selects New Sediment Data or Save Sediment Data As from the
Sediment Data window. Currently, the sediment option is not available in
HEC-RAS. This option will be included in a future version.

Hydraulic Design Data Files

Hydraulic design data files have the extension .HO1 to .H99. The "H"
represents that it is a Hydraulic design data file, while the number
corresponds to the order in which they were saved for that particular project.
Hydraulic design data files contain information corresponding to the type of
hydraulic design calculation that is requested. The Hydraulic design data
files are stored in an ASCII format. The file contains key words to describe
each piece of data, and is for-the most-part self explanatory. Hydraulic
Design data files are automatically created by the user interface when the
modeler selects New Hydraulic Design Data or Save Hydraulic Design
Data As from the File menu of the Hydraulic Design Functions window.

A schematic diagram of how the data files fit together is shown in Figure 5.1
on the next page. In this example there are three plans in the project. Each
plan represents a specific set of steady flow data and geometry data. In this
example there are three geometry files and one steady flow file. The first
geometry file could represent the existing conditions of the stream. The
second and third geometry file could represent some modification of that base
geometry file, such as adding a bridge or culvert crossing; a channel
modification; different roughness coefficients; or any other change to the base
geometry file. A plan is formulated by selecting a steady flow file and a
geometry file, and then saving that plan with a specific title and short
identifier. For more information about formulating plans, see Chapter 7 of
the HEC-RAS User’s Manual and Chapter 7 of the HEC-RAS Applications
Guide.
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Project File: filename.prj
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Figure 5.1 Schematic of Project Data Files.
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Creating, Opening, Saving, Renaming, and Deleting

Projects

The following commands from the File menu of the HEC-RAS main window
allow you to create, open, save, rename, and delete projects.

File menu command Description

New Project Closes the current project, prompting you to
save the data if anything has been changed.
The user is then prompted to enter a title and
filename for the new project.

Open Project Closes the current project, prompting you to
save the data if anything has been changed.
Opens an existing project and all of the
associated files.

Save Project Updates the project file and all other files in
which data have been modified.

Save Project As Updates the project file and all other
associated data, saving all the information to a
new filename that you specify.

Rename Project Allows the user to rename the title of the
currently opened project.

Delete Project Deletes the project file and all other files
associated with the selected project. The user
is prompted to make sure that they really want
to delete all of the files.

These commands are the same for all of the other data types that get created
by the user interface (Plan data, geometry data, steady flow data, unsteady
flow data, sediment data, and hydraulic design data).

Project Options

5-6

From the Options menu of the main HEC-RAS window, the user can set
several default project options. These options include: setting default margins
and color control for printing; setting default hydraulic variables; establishing
the default units system (English or Metric); and converting existing projects
to a different units system (English to Metric or Metric to English). The
following four options are available from the Options menu:
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Options menu command
Program Setup

- BW to Printer

- BW to Clipboard

- Default Margins

- Default File Viewer

- Open last project

Description

When this option is set all graphics are sent to
the printer/plotter in Black and White. When
this option is turned off, all graphics are sent
as color drawings. Color drawings that are
sent to a black and white printer will come out
in grey scale shadings.

When this option is set all graphics are sent to
the Windows Clipboard in a Black and White
mode. When this option is turned off, the
graphics are sent to the Clipboard as color
drawings.

This option allows the user to change the
default margins for printing graphics and
tables. The default settings are 1 inch margins
on all four sides.

This option allows the user to change which
program is used for viewing the report
generator and logfile output. The default is
the Windows Write program. The user can
change this to any file viewer on their system.

When this option is selected, the program will
automatically open the last project worked on,
during startup.

- Automatically backup

data

- Set time for
automatic backup

When this option is checked, the program will
automatically make a backup of the currently
opened project, plan, geometry, and flow files.
The backup files are updated at specific timed
intervals, which is user controlled. The
backup files are stored in the \HEC\RAS
directory, with the titles RasBackup.prj,
RasBackup.p01, RasBackup.g01, and
RasBackup.f01.

This option allows the user to control the time
interval between updating the backup files.
The default value is 20 minutes.
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Options menu command

Default Parameters

Unit System

Convert Project Units

Description

This option allows the user to set defaults for
some of the hydraulic variables.

This option allows the user to set the default
units system to either English or Metric. Once
the units system is set, the program assumes
that all input data are entered in that units
system. Likewise, the display of all output
data will be done in the default units system.

This option allows the user to convert an
existing project from one units system to
another. Projects can be converted from
English to Metric or from Metric to English.
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CHAPTER 6

Entering and Editing Geometric Data

Geometric data consist of establishing the connectivity of the river system
(River System Schematic), entering cross-section data, defining all the
necessary junction information, adding hydraulic structure data (bridges,
culverts, weirs, etc.) and cross section interpolation. The geometric data is
entered by selecting Geometric Data from the Edit menu on the HEC-RAS
main window. Once this option is selected, the Geometric Data window will
appear as shown in Figure 6.1. The drawing area will be blank on your
screen, until you have drawn in your own river system schematic.

This chapter describes how to enter and edit all of the necessary geometric
data for a river system.

Contents

» Developing the River System Schematic
. = Cross Section Data

» Stream Junctions

= Bridges and Culverts

= Multiple Bridge and/or Culvert Openings

* Inline Weirs and Gated Spillways

= Lateral Weirs and Gated Spillways

= Cross Section Interpolation

= River Ice

» Viewing and Editing Data Through Tables

* Importing Geometric Data

» Geometric Data Tools

» Attaching and Viewing Pictures

= Saving the Geometric Data
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Developing the River System Schematic

Building The Schematic

The modeler develops the geometric data by first drawing in the river system
schematic on the Geometric Data window (Figure 6.1). The River System
Schematic is a diagram of how the stream system is connected together. The
river system is drawn on a reach-by-reach basis, by pressing the River Reach
button and then drawing in a reach from upstream to downstream (in the
positive flow direction). Each reach is identified with a River Name and a
Reach Name. The River Name should be the actual name of the stream,
while the reach name is an additional qualifier for each hydraulic reach within
that river. A river can be comprised of one or more reaches. Reaches start or
end at locations where two or more streams join together or spilt apart.
Reaches can also start or end at the open ends of the river system being
modeled. In other words, the first and last cross section that will be modeled
in a particular river will be the start or end of a particular reach.
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Figure 6.1 Geometric Data Editor Window
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Reaches are drawn as multi-segmented lines. Each reach must have at least
two points, defining the start and end of the reach. However, it is more
typical to draw a reach with several points that would follow along the main
channel invert of the stream. To draw a reach, first press the River Reach
button on the upper left side of the Geometric Data editor. Move the mouse
pointer to the location on the drawing area that you would like to have the
reach begin (upstream end of the reach). Click the left mouse button once to
define the first point of the reach. Move the mouse and continue to click the
left mouse button to add additional points to the reach. To end a reach, move
the mouse pointer to the location in which you would like the last point of the
reach to be located, then double click the left mouse button. After the reach is
drawn, the user is prompted to enter the River Name and the Reach Name to
identify the reach. The river and reach identifiers are limited to sixteen
characters in length. If a particular River Name has already been entered for
a previously defined reach of the same river, the user should simply select
that river name from the list of available rivers in the river name text box. As
reaches are connected together, junctions are automatically formed by the
interface. The modeler is also prompted to enter an identifier for each
junction. Junctions are locations where two or more streams join together or
split apart. Junction identifiers are also limited to sixteen characters. An
example of a simple stream system schematic is shown in Figure 6.1.

In addition to river reaches, the user can draw Storage Areas and Hydraulic
Connections to storage areas. A storage area is used to define an area in
which water can flow into and out of. The water surface in a storage area is
assumed to be a level pool. Storage areas can be connected to river reaches
as well as other storage areas. The user connects a storage area to a reach by
using the lateral weir option or the hydraulic connections option. Storage
areas can be connected to other storage areas by using a hydraulic connection
between the storage areas. Hydraulic connections consist of culverts, gated
spillways and a weir. The user can set up a hydraulic connection as justa
weir, a weir and culverts, or a weir and gated spillways. For connections
between a storage area and a river reach, if you are going to use a weir and/or
gated spillways, the lateral weir/spillway option should be used instead ofa
hydraulic connection. However, for connecting two storage areas, the
hydraulic connection option is the only means of doing this in HEC-RAS.

To draw a Storage Area, select the storage area button at the top of the
geometric editor window. Storage areas are drawn as polygons. Move the
mouse pointer to the location in which you would like to start drawing the
storage area. Press the left mouse button one time to start adding points to
define the storage area. Continue using single left mouse clicks to define the
points of the storage area. To end the storage area use a double left mouse
click. The storage area will automatically be closed into a polygon. Once
you have finished drawing the storage area, a window will appear asking you
to enter a name for the storage area. To enter and edit the data for a storage
area, use the storage area editor button on the left panel of the geometric data
window.
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To enter a Hydraulic Connection, select the hydraulic connection button at
the top of the Geometric data editor. Move the mouse pointer to the storage
area or the area of a river reach that you want to connect. Then click the left
mouse pointer one time to start the drawing of the connection. You can
continue to use single mouse clicks to add as many points as you want into
the line that represents the hydraulic connection. When you want to end the
connection, place the mouse pointer over the storage area or reach that you
want to connect to, and then double click the mouse pointer. A window will
pop up asking you to enter a name for the hydraulic connection. The
direction in which you draw the hydraulic connection is important for
establishing the positive flow direction for the flow. If you want the program
to output positive flow when the flow is going from a river each to a storage
area, then you must draw the hydraulic connection from the river reach to the
storage area. This is establishing the positive flow direction for the hydraulic
connection. If flow happens to go in the other direction during the
calculations, that flow will be output as negative numbers. To enter and edit
the data for a hydraulic connection use the hydraulic connection data editor
on the left panel of the geometric data window.

Adding Tributaries into an Existing Reach

If you would like to add a tributary or bifurcation into the middle of an
existing reach, this can be accomplished by simply drawing the new reach,
and connecting it graphically to the existing reach at the location where you
would like the new junction to be formed. Once the new reach is connected
into the middle of an existing reach, you will first be prompted to enter a
River and Reach identifier for the new reach. After entering the river and
reach identifiers, you will be asked if you want to "Split" the existing reach
into two reaches. If you answer "yes", you will be prompted to enter a Reach
identifier for the lower portion of the existing reach and a Junction name for
the newly formed stream junction.

Editing The Schematic

There are several options available for editing the river system schematic.
These options include: changing labels, moving objects (such as labels,
junctions, and points in a reach), adding points to a reach, deleting points in a
reach, deleting entire reaches, deleting junctions, numerically editing the
reach schematic lines, and numerically editing the cross section schematic
lines. Editing functions for the schematic are found under the Edit menu of
the geometric data window. When a specific editing function is selected, the
interaction of the user with the schematic is restricted to performing that type
of operation. When the user is finished performing that editing function they
should turn off that editing function by selecting it again from the Edit menu.
When none of the editing functions are turned on, the schematic goes back to
the default mode of interaction. The default interaction mode for the
schematic is described in the "Interacting with the Schematic" section of this
document. A description of each editing function follows:
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Change Name: This option allows the user to change the identifiers of any
reach or junction. To change an identifier, you must be in the Change Name
edit mode. This is accomplished by selecting the Change Name option from
the Edit menu. Once you are in the Change Name edit mode, you then select
the particular label that you would like to change by clicking the left mouse
button over that label. When a label is selected, a pop up window will appear
allowing you to enter a new label. The user can continue to change names by
simply selecting the next label to be changed. The Change Name option can
only be turned off by re-selecting it from the edit menu or by selecting any
other edit option.

Move Object: This option allows you to move any label, junction, or point
in a reach. This is accomplished by first selecting Move Object from the
Edit menu, then selecting the particular object that you would like to move.
To select an object and then move it, simply place the mouse pointer over the
object, then press the left mouse button down. Move the object to the desired
location and then release the left mouse button. The Move Object option
will remain in effect until the user either turns it off (which is accomplished
by re-selecting it) or selects any other edit option.

Add Points to a Reach: This option allows the user to add additional points
to the line that defines a reach. This allows the user to make the schematic
look more like the actual river system. To add additional points, first select
Add Points to a Reach from the Edit menu. Move the mouse pointer to the
location in which you would like to add an additional point on the reach line,
then click the left mouse button. After you have finished adding points to a
reach, you can move them around by selecting the Move Object option from
the Edit menu. To turn the "Add Points to a Reach" mode off, simply re-
select it from the Edit menu, or select any other edit function.

Remove Points in a Reach: This option allows the user to remove points
from a reach line. To use this option, first select Remove Points in a Reach
from the Edit menu. Move the mouse pointer over the point that you would
like to delete and then click the left mouse button. This option can only be
turned off by either re-selecting the option from the Edit menu or by selecting
another edit function.

Delete Reach: This option is used to delete a reach. This is accomplished by
selecting the Delete Reach option from the Edit menu. A list box containing
all the available reaches will appear allowing you to select those reaches that
you would like to delete. Warning - Be careful when you delete reaches.
When you delete a reach, all of its associated data will be deleted also.

Delete Junction: This option is used to delete a junction. This is
accomplished by selecting the Delete Junction option from the Edit menu. A
list box containing all the available junctions will appear allowing you to
select those junctions that you would like to delete.

Delete Storage Area: This option is used to delete a storage area. This is
accomplished by selecting Delete Storage Area from the Edit menu. A
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selection box will appear allowing you to pick the storage areas that you
would like to delete.

Delete Hydraulic Connection: This option is used to delete a hydraulic
connection. This is accomplished by selecting the Delete Hydraulic
Connection option from the Edit menu. A list box containing all the
available hydraulic connections will appear allowing you to select the ones
that you would like to delete.

Reach Schematic Lines: This option allows the user to numerically edit the
coordinates of the river reach schematic lines. When the river system
schematic is hand drawn on the screen, the coordinates of the river reach lines
are put into a simple coordinate system that ranges from 0.0 to 1.0 in both the
X and Y direction. However, the user has the option of taking real world
coordinates (such as UTM or State Plane coordinates) off of a map and
entering them into this table. If the user decides to use real world
coordinates, real world coordinates must be added for all of the reaches of the
schematic. If this is not done, the schematic will still be displayed in the
simple 0.0 to 1.0 coordinate system (the hand drawn coordinates). Once real
world coordinates have been entered for all of the river reaches, then the
schematic will be drawn in that coordinate system. To enter/edit the reach
schematic lines, select the Reach Schematic Lines option from the Edit
menu. Once this option is selected, a window will appear allowing the user to
enter/edit the coordinates of any of the reaches defined in the schematic.

XS Schematic Lines: This option allows the user to numerically edit the
coordinates of the cross section schematic lines. When the river system is
hand drawn on the screen, the default coordinate system is a simple 0.0 to 1.0
range for both the X and Y direction. As cross sections are entered, they are
automatically scaled based on the coordinates of the river reach line and the
main channel distance between cross sections. Each cross section is drawn as
a straight line perpendicular to the river reach schematic line. The user has
the option of entering the real world coordinates (UTM or State Plane) of the
cross section schematic lines. Each cross section schematic line must have at
least two points, a start and an end, but additional points can be added if the
cross section was taken as a multi segmented line. In order for the cross
section schematic lines to be plotted in the real world coordinate system, the
user must enter real world coordinates for all of the cross sections in the
reach. To enter/edit the cross section schematic lines, select the XS
Schematic Lines option from the Edit menu. Once this option is selected, a
window will appear allowing the user to enter/edit the coordinates of any of
the cross section schematic lines.

Interacting With The Schematic

In addition to modifying the river schematic, there are options available to
zoom in, zoom out, display the cross section river stationing, and reset the
viewing extent of river system schematic. Additionally, the user has the
ability to use the mouse to interact with the schematic. This is accomplished
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by moving the mouse pointer over an object (river reach line, junction,
bridge, culvert, etc.) on the schematic and pressing down the left mouse
button. Once the left mouse button is pressed down, a pop up menu will
appear with options that are specific to that type of object. For example,
when the left mouse button is pressed down over a cross section, a menu will
appear allowing the user to select options to: edit the cross section, plot the
cross section, plot the profile for the reach that the cross section is in, display
tabular output for the cross section, and plot the computed rating curve for
that cross section. Another way of interacting with the schematic is to press
the right mouse button while the mouse pointer is located any where over the
schematic drawing area. This will bring up a pop up menu that is exactly the
same as the View menu at the top of the drawing. This option is providing
for convenience in getting to the View menu options. The options available
from the View menu are as follows:

Zoom In: This option allows the user to zoom in on a piece of the schematic.
This is accomplished by selecting Zoom In from the View menu, then
specifying the area to zoom in on with the mouse. Defining the zoom area is
accomplished by placing the mouse pointer in the upper left corner of the
desired area. Then press down on the left mouse button and drag the mouse
to define a box containing the desired zoom area. Finally, release the left
mouse button and the viewing area will display the zoomed in schematic.
Also displayed will be a small box in the upper right corner of the viewing
area. This box will contain a picture of the entire schematic, with a rectangle
defining the area that is zoomed in. In addition to showing you where you are
at on the schematic, this zoom box allows you to move around the schematic
without zooming out and then back in. To move the zoomed viewing area,
simply hold down the left mouse button over the rectangle in the zoom box
and move it around the schematic. The zoom box can also be resized.
Resizing the zoom box is just like resizing a window.

Zoom Out: This option zooms out to an area that is twice the size of the
currently zoomed in window. Zooming out is accomplished by selecting
Zoom Out from the View menu on the geometric data window.

Full Plot: This option re-draws the plot to its full original size. The Full Plot
option is accomplished by selecting Full Plot from the View menu on the
geometric data window.

Pan: This option allows the user to move around when in a zoomed in mode.
The pan option is accomplished by selecting Pan from the View menu of the
geometric data window. When this option is selected, the mouse pointer will
turn into a hand. Press the left mouse button and hold it down, then move the
mouse. This will allow the user to move the zoomed in graphic. To turn the

pan mode off, re-select the pan option from the view menu.

Display River Stationing: This option allows you to display river station
identifiers on the schematic. This is accomplished by selecting Display
River Stationing from the View menu on the geometric data window.
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Display Bank Stations: This option allows the user to display the main
channel bank stations on the cross section lines of the schematic. This is
accomplished by selecting Display Bank Stations from the View menu of
the geometric data window.

Display Ineffective Areas: This option allows the user to display the
location of ineffective flow areas on top of the cross section lines of the
schematic. This is accomplished by selecting Display Ineffective Areas
from the View menu of the geometric data window.

Display Levees: This option allows the user to display the location of levees
on the cross section lines of the schematic. This is accomplished by selecting
Display Levees from the Yiew menu of the geometric data window.

Display XS Direction Arrows: This option allows the user to display arrows
along the cross sections in the direction in which they were extracted. This
option is useful when you have coordinates defined for the cross section, such
that the software can detect the direction that the cross section was extracted.
Cross-sections are suppose to be entered from left to right while looking
downstream. If a cross section has not been entered in this manner, it should
be reversed. HEC-RAS has an option to reverse the cross section stationing.
This option can be found under the Tools menu bar of the geometric data
editor. To display the cross section direction arrows, select Display XS
Direction Arrows from the View menu of the geometric data window.

Display Background Pictures: This option allows the user to turn on and off
the display of any background pictures that have been loaded.

Set Plot Extents: This option allows the user to set the extents of the
viewing area for the river system schematic. The user can enter a specific
coordinate system, or utilize the default data system. The default data plot
extents are from 0 to 1 for both the X and Y axis.

Background Pictures

Another option available to users is the ability to add background images for
displayed behind the river system schematic. One or more pictures can be
added. The user has the option of rectifying the picture by entering
coordinates for the left, right, top, and bottom sides of the picture, with
respect to the coordinates of the river system schematic. If coordinates are
not entered for the extent of the picture, the size of the picture will be based
on its resolution and the resolution of your screen. The following graphical
formats are supported for background maps: bitmap (*.bmp); icon (*.ico);
windows metafile (*.wmf); extended metafile (*.emf); GIF (*.gif); and JPEG

(*.jpg)-
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Cross Section Data

After the river system schematic is completed, the next step for the modeler is

. to enter the cross section data. Cross section data represent the geometric
boundary of the stream. Cross sections are located at relatively short intervals
along the stream to characterize the flow carrying capacity of the stream and
its adjacent floodplain. Cross sections are required at representative locations
throughout the stream and at locations where changes occur in discharge,
slope, shape, roughness, at locations where levees begin and end, and at
hydraulic structures (bridges, culverts, and weirs).

Entering Cross Section Data

To enter cross section data, the user presses the Cross Section button on the
Geometric Data window (Figure 6.1). Once the cross section button is
pressed, the Cross Section Data Editor will appear as shown in Figure 6.2
(except yours will be blank until you have added some data). To add a cross
section to the model, the user must do the following:

i From the Cross Section Editor, select the river and the reach that you
would like to place the cross section in. This is accomplished by
. pressing the down arrow on the River and Reach boxes, and then
selecting the river and reach of choice.

2. Go to the Options menu and select Add a new Cross Section from
the list. An input box will appear prompting you to enter a river
station identifier for the new cross section.

3. Enter all of the required data for the new cross section. Required data
is the data that is openly displayed in the cross section editor window.

4. Enter any desired optional information (i.e., ineffective flow areas,
levees, blocked obstructions, etc.). Optional cross section information
is found under the Options menu.

5. Press the Apply Data button in order for the interface to accept the
data. The apply data button does not save the data to the hard disk, it
is used as a mechanism for telling the interface to use the information
that was just entered. If you want the data to be saved to the hard disk
you must do that from the File menu on the geometric data window.

The required information for a cross section consists of: the river, reach and
river station identifiers; a description; X & Y coordinates (station and
elevation points); downstream reach lengths; Manning’s roughness
coefficients; main channel bank stations; and contraction and expansion
coefficients. All of the required information is displayed openly on the Cross
. Section Data editor (Figure 6.2). A description of this information follows:
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Figure 6.2 Cross Section Data Editor

River, Reach, and River Station. The River and Reach boxes allow the user
to select a specific hydraulic reach from the available reaches in the

schematic diagram. The river and reach labels define which reach the cross
section will be located in. The River Station tag defines where the cross
section will be located within the specified reach. The river station tag does
not have to be the actual river station of the cross section, but it must be a
numeric value. Cross sections are ordered in the reach from highest river
station upstream to lowest river station downstream. The up and down arrow
buttons next to the river station box can be used to sequentially move through
the river stations.

Description. The description box is used to describe the cross section
location in more detail than just the river, reach, and river station. This box
has a limit of 512 characters. The first line of information is displayed, unless
the button to the right of the box is pressed. Also, the first 40 characters of
the description are used as a label for cross section plots and tables.

Cross Section X & Y Coordinates. This table is used to enter the station
and elevation information of the cross section. Station and elevation
information is entered in feet (meters for metric). The cross section
stationing (x-coordinates) are entered from left to right looking in the
downstream direction. Cross section stationing must be in increasing order.
However, two or more stations can have the same value to represent vertical
walls.
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Downstream Reach Lengths. The downstream cross section reach lengths
describe the distance between the current cross section and the next cross
section downstream. Cross section reach lengths are defined for the left
overbank, main channel, and the right overbank. Cross section reach lengths
are entered in feet (meters for metric).

Manning's n Values. At a minimum, the user must specify Manning's n
values for the left overbank, main channel, and the right overbank.
Alternative roughness options are available from the Options menu.

Main Channel Bank Stations. The main channel bank stations are used to
define what portion of the cross section is considered the main channel and
what is considered left and right overbank area. The bank stations must
correspond to stations entered on the cross section X & Y coordinates table.
If the user enters a value that does not correspond to the station points of the
cross section, the interface will ask the user if they would like the value to be
automatically interpolated and added to the cross section data.

Contraction & Expansion Coefficients. Contraction and expansion
coefficients are use to evaluate the amount of energy loss that occurs because
of a flow contraction or expansion. The coefficients are multiplied by the
change in velocity head from the current cross section to the next downstream
cross section. In other words, the values entered at a particular cross section
are used to compute losses that occur between that cross section and the next
downstream cross section.

Once all of the required data for the cross section are entered, make sure you
press the Apply data button to ensure that the interface accepts the data that
was just entered.

Editing Cross Section Data

The bulk of the cross section data is the station and elevation information.
There are several features available under the Edit menu to assist the user in
modifying this information. These features include the following:

Undo Editing. This editing feature applies to all of the information on the
cross section data editor. Once data has been entered and the Apply Data
button has been pressed, the Undo Editing feature is activated. If any
changes are made from this point, the user can get the original information
back by selecting the Undo Edit option from the Edit menu. Once the Apply
Data button is pressed, the new information is considered good and the Undo
Edit feature is reset to the new data.

Cut, Copy, and Paste. Cut, Copy, and Paste features are available for the
station and elevation information on the cross section editor. These features
allow the user to pass cross section station and elevation data to and from the
Windows Clipboard. To use this feature, first highlight a cell or multiple
cells on the station and elevation table. Cells are highlighted by pressing
down on the left mouse button and moving it over the cells that you would
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like to be highlighted. Next select either the Cut or Copy feature from the
Edit menu. If Cut is selected, the information is placed in the Windows
Clipboard and then it is deleted from the table. If Copy is selected, the
information is placed in the Windows Clipboard, but it also remains in the
table. Once the information is in the Windows Clipboard it can be pasted into
the station and elevation table of any cross section. To paste data into another
cross section, first go to the cross section in which you would like the data to
be placed. Highlight the area of the table in which you want the data to be
placed. Then select the Paste option from the Edit menu. The cut, copy, and
paste features can also be used to pass station and elevation information
between HEC-RAS and other programs. -

Delete. This option allows the user to delete a single cell or multiple cells in
the station/elevation table. Once the cells are deleted, everything below those
cells is automatically moved up. To use this option, first highlight the cells
that you would like to delete, then select the Delete option from the Edit
menu. If you would like to clear cells, without moving the data below those
cells, simply highlight the cells and press the delete key.

Insert. This option allows the user to insert one or several rows in the middle
of existing data in the station/elevation table. To use this option, first
highlight the area in the table that you would like to be inserted. Then select
Insert from the Edit menu. The rows will be inserted and all of the data will
be moved down the appropriate number of rows. The user can also insert a
single row by placing the curser in the row just below where you would like
the new row to be inserted. Then select Insert from the Edit menu. The row
will be inserted and all of the data below the current row will be moved down
one row.

Cross Section Options

Information that is not required, but is optional, is available from the Options
menu at the top of the cross section data editor window (Figure 6.2). Options
consist of the following:

Add a new Cross Section. This option initiates the process of adding a cross
section to the data set. The user is prompted to enter a river station tag for the
new cross section. The river station tag locates the cross section within the
selected reach. Once the river station is entered, the cross section data editor
is cleared (except for some default values that get set) and the user can begin
entering the data for the cross section. Whenever a new cross section is
added to the data set, default values will appear for the contraction and
expansion coefficients (0.1 and 0.3 respectively). Also, if the new cross
section is not the first or most upstream cross section of the reach, the
program will set default Manning’s n values equal to the n values of the cross
section just upstream of the new cross section. If the user does not want these
default values, they can simply change them to whatever values they would
like.
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Copy Current Cross Section. This option allows the user to make a copy of
the cross section that is currently displayed in the editor. When this option is
selected, the user is prompted to select a river and reach for the new section,
and then enter the a river station. Once the information is entered, the new
cross section is displayed in the editor. At this point it is up to the user to
change the description and any other information about the cross section.
This option is normally used to make interpolated cross sections between two
surveyed cross sections. Once the section is copied, the user can adjust the
elevations and stationing of the cross section to adequately depict the
geometry between the two surveyed sections.

Rename River Station. This option allows the user to change the River
Station of the currently displayed cross section.

Delete Cross Section. This option will delete the currently displayed cross
section. The user is prompted with a message stating specifically which cross
section is going to be deleted, and requesting the user to press the OK button
or the Cancel button. Once the OK button is pressed, the user will be
prompted with a question of whether or not they would like the cross section
reach lengths to be automatically adjusted to account for the removal of the
cross section. If the user answers YES then the reach lengths of the current
cross section, that is being deleted, will be added to the reach lengths of the
next upstream cross section. If the user answers NO, then the cross section
will be deleted with out adjusting any reach lengths.

Adjust Elevations. This option allows the user to adjust all of the elevations
of the currently displayed cross section. Positive or negative elevation
changes can be entered. Once the value is entered, the interface automatically
adjusts all the elevations in the table.

Adjust Stations. This option allows the user to adjust the stationing of the
currently displayed cross section. Two options are available. The first
option (Multiply by a Factor) allows the user to separately expand and/or
contract the left overbank, main channel, and the right overbank. When this
option is selected, the user is prompted to enter a multiplier for each of the
three flow elements (left overbank, main channel, and right overbank). If the
multiplier is less than one, the flow element is contracted. If the multiplier is
greater than one, the flow element is expanded. Once the information is
entered, and the user hits the OK button, the interface automatically performs
the contraction and/or expansions. The cross section should be reviewed to
ensure that the desired adjustments were performed. The second option (Add
a Constant) allows the user to add or subtract a constant value from all the
stations in the cross section. This would allow the entire cross section to be
shifted to the right or the left.

Adjust n or k Values. This option allows the user to either increase or
decrease all the n or k values of the current cross section. The user is
prompted for a single value. This value is then used as the multiplier for all
of the n or k values of the current cross section.
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Skew Cross Section. This option allows the user to adjust the stationing of a
cross section based on a user entered skew angle. Cross sections are suppose
to be taken perpendicular to the flow lines. This may not always be the case,
such as at bridges. In order for the program to use the correct flow area, the
cross section stationing must be adjusted by taking the cosine of the skew
angle times the stationing. When this option is selected, a window will
appear allowing the user to enter a skew angle. Once the angle is entered, the
software will automatically adjust the cross section stationing. The user can
get back to the original stationing by putting a zero skew into the field.

Ineffective Flow Areas. This option allows the user to define areas of the
cross section that will contain water that is not actively being conveyed
(ineffective flow). Ineffective flow areas are often used to describe portions
of a cross section in which water will pond, but the velocity of that water, in
the downstream direction, is close to or equal to zero. This water is included
in the storage calculations and other wetted cross section parameters, but it is
not included as part of the active flow area. When using ineffective flow
areas, no additional wetted perimeter is added to the active flow area. An
example of an ineffective flow area is shown in Figure 6.3. The cross-
hatched area on the left of the plot represents the ineffective flow area.

Two alternatives are available for setting ineffective flow areas. The first
option allows the user to define a left station and elevation and a right station
and elevation (normal ineffective areas). When this option is used, and if
the water surface is below the established ineffective elevations, the areas to
the left of the left station and to the right of the right station are considered
ineffective. Once the water surface goes above either of the established
elevations, then that specific area is no longer considered ineffective. In other
words, the program now assumes that the area will be conveying water in the
downstream direction, such that it now uses that area in the conveyance
calculations of the active flow area.

The second option allows for the establishment of blocked ineffective flow
areas. Blocked ineffective flow areas require the user to enter an elevation, a
left station, and a right station for each ineffective block. Up to ten blocked
ineffective flow areas can be entered at each cross section. Once the water
surface goes above the elevation of the blocked ineffective flow area, the
blocked area is no longer considered ineffective.
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Levees. This option allows the user to establish a left and/or right levee
station and elevation on any cross section. When levees are established, no
water can go to the left of the left levee station or to the right of the right
levee station until either of the levee elevations are exceeded. Levee stations
must be defined explicitly, or the program assumes that water can go
anywhere within the cross section. An example of a cross section with a
levee on the left side is shown in Figure 6.4. In this example the levee station
and elevation is associated with an existing point on the cross section.

The user may want to add levees into a data set in order to see what effect a
levee will have on the water surface. A simple way to do this is to set a levee
station and elevation that is above the existing ground. If a levee elevation is
placed above the existing geometry of the cross section, then a vertical wall is
placed at that station up to the established levee height. Additional wetted
perimeter is included when water comes into contact with the levee wall. An
example of this is shown in Figure 6.5.
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Figure 6.5 Example Levee Added to a Cross Section
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Blocked Obstructions. This option allows the user to define areas of the
cross section that will be permanently blocked out. Blocked obstructions
decrease flow area and add wetted perimeter when the water comes in contact
with the obstruction. A blocked obstruction does not prevent water from
going outside of the obstruction.

Two alternatives are available for entering blocked obstructions. The first
option allows the user to define a left station and elevation and a right station
and elevation (normal blocked obstructions). When this option is used, the
area to the left of the left station and to the right of the right station will be
completely blocked out. An example of this type of blocked obstruction is

shown in Figure 6.6.
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Figure 6.6 Example of Normal Blocked Obstructions

The second option, for blocked obstructions, allows the user to enter up to 20
individual blocks (multiple blocked obstructions). With this option the user
enters a left station, a right station, and an elevation for each of the blocks.

An example of a cross section with multiple blocked obstructions is shown in

Figure 6.7.
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Figure 6.7 Example of a Cross Section With Blocked Obstruction

Add a Lid to XS. This option allows the user to add a lid (similar to a bridge
deck/roadway) to any cross section. This is commonly used when trying to
model a long tunnel. The ground geometry can be used to describe the
bottom half of the tunnel, while the lid can describe the top half. A lid can be
added to any number of cross sections in a row. The program treats cross
sections with lids just like any other cross section. The energy equation is
used to balance a water surface, with the assumption of open channel flow.
The only difference is that the program will subtract out area and add wetted
perimeter when the water surface comes into contact with the lid.

Add Ice Cover. This option allows the user to enter ice cover for the
currently opened cross section. For a detailed discussion of ice cover, and ice
modeling, please review the section called Modeling Ice Cover later in this
chapter.

Add a Rating Curve. This option allows the user to add a rating curve to a
cross section as an alternative to the program computing the water surface.
The user is required to enter flow versus elevation information for the rating
curve. When the program is executed in a steady flow mode, the program
will interpolate a water surface elevation from the rating curve for the given
flow of a particular profile.

Horizontal Variation in n Values. This option allows the user to enter more

than three Manning's n values for the current cross section. When this option

is selected, an additional column for n values is added to the cross section
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coordinates table as shown in Figure 6.8. A Manning's n value must be
placed in the first row of the table. This n value is good for all cross section
stations until a new n value shows up in the table. The user does not have to
enter an n value for every station, only at the locations where the n value is
changing.

" Cross Section Data ‘ Bridge - P/W

10Nn3

BBk

ContsExp Coefficients

Figure 6.8 Cross section with horizontal variation of n values selected

Horizontal Variation in k Values. This option allows the user to enter k
values (roughness heights) instead of n values. The k values are entered in
the same manner as the horizontal variation of n values. To learn more about
k values and how they are used in the program, see Chapter 3 of the
Hydraulic Reference manual.

Vertical Variation in n Values. This option allows the user to enter
Manning’s n values that vary both horizontally as well as vertically. The user
can vary the n value either by elevation or by flow. When this option is
selected a window will appear as shown in Figure 6.9. The user enters the
stationing for horizontal changes in n values across the top in row 0 (these
stations are entered in the same manner as the horizontal variation of
Manning’s n value option). The elevations in which changes occur are
entered in the first column. Then the actual Manning’s n values are entered in
rows 1-20 (columns 2-21). The program will interpolate Manning’s n values
whenever the actual water surface is between the entered elevations. If the
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water surface is below the first elevation entered, then the values from that
elevation will be used. Likewise, if the water surface is above the last
elevation entered, the program will use the n values from the last elevation
specified. No extrapolation is done on either side of the user entered values.
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2| 210 -|0.08 0.1 0.038 0.06
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220 0.085 0.08 0.032 {005

e

Figure 6.9 Vertical Variation of Manning’s n Values Window

Plotting Cross Section Data

Once all the data have been entered for a cross section, you should plot the
cross section to inspect it for possible data errors. To plot the current cross
section from the cross section editor, select Plot Cross Section from the Plot

menu.

Stream Junctions

6-20

Entering Junction Data

Stream junctions are defined as locations where two or more streams come
together or split apart. Junction data consist of a description, reach lengths
across the junction, tributary angles, and modeling approach. To enter
junction data the user presses the Junction button on the Geometric Data
window (Figure 6.1). Once the junction button is pressed, the junction editor
will appear as shown in Figure 6.10.
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Figure 6.10 Junction Data Editor

The junction editor will come up with one of the junctions loaded. Fill out the
description and reach lengths for the junction. Reach lengths across the
junction are entered here instead of the cross section data editor. This allows
for the lengths across very complicated confluences (i.e., flow splits) to be
accommodated. In the cross section data, the reach lengths for the
downstream cross section of each reach should be left blank or set to zero.

Selecting A Modeling Approach

In HEC-RAS a junction can be modeled by either the energy equation or the
momentum equation. The energy equation does not take into account the
angle of a tributary coming in or leaving, while the momentum equation does.
In most cases the amount of energy loss due to the angle of the tributary flow
is not significant, and using the energy equation to model the junction is more
than adequate. However, there are situations where the angle of the tributary
can cause significant energy losses. In these situations it would be more
appropriate to use the momentum approach. When the momentum approach
is selected, an additional column is added to the table next to the junction
lengths. This column is used to enter an angle for any river reach that is
coming into or exiting the main river. For the reaches that are considered to
be the main river, the angle should be left blank or set to zero. Also, the user
has the option to turn friction and weight forces on or off during the
momentum calculations. The default is to have the weight force turned off.

If there is more than one junction in the river schematic, the other junctions
can be selected from the Junction Name box at the upper left corner of the
window. Enter all the data for each junction in the river system, then close
the window by pressing the OK button in the lower left corner of the window.
When the junction data editor is closed the data are automatically applied.
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Bridges and Culverts
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Once all of the necessary cross-section data have been entered, the modeler
can then add any bridges or culverts that are required. HEC-RAS computes
energy losses caused by structures such as bridges and culverts in three parts.
One part consists of losses that occur in the reach immediately downstream
from the structure where an expansion of flow takes place. The second part is
the losses at the structure itself, which can be modeled with several different
methods. The third part consists of losses that occur in the reach immediately
upstream of the structure where the flow is contracting to get through the
opening.

The bridge routines in HEC-RAS allow the modeler to analyze a bridge with
several different methods without changing the bridge geometry. The bridge
routines have the ability to model low flow (Class A, B, and C), low flow and
weir flow (with adjustments for submergence), pressure flow (orifice and
sluice gate equations), pressure and weir flow, and high flows with the energy
equation only. The model allows for multiple bridge and/or culvert openings
at a single location.

The culvert hydraulics in HEC-RAS are based on the Federal Highway
Administrations (FHWA) standard equations from the publication Hydraulic
Design of Highway Culverts (FHWA, 1985). The culvert routines include the
ability to model circular, box, elliptical, arch, pipe arch, low profile arch, high
profile arch, and semi circular culverts. The HEC-RAS program has the
ability to model multiple culverts at a single location. The culverts can have
different shapes, sizes, elevations, and loss coefficients. The user can also
specify the number of identical barrels for each culvert type.

Cross Section Locations

The bridge and culvert routines utilize four user defined cross sections in the
computations of energy losses due to the structure. A plan view of the basic
cross section layout is shown in Figure 6.11.

Cross section 1 is located sufficiently downstream from the structure so that
the flow is not affected by the structure (i.e., the flow has fully expanded).
This distance should generally be determined by field investigation during
high flows. Generally, field investigation during high flows is not possible.
The expansion distance will vary depending upon the degree of constriction,
the shape of the constriction, the magnitude of the flow, and the velocity of
the flow. Table 6.1 offers ranges of expansion ratios, which can be used for
different degrees of constriction, different slopes, and different ratios of the
overbank roughness to main channel roughness. Once an expansion ratio is
selected, the distance to the downstream end of the expansion reach (the
distance L. on Figure 6.11) is found by multiplying the expansion ratio by the
average obstruction length (the average of the distances A to B and C to D
from Figure 6.11).
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Figure 6.11 Cross Section Locations at a Bridge or Culvert

The average obstruction length is half of the total reduction in floodplain
width caused by the two bridge approach embankments. In Table 6.1, b/B is
the ratio of the bridge opening width to the total floodplain width, ng is the
Manning #n value for the overbank, 7. is the n value for the main channel, and
S is the longitudinal slope. The values in the interior of the table are the
ranges of the expansion ratio. For each range, the higher value is typically
associated with a higher discharge.

Table 6.1
Ranges of Expansion Ratios
Nob / D= Nop / D=2 Nop / Ne=4

b/B =0.10 S =1 ft/mile 14-3.6 1.3-3.0 12-21
5 ft/mile 1.0-25 0.8-2.0 0.8-2.0

10 ft/mile 1.0-22 0.8-2.0 0.8-2.0

b/B =0.25 S =1 f/mile 1.6-3.0 14-25 1.2-2.0
5 ft/mile 1.5-25 1.3-2.0 13-20

10 ft/mile 1.5-2.0 1.3-2.0 1.3-2.0

b/B =0.50 S =1 ft/mile 14-2.6 1.3-1.9 12-14
5 ft/mile 1.3=2.d 1.2-1.6 1.0-14

10 ft/mile 1.3-2.0 1.2-15 1.0-14
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A detailed study of flow contraction and expansions at bridges was
undertaken by the Hydrologic Engineering Center. The results of this study
have been published as a research document entitled "Flow Transitions in
Bridge Backwater Analysis" (RD-42 HEC, 1995). The purpose of this study
was to provide better guidance to hydraulic engineers performing water
surface profile computations through bridges. Specifically the study focused
on determining the expansion reach length, L.; the contraction reach length,
L.; the expansion energy loss coefficient, C,; and the contraction energy loss
coefficient, C.. A summary of this research, and the final recommendations,
can be found in Appendix B of the HEC-RAS Hydraulic Reference manual.

The user should not allow the distance between cross section 1 and 2 to
become so great that friction losses will not be adequately modeled. If the
modeler feels that the expansion reach will require a long distance, then
intermediate cross sections should be placed within the expansion reach in
order to adequately model friction losses. The user will need to estimate
ineffective flow areas for these intermediate cross sections.

Cross section 2 is located immediately downstream from the bridge (i.e.,
within a few feet). This cross section should represent the natural ground just
outside the bridge. This section is normally located at the toe of the
downstream bridge embankment.

Cross section 3 should be located just upstream from the bridge. The
distance between cross section 3 and the bridge should be relatively short.
This distance should only reflect the length required for the abrupt
acceleration and contraction of the flow that occurs in the immediate area of
the opening. Cross section 3 represents the natural ground just upstream of
the bridge. This section is normally located at the toe of the upstream bridge
embankment.

Both cross sections 2 and 3 will have ineffective flow areas to either side of
the bridge opening during low flow and pressure flow. In order to model only
the effective flow areas at these two sections, the modeler should use the
ineffective flow area option. This option is selected from the cross section
data editor. For a detailed discussion of how to set the ineffective flow area
stations and elevations, see Chapter 5 of the Hydraulic Reference manual.

Cross section 4 is an upstream cross section where the flow lines are
approximately parallel and the cross section is fully effective. In general,
flow contractions occur over a shorter distance than flow expansions. The
distance between cross section 3 and 4 (the contraction reach length, L)
should generally be determined by field investigation during high flows.
Traditionally, the Corps of Engineers recommends locating the upstream
cross section a distance equal to one times the average length of the side
constriction caused by the structure abutments. The contraction distance will
vary depending upon the degree of constriction, the shape of the constriction,
the magnitude of the flow, and the velocity of the flow. As mentioned
previously, the detailed study "Flow Transitions in Bridge Backwater
Analysis" (RD-42, HEC, 1995) was performed to provide better guidance to
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hydraulic engineers performing water surface profile computations through
bridges. A summary of this research, and the final recommendations, can be
found in Appendix B of the HEC-RAS Hydraulic Reference manual.

When the user adds a bridge at a particular river station, the program
automatically formulates two additional cross sections inside of the bridge
structure. The geometry inside of the bridge is a combination of the bounding
cross sections (2 and 3) and the bridge geometry. The bridge geometry
consists of the bridge deck, abutments if necessary, and any piers that may
exist. The user can specify different bridge geometry for the upstream and
downstream sides of the structure if necessary. Cross section 2 and the
structure information on the downstream side are used as the geometry just
inside the structure at the downstream end. Cross section 3 and the upstream
structure information are used as the bridge geometry just inside the structure
at the upstream end. The user has the option to edit these internal bridge
cross sections, in order to make adjustments to the geometry.

For a more detailed discussion on laying out cross sections around bridges,
the user is referred to chapter 5 of the Hydraulic Reference Manual.

Contraction and Expansion Losses

Losses due to the contraction and expansion of flow between cross sections
are determined during the standard step profile calculations. Contraction and
Expansion losses are described in terms of coefficient times the absolute
value of the change in velocity head between adjacent cross sections. When
the velocity head increases in the downstream direction a contraction
coefficient is used; and when the velocity head decreases in the downstream
direction, an expansion coefficient is used. For a detailed discussion on
selecting contraction and expansion coefficients at bridges, the user is
referred to chapter 5 of the HEC-RAS Hydraulic Reference Manual.

Bridge Hydraulic Cbmputations

Low Flow Computations. For low flow computations the program first uses
the momentum equation to identify the class of flow. This is accomplished
by first calculating the momentum at critical depth inside the bridge at the
upstream and downstream ends. The end with the higher momentum
(therefore most constricted section) will be the controlling section in the
bridge. The momentum at critical depth in the controlling section is then
compared to the momentum of the flow downstream of the bridge when
performing a subcritical profile (upstream of the bridge for a supercritical
profile). If the momentum downstream is greater than the critical depth
momentum inside the bridge, the class of flow is considered to be completely
subcritical (i.e., class A low flow). If the momentum downstream is less than
the momentum at critical depth in the bridge, then it is assumed that the
constriction will cause the flow to pass through critical depth and a hydraulic
jump will occur at some distance downstream (i.e., class B low flow). Ifthe
profile is completely supercritical through the bridge then this is class C low
flow. Depending on the class of flow the program will do the following:
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. Class A low flow. Class A low flow exists when the water surface through
. the bndge is completely suberitical (i.e., above critical depth). Energy losses
- through the .expansion (sectlons 2to 1) are calculated as friction losses and

expansion losses Friction losses are based on a weighted friction slope times
a weighted reach length between sections 1 and 2. The average friction slope
is. based on one of the four available altemat1ves in HEC-RAS, with the
average- conveyance method being the default. This, .option is user selectable.
The average length used in the calculatlon 1s based on a discharge-weighted
reach length. -

| There At four methods for computinglosses through the bridge (from 2 to 3):

- Energy equation (standard step method)
- Moment}nn_ balance

 Yarnell equation

- FHWA WSPRO method

The user can select any or all of these methods in the computations. If more
than one method is selected, the user must choose either a single method as

the final solution or tell the program to use the method that computes the

) greatest energy loss through the bridge as the answer at section 3. This
~ allows the modeler to | compare the answers from several techniques all in a
""smgle execution of the program. Mmlmal results are available for all the
~methods computed, but detailed results are available for the method that is

selected as the final answer. ‘

iy ,Energy losses through the contraction (sectlons 3 to 4) are calculated as
3 &1ct10n losses and contraction losses. Friction and contraction losses between
sections 3 and 4 are calculated the same as friction and expansion losses

between sections 1 and 2.

Class B low flow. Class B low flow can exist for either subcritical or
supercritical profiles: For either profile, class B flow occurs when the profile
passes through critical depth in the bridge constriction. For a subcritical
profile, the momentum equation is used to-compute an upstream water
surface above critical depth and a downstream water surface below critical
depth, using a momentum balance through-the bridg'e For a supercritical

“profile, the bridge is acting as a ¢ontrol and is causing the upstream water

surface elevation to be above critical depth. Momentum is used again to
calculate an upstream water surface above eritical depth and a downstream
water surface below critical depth. The program will proceed with forewater
calculations downstream from the bridge.”

Class C low flow. Class C low flow exists when the water surface through

the bridge is completely supercritical. ‘The program can use either the energy
or the momentum equatmn to compute the water surface through the bridge.
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Pressure Flow Computations. Pressure flow occurs when the flow comes
into contact with the low chord of the bridge. Once the flow comes into
contact with the upstream side of the bridge, a backwater occurs and orifice
flow is established. The program will handle two cases of orifice flow: the
first is when only the upstream side of the bridge is in contact with the water;
and the second is when the bridge constriction is flowing completely full. For
the first case, a sluice gate type of equation is used, as described in
"Hydraulics of Bridge Waterways" (FHWA, 1978). In the second case, the
standard full flowing orifice equation is used. The program will begin
checking for the possibility of pressure flow when the energy grade line goes
above the maximum low chord elevation. Once pressure flow is computed,
the pressure flow answer is compared to the low flow answer and the higher
of the two is used. The user has the option to tell the program to use the
water surface, instead of energy, to trigger the pressure flow calculation.

Weir Flow Computations. Flow over the bridge and the roadway
approaching the bridge will be calculated using the standard weir equation.
For high tailwater elevations the program will automatically reduce the
amount of weir flow to account for submergence on the weir. This is
accomplished by reducing the weir coefficient based on the amount of
submergence. When the weir becomes highly submerged, the program will
automatically switch to calculating losses based on the energy equation
(standard step backwater). The criteria for when the program switches to
energy based calculations is user controllable.

Combination Flow. Sometimes combinations of low flow or pressure flow
occur with weir flow. In these cases an iterative procedure is used to
determine the amount of each type of flow.

Entering and Editing Bridge Data

To enter bridge data the user presses the Bridge/Culvert button on the
geometric data window (Figure 6.1). Once the bridge/culvert button is
pressed, the Bridge/Culvert Data Editor will appear as shown in Figure 6.12
(your bridge/culvert editor will come up with a blank window until you have
entered the bridge data). To add a bridge to the model, do the following:

1. Select the river and reach that you would like to place the bridge in.
Selecting a reach is accomplished by pressing the down arrow on the
river and reach box, then selecting the river and reach of choice.

2; Go to the Options menu and select Add a Bridge and/or Culvert
from the list. An input box will appear prompting you to enter a river
station identifier for the new bridge.

3. Enter all of the required data for the new bridge. This includes:
- Bridge Deck
- Sloping Abutments (optional)
- Piers (optional)
- Bridge modeling approach information
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4, Enter any desired optional information. Optional bridge information
is found under the Options menu at the top of the window.

5. Press the Apply Data button for the interface to accept the data.
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Figure 6.12 Bridge/Culvert Data Editor

The required information for a bridge consists of: the river, reach, and river
station identifiers; a short description of the bridge; the bridge deck; bridge
abutments (if they exist); bridge piers (if the bridge has piers); and specifying
the bridge modeling approach. A description of this information follows:

River, Reach and River Station. The River and Reach boxes allow the user
to select a river and reach from the available reaches that are defined in the
schematic diagram. The reach label defines which reach the bridge will be
located in. The River Station tag defines where the bridge will be located
within the specified reach. The river station tag does not have to be the actual
river station of the bridge, but it must be a numeric value. The river station
tag for the bridge should be numerically between the two cross sections that
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bound the bridge. Once the user selects Add a Bridge and/or Culvert from
the options menu, an input box will appear prompting you to enter a river
station tag for the new bridge. After the river station tag is entered, the two
cross sections that bound the bridge will be displayed on the editor.

Description. The description box is used to describe the bridge location in
more detail than just the reach and river station. This box has a limit of 256
characters. Only the first line of information is displayed, unless the button to
the right of the box is pressed. Also, the first 40 characters of the description
are used as a label for bridge plots and tables.

Bridge Deck/Roadway. The bridge deck editor is used to describe the area
that will be blocked out due to the bridge deck, road embankment and vertical
abutments. To enter bridge deck information the user presses the Deck
button on the Bridge/Culvert Data Editor. Once the deck button is pressed,
the Deck Editor will appear as in Figure 6.13 (except yours will be blank).
The information entered in the deck editor consists of the following:

Decka"cuad-m-.i';r Data Editor

Dpstream
216.93
216.93
216.93
216.93
216.93
216.93

Distance - The distance field is used to enter the distance between the
upstream side of the bridge deck and the cross section immediately upstream
of the bridge. This distance is entered in feet (or meters for metric).

Width - The width field is used to enter the width of the bridge deck along the
stream. The distance between the bridge deck and the downstream bounding
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cross section will equal the main channel reach length minus the sum of the
bridge "width" and the "distance" between the bridge and the upstream
section. The width of the bridge deck should be entered in feet (meters for
metric).

Weir Coefficient - Coefficient that will be used for weir flow over the bridge
deck in the standard weir equation.

Upstream Stationing, High Chord, and Low Chord - This table is used to
define the geometry of the bridge deck on the upstream side of the bridge.
The information is entered from left to right in cross section stationing. The
deck is the area between the high and low chord elevation information. The
stationing of the deck does not have to equal the stations in the bounding
cross section, but it must be based on the same origin. The Del Row and Ins
Row buttons allow the user to delete and insert rows.

Downstream Stationing, High Chord, and Low Chord - This portion of the
table is used to define the geometry of the bridge deck on the downstream
side of the bridge. If the geometry of the downstream side is the same as the
upstream side, then the user only needs to press the Copy Up to Down
button. When this button is pressed, all of the upstream bridge deck
information is copied to the downstream side. If the bridge deck information
on the downstream side is different than the upstream side, then the user must
enter the information into the table.

U.S. Embankment SS - This field is used to enter the slope of the road
embankment on the upstream side of the bridge. The slope should be entered
as the horizontal to vertical distance ratio of the embankment. This variable
is generally not used in the computations, but is used for display purposes in
the profile plot. However, if the user has selected the FHWA WSPRO bridge
method for low flow, this field will be used in the computation of the bridge
discharge coefficient.

D.S. Embankment SS - This field is used to enter the slope of the road
embankment on the downstream side of the bridge. The slope should be
entered as the horizontal to vertical distance ratio of the embankment. This
variable is generally not used in the computations, but is used for display
purposes in the profile plot. However, if the user has selected the FHWA
WSPRO bridge method for low flow, this field will be used in the
computation of the bridge discharge coefficient.

Max Allowable Submergence - The maximum allowable submergence ratio
that can occur during weir flow calculations over the bridge deck. If this ratio
is exceeded, the program automatically switches to energy based calculations
rather than pressure and weir flow.

Submergence Criteria - When submergence occurs there are two choices
available to figure out how much the weir coefficient should be reduced due
to the submergence. The first method is based on work that was done on a
trapezoidal shaped broad crested weir (FHWA, 1978). The second criterion
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was developed for an Ogee spillway shape (COE,1965). The user should
pick the criterion that best matches their problem.

Min Weir Flow EI - This field is used to set the minimum elevation for which
weir flow will begin to be evaluated. Once the computed upstream energy
becomes higher than this elevation, the program begins to calculate weir flow.
However, the weir flow calculations are still based on the actual geometry of
the deck/roadway, and are not effected by this elevation. If this field is left
blank, the elevation that triggers weir flow is based on the lowest high chord
elevation on the upstream side of the bridge deck. Also, weir flow is based
on the elevation of the energy grade line and not the water surface.

Once all of the bridge deck information is entered, the user should press the
OK button at the bottom of the window. Pressing the OK button tells the
interface to accept the data and close the window. Once the deck editor
closes, the graphic of the bridge deck will appear on the Bridge/Culvert Data
window. An example of this is shown in Figure 6.14. Note! The data are
not saved to the hard disk at this point. Geometric data can only be saved
to the hard disk from the File menu of the Geometric Data window.
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Sloping Bridge Abutments. The sloping bridge abutments editor is used to
supplement the bridge deck information. Whenever bridge abutments are
protruding towards the main channel (sloping inward abutments), it will be
necessary to block out additional area that cannot be accounted for in the
bridge deck/roadway editor. If the bridge has vertical wall abutments, then it
is not necessary to use this editor. Vertical wall abutments can be included as
part of the bridge deck/roadway data. To add sloping abutments, the user
presses the Sloping Abutment button on the Bridge/Culvert Data editor.
Once this button is pressed the Abutment data editor will appear as in Figure
013

Sloping abutments are entered in a similar manner to the bridge
deck/roadway. When the editor is open, it has already established an
abutment # of 1. Generally a left and right abutment are entered for each
bridge opening. Sloping abutment data are entered from left to right, looking
in the downstream direction. In general it is usually only necessary to enter
two points to describe each abutment.

Figure 6.15 Abutment Data editor

The data for each abutment consist of a skew angle (this is optional) and the
station and elevation information. The station and elevation information
represents the high chord information of the abutment. The low chord
information of the abutment is assumed to be below the ground, and it is
therefore not necessary to enter it. The geometric information for each
abutment can vary from upstream to downstream. If this information is the
same, then the user only needs to enter the upstream geometry and then press
the Copy Up to Down button.
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To add additional sloping abutments, the user can either press the ADD or the
Copy button. To delete an abutment, press the Delete button. Once all of the
abutment data are entered, the user should press the OK button. When the
OK button is pressed, the abutment information is accepted and the editor is
closed. The abutments are then added to the bridge graphic on the
Bridge/Culvert Data editor. An example of a sloping bridge abutment is

o shown in Figure 6.16. This graphic is zoomed in on the left abutment of the
bridge.

LBr

Legend
2

Ground
e

Ineff
*
Bank Sta

Elevation (1)

2460
Station (ft)

Figure 6.16 Example of a Sloping Abutment

Bridge Piers. The bridge pier editor is used to describe any piers that exist in
the bridge opening. Note! All piers must be entered through the Pier
Editor, they should not be included as part of the ground or bridge deck.
Several of the low flow bridge computations require that the piers be defined
separately in order to determine that amount of area under the water surface

. that is blocked by the piers. If the piers are included with the ground or the
bridge deck, several of the methods will not compute the correct amount of
energy loss for the piers.
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To enter pier information, the user presses the Pier button on the
Bridge/Culvert Data editor. Once the pier button is pressed, the pier data
editor will appear as in Figure 6.17 (except yours will not have any data in it

yet).

Downstream

Figure 6.17 Per Data Editor

When the pier data editor appears it will have already defined the first pier as
pier # 1. The user is required to enter a centerline station for both the
upstream and downstream side of the pier. The skew angle is entered in
degrees that the pier is skewed from a line parallel to the flow. The skew
angle is an optional item. The pier geometry is entered as pier widths and
elevations. The elevations must start at the lowest value and go to the highest
value. Generally the elevations should start below the ground level. Any pier
area below the ground will be clipped off automatically. Pier widths that
change at a single elevation are handled by entering two widths at the same
elevation. The order of the widths in the table is very important. Keep in
mind that the pier is defined from the ground up to the deck. If the pier
geometry on the downstream side is the same as the upstream side, simply
press the Copy Up to Down button after the upstream side data are entered.
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The user also has the option of defining floating pier debris. If the Floating
Debris option is selected, two boxes will appear allowing the user to enter a
width and a height for the debris. The user can set a different height and
width of debris for each pier, or there is a button that will allow the user to
enter a single height and width that will be used for all of the piers.

Additional piers can be added by pressing either the Add or the Copy button.
If the piers are the same shape, it is easier to use the copy button and simply
change the centerline stations of the new pier. To delete a pier, simply press
the Delete button and the currently displayed pier will be deleted. Once all of
the pier data are entered, press the OK button. When the OK button is
pressed, the data will be accepted and the pier editor will be closed. The
graphic of the bridge will then be updated to include the piers. An example
bridge with piers is shown in Figure 6.18. This graphic is only the upstream
side of the bridge with a zoomed in view.
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Figure 6.18 Bridge with Piers, zoomed in view
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Bridge Modeling Approach. The Bridge Modeling Approach editor is used
to define how the bridge will be modeled and to enter any coefficients that are
necessary. To bring up the Bridge Modeling Approach editor press the
Bridge Modeling Approach button on the Bridge/Culvert Data editor. Once
this button is pressed, the editor will appear as shown in Figure 6.19 (except
yours will only have the default methods selected).

Bridge Hodeling Apprdach Editor

Figure 6.19 Bridge Modeling Approach Editor

When the Bridge Modeling Approach editor comes up it will be ready to
enter data for the first bridge opening (coefficient set # 1). If there is more
than one bridge opening at the current location, the user can either use a
single set of modeling approaches and coefficients, or establish a different set
for each bridge opening.

Establishing a bridge modeling approach consists of defining which methods
the program will use for low flow computations and high flow (flow at or
above the maximum low chord) computations. The user can instruct the
program to use any or all of the low flow methods during the computations by
clicking the buttons under the Compute column. If either the Momentum or
Yarnell method are selected, the user must enter a value for the pier loss
coefficient that corresponds to that method. If the WSPRO method is
selected, the user must press the "WSPRO Variables" button and enter
additional information that is required for the method. Once the WSPRO
Variables button is pressed, a data editor as shown in Figure 6.20 will
appear.
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. Figure 6.20 WSPRO Data Editor

As shown in Figure 6.20, there are several variables that must be entered as
well as some options that are available to the user. All of the required
variables shown on the WSPRO data editor are used in the computation of the
discharge coefficient, C, which is used in the WSPRO expansion loss
equation. A detailed discussion of how the discharge coefficient is computed
can be found in appendix D of the HEC-RAS Hydraulic Reference manual.
The following is a description of each of the variables on the WSPRO Data
Editor:

El of the top of the Embankment - These fields are used for entering the
elevation of the top of the embankment (top of road) at the edges of the
bridge opening. An elevation must be entered for both the left and right side
of the bridge opening.

El of the toe of the Abutment - These fields are used for entering the elevation
of the abutment toe (elevation at the station in which the abutment toe
intersects with the natural ground inside the bridge opening) on both the left
and right side of the bridge opening.

Abutment Ty