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Many of the HEC staff made contributions in the development of this software,
including: Vern R. Bonner, Richard Hayes, John Peters, and Michael Gee. Mr.
Darryl Davis was the director during the development of this software.

This manual was written by Mr. Gary W. Brunner.

- The HEC-RAS software was developed at the Hydrologic Engineering Center (HEC).I
The software was designed by Mr. Gary W. Brunner, leader of the HEC-RAS
development team. The user interface and graphics were programmed by Mr. Mark
R. Jensen. The steady flow water surface profiles module was programmed by Mr.
Steven S. Piper. The routines that import HEC-2 data were developed by Ms. Joan
Klipsch. The cross section interpolation routines were developed by Mr. Alfredo
Montalvo. The routines for modeling ice cover and wide river ice jams were
developed by Mr. Steven F. Daly of the Cold Regions Research and Engineering
Laboratory (CRREL). The Example Applications Manual was put together by Mr.
John W. Warner and Mr. Gary W. Brunner.
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Chapter i introduction

CHAPTER 1

Introductfon

Welcome to the Hydrologic Engineering Center's River Analysis System
(HEC-RAS). This software allows you to perform one-dimensional steady
flow, unsteady flow, and sediment transport calculations (The current version
of HEC-RAS can only perform steady flow calculations. Unsteady flow and
sediment transport will be added in future versions).

The HEC-RAS modeling system was developed as a part of the Hydrologic
Engineering Center's "Next Generation" (NexGen) of hydrologic engineering
software. The NexGen project encompasses several aspects of hydrologic
engineering, including: rainfall-runoff analysis; river hydraulics; reservoir
system simulation; flood damage analysis; and real-time river forecasting for
reservoir operations.

This chapter discusses the general philosophy of HEC-RAS and gives you a
brief overview of the capabilities of the modeling system. Documentation for
HEC-RAS is discussed, as well as an overview of this manual.

Contents

• General Philosophy of the Modeling System

• Overview of Program Capabilities

• HEC-RAS Documentation

• Overview of This Manual
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Chapter Introduction

General Philosophy of the Modeling System

HEC-RAS is an integrated system of software, designed for interactive use in
a multi-tasking, multi-user network environment. The system is comprised of
a graphical user interface (GUI), separate hydraulic analysis components, data
storage and management capabilities, graphics and reporting facilities.

The HEC-RAS system will ultimately contain three one-dimensional
hydraulic analysis components for: (1) steady flow water surface profile
computations; (2) unsteady flow simulation; and (3) movable boundary
sediment transport computations. A key element is that all three components
will use a common geometric data representation and common geometric and
hydraulic computation routines. In addition to the three hydraulic analysis
components, the system contains several hydraulic design features that can be
invoked once the basic water surface profiles are computed.

The current version of HEC-RAS only supports Steady Flow water surface
profile calculations. New features and additional capabilities will be added in
future releases.

Oveliview of Program Capabilities

HEC-RAS is designed to perform one-dimensional hydraulic calculations for
a full network of natural and constructed channels. The following is a
description of the major capabilities of HEC-RAS.

User Interface

The user interacts with HEC-RAS through a graphical user interface (GUI).
The main focus in the design of the interface was to make it easy to use the
software, while still maintaining a high level of efficiency for the user. The
interface provides for the following functions:

• File management

• Data entry and editing

• Hydraulic analyses

• Tabulation and graphical displays of input and output data

• Reporting facilities

• On-line help

1-2
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Chapter 1 Introduction

Hydraulic Analysis Components

- Steady Flow Water Surface Profiles. This component of the modeling system
is intended for calculating water surface profiles for steady gradually varied
flow. The system can handle a full network of channels, a dendritic system,
or a single river reach. The steady flow component is capable of modeling
subcritical, supercritical, and mixed flow regime water surface profiles.

The basic computational procedure is based on the solution of the one­
dimensional energy equation. Energy losses are evaluated by friction
(Manning's equation) and contraction/expansion (coefficient multiplied by the
change in velocity head). The momentum equation is utilized in situations
where the water surface profile is rapidly varied. These situations include
mixed flow regime calculations (i.e., hydraulic jumps), hydraulics of bridges,
and evaluating profiles at river confluences (stream junctions).

The effects of various obstructions such as bridges, culverts, weirs, and
structures in the flood plain may be considered in the computations. The
steady flow system is designed for application in flood plain management and
flood insurance studies to evaluate floodway encroachments. Also,
capabilities are available for assessing the change in water surface profiles
due to channel improvements, and levees.

Special features of the steady flow component include: multiple plan analyses;
multiple profile computations; and multiple bridge and/or culvert opening
analysis.

Unsteady Flow Simulation. This component of the HEC-RAS modeling
system will be capable of simulating one-dimensional unsteady flow through
a full network of open channels. The unsteady flow equation solver will be
adapted from Dr. Robert L. Barkau's UNET model (Barkau, 1992 and HEC,
1993). This unsteady flow component was developed primarily for
subcritical flow regime calculations.

The hydraulic calculations for cross-sections, bridges, culverts, and other
hydraulic structures that were developed for the steady flow component will
be"incorporated into the unsteady flow module. Additionally, the unsteady
flow component will have the ability to model storage areas, navigation dams,
tunnels, pumping stations, and levee failures.

Sediment Transport/Movable Boundary Computations. This component of
the modeling system is intended for the simulation of one-dimensional
sediment transport/movable boundary calculations resulting from scour and
deposition over moderate time periods (typically years, although applications
to single flood events are possible).

1-3
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1-4

The sediment transport potential is computed by grain size fraction, thereby
allowing the simulation of hydraulic sorting and armoring. Major features

. will include the ability to model a full network of streams, channel dredging,
various levee and encroachment alternatives, and the use of several different
equations for the computation of sediment transport.

The model will be designed to simulate long-term trends of scour and
deposition in a stream channel that might result from modifying the frequency
and duration of the water discharge and stage, or modifying the channel
geometry. This system can be used to evaluate deposition in reservoirs,
design channel contractions required to maintain navigation depths, predict
the influence of dredging on the rate of deposition, estimate maximum
possible scour during large flood events, and evaluate sedimentation in fixed
channels.

Data Storage and Management

Data storage is accomplished through the use of "flat" files (ASCII and
binary). User input data are stored in flat files under separate categories of
project, plan, geometry, steady flow, unsteady flow, and sediment data.
Output data is predominantly stored in separate binary files.

Data management is accomplished through the user interface. The modeler is
requested to enter a single filename for the project being developed. Once the
project filename is entered, all other files are automatically created and named
by the interface as needed. The interface provides for renaming, moving, and
deletion of files on a project by project basis.

Graphics and Reporting

Graphics include X-Y plots of the river system schematic, cross-sections,
profiles, rating curves, hydrographs, and many other hydraulic variables. A
three-dimensional plot of multiple cross-sections is also provided. Tabular
output is available. Users can select from pre-defined tables or develop their
own customized tables. All graphical and tabular output can be displayed on
th~ screen, sent directly to a printer (or plotter), or passed through the
Windows Clipboard to other software, such as a word-processor or
spreadsheet.

Reporting facilities allow for printed output of input data as well as output
data. Reports can be customized as to the amount and type of information
desired.

I
I
,I
I
1,

I
I
I
I
I
I
I
I
1
I
I
I
I,
I



Chapter I Introduction

Documentation Description

• Chapters 1-2 provide an introduction and overview of HEC-RAS, as
well as instructions on how to install the software.

Overview of T is Manual

1-5

Chapters 3-5 describe how to use the HEC-RAS software in a step­
by-step procedure, including a sample problem that the user can
follow along with. Understanding how this system works with
projects is also discussed.

User's Manual This manual is a guide to using HEC-RAS.
The manual provides an introduction and
overview of the modeling system, installation
instructions, how to get started, a simple
example, detailed descriptions of each of the
major modeling components, and how to view
graphical and tabular output.

•

Applications Guide This document contains a series of examples
that demonstrate various aspects of HEC­
RAS. Each example consists of a problem
statement, data requirements, general outline
of solution steps, displays of key iJ?put and
output screens, and discussions of important
modeling aspects.

Hydraulic Reference Manual This manual describes the theory and data
requirements for the hydraulic calculations
performed by HEC-RAS. Equations are
presented along with the assumptions used in
their derivation. Discussions are provided on
how to estimate model parameters, as well as
guidelines on various modeling approaches.

This user's manual is the primary piece of documentation on how to use the
HEC-RAS system. The manual is organized as follows:

- The HEC-RAS package includes several documents. Each document is
designed to help the modeler learn to use a particular aspect of the modeling
system. The documentation has been broken up into the following three
categories:

HEC-RAS Doc mentation
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•

•

•

•

•

•

•

•

•

•

Chapters 6-7 explain in detail how to enter and edit data, and how to
perform the different types of analyses that are available.

Chapter 8 provides detailed discussions on how to view graphical and
tabular output, as well as how to develop user defined tables.

Chapter 9 describes how to perform a floodway encroachment
analysis.

Chapter 10 provides discussions on "Trouble Shooting" and
understanding the most common Errors, Warnings, and Notes.

Chapter 11 describes how to perform bridge scour computations from
within HEC-RAS.

Chapter 12 describes how to perform channel modifications within
HEC-RAS.

Chapter 13 explains how to utilize GIS/CADD data in HEC-RAS, as
well as how to export HEC-RAS results back to the GIS/CADD
system.

Appendix A contains a list of references.

Appendix B contains a detailed description of the file formats used for
importing and exporting GIS data to and from HEC-RAS.

Appendix C contains a description of all the output variables available
from the HEC-RAS program.
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Chapter 2 Installing HEC-RAS

CHAPTER 2

Installing HEC-RAS

You install HEC-RAS using the program SETUP.EXE. The Setup program
installs the software, sample applications, and the Help system.

This chapter discusses the hardware and system requirements needed to use
HEC-RAS, how to install the software, and how to uninstall the software.

Contents

• Hardware and Software Requirements

• Installation Procedure

• Uninstall Procedure

Important

You cannot simply copy files from the distribution disks to your hard disk and
run HEC-RAS. You must use the Setup program, which decompresses and
installs the files to the appropriate directories.

2-1



Chapter 2 {nstalling HEC-RAS

Hard1are and Software Requirements

Before you install the HEC-RAS software, make sure that your computer has
at least the minimum required hardware and software. In order to get the
maximum performance from the HEC-RAS software, recommended hardware
and software is shown in parentheses. This version of HEC-RAS will run on
a microcomputer that has the following:

• Any IBM or compatible machine with an 80486 processor or higher
(a Pentium or higher is recommended).

• A hard disk with at least 10 megabytes of free space (20 megabytes or
more is recommended).

• A 3 Yz" floppy drive.

• A minimum of 16 megabytes of RAM if using Windows 95 or 24
megabytes if using Windows NT (32 or more is recommended).

• A mouse.

• Color VGA or better Video Display (Recommend running in Super
VGA (800x600) or higher, and as large a monitor as possible).

• MS Windows 95 or Windows NT 4.0 (or later versions).

Insta lation Procedure

Installation of the HEC-RAS software is accomplished through the use of the
Setup program. When you run the Setup program, you will be asked to set a
path for the program and data files. A suggested directory of "\HEC\RAS"
will be provided. You may choose to use this directory name or provide one
of your own.

To install the software onto your hard disk from Windows 95 or
Windows NT 4.0, do the following:

1. Insert Disk 1 into the A drive (or B if necessary).

2. Press the Start button in the lower left comer of the screen, then
select the Run option from the menu.

3. Type a:setup (or b:setup if disk 1 is in the B drive) and press
ENTER.

2-2
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Chapter 2 Installing HEC-RAS

4. Follow the setup instructions on the screen.

_ The setup program automatically creates a program group called HEC. This
program group will be listed under the Programs menu, which is under the
Start menu. The HEC-RAS program icon will be contained within the HEC
program group. The user can create a shortcut icon by opening Windows
Explorer and dragging the HEC-RAS executable onto the desktop. The
HEC-RAS executable can be found in the \hec\ras directory with the name
"RAS.EXE".

Uninstall Procedure

The HEC-RAS Setup program automatically registers the software with the
Windows operating system. To unistall the software, do the following:

• From the Start Menu select Settings and then Control Panel.

• From within the Control Panel folder select AddlRemove Programs.

• From the Tab marked as InstalVUninstall select the HEC-RAS
program from the list of installed software, then press the
AddlRemove button.

• Follow the uninstall directions on the screen and the software will be
removed from your hard disk. It is up to the user to remove the HEC-
RAS icon from the desktop. .

2-3
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CHAPTER 3

Working With HEC-RAS - An Overview

HEC-RAS is an integrated package of hydraulic analysis programs, in which
the user interacts with the system through the use of a Graphical User
Interface (GUT). The system is capable of performing Steady Flow water
surface profile calculations, and will include Unsteady Flow, Sediment
Transport, and several hydraulic design computations in the future.

In HEC-RAS terminology, a Project is a set of data files associated with a
particular river system. The modeler can perform any or all of the various
types of analyses, included in the HEC-RAS package, as part of the project.
The data files for a project are categorized as follows: plan data, geometric
data, steady flow data, unsteady flow data, sediment data, and hydraulic
design data.

During the course of a study the modeler may want to formulate several
different Plans. Each plan represents a specific set of geometric data and
flow data. Once the basic data are entered into the HEC-RAS, the modeler
can easily formulate new plans. After simulations are made for the various
plans, the results can be compared simultaneously in both tabular and
graphical form.

This chapter provides an overview of how a study is performed with the
HEC-RAS software. Special topics on how to import HEC-2 data,
reproducing HEC-2 results, and how to use on-line help are also covered.

Contents

• Starting HEC-RAS

• Steps in Developing a Hydraulic Model With HEC-RAS

• Importing HEC-2 Data

• Reproducing HEC-2 Results-

• Getting and Using Help
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Figure 3.1 The HEC·RAS Icon in Windows

• Double-click on the HEC-RAS Icon. If you do not have an HEC­
RAS shortcut on the desktop, go to the Start menu and select
Programs, then select HEC, and then HEC-RAS.

II
HEC-RAS

21

When you run the HEC-RAS Setup program, you automatically get a new
program group called HEC and program icon called HEC-RAS. They
should appear in the start menu under the section called Programs. The user
also has the option of creating a shortcut on the desktop. If a shortcut is
created, the icon for HEC-RAS will look like the following:

When you first start HEC-RAS, you will see the main window as shown in
Figure 3.2 (except you will not have any project files listed on your main
window).

To Start HEC-RAS from Windows:

I
Starting HEC-RAS

Figure 312 The HEC-RAS Main Window

Chapter 3 Working With HEC-RAS - An Overview
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Figure 3.3 HEC-RAS Main Window Menu Bar Structure

At the top of the HEC-RAS main window is a Menu bar (Figure 3.3) with the
following options:

Help
Contents
Using HEC-RAS Help

About HEC-RAS

View
Cross Sections...
Water Surface Profiles...
Rating Curves .
Hydrographs .
X-Y-Z Perspective Plots...

Cross Section Table...
E.rofile Table...
Summary Err, Warn, Notes...

Chapter 3 Working With HEC-RAS - An Overview

Options
E.rogram Setup
Default Parameters
Unit System...
Convert Project Units..

Simulate
Steady Flow Analysis...
Unsteady Flow Analysis...
Se..diment Analysis...
Hydraulic Design Functions...

Edit
Geometric Data...
Steady Flow·Data...
Unsteady Flow Data...
Se..diment Data...

~.;':~' ..

File: This option is used for file management. Options available under the
File menu include: New Project; Open Project; Save Project; Save Project As;
Rename Project: Delete Project; Import HEC-2 Data; Import HEC-RAS data;
Generate Report; Export GIS Data; Open Backup Project; and Exit. In
addition, the four most recently opened projects will be listed at the bottom of
the File menu, which allows the user to quickly open a project that was
recently worked on.

File
New Project...
Open Project...
Save Project
Save Project As .
Rename Project .
D.elete Project .

Import HEC-2 Data...
Import HEC-RAS Data...
Generate Report .
Export GIS Data .
Open Backup Project

E29t
d:\hec\ras\data\buffalo.prj
d:\hec\ras\data\example.prj
d:\hec\ras\data\onebox. prj
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Edit: This option is used for entering and editing data. Data are categorized
into four types: Geometric Data; Steady Flow Data; Unsteady Flow Data; and

_ Sediment Data. In the current version, only Geometric Data and Steady Flow
Data are active.

Simulate: This option is used to perform the hydraulic calculations. The
options under this menu item include: Steady Flow Analysis; Unsteady Flow
Analysis; Sediment Analysis; and Hydraulic Design Functions. In the current
version, Unsteady Flow Analysis and Sediment Analysis are not available.

View: This option contains a set of tools that provide for graphical and
tabular displays of the model output. The View menu item currently includes:
Cross Sections; Water Surface Profiles; Rating Curves; X- Y-Z Perspective
Plots; Cross Section Tables; Profile Tables; and Summary Err, Warn, Notes.
Hydrograph plots are not available yet, but will be included when unsteady
flow capabilities are added to the system.

Options: This menu item allows the user to change Program Setup options;
set Default Parameters; establish the Default Units System (U.S. Customary
or Metric); and Convert Project Units (U.S. Customary to Metric, or Metric to
U.S. Customary).

Help: This option allows the user to get on-line help, as well as display the
current version information about HEC-RAS.

Also on the HEC-RAS main window is a Button bar (Figure 3.4). The Button
bar provides quick access to the most frequently used options under the HEC­
RAS menu bar. A description of each button is shown in Figure 3.4.

3-4
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Figure 3.4 HEC-RAS Main Window Button Bar

Chapter 3 Working With HEC-RAS - An Overview

XYZ Perspective Plots:
View 3D multiple cross­
section plot

Sum Err, Warn, Notes:
Summary of errors,
warnings, and notes

Prome Table:
View output at multiple
locations by profile

Promes:
View profile
plots

Rating Curves:
View computed
rating curves

Cross Sections: Cross Table:
View cross- View detailed output
section plots at cross sections, bridges,

S d Fl A 1 · culverts, and inline weirstea y ow na YSIS:

Perfonn a steady
flow simulation

Save Project:
Save an existing
project

Steady Flow Data:
Edit and/or enter
st~ad flow data

Hydraulic Design Functions:
Perfonn hydraulic desigt!
Computations

Geometric Data:
Edit and!or enter
geometric data

Open Project:
Open an existing
project.
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• Entering geometric data

• Viewing and printing results

• Performing the hydraulic calculations
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beavcrek.prj
bogchitprj
critcrek.prj
ex1prj
flodencr.prj
junction.prj
loop.prj

• Entering flow data and boundary conditions

There are five main steps in creating a hydraulic model with HEC-RAS:

• Starting a new project

Starting a New Project

The first step in developing a hydraulic model with HEC-RAS is to establish
which directory you wish to work in and to enter a title for the new project.
To start a new project, go to the File menu on the main HEC-RAS window
and select New Project. This will bring up a New Project window as shown
in Figure 3.5.

Single Bridge - Example 2
Bogue Chitto. MS - Example 13
Critical Creek - Example 1
Steady Flow Example from Chapter 4
Floodway Determination - Example 6
Stream Junction - Example 10
Looped Network - Example 8

Figure 3.5 New Project window

Chapter ~ Working With HEC-RAS - An Overview

As shown in Figure 3.5, you first select the drive and path that they want to
work in (to actually select a path you must double click the directory you want
in the directory box), then enter a project title and file name. The project
filename must have the extension" .prj", the user is not allowed to change this.
Once you have entered all the information, press the "OK" button to have the
information accepted. After the OK button is pressed, a message box will
appear with the title of the project and the directory that the project is going to

3-6
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Chapter 3 Working With HEC-RAS - An Overview

Entering Geometric Data

The next step is to enter the necessary geometric data, which consist of
connectivity information for the stream system (River System Schematic),
cross-section data, and hydraulic structure data (bridges, culverts, weirs, etc.).
Geometric data are entered by selecting Geometric Data from the Edit menu
on the main HEC-RAS window. Once this option is selected, the geometric
data window will appear as show in Figure 3.6 (except yours will be blank
when you first bring this screen up for a new project).

Note: Before any Geometric data and Flow data are entered, the user
should select the Units System (English or Metric) that they would like to
work in. This is accomplished by selecting Unit System from the Options
menu on the main HEC-RAS window.

be placed in. If this information is correct, press the OK button. If the
information is not correct, press the Cancel button and you will be placed

_ back into the New Project window.

Figure 3.6 Geometric Data Window
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The modeler develops the geometric data by first drawing in the river system
schematic. This is accomplished, on a reach-by-reach basis, by pressing the

_ River Reach button and then drawing in a reach from upstream too
downstream (in the positive flow direction). After the reach is drawn, the
user is prompted to enter a "River" and a "Reach" identifier. The River and
reach identifiers can be up to 16 characters in length. As reaches are
connected together, junctions are automatically formed by the interface. The
modeler is also prompted to enter an identifier for each junction. For more
information on developing the river system schematic, see Chapter 6
"Entering and Editing Geometric Data."

After the river system schematic is drawn, the modeler can start entering
cross-section and hydraulic structure data. Pressing the Cross Section button
causes the cross section editor to pop up. This editor is shown in Figure 3.7.
As shown, each cross section has a River name, Reach name, River Station,
and a Description. The River, Reach and River Station identifiers are used
to describe where the cross section is located in the river system. The "River
Station" identifier does not have to be the actual river station (miles or
kilometers) at which the cross section is located on the stream, but it does
have to be a numeric value (e.g., 1.1,2,3.5, etc.). The numeric value is used
to place cross sections in the appropriate order within a reach. Cross
sections are ordered within a reach from the highest river station
upstream to the lowest river station downstream.

Figure 3.7 Cross Section Data editor
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Chapter 3 Working With HEC-RAS - An Overview

The basic data required for each cross section are shown on the Cross Section
Data editor in Figure 3.7. Additional cross section features are available

_ under Options from the menu bar. These options include: adding, copying,
renaming and deleting cross sections; adjusting cross section elevations,
stations, and n or k-values; ineffective flow areas; levees; blocked
obstructions; adding a lid to a cross section; horizontal variation of n or k­
values; and setting the maximum number of station and elevation points.

Also, available from the Cross Section Data editor is the ability to plot any
cross section or reach profile. Edit features are available to cut, copy, paste,
insert, and delete data from the Cross Section X-Y Coordinates grid.

Once the cross-section data are entered, the modeler can then add any
hydraulic structures such as bridges, culverts, weirs and spillways. Data
editors, similar to the cross section data editor, are available for the various
types of hydraulic structures. If there are any stream junctions in the river
system, additional data are required for each junction. The Junction data
editor is available from the Geometric Data window.

Once geometric data are entered, the data should be saved to a file on the hard
disk. This is accomplished by selecting the Save Geometric Data As option
from the File menu on the Geometric Data editor. This option allows the user
to enter a title for the geometric data. A filename is automatically established
for the geometric data, and then saved to the disk. Once a title is established,
geometric data can be saved periodically by selecting Save Geometric Data
from the File menu of the Geometric Data editor.

Entering Flow Data and Boundary Conditions

Once the geometric data are entered, the modeler can then enter any flow data
that are required. The data entry form for flow data is available under the
Edit menu bar option on the HEC-RAS main window.

An example of the flow data entry form is shown in Figure 3.8, which is the
Steady Flow Data Editor. As shown in Figure 3.8, Steady Flow Data
consist of: the number of profiles to be computed; the flow data; and the river
system boundary conditions. At least one flow must be entered for every
reach within the system. Additionally, flow can be changed at any location
within the river system. Flow values must be entered for all profiles.

Boundary conditions are required in order to perform the calculations. If a
subcritical flow analysis is going to be performed, then only the downstream
boundary conditions are required. If a supercritical flow analysis is going to
be performed, then only the upstream boundary conditions are required. If the
modeler is going to perform a mixed flow regime calculation, then both
upstream and downstream boundary conditions are required. The Boundary
Conditions data entry form can be brought up by pressing the Enter

3-9
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Boundary Conditions button from the Steady Flow Data entry form.

_ Once all of the steady flow data and boundary conditions are entered, the
modeler should save the data to the hard disk. This can be accomplished by
selecting Save Flow Data As from the File option on the Steady Flow Data
menu bar. Flow data is saved in a separate file. The user is only required to
enter a title for the data, the filename is automatically assigned.

Figure 3.8 Steady Flow Data window

Performing the Hydraulic Computations

Once all of the geometric data and flow data are entered, the modeler can
begin to perform the hydraulic calculations. As stated previously, there are
two types of calculations that can be performed in the current version of HEC­
RAS: Steady Flow Analysis, and Hydraulic Design Functions. The modeler
can select any of the available hydraulic analyses from the Simulate menu bar
option on the HEC-RAS main window. An example of the simulation
window is shown in Figure 3.9, which is the Steady Flow Analysis window.

3-10
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Figure 3.9 Steady Flow Analysis window

As shown in Figure 3.9, the modeler puts together a Plan by selecting a
specific set of geometric data and flow data. A Plan can be put together by
selecting New Plan from the File menu bar option of the Steady Flow
Analysis window. Once a Plan Title and Short Identifier (Short ID) have
been entered, the modeler can select a Flow Regime for which the model will
perform calculations. Subcritical, Supercritical, or Mixed flow regime
calculations are available.

Additional features are available under the Options menu for: performing a
Floodway Encroachment Analysis; Setting locations for calculating flow
distribution output; setting output options; conveyance calculation options;
friction slope methods; calculation tolerances; critical depth computation
method; data checking; setting log file levels; and viewing the log file output.

Once the modeler has selected a Plan and set all of the calculation options, the
steady flow calculations can be performed by pressing the Compute button at
the bottom of the Steady Flow Analysis window. When this button is
pressed, the HEC-RAS system packages up all the data for the selected plan
and writes it to a run file. The system then runs the steady flow model
CSNET) and passes it the name of the run file. This process is executed in a
separate window. Therefore, the modeler can work on other tasks while it is
executing.
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Viewing and Printing Results

Once the model has finished all of the computations, the modeler can begin
viewing the results. Several output features are available under the View
option from the main window. These options include: cross section plots;
profile plots; rating curve plots; X-Y-Z perspective plots; tabular output at
specific locations (Cross Section Table); tabular output for many locations
(Profile Table); and the summary of errors, warnings, and notes.

An example of a cross section plot is shown in Figure 3.10. The user can plot
any cross section by simply selecting the appropriate River, Reach and River
Station from the list boxes at the top of the plot. The user can also step
through the plots by using the up and down arrow buttons. Several plotting
features are available under the Options menu of the Cross Section plot.
These options include: zoom in; zoom out; selecting which plans, profiles
and variables to plot; and control over the lines, symbols, labels, scaling, and
grid options.

Hard copy outputs of the graphics can be accomplished in two different ways.
Graphical plots can be sent directly from HEC-RAS to whichever printer or
plotter the user has defined under the Windows Print Manager. Graphical
plots can also be sent to the Windows clipboard. Once the plot is in the
clipboard it can then be pasted into other programs, such as a word processor.
Both of these options are available from the File menu on the various plot
windows.

An example of a profile plot is shown in Figure 3.11. All of the options
available in the cross section plot are also available in the profile plot.
Additionally, the user can select which specific reaches to plot when a
multiple-reach river system is being modeled.

An example of an X-Y-Z Perspective Plot is shown in Figure 3.12. The user
has the option of defining the starting and ending location for the extent of the
plot. The plot can be rotated left or right, and up or down, in order to get
different perspectives of the river reach. The computed water surface profiles
can be overlaid on top of the cross section data. The graphic can be sent to
the printer or plotter directly, or the plot can be sent through the Windows
Clipboard to other programs.

3-12
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!f:f. Profile Output Table .. Standard Table 1 1!!ll1iIf3

.......~q9.ll.:p..Qr 1803.60 1815.54 1814.46 181602 0.004559 895 915.36 i
9000.00 1800.?q 1810.67 1810.42 181190 0.007044 11.20 651.40 ..

9000.00 '79440 1804.83 1803.89 '80S08 0.008883 9.84 980.38
:.;

;.;

900000 178870 179904 179931 ...... 1.80°?~· .... 0012421 1121 120984....................

I9500.00 1784.30 1794.30 1793.92 1795.14 0.006072 10.79 119187
9500.00 1777.20 1789.68 1788.91' 179095 0008486 13.88 52290
9500.00 1774.50 1784.29 1784.29 178635 0.011147 13.38 332.35.... _.... .... " ... ..;,....

950000 175850 1777.28 1775.80 177827 0009072 1179 595.10 ..

9500.00 1763.00 1772.79 1772.23 1773.49 0.007994 11.30 734.37 :.:

950000 175940 175785 1755.80 ...... 1.7 59:14•.... 0.011972 13.33 653.56 :;.

9500.00 1753.60 1761.54 1760.03 1762.10 0009423 10.36 68268 ..

9500.00 1747.40 1758.71 1755.80 175721r 001 0001 991 72801 ::::

"'i" Y

Figure 1014 Profile Output Table

Importing HEC-2 Data

An important feature of HEC-RAS is the ability to import HEC-2 data. This
feature makes it easy for a user to import existing HEC-2 data sets and start
using HEC-RAS immediately.

What You Should Know First

Before importing HEC-2 data, there are several things that you should be
aware of. First, not all of the options available in HEC-2 have been
incorporated into the current version of HEC-RAS. The following is a list of
HEC-2 options that are not available in the current version of HEC-RAS:

- Split flow optimization (SF, etc.)
- Ice (IC)
- Vertical variation of Manning's n values (NY)
- Compute Manning's n from high water marks (Jl)
- Internal Rating Curves (RC)
- Archive (AC)
- Free Format (FR)
- Storage Outflow for HEC-l (14)

HEC-2 data sets containing these options can still be imported, but these data
options will be ignored.

3-16

I
I
I
I
I
I
I

I
I
I

I

I

I

I

I
I

I
I

I



I
I
I
I
I"
I
I
I
I
I
I
I
I
I
I
I
I
I
I

Chapter 3 Working With HEC-RAS - An Overview

Another important issue to be aware of is how the cross sections are
identified. In HEC-RAS, each cross section is identified with a River name,
Reach name, and a River Station. The river stationing must be in order from
highest river stationing upstream to lowest river stationing downstream.
When the user goes to import HEC-2 data, a pop up window will appear
(Figure 3.15), asking the user to select a method for identifying the river
stationing of the cross sections. If you select "Use HEC-2 Section ID's," the
program will use the first field of the Xl record for the river stationing of the
cross section. If you choose this method, you must be sure that the cross
sections in the HEC-2 file are numbered with highest river stationing
upstream, and that no two cross sections have the same river station identifier.
If these two requirements are not met, the program will not import the data
correctly. An alternative is to select "Use Sequential Counter." This method
simply assigns river stations as 1,2, 3, etc. in the order in which the cross
sections are found in the HEC-2 file (still maintaining highest numbers
upstream and lowest numbers downstream.

Figure 3.15 Method for Identifying River Stations from HEC-2 Data

After the HEC-2 data is imported into HEC-RAS, you may need to make
some modifications to the data. HEC-RAS is a completely new program. As
HEC-RAS was being developed, we tried to improve the hydraulic
computations in every way we could. Some of these improvements have
made it necessary to get more information and/or different information from
the user for a specific type of computation. The following is a list of features
in which the data requirements for HEC-2 and HEC-RAS have changed, and
it may be necessary for the user to modify the data after it is imported:

- Special Bridge (SB)
- Special Culvert (SC)
- Normal Bridge (X2, BT)
- Encroachments and Floodway Determination (X3, ET)
- Ineffective Flow Areas (X3)
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1. Special Bridge Data Sets

The pressure flow equations in HEC-RAS use the actual bridge
opening, defined by the ground and the bridge data. In HEC-2, the
user was required to enter an area for pressure flow. If the actual
bridge opening produces a different area than what the user had
entered in the HEC-2 data deck, the program will get different results
for pressure flow, and pressure and weir flow answets.

HEC-RAS does not use a trapezoidal approximation for low flow
through the bridge opening. The actual bridge opening is used in both
the Yamell method and the momentum method. This could be a
problem for HEC-2 special bridge data sets that do not include low
chord information on the BT data. If you have a data set like this, you
will need to modify the bridge deck information after the data have
been imported. This can be done from the HEC-RAS DeckIRoadway
editor.
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Normal Bridge Data Sets

Pier information from the SB record is incorporated as a single pier in
the HEC-RAS data set. Piers are treated as separate pieces of data in
HEC-RAS. For special bridges that have piers, you may want to
change the single pier to multiple piers, depending on what is actually
at the bridge. Pier information can be modified using the Pier editor.

Because piers are treated as a separate piece of data in HEC-RAS,
they must not be included in the cross section data or the bridge deck.
Since it is common to include pier information as part of the cross
section or bridge deck in HEC-2, these data will need to be modified.
For data sets that have piers, you will need to remove the pier
information from the cross section or bridge deck, and then add the
information back in using the Pier editor.

2.

When bridge data are imported, the user must take special care to ensure that
the data are correctly representing the bridge. The bridge routines in HEC-

_ RAS are more detailed than HEC-2, and therefore you may have to modify
some data and/or enter some additional data. Whenever you import an HEC-2
data set with bridge data, carefully review all the data for each bridge.
Chapter 6 of this user's manual describes the required data for bridges in
HEC-RAS. Appendix C of the HEC-RAS Hydraulic Reference Manual
contains a detailed discussion of the computational differences between
HEC·RAS and HEC-2. Some key differences between the bridge routines
of HEC-2 and HEC-RAS are as follows:
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Chapter 3 Working With HEC-RAS - An Overview

Steps for Importing HEC-2 Data

- To import HEC-2 data, do the following:

1. Start a new project by selecting New Project under the File menu
option on the HEC-RAS main window (Figure 3.16). When this
option is selected a window will appear allowing you to select the
drive and directory for the new project, then enter a project title and
filename. Press the OK button, and then a pop up window will appear
asking you to confirm the information.

Figure 3.16 HEC-RAS Main Window With File Menu Options Shown

2. Select the Import HEC-2 Data option under the File menu on the
main window (Figure 3.16). A pop up window will appear (Figure
3.17), which will allow you to select a drive, path, and filename for
the HEC-2 data file. In addition to the filenames being listed, the first
line of each HEC-2 data file is shown under the title field on the
window. Once you have selected the file you want, press the OK
button.
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Figure 3.17 Window for Importing HEC-2 Data

3. Once you have selected an HEC-2 file and pressed the OK button, a
pop up window will appear asking you to select a method for
identifying the river stationing of the cross sections (this was
discussed under the "What You Should Know First" section). Select
a method and press the Import HEC-2 button.

4. If the HEC-2 data file contains any bridges or culverts, a note will
appear reminding you to look at the imported data of all of the bridges
and culverts to ensure the data is complete and correct.

The data are automatically saved in HEC-RAS format with default names and
titles. The user can change the titles at any time by using the Rename feature,
which is available from the File menu of the various data editors (Geometric
data, flow data, and plan data).

Reprpducing HEC-2 Results

The HEC-RAS program is a completely new piece of software. one of the
hydraulic routines from HEC-2 were used in the HEC-RAS software. When
HEC-RAS was being developed, a significant effort was spent on improving
the computational capabilities over those in the HEC-2 program. Because of
this, there are computational differences between the two programs.
Appendix C, of the HEC-RAS Hydraulic Reference Manual, outlines in
detail the computational differences between the two programs. Please
review this closely!

3-20
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Figure 3.18 HEC-RAS Conveyance Calculation Methods

HEG-RAS
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2. The default method for calculating conveyance in HEC-RAS is
different from HEC-2. However, HEC-RAS has the ability to
compute conveyance with the HEC-2 methodology. If you are trying
to reproduce HEC-2 results, you may want to switch HEC-RAS to the
HEC-2 method of computing conveyance. To do this, from the
Steady Flow Analysis window select Options from the menu bar,
then select Conveyance Calculations. When this is selected, a pop
up window will appear as shown in Figure 3.18. There are two
options available, the HEC-RAS default method (break in n-value
method) and the HEC-2 style method. Select the HEC-2 style method
if you are trying to reproduce HEC-2 results. For more information
on the differences in conveyance calculations, see Appendix C of the
HEC-RAS Hydraulic Reference manual.

1. First, is the data that you have imported good data? In other words,
did it come from a working HEC-2 model, and was that model
considered being hydraulically sound. Are there an adequate number
of cross sections? And are there any mistakes in the cross section
data? Review the data closely, before you assume that it is good!

When importing HEC-2 data, and attempting to reproduce the results of a
previous study, the following is a list of items that should be considered:

3. The HEC-RAS bridge routines are more comprehensive than the
HEC-2 bridge routines, and therefore differences can occur at bridge
locations. First, review the bridge data closely and make sure it
accurately represents the bridge you are trying to model. If you feel it
is necessary to match the results of a previous study at the bridge, then
your only alternative is to adjust the coefficients that are being used in
the bridge modeling approach (i.e., pressure and weir flow
coefficients, low flow coefficients, contraction and expansion
coefficients, etc .). For detailed information on the differences
between the HEC-RAS and HEC-2 bridge routines, please review
Appendix C of the Hydraulic Reference manual.
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Chapter 3 Working With HEC-RAS - An Overview

Getting and Using Help

On-line help is available from within the HEC-RAS software. Help can be
accessed by selecting the Help menu option at the top of each window, or by
pressing the Fl function key.

6. After carefully reviewing items one through five above, if you still
have computational differences in the computed profiles, you may
need to modify Manning's n values in order to reproduce the previous
study results. In general, this is not suggested. If you do decide to
modify the n values, try to keep them within a realistic range of what
is appropriate for the stream you are working on.

I
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Sometimes differences can occur at locations where the programs
have defaulted to a critical depth solution. First you should ask
yourself if critical depth is an appropriate solution for this location. It
is a common problem for both programs to default to critical depth
when the cross sections are spaced too far apart. If you feel critical
depth is an appropriate solution, then in general the HEC-RAS answer
will be better than HEC-2. The critical depth routines in HEC-RAS
are much more comprehensive than HEC-2. HEC-RAS has tighter
error limits for locating critical depth, as well as the ability to find
multiple critical depths and detect which is the most appropriate.

4.

5. Differences can also occur at locations where floodway
encroachments are being computed. The HEC-RAS floodway
encroachment routines have been improved over those available in
HEC-2. Also, the default at bridges in HEC-RAS is to perform the
encroachment analysis, while the default in HEC-2 was to not
encroach at bridges. For more details on differences between
encroachment routines, please review Appendix C of the HEC-RAS
Hydraulic Reference Manual.
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Chapter 4 Example Application

CHAPTER 4

Example -Application

This chapter provides an example application of how to perform steady flow
water surface profile calculations with HEC-RAS. The user is taken through
a step by step procedure of how to enter data, perform calculations, and view
the results.

In order to get the most out of this chapter, you should perform each of the
steps on your own computer. Also, before you try the example application,
you should have read the first three chapters in this manual.

Contents

• Starting a New Project

• Entering Geometric Data

• Entering Steady Flow Data

• Performing the Hydraulic Calculations

• Viewing Results

• Printing Graphics and Tables

• Exiting the Program
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flodencrprj
junction.prj
loop.prj
mixed.prj
mixflow.prj
multculv.prj
multopen.prj

First set the drive (e.g., C) and the directory that you would like to work in.
Next enter the project title and filename as shown in Figure 4.2. Once you
have entered the information, press the OK button to have the data accepted.

The first step in developing an HEC-RAS application is to start a new project.
Go to the File menu on the main window and select New Project. The New
Project window should appear as shown in Figure 4.2 (except the title and file
name fields will be blank when it first comes up).

To begin this example, let's first start the HEC-RAS program. Double click
the HEC-RAS icon in Windows. The main window should appear as shown
in Figure 4.1 (except yours will be blank the first time you start the program).

Floodway Determination - Example 6
Stream Junction - Example' 0
Looped Network - Example B
Mixed Flow Project
Mixed Flow- Example 9
Multiple Culverts - Example 4
Multiple Openings - Example 5

Cr.

Figure 4.2 New Project Window

Starting a New Project
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Chapter 4 Example Application

Entering Geometric Data

The next step in developing a steady flow model with HEC-RAS is to enter
the geometric data. This is accomplished by selecting Geometric Data from
the Edit menu on the HEC-RAS main window. Once this option is selected
the geometric data window will appear, except yours will be blank when you
fust bring it up (Figure 4.3).

Drawing the Schematic of the River System

In this example we are going to develop a two-river (three hydraulic reaches)
system as shown in Figure 4.3. Draw the river system schematic by
performing the following steps:

1. Click the River Reach button on the geometric data window.

2. Move the mouse pointer over to the drawing area and place the
pointer at the location in which you would like to start drawing the
first reach.

3. Press the left mouse button once to start drawing the reach. Move the
mouse pointer and continue to press the left mouse button to add
additional points to the line segment. To end the drawing of the reach,
double click the left mouse button and the last point of the reach will
be placed at the current mouse pointer location. All reaches must be
drawn from upstream to downstream (in the positive flow direction),
because the program assumes this to be true.

4. Once the reach is drawn, the interface will prompt you to enter an
identifier for the River name and the Reach name. The River
identifier can be up to 32 characters, while the reach name is limited
to 12 characters. In this example, there is one river named Fall River
and another one named Butte Cr. Fall river contains two hydraulic
reaches, which are labeled Upper Reach and Lower Reach. Butte
Cr. has been entered as a single hydraulic reach, and the reach name
is Tributary.

s. Repeat steps one through four for each reach. After you enter the
identifiers for Butte Cr., 'you will also be prompted to enter an
identifier for the junction. Junctions in HEC-RAS are locations where
two or more reaches join together or split apart.

4-3
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Figure 4.3 Geometric Data Window with example river schematic
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Entering Cross Section Data

1. Select a River and a Reach to work with. For this example start with
the Fall River, Upper Reach.

The next step is to enter the cross section data. This is accomplished by
pressing the Cross Section button on the Geometric Data window (Figure
4.3). Once this button is pressed, the Cross Section Data editor will appear as
shown in Figure 4.4 (except yours should be blank). To enter cross section
data do the following:

Once you have finished drawing in the river system, there are several options
available for editing the schematic. These options include: change name,
move object (objects are labels, junctions, and points in the reaches), add
points to a reach, remove points from a reach, delete a reach, and delete a
junction. The editing features are located under the Edit menu on the
Geometric Data window. Note: when you first draw your schematic there
will not be any tic marks representing cross sections as shown in Figure
4.3. The tic marks only show up after you have entered cross section
data.

2. Go to the Options menu and select Add a new Cross Section. An
input box will appear to prompt you to enter a river station identifier

l.::-::-,========================.=:./==.~.=:5~
dIh$PU

IriIlMW<#i.:=
·••••·0~yr;
P@1#~?
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Chapter 4 Example Application

for the new cross section. The identifier does not have to be the actual
river station, but it must be a numeric value. The numeric value
describes where this cross section is located in reference to all the
other cross sections within the reach. Cross sections are located from
upstream (highest river station) to downstream (lowest river station).
For this cross section enter a value of 10.0.

w
•.·.·h··i·.'~~~·~~@jiiim1&li1i;;jiiJ"9~§~~· ••··.ii i

1200 [240
•• •;-:'." ··;"::-;":::v :;::::,:::::::::::;:;:;:::~~~?~{:~~~{:;:~;{:~.:.:;::-.;;: ;.;.;.;. :.:.:.;.;.;.;.;.:...;.:.,;-,-;.: :':::':":;:::': ;':::;';::; :: ::::'~~J

Figure 4.4 Cross Section Data Editor with example data

3. Enter all of the data for this cross section as it is shown in Figure 4.4.

I
I
I
I
I
I

4.

5.

Once all the data are entered press the Apply Data button. This
button is used to tell the interface that you want the data to be
accepted into memory. This button does not save the data to your
hard disk, which can only be accomplished from the File menu on the
Geometric Data window.

Plot the cross section to visually inspect the data. This is
accomplished by pressing the Plot Cross Section option under the
Plot menu on the Cross Section Data Editor. The cross section should
look the same as that shown in Figure 4.5.
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In general, the five steps listed would be repeated for every cross section that
is entered. In order to reduce the amount of data entry for this example, the

_ current cross section will be copied and adjusted to represent other cross
sections within the river system.

Legend
•

Ground•
Bank Sta
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~igure 4.5 Cross Section Plot for river mile 10.0 of Fall Creek I
The following steps should be followed to copy the current cross section:

4-6

1.

2.

3.

Go to the Options menu on the Cross Section Data Editor and select
Copy Current Cross Section. An input box will appear to prompt
you to select a river and a reach, and then enter a river station for the
new cross section. For this example, keep the river and reach as Fall
River and Upper Reach, then enter a new river station of 9.9. Press
the OK button and the new cross section will appear in the editor.

Change the description for the cross section to "River Mile 9.9 of Fall
River."

Adjust all the elevations of the cross section by -0.5 feet. This is
accomplished by selecting the Adjust Elevations feature from the
Options menu on the Cross Section Data Editor.
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5. Downstream reach lengths remain the same for this cross section.

7. Plot the cross section to visually inspect it.

6. Press the Apply Data button.

Chapter 4 Example Application

ftst d r fdO tS f

4. Adjust the cross section stationing to reduce the overbanks by 10%.
This is accomplished by selecting the Adjust Stations feature from
the Options menu on the Cross Section Data Editor, then select
Multiply by a Factor. When the input box appears for this option,
three data entry fields will be available to adjust the stationing of the
left overbank, channel, and the right overbank separately. Enter
values of 0.90 for the right and left overbanks, but leave the main
channel field blank. This will reduce the stationing of both overbanks
by 10%, but the main channel will not be changed.

1. Go to the River text box on the Cross Section Data Editor and select
the Butte Cr. river. The Reach of "Tributary" will automatically be
selected since it is the only reach in Butte Creek.

These seven steps should be repeated to enter all the data for Fall River
(Upper and Lower Reach). The necessary adjustments are listed in Table 4.1.
Perform the cross section duplications in the order that they are listed in the
table. Make sure to change the description of each cross section, and 'also
press the Apply Data button after making the adjustments for each cross
section.

This completes all the cross section data for Fall River (upper and Lower
reach). Now let's work on entering the data for the Butte Creek tributary. To
enter the first cross section in the Butte Creek tributary do the following:

T bl 41 Ca e . ross ec Ion a IJUS men or Upllca Illg sec lOllS

Cross Section Adjusted Adjusted Stationing Downstream ,Reach Lengths
Elevation

Reach River Left Channel Right O.B. Left O.B. Channel Right
Sta. O.B. O.B.

Upper 9.8 -0.4 0.80 - 0.80 0.0 0.0 0.0

Lower 9.79 -0.1 1.20 1.20 1.20 500 500 500

Lower 9.7 -0.5 1.20 1.20 1.20 500 500 500

Lower 9.6 .-0.3 - - - 500 500 500

Lower 9.5 -0.2 - - - 0.0 0.0 0.0
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2. Select Add a new Cross Section from the Options menu. When the
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popup box appears to prompt you to enter a new river station, enter a
value of 0.2.

3. Enter all the data for this cross section as shown in Figure 4.6.

4. Once all the data are entered for this section, press the Apply Data
button.

I
I
I
I

5. Plot the cross section to inspect the data.

I
Cross SectIOn De.te.- Be.se Geometry De.te. El

Figure 4.6 Cross Section Editor with river mile 0.2 of Butte Creek

There are two other cross sections that need to be developed for the Butte
Creek tributary. These two cross sections will be developed by duplicating
the cross section that you just entered, and then adjusting the elevations and
stationing. The necessary adjustments are listed in Table 4.2. Perform the
cross section adjustments in the order that they are listed in the table. Make
sure to change the description of each cross section and press the Apply Data
button after editing is complete.

4-8
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C kt Bd· tST hI 42 Ca e ross ecbon a IJUS ments or utte ree sectIOns

Cross Section - Adjusted Adjusted Stationing Downstream Reach Lengths
Elevation

Reach River Sta. Left Channel Right O.B. Left O.B. Channel Right
O.B. O.B.

Butte Cr. 0.1 -0.6 - - - 500 500 500

Butte Cr. 0.0 -0.3 - - - 0.0 0.0 0.0

I
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Now that all of the cross section data are entered, save the data to a file before
continuing. Saving the data to a file is accomplished by selecting the "Save
Geometry Data As" option from the File menu on the Geometric Data
window. After selecting this option you will be prompted to enter a Title for
the geometric data. Enter "Base Geometry Data" for this example, then press
the OK button. A file name is automatically assigned to the geometry data
based on what you entered for the project filename.

Entering Junction Data

The next step is to enter the junction data. Junction data consist of a
description, and reach lengths across the junction. In this example there is
only one junction, which is labeled Sutter. Junction data is entered by
pressing the Junction button on the Geometric Data window. Enter the
junction data as shown in Figure 4.7.

I Junction Data - Base Geometry Data

Figure 4.7 Junction Data Editor, with Sutter junction data

I
I
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Reach lengths across the junction are entered in the junction editor, rather than·
in the cross section data. This allows for the lengths across very complicated
confluences (i.e., flow splits) to be accommodated. In the cross section data,
the reach lengths for the last cross section of each reach should be left blank
or set to zero.

In this example the energy equation will be used to compute the water surface
profile through the junction. If the momentum equation is selected, then an
angle can be entered for one or more of the reaches flowing into or out of a
junction. The momentum equation is set up to account for the angle of the
flow entering the junction.

Once you have all of the data entered for the junction, apply the data and close
the window by pressing the OK button.

Savin9 the Geometry Data

At this point in the example, all of the geometric data has been entered.
Before we continue with the example, you should save the geometric data to
the hard disk. Since the data have already been saved once, you simply have
to select Save Geometry Data from the File menu on the Geometric Data
window. We can now go on to enter the Steady Flow data.

Entering Steady Flow Data

I The next step in developing the required data to perfonn steady flow water
surface profile calculations is to enter the steady flow data. To bring up the
steady flow data editor, select Steady Flow Data from the Edit menu on the
HEC-RAS main window. The Steady Flow Data editor should appear as
shown in Figure 4.8.

The first piece of data to enter is the number of profiles to be calculated. For
this example, enter "3" as shown in Figure 4.8. The next step is to enter the
flow data. Flow data are entered from upstream to downstream for each
reach. At least one flow rate must be entered for every reach in the river
system. Once a flow value is entered at the upstream end of a reach, it is
assumed that the flow remains constant until another flow value is
encountered within the reach. Additional flow values can be entered at any
cross section location within a reach.

4-10
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Chapter 4 Example Application

Figure 4.8 Steady Flow Data Editor, with example problem data

In this example, flow data will be entered at the upstream end of each reach.
An additional flow change location will be entered at river mile 9.6 of the Fall
River in the Lower Reach. To add an additional flow change location into the
table, first select the Fall River, Lower Reach from the Reach list box. Next,
select the desired river station location (9.6 in this example) from the River
Sta. list box. Finally, press the Add a Flow Change Location button. The
new flow location should appear in the table. Now enter all of the flow data
into the table as shown in Figure 4.8. Profile labels will automatically default
to "PF #1," "PF#2," etc. You can change these labels to whatever you want.
In this example they have been changed to "10 yr," "50 yr," and "100 yr," to
represent the statistical return period of each of the events being modeled.

The next step is to enter any required boundary conditions. To enter
boundary conditions, press the Enter Boundary Conditions button at the top
of the Steady Flow Data editor. The boundary conditions editor will appear
as shown in Figure 4.9, except yours will be blank the first time you open it.

Boundary conditions are necessary to establish the starting water surface at
the ends of the river system. A starting water surface is necessary in order for
the program to begin the calculations. In a subcritical flow regime, boundary
conditions are only required at the downstream ends of the river system. If a
supercritical flow regime is going to be calculated, boundary conditions are
only necessary at the upstream ends of the river system. If a mixed flow
regime calculation is going to be made, then boundary conditions must be
entered at all open ends of the river system.
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Figure 4.9 Steady Flow Boundary Conditions

The boundary conditions editor contains a table listing every river and reach.
Each reach has an upstream and a downstream boundary condition.
Connections to junctions are considered internal boundary conditions:
Internal boundary conditions are automatically listed in the table, based on
how the river system is connected in the geometric data editor. The user is
only required to enter the necessary external boundary conditions.

Steady Flow Boundary Conditions
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Chapter 4 Example Application

In this example, it is assumed that the flow is subcritical throughout the river
system. Therefore, it is only necessary to enter a boundary condition at the
downstream end of the Fall River, Lower Reach. Boundary conditions are
entered by first selecting the cell in which you wish to enter a boundary
condition. Then the type of boundary condition is selected from the four
available types listed above the table. The four types of boundary conditions
are:

• Known water surface elevations

• Cri tical depth

• Normal depth

I
I
I
I
I

• Rating curve

I
For this example, use the normal depth boundary condition. Once you have
selected the cell for the downstream end of Fall River, Lower Reach, press the I
Normal Depth button. A pop up box will appear requesting you to enter an
average energy slope at the downstream end of the Fall River. Enter a value
of 0.0004 (ft/ft), then press the Enter key. This completes all of the I
necessary boundary condition data. Press the OK button on the Boundary
Conditions form to accept the data.

I
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Chapter 4 Example Application

The last step in developing the steady flow data is to save the data to a file.
To save the data, select the Save Flow Data As option from the File menu on
the Steady Flow Data Editor. A pop up box will prompt you to enter a
description of the flow data. For this example, enter" 10, 2, and 1% chance
events." Once the data are saved, you can close the Steady Flow Data Editor.

Performing the Hydraulic Calculations

Now that all of the data have been entered, we can calculate the steady water
surface profiles. To perform the simulations, go to the HEC-RAS main
window and select Steady Flow Analysis from the Simulate menu. The
Steady Flow Analysis window should appear as shown in Figure 4.10, except
yours will not have any plan titles yet.

Figure 4.10 Steady Flow Analysis Simulation Window

The first step is to put together a Plan. The Plan defines which geometry and
flow data are to be used, as well as providing a title and short identifier for the
run. To establish a plan, select New Plan from the File menu on the Steady
Flow Analysis window. Enter the plan title as "Existing Conditions Run" and
then press the OK button. You will then be prompted to enter a short
identifier. Enter a title of "Existing" in the Short ID box.

The next step is to select the desired flow regime for which the model will
perform calculations. For this example we will be performing Subcritical
flow calculations only. Make sure that Subcritical is the selected flow
regime. Additional job control features are available from the Options menu
bar, but none are required for this example. Once you have defined a plan and
set all the desired job control information, the plan information should be
saved. Saving the plan information is accomplished by selecting Save Plan
from the File menu of the Steady Flow Analysis window.
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Now that everything has been set, the steady flow computations can be
performed by pressing the Compute button at the bottom of the Steady Flow

_ Simulation window. Once the compute button has been pressed, a separate
window will appear showing you the progress of the computations. Once the
computations have been completed, the computation window can be closed by
double clicking the upper left corner of the window. At this time the Steady
Flow Simulation window can also be closed.

I
I
I
I

Viewing Results

Once the model has finished all of the computations successfully, you can
begin viewing the results. Several output options are available from the View
menu bar on the HEC-RAS main window. These options include:

• Cross section plots

• Profile plots

• Rating curves

• X-Y-Z Perspective Plots

• Detailed tabular output at a specific cross section (cross section table)

• Limited tabular output at many cross sections (profile table)

Let's begin by plotting a cross section. Select Cross Sections from the View
menu bar on the HEC-RAS main window. This will automatically bring up a
plot of the first cross section in Butte Cr., as shown in Figure 4.11. Any cross
section can be plotted by selecting the appropriate river, reach, and river
station from the list boxes at the top of the cross section plot window. The
user can also step through the plots by using the up and down arrow buttons.
Several plotting features are available from the Options menu bar on the
cross section plot window. These options include: zoom in; zoom out;
selecting which plans, profiles and variables to plot; and control over lines,
symbols, labels, scaling, and grid options.

4-14
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Figure 4.11 Cross Section Plot for Example Application
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I Select different cross sections to plot and practice using some of the features

available under the Options menu bar.
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Next let's plot a water surface profile. Select Water Surface Profiles from
the View menu bar on the HEC-RAS main window. This will automatically
bring up a water surface profile plot for the first reach, which is Butte Cr. in
our example. To plot more than one reach, select Reaches from the Options
menu bar on the profile plot. This option brings up a list of available rivers
and reaches from which to choose. Select the Upper and Lower reaches of
the Fall river. This should give you a profile plot as shown in Figure 4.12.
Plot the additional profiles that were computed and practice using the other
features available under the Options menu bar on the profile plot.

I
I
I
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Figur~ 4.12 Profile Plot for Example Application
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Now let's plot a computed rating curve. Select Rating Curves from the View
menu on the HEC-RAS main window. A rating curve based on the computed
water surface profiles will appear for the first cross section in Butte Cr., as
shown in Figure 4.13. You can look at the computed rating curve for any
location by selecting the appropriate river, reach, and river station from the
list boxes at the top of the plot. Plotting options similar to the cross section
and profile plots are available for the rating curve plots. Plot rating curves for
various locations and practice using the available plotting options.
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Figure 4.13 Computed Rating Curve for Example Application
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Next look at an X-Y-Z Perspective Plot of the river system. From the View
menu bar on the HEC-RAS main window, select X-Y-Z Perspective Plots.
A multiple cross section perspective plot should appear on the screen. From
the Options menu, select Reaches. A pop up window will appear allowing
you to select which rivers and reaches you would like to have on the plot.
Press the Select All button and then the OK button. Also, under the Options
menu, select the Profiles option. Select profile two to be plotted from the
three available profiles. Once you have selected these options, and X-Y-Z
perspective plot should appear on the screen, similar to the one shown in
Figure 4.14. Try rotating the perspective view in different directions, and
select different reaches to look at.

Now let's look at some tabular output. Go to the View menu bar on the HEC­
RAS main window. There are two types of tables available, a cross section
specific table and a profile table. Select Cross Section Table to get the first
table to appear. The table should look like the one shown in Figure 4.15.
This table shows detailed hydraulic information at a single cross section.
Other cross sections can be viewed by selecting the appropriate reach and
river mile from the table.

I
I
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Now bring up the profile table. This table shows a limited number of
hydraulic variables for several cross sections. There are several types of
profile tables listed under the Tables menu bar of the profile table window.
Some of the tables are designed to provide specific information at hydraulic
structures (e.g., bridges and culverts), while others provide generic
information at all cross sections. An example of this type of table is shown in
Figure 4.16.

Steady Flow Example from Chapter 4 Existing Conditions Run
Geom: Base Geometry Data Flow: 10,2 and 1% chance events
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Figure 4.14 X-Y-Z Perspective Plot of All Three River Reaches
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Figure 4.15 Detailed Tabular Output at a Cross Section
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Figure 4.16 Tabular Output in Profile Format
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priniing Graphics and Tables

All of the plots and tables can be sent directly to a printer/plotter or passed
through the Windows clipboard to another program (e.g., a word processor).
The printer or plotter that gets used is based on what you currently have
selected as the default printer for Windows. The user has the ability to change
many of the default printer settings (e.g., portrait to landscape) before printing
occurs.

Sending Graphics Directly to the Printer

To send a graphic to the printer/plotter, do the following:

1. Display the graphic of interest (cross section, profile, rating curve, or
river system schematic) on the screen.

2. Using the available options (scaling, labels, grid, etc.), modify the plot
to be what you would like printed out.

3. Select Print from the File menu of the displayed graphic. Once Print
is selected, a Printer Options window will appear, giving the user
the opportunity to change any of the default printer settings. Once
you have the print settings the way you want them, press the Print
button on the Printer Options window and the plot will automatically
be sent to the Windows Print Manager. From that point the Windows
Print Manager will control the printing.

Sending Graphics to the Windows Clipboard

To pass a graphic to the Windows clipboard and then to another program, do
the following:

1. Display the graphic of interest on the screen.

2. Using the available options, modify the plot to be what you want it to
look like.

3. Select Copy to Clipboard from the File menu of the displayed
graphic. The plot will automatically be sent to the Windows
clipboard.

4. Bring up the program that you want to pass the graphic into (e.g.,
word processor). Select Paste from the Edit menu of the receiving
program. Once the graphic is pasted in, it can be resized to the
desired dimensions.

4-20
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Chapter 4 Example Application

Sending Tables Directly to the Printer

To send a table to the printer do the following:

1. Bring up the desired table from the tabular output section of the
program.

2. Select Print from the File menu of the displayed table. Once the Print
option is selected, a Printer Options window will appear. Set any
print options that are desired, then press the Print button. This will
send the entire table to the Windows Print Manager. From this point
the Windows Print Manager will control the printing of the table.

The profile type of table allows you to print a specific portion of the table,
rather than the whole thing. If you desire to only print a portion of the table,
do the following:

1. Display the desired profile type table on the screen.

2. Using the mouse, press down on the left mouse button and highlight
the area of the table that you would like to print. To get an entire row
or column, press down on the left mouse button while moving the
pointer across the desired row or column headings.

3. Select Print from the File menu of the displayed table. Only the
highlighted portion of the table and the row and column headings will
be sent to the Windows Print Manager.

Sending Tables to the Windows Clipboard

To pass a table to the Windows clipboard and then to another program, do the
following:

1. Display the desired table on the screen.

2. Select Copy to Clipboard from the File menu of the displayed table.

3. Bring up the program that you want to pass the table into. Select
Paste from the Edit menu of the receiving program.

Portions of the profile table can be sent to the clipboard in the same manner as
sending them to the printer.

Practice sending graphics and tables to the printer and the clipboard with the
example data set that you currently have open.
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Exiting the Program

Before you exit the HEC-RAS software, make sure you have saved all the
data. This can be accomplished easily by selecting Save Project from the
File menu on the HEC-RAS main window. Any data (geometric, flow, and
plan data) that have not been saved will automatically be saved for you.

To exit the HEC-RAS software, select Exit from the File menu of the HEC­
RAS main window. The program will prompt you to save the project if the
data have not been saved previously.
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Chapter 5 Working With Projects

CHAPTER 5

Working With Projects

To create a river hydraulics application with HEC-RAS, you work with
projects. A project is a collection of files that are used to build a model. This
chapter describes projects and how you build and manage them.

Contents

• Vnderstanding Projects

• Elements of a Project

• Creating, Opening, Saving, Renaming, and Deleting Projects

• Project Options

Understanding Projects

As you develop an application, the management of all the fIles that get created
is accomplished through the user interface. When a new project is started, the
user is requested to enter a title and filename for the project. All other data are
automatically stored by the user interface using the same name as the project
file, except for the three character extension. A project consists of:

• One Project file (.PRJ)

• One fIle for each Plan (.POI to .P99)

• One Run file for each plan (.ROI to .R99)

• One Output file for each plan (.001 to .099)

• One file for each set of Geometry data (.001 to .099)

• One file for each set of Steady Flow data (.FOI to .F99)

• One file for each set of Unsteady Flow data (.VOI to .U99)

• One file for each set of Sediment data (.SOI to .S99)

• One file for each set of Hydraulic Design data (.HOI to .H99)

5-1
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The Project File contains: the title of the project; the units system of the
project; a list of all the files that are associated with the project; and a list of
default variables that can be set from the interface. Also included in the project
file is a reference to the last plan that the user was working with. This
information is updated every time you save the project.

I
I
I

Elements of a Project

The following sections describe the various types of fIles that can be included
in a project. All of these fIles are either created by the user interface or the
various computation engines. The modeler interacts with the data through the
user interface, and is not required to create or edit any of these files directly.

Plan Files

Plan files have the extension .POI to .P99. The "P" indicates a Plan file, while
the number represents the plan number. As plans are created, they are
numbered from 01 to 99. The plan file contains: a description and short
identiller for the plan; a list of files that are associated with the plan (e.g.,
geometry file and steady flow file); and a description of all the simulation
options that were set for the plan. The plan file is created automatically by the
interface each time the user selects New Plan or Save Plan As from the
simulation windows.

Run Files

Run files have the extension .ROI to .R99. The "R" indicates a Run file, while
the number represents an association to a particular plan file. A file with an
extension of .ROI is the run file that corresponds to the plan file with the
extension .POL The run file contains all of the necessary data to perform the
computations that are requested by the associated plan file. For example, if a
steady flow analysis is requested, the run file will contain geometry data, steady
flow data, and all the necessary computational options that are associated with
the plan file. The run file contains the input to any of the computational engines
av.ailable in the HEC-RAS system. The run file is automatically generated by
the ·interface whenever the user presses the Compute button on the Simulation
windows. The run file is in an ASCII format, but it is not self explanatory.
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Chapter 5 Working With Projects

Output Files

Output files have the extension .001 to .099. The "0" indicates an Output
fUe, while the number represents an association to a particular plan fIle. A fUe
with the extension .012 is the output flie that corresponds to the plan fIle with
an extension .P12. The output flie contains all of the computed results from the
requested computational engine. For example, if a steady flow analysis is
requested, the output flie will contain results from the steady flow
computational engine. The output flies are in a binary flie format and can only
be read from the user interface.

Geometry Fi les

Geometry flies have the extension .GOI to .G99. The "G" indicates a
Geometry fIle, while the number corresponds to the order in which they were
saved for that particular project. Geometry flies contain all of the geometric
data for the river system being analyzed. The geometric data consist of: cross
section information; hydraulic structures data (e.g., bridges and culverts);
coefficients; and modeling approach information. The geometry data are stored
in an ASCII format. The flie contains key words to describe each piece of data,
and is for-the-most-part self explanatory. A geometry flie is created by the
user interface whenever the modeler selects New Geometry Data or Save
Geometry Data As from the Geometric Data window.

Steady Flow Data Files

Steady flow data flies have the extension .FOl to .F99. The "F" represents that
it is a steady Flow data flie, while the number corresponds to the order in
which they were saved for that particular project. Steady flow data flies
contain: the number of proftles to be computed; flow data; and boundary
conditions for each reach. The steady flow data flies are stored in an ASCII
format. The flie contains key words to describe each piece of data, and is for­
the-most-part self explanatory. Steady flow data flies are automatically created
by the user interface when the modeler selects New Flow Data or Save Flow
Data As from the Steady Flow Data window.

Unsteady Flow Data Files

Unsteady flow data flies have the extension .UOl to .U99. The "U" represents
that it is an Unsteady flow data flie, while the number corresponds to the order
in which they were saved for that particular project. Unsteady flow data flies
contain: flow hydrographs at the upstream boundaries; starting flow conditions;
and downstream boundary conditions. The unsteady flow data flies are stored
in an ASCII format. The flie contains key words to describe each piece of data,
and is for-the-most-part self explanatory. Unsteady flow data flies are
automatically created by the user interface when the modeler selects New Flow
Data or Save Flow Data As from the Unsteady Flow Data window.
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Currently, the unsteady flow data option is not available in HEC-RAS. This
option will be included in a future version.

Sediment Data Files

Sediment data fIles have the extension .SO1 to .S99. The "S" represents that it
is a Sediment data fIle, while the number corresponds to the order in which
they were saved for that particular project. Sediment data fIles contain: flow
data; boundary conditions for each reach; and sediment data. The sediment
data fIles are stored in an ASCII format. The fIle contains key words to
describe each piece of data, and is for-the- most-part self explanatory.
Sediment data fIles are automatically created by the user interface when the
modeler selects New Sediment Data or Save Sediment Data As from the
Sediment Data window. Currently, the sediment option is not available in
HEC-RAS. This option will be included in a future version.

Hydraulic Design Data Files

Hydraulic design data fIles have the extension .HOI to .H99. The "H"
represents that it is a Hydraulic design data fIle, while the number corresponds
to the order in which they were saved for that particular project. Hydraulic
design data fIles contain information corresponding to the type of hydraulic
design calculation that is requested. The Hydraulic design data fIles are stored
in an ASCII format. The fIle contains key words to describe each piece of data,
and is for-the most-part self explanatory. Hydraulic Design data fJ.les are
automatically created by the user interface when the modeler selects New
Hydraulic Design Data or Save Hydraulic Design Data As from the File
menu of the Hydraulic Design Functions window.

A schematic diagram of how the data fIles fIt together is shown in Figure 5.1
on the next page. In this example there are three plans in the project. Each
plan represents a specifIc set of steady flow data and geometry data. In this
example there are three geometry fIles and one steady flow fIle. The fIrst
geometry fIle could represent the existing conditions of the stream. The second
and third geometry fIle could represent some modifIcation of that base
geometry fIle, such as adding a bridge or culvert crossing; a channel
modifIcation; different roughness coefficients; or any other change to the base
geometry fJ.le. A plan is formulated by selecting a steady flow fJ.le and a
geometry file, and then saving that plan with a specifIc title and short identifIer.
For more information about formulating plans, see Chapter 7 of the HEC-RAS
User's Manual and Chapter 7 of the HEC-RAS Applications Guide.

5-4

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I



I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I

Chapter 5 Working With Projects

I Project File: fIlename.prj

~~
Geometry Data Geometry Data Geometry Data Steady Flow Data
fIlename. gO 1 fIlename.g02 fIlename.g03 fIlename.fO 1

\ ~" ~ --.".."

Plan 1 Plan 2 Plan 3
fJlename.pOl fJlename.p02 fJlename. pO 13

l l it

Run File 1 Run File 2 Run File 3

fIlename.fO 1 fIlename.r02 fIlename.r03

, ,

Output File 1 Output File 2 Output File 3

fIlename.oO 1 fJlename.o02 fIlename.o03

Figure 5.1 Schematic of Project Data Files.
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The following commands fromthe File menu of the HEC-RAS main window
allow you to create, open, save, rename, and delete projects.

Project Options

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
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Description

Deletes the project file and all other .flles
associated with the selected project. The user
is prompted to make sure that they really want
to delete all of the fIles.

Updates the project fIle and all other fIles in
which data have been modified.

Allows the user to rename the title of the
currently opened project.

Closes the current project, prompting you to
save the data if anything has been changed.
Opens an existing project and all of the
associated files.

Updates the project fIle and all other associated
data, saving all the information to a new
fIlename that you specify.

Closes the current project, prompting you to
save the data if anything has been changed.
The user is then prompted to enter a title and
fIlename for the new project.

File menu command

New Project

Open Project

Delete Project

Rename Project

Save Project

From the Options menu of the main HEC-RAS window, the user can set
several default project options. These options include: setting default margins
and color control for printing; setting default hydraulic variables; establishing
the default units system (English or Metric); and converting existing projects to
a different units system (English to Metric or Metric to English). The
following four options are available from the Options menu:

Save Project As

These commands are the same for all of the other data types that get created by
the user interface (Plan data, geometry data, steady flow data, unsteady flow
data, sediment data, and hydraulic design data).

Creating, Opening, Saving, Renaming, and Deleting
prOjJcts
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Chapter 5 Working With Projects

Options menu command Description

Program Setup

- BW to Printer When this option is set all graphics are
sent to the printer/plotter in Black and
White. When this option is turned off,
all graphics are sent as color drawings.
Color drawings that are sent to a black
and white printer will come out in grey
scale shadings.

- BW to Clipboard When this option is set all graphics are sent to
the Windows Clipboard in a Black and White
mode. When this option is turned off, the
graphics are sent to the Clipboard as color
drawings.

- Default Margins This option allows the user to change the
default margins for printing graphics and
tables. The default settings are 1 inch margins
on all four sides.

- Default File Viewer This option allows the user to change which
program is used for viewing the report
generator and logfile output. The default is the
Windows Write program. The user can change
this to any file viewer on their system.

- Open last project When this option is selected, the program will
automatically open the last project worked on,
during startup.

- Automatically backup
data When this option is checked, the program will

automatically make a backup of the currently
opened project, plan, geometry, and flow files.
The backup files are updated at specific timed
intervals, which is user controlled. The backup
fJ.1es are stored in the \HEC\RAS directory,
with the titles RasBackup.prj, RasBackup.pOl,
RasBackup.gOl, and RasBackup.fOl.

I
I
I
I
I
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- Set time for
automatic backup This option allows the user to control the time

interval between updating the backup fJ.1es.
The default value is 20 minutes.
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Options menu command

Default Parameters

Unit System

Convert Project Units

5-8

Description

This option allows the user to set defaults for
some of the hydraulic variables.

This option allows the user to set the default
units system to either English or Metric. Once
the units system is set, the program assumes
that all input data are entered in that units
system. Likewise, the display of all output data
will be done in the default units system.

This option allows the user to convert an
existing project from one units system to
another. Projects can be converted from
English to Metric or from Metric to English.
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Chapter 6 Entering and Editing Geometric Data

CHAPTER 6

Entering and Editing Geometric Data
Geometric data consist of establishing the connectivity of the river system
(River System Schematic), entering cross-section data, defining all the
necessary junction information, adding hydraulic structure data (bridges,
culverts, weirs, etc.) and cross section interpolation. The geometric data is
entered by selecting Geometric Data from the Edit menu on the HEC-RAS
main window. Once this option is selected, the Geometric Data window will
appear as shown in Figure 6.1. The drawing area will be blank on your
screen, until you have drawn in your own river system schematic.

This chapter describes how to enter and edit all of the necessary geometric
data for a river system.

Contents

• Developing the River System Schematic

• Cross Section Data

• Stream Junctions

• Bridges and Culverts

• Multiple Bridge and/or Culvert Openings

• Inline Weirs and Gated Spillways

• Cross Section Interpolation

• Viewing and Editing Data Through Tables

• Importing Geometric Data

• Graphical Cross Section Editor

• Attaching and Viewing Pictures

• Saving the Geometric Data
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Figure 6.1 Geometric Data Window

Dev loping the River System Schematic

Building The Schematic

The modeler develops the geometric data by first drawing in the river system
schematic on the Geometric Data window (Figure 6.1). The River System
Schematic is a diagram of how the stream system is connected together. The
river system is drawn on a reach-by-reach basis, by pressing the River Reach
bult-on and then drawing in a reach from upstream to downstream (in the
positive flow direction). Each reach is identified with a River Name and a
Reach Name. The River Name should be the actual name of the stream,
while the reach name is an additional qualifier for each hydraulic reach within
that river. A river can be comprised of one or more reaches. Reaches start or
end at locations where two or more streams join together or spilt apart.
Reaches can also start or end at the open ends of the river system being
modeled. In other words, the first and last cross section that will be modeled
in a particular river will be the start or end of a particular reach.
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Chapter 6 Entering and Editing Geometric Data

Reaches are drawn as multi-segmented lines. Each reach must have at least
two points, defining the start and end of the reach. However, it is more
typical to draw a reach with several points that would follow along the main
channel invert of the stream. To draw a reach, first press the River Reach
button on the upper left side of the Geometric Data editor. Move the mouse
pointer to the location on the drawing area that you would like to have the
reach begin (upstream end of the reach). Click the left mouse button once to
define the first point of the reach. Move the mouse and continue to click the
left mouse button to add additional points to the reach. To end a reach, move
the mouse pointer to the location in which you would like the last point of the
reach to be located, then double click the left mouse button. After the reach is
drawn, the user is prompted to enter the River Name and the Reach Name to
identify the reach. The river and reach identifiers are limited to sixteen
characters in length. If a particular River Name has already been entered for a
previously defined reach of the same river, the user should simply select that
river name from the list of available rivers in the river name text box. As
reaches are connected together, junctions are automatically formed by the
interface. The modeler is also prompted to enter an identifier for each
junction. Junctions are locations where two or more streams join together or
split apart. Junction identifiers are also limited to sixteen characters. An
example of a simple stream system schematic is shown in Figure 6.1.

Adding Tributaries into an Existing Reach

If you would like to add a tributary or bifurcation into the middle of an
existing reach, this can be accomplished by simply drawing the new reach and
connecting it graphically to the existing reach at the location where you would
like the new junction to be formed. Once the new reach is connected into the
middle of an existing reach, you will first be prompted to enter a River and
Reach identifier for the new reach. After entering the river and reach
identifiers, you will be asked if you want to "Split" the existing reach into two
reaches. If you answer "yes", you will be prompted to enter a Reach identifier
for the lower portion of the existing reach and a Junction name for the newly
formed stream junction.

E~iting The Schematic

There are several options available for editing the river system schematic.
These options include: changing labels, moving objects (such as labels,
junctions, and points in a reach), adding points to a reach, deleting points in a
reach, deleting entire reaches, deleting junctions, numerically editing the reach
schematic lines, and numerically editing the cross section schematic lines.
Editing functions for the schematic are found under the Edit menu of the
geometric data window. When a specific editing function is selected, the
interaction of the user with the schematic is restricted to performing that type
of operation. When the user is finished performing that editing function they
should turn off that editing function by selecting it again from the Edit menu.
When none of the editing functions are turned on, the schematic goes back to
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the default mode of interaction. The default interaction mode for the
schematic is described in the "Interacting with the Schematic" section of this
document. A description of each editing function follows:

Change Name: This option allows the user to change the identifiers of any
reach or junction. To change an identifier, you must be in the Change Name
edit mode. This is accomplished by selecting the Change Name option from
the Edit menu. Once you are in the Change Name edit mode, you then select
the particular label that you would like to change by clicking the left mouse
button over that label. When a label is selected, a pop up window will appear
allowing you to enter a new label. The user can continue to change names by
simply selecting the next label to be changed. The Change Name option can
only be turned off by re-selecting it from the edit menu or by selecting any
other edit option.

Move Object: This option allows you to move any label, junction, or point in
a reach. This is accomplished by first selecting Move Object from the Edit
menu, then selecting the particular object that you would like to move. To
select an object and then move it, simply place the mouse pointer over the
object, then press the left mouse button down. Move the object to the'desired
location and then release the left mouse button. The Move Object option will
remain in effect until the user either turns it off (which is accomplished by re­
selecting it) or selects any other edit option.

Add Points to a Reach: This option allows the user to add additional points
to the line that defines a reach. This allows the user to make the schematic
look more like the actual river system. To add additional points, first select
Add Points to a Reach from the Edit menu. Move the mouse pointer to the
location in which you would like to add an additional point on the reach line,
then click the left mouse button. After you have finished adding points to a
reach, you can move them around by selecting the Move Object option from
the Edit menu. To turn the "Add Points to a Reach" mode off, simply re­
select it from the Edit menu, or select any other edit function.

Remove Points in a Reach: This option allows the user to remove points
from a reach line. To use this option, first select Remove Points in a Reach
from the Edit menu. Move the mouse pointer over the point that you would
like to delete and then click the left mouse button. This option can only be
turned off by either n~-selecting the option from the Edit menu, or by selecting
another edit function.

Delete Reach: This option is used to delete a reach. This is accomplished by
selecting the Delete Reach option from the Edit menu. A list box containing
all the available reaches will appear allowing you to select those reaches that
you would like to delete. Warning - Be careful when you delete reaches.
When you delete a reach, all of its associated data will be deleted also.
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Chapter 6 Entering and Editing Geometric Data

Delete Junction: This option is used to delete a junction. This is
accomplished by selecting the Delete Junction option from the Edit menu. A
list box containing all the available junctions will appear allowing you to
select those junctions that you would like to delete.

Reach Schematic Lines: This option allows the user to numerically edit the
coordinates of the river reach schematic lines. When the river system
schematic is hand drawn on the screen, the coordinates of the river reach lines
are put into a simple coordinate system that ranges from 0.0 to 1.0 in both the
X and Y direction. However, the user has the option of taking real world
coordinates (such as UTM or State Plane coordinates) off of a map and
entering them into this table. If the user decides to use real world coordinates,
real world coordinates must be added for all of the reaches of the schematic.
If this is not done, the schematic will still be displayed in the simple 0.0 to l.0
coordinate system (the hand drawn coordinates). Once real world coordinates
have been entered for all of the river reaches, then the schematic will be
drawn in that coordinate system. To enter/edit the reach schematic lines,
select the Reach Schematic Lines option from the Edit menu. Once this
option is selected, a window will appear allowing the user to enter/edit the
coordinates of any of the reaches defined in the schematic. '

XS Schematic Lines: This option allows the ,user to numerically edit the
coordinates of the cross section schematic lines. When the river system is
hand drawn on the screen, the default coordinate system is a simple 0.0 to 1.0
range for both the X and Y direction. As cross sections are entered, they are
automatically scaled based on the coordinates of the river reach line and the
main channel distance between cross sections. Each cross section is drawn as
a straight line perpendicular to the river reach schematic line. The user has
the option of entering the real world coordinates (UTM or State Plane) of the
cross section schematic lines. Each cross section schematic line must have at
least two points, a start and an end, but additional points can be added if the
cross section was taken as a multi segmented line. In order for the cross
section schematic lines to be plotted in the real world coordinate system, the
user must enter real world coordinates for all of the cross sections in the
reach. To enter/edit the cross section schematic lines, select the XS
Schematic Lines option from the Edit menu. Once this option is selected, a
window will appear allowing the user to enter/edit the coordinates of any of
the cross section schematic lines.

Interacting With The Schematic

In addition to modifying the river schematic, there are options available to
zoom in, zoom out, display the cross section river stationing, and reset the
viewing extent of river system schematic. Additionally, the user has the
ability to use the mouse to interact with the schematic. This is accomplished
by moving the mouse pointer over an object (river reach line, junction, bridge,
culvert, etc.) on the schematic and pressing down the left mouse button. Once
the left mouse button is pressed down, a pop up menu will appear with
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options that are specific to that type of object. For example, when the left
mouse button is pressed down over a cross section, a menu will appear
allowing the user to select options to: edit the cross section, plot the cross
section, plot the profile for the reach that the cross section is in, display
tabular output for the cross section, and plot the computed rating curve for
that cross section. Another way of interacting with the schematic is to press
the right mouse button while the mouse pointer is located any where over the
schematic drawing area. This will bring up a pop up menu that is exactly the
same as the View menu at the top of the drawing. This option is providing for
convenience in getting to the View menu options. The options available from
the View menu are as follows:

Zoom In: This option allows the user to zoom in on a piece of the schematic.
This is accomplished by selecting Zoom In from the View menu, then
specifying the area to zoom in on with the mouse. Defining the zoom area is
accomplished by placing the mouse pointer in the upper left corner of the
desired area. Then press down on the left mouse button and drag the mouse
to define a box containing the desired zoom area. Finally, release the left
mouse button and the viewing area will display the zoomed in schematic.
Also displayed will be a small box in the upper right corner of the viewing
area. This box will contain a picture of the entire schematic, with a rectangle
defining the area that is zoomed in. In addition to showing you where you are
at on the schematic, this zoom box allows you to move around the schematic
without zooming out and then back in. To move the zoomed viewing area,
simply hold down the left mouse button over the rectangle in the zoom box
and move it around the schematic. The zoom box can also be resized.
Resizing the zoom box is just like resizing a window.

Zoom Out: This option zooms out to an area that is twice the size of the
currently zoomed in window. Zooming out is accomplished by selecting
Zoom Out from the View menu on the geometric data window.

Full Plot: This option re-draws the plot to its full original size. The Full Plot
option is accomplished by selecting Full Plot from the View menu on the
geometric data window.

Display River Stationing: This option allows you to display river station
identifiers on the schematic. This is accomplished by selecting Display River
Stationing from the View menu on the geometric data window.

Display Background Pictures: This option allows the user to turn on and off
the display of any background pictures that have been loaded.

Reset Plot Extent: This option allows the user to reset the extent of the river
system schematic, such that the plot will utilize the maximum amount of the
available plot area.
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Chapter 6 Entering and Editing Geometric Data

Background Pictures

Another option available to user's is the ability to add background images for
displayed behind the river system schematic. One or more pictures can be
added. The user has the option of rectifying the picture by entering
coordinates for the upper, lower, top, and bottom sides of the picture, with
respect to the coordinates of the river system schematic. If coordinates are not
entered for the extent of the picture, the size of the picture will be based on its
resolution and the resolution of your screen. The following graphical formats
are supported for background maps: bitmap (*.bmp); icon (*.ico); windows
metafile (*.wmf); GIF (*.gif); and JPEG (*.jpg).

Cross Section Data

After the river system schematic is completed, the next step for the modeler is
to enter the cross section data. Cross section data represent the geometric
boundary of the stream. Cross sections are located at relatively short intervals
along the stream to characterize the flow carrying capacity of the stream and
its adjacent floodplain. Cross sections are required at representative locations
throughout the stream and at locations where changes occur in discharge,
slope, shape, roughness, at locations where levees begin and end, and at
hydraulic structures (bridges, culverts, and weirs).

Entering Cross Section Data

To enter cross section data, the user presses the Cross Section button on the
Geometric Data window (Figure 6.1). Once the cross section button is
pressed, the Cross Section Data Editor will appear as shown in Figure 6.2
(except yours will be blank until you have added some data). To add a cross
section to the model, the user must do the following:

1. From the Cross Section Editor, select the river and the reach that you
would like to place the cross section in. This is accomplished by
pressing the down arrow on the River and Reach boxes, and then
selecting the river and reach of choice.

2. Go to the Options menu and select Add a new Cross Section from
the list. An input box will appear prompting you to enter a river
station identifier for the new cross section.

3. Enter all of the required data for the new cross section. Required data
is the data that is openly displayed in the cross section editor window.
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4. Enter any desired optional information (i.e., ineffective flow areas,
levees, blocked obstructions, etc.). Optional cross section information
is found under the Options menu.

5. Press the Apply Data button in order for the interface to accept the
data. The apply data button does not save the data to the hard disk, it
is used as a mechanism for telling the interface to use the information
that was just entered. If you want the data to be saved to the hard disk
you must do that from the File menu on the geometric data window.

The required information for a cross section consists of: the river, reach and
river station identifiers; a description; X & Y coordinates (station and
elevation points); downstream reach lengths; Manning's roughness
coefficients; main channel bank stations; and contraction and expansion
coefficients. All of the required information is displayed openly on the Cross
Section Data editor (Figure 6.2). A description of this information follows:

Figure 6.2 Cross Section Data Editor
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Chapter 6 Entering and Editing Geometric Data

River, Reach, and River Station. The River and Reach boxes allow the user
to select a specific hydraulic reach from the available reaches in the schematic
diagram. The river and reach labels define which reach the cross section will
be located in. The River Station tag defines where the cross section will be
located within the specified reach. The river station tag does not have to be
the actual river station of the cross section, but it must be a numeric value.
Cross sections are ordered in the reach from highest river station upstream to
lowest river station downstream. The up and down arrow buttons next to the
river station box can be used to sequentially move through the river stations.

Description. The description box is used to describe the cross section
location in more detail than just the river, reach, and river station. This box
has a limit of 512 characters. The first line of information is displayed, unless
the button to the right of the box is pressed. Also, the first 40 characters of
the description is used as a label for cross section plots and cross section
tables.

Cross Section X & Y Coordinates. This table is used to enter the station
and elevation information of the cross section. Station and elevation
information is entered in feet (meters for metric). The cross section
stationing (x-coordinates) are entered from left to right looking in the
downstream direction. Cross section stationing must be in increasing order.
However, two or more stations can have the same value to represent vertical
walls.

Downstream Reach Lengths. The downstream cross section reach lengths
describe the distance between the current cross section and the next cross
section downstream. Cross section reach lengths are defined for the left
overbank, main channel, and the right overbank. Cross section reach lengths
are entered in feet (meters for metric).

Manning's n Values. At a minimum, the user must specify manning's n
values for the left overbank, main channel, and the right overbank.
Alternative roughness options are available from the Options menu.

Main Channel Bank Stations. The main channel bank stations are used to
define what portion of the cross section is considered the main channel and
what is considered left and right overbank area. The bank stations must
correspond to stations entered on the cross section X & Y coordinates table.
If the user enters a value that does not correspond to the station points of the
cross section, the interface will ask the user if they would like the value to be
automatically interpolated and added to the cross section data.

Contraction & Expansion Coefficients. Contraction and expansion
coefficients are use to evaluate the amount of energy loss that occurs because
of a flow contraction or expansion. The coefficients are multiplied by the
change in velocity head from the current crosS section to the next downstream
cross section. In other words, the values entered at a particular cross section
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are used to compute losses that occur between that cross section and the next
downstream cross section.

Once all of the required data for the cross section are entered, make sure you
press the Apply data button to ensure that the interface accepts the data that
was just entered.

Editing Cross Section Data

The bulk of the cross section data is the station and elevation information.
There are several features available under the Edit menu to assist the user in
modifying this information. These features include the following:

Undo Editing. This editing feature applies to all of the information on the
cross section data editor. Once data has been entered and the Apply Data
button has been pressed, the Undo Editing feature is activated. If any
changes are made from this point, the user can get the original information
back by selecting the Undo Edit option from the Edit menu. Once the Apply
Data button is pressed, the new information is considered good and the Undo
Edit feature is reset to the new data.

Cut, Copy, and Paste. Cut, Copy, and Paste features are available for the
station and elevation information on the cross section editor. These features
allow the user to pass cross section station and elevation data to and from the
Windows Clipboard. To use this feature, first highlight a cell or multiple cells
on the station and elevation table. Cells are highlighted by pressing down on
the left mouse button and moving it over the cells that you would like to be
highlighted. Next select either the Cut or Copy feature from the Edit menu.
If Cut is selected, the information is placed in the Windows Clipboard and
then it is deleted from the table. If Copy is selected, the information is placed
in the Windows Clipboard, but it also remains in the table. Once the
information is in the Windows Clipboard it can be pasted into the station and
elevation table of any cross section. To paste data into another cross section,
first go to the cross section in which you would like the data to be placed.
Highlight the area of the table in which you want the data to be placed. Then
sel.ect the Paste option from the Edit menu. The cut, copy, and paste features
can also be used to pass station and elevation information between HEC-RAS
and other programs.

Delete. This option allows the user to delete a single cell or multiple cells in
the station/elevation table. Once the cells are deleted, everything below those
cells is automatically moved up. To use this option, first highlight the cells
that you would like to delete, then select the Delete option from the Edit
menu. If you would like to clear cells, without moving the data below those
cells, simply highlight the cells and press the delete key.
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Chapter 6 Entering and Editing Geometric Data

Insert. This option allows the user to insert one or several rows in the middle
of existing data in the station/elevation table. To use this option, first
highlight the area in the table that you would like to be inserted. Then select
Insert from the Edit menu. The rows will be inserted and all of the data will
be moved down the appropriate number of rows. The user can also insert a
single row by placing the curser in the row just below where you would like
the new row to be inserted. Then select Insert from the Edit menu. The row
will be inserted and all of the data below the current row will be moved down
one row.

Cross Section Options

Information that is not required, but is optional, is available from the Options
menu at the top of the cross section data editor window (Figure 6.2). Options
consist of the following:

Add a new Cross Section. This option initiates the process of adding a cross
section to the data set. The user is prompted to enter a river station tag for the
new cross section. The river station tag locates the cross section within the
selected reach. Once the river station is entered, the cross section data editor
is cleared (except for some default values that get set) and the user can begin
entering the data for the cross section. Whenever a new cross section is added
to the data set, default values will appear for the contraction and expansion
coefficients (0.1 and 0.3 respectively). Also, if the new cross section is not
the first or most upstream cross section of the reach, the program will set
default Manning's n values equal to the n values of the cross section just
up tream of the new cross section. If the user does not want these default
values, they can simply change them to whatever values they would like.

Copy Current Cross Section. This option allows the user to make a copy of
the cross section that is currently displayed in the editor. When this option is
selected, the user is prompted to select a river and reach for the new section,
and then enter the a river station. Once the information is entered, the new
cross section is displayed in the editor. At this point it is up to the user to
change the description and any other information about the cross section.
Th}s option is normally used to make interpolated cross sections between two
surveyed cross sections. Once the section is copied, the user can adjust the
elevations and stationing of the cross section to adequately depict the
geometry between the two surveyed sections.

Rename River Station. This option allows the user to change the River
Station of the currently displayed cross section.

Delete Cross Section. This option will delete the currently displayed cross
section. The user is prompted with a message stating specifically which cross
section is going to be deleted, and requesting the user to press the OK button
or the Cancel button. Once the OK button is pressed, the user will be
prompted with a question of whether or not they would like the cross section
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The user may want to add levees into a data set in order to see what effect a
levee will have on the water surface. A simple way to do this is to set a levee
station and elevation that is above the existing ground. If a levee elevation is
placed above the existing geometry of the cross section, then a vertical wall is
placed at that station up to the established levee height. Additional wetted
perimeter is included when water comes into contact with the levee wall. An
example of this is shown in Figure 6.5.
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The second option, for blocked obstructions, allows the user to enter up to 20
individual blocks (Multiple Blocks). With this option the user enters a left
station, a right station, and an elevation for each of the blocks. An example of
a cross section with multiple blocked obstructions is shown in Figure 6.7.
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Two alternatives are available for entering blocked obstructions. The first
option allows the user to define a left station and elevation and a right station
and elevation (normal blocked obstructions). When this option is used, the
area to the left of the left station and to the right of the right station will be
completely blocked out. An example of this type of blocked obstruction is
shown in Figure 6.6.

Blocked Obstructions. This option allows the user to define areas of the
cross section that will be permanently blocked out. Blocked obstructions
decrease flow area and add wetted perimeter when the water comes in contact
with the obstruction. A blocked obstruction does not prevent water from
going outside of the obstruction.
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Horizontal Variation in n Values. This option allows the user to enter more
than three Manning's n values for the current cross section. When this option
is selected, an additional column for n values is added to the cross section
coordinates table as shown in Figure 6.8. A Manning's n value must be
placed in the first row of the table. This n value is good for all cross section
stations until a new n value shows up in the table. The user does not have to
enter an n value for every station, only at the locations where the n value is
changing.
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Add a Lid to XS. This option allows the user to add a lid (similar to a bridge
deck/roadway) to any cross section. This is commonly used when trying to
model a long tunnel. The ground geometry can be used to describe the
bottom half of the tunnel, while the lid can describe the top half. A lid can be
added to any number of cross sections in a row. The program treats cross
sections with lids just like any other cross section. The energy equation is
used to balance a water surface, with the assumption of open channel flow.
The only difference is that the program will subtract out area and add wetted
perimeter when the water surface comes into contact with the lid.
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Figure 6.7 Example of a Cross Section With Blocked Obstructions
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Cross Section Dota- Base Geometry Dota E

Figure 6.8 Cross section with horizontal variation of n values selected

Horizontal Variation in k Values. This option allows the user to enter k
values (roughness heights) instead of n values. The k values are entered in
the same manner as the horizontal variation of n values. To learn more about
k values and how they are used in the program, see Chapter 3 of the Hydraulic
Reference manual.

Set Maximum Sta./Elev. Points. This option allows the user to set the
maximum number of station and elevation points in a cross section. The
default value is set to 100 points. A maximum value of 500 can be set. This
option is only necessary when the user wants to enter more than 100 points
for the station and elevation points of a cross section.
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Plotting Cross Section Data

Once all the data have been entered for a cross section, you should plot the
cross section to inspect it for possible data errors. To plot the current cross
section from the cross section editor, select Plot Cross Section from the Plot
menu.

Stre~m Junctions

Entering Junction Data

Stream junctions are defined as locations where two or more streams come
together or split apart. Junction data consist of a description, reach lengths
across the junction, tributary angles, and modeling approach. To enter
junction data the user presses the Junction button on the Geometric Data
window (Figure 6.1). Once the junction button is pressed, the junction editor
will appear as shown in Figure 6.9.

==""".""".""".--....-.-=.=====
Junction Data - base geo data
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Figure 6.9 Junction Data Editor

The junction editor will come up with one of the junctions loaded. Fill out the
description and reach lengths for the junction. Reach lengths across the
junction are entered here instead of the cross section data editor. This allows
for the lengths across very complicated confluences (i.e., flow splits) to be
accommodated. In the cross section data, the reach lengths for the
downstream cross section of each reach should be left blank or set to zero.

6-18

I
I
I
I
I
I
I
I
I
I
I
I
I
I
,I
I
I
I
I



I
I
I'
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I

Chapter 6 Entering and Editing Geometric Data

Selecting A Modeling Approach

In HEC-RAS ajunction can be modeled by either the energy equation or the
momentum equation. The energy equation does not take into account the
angle of a tributary corning in or leaving, while the momentum equation does.
In most cases the amount of energy loss due to the angle of the tributary flow

is not significant, and using the energy equation to model the junction is more
than adequate. However, there are situations where the angle of the tributary
can cause significant energy losses. In these situations it would be more
appropriate to use the momentum approach. When the momentum approach
is selected, an additional column is added to the table next to the junction
lengths. This column is used to enter an angle for any river reach that is
corning into or exiting the main river. For the reaches that are considered to
be the main river, the angle should be left blank or set to zero. Also, the user
has the option to turn friction and weight forces on or off during the
momentum calculations. The default is to have the weight force turned off.

If there is more than one junction in the river schematic, the other junctions
can be selected from the Junction Name box at the upper left corner of the
window. Enter all the data for each junction in the river system, then' close
the window by pressing the OK button in the lower left corner of the window.
When the junction data editor is closed the data are automatically applied.

Bridges and Culverts

Once all of the necessary cross-section data have been entered, the modeler
can then add any bridges or culverts that are required. HEC-RAS computes
energy losses caused by structures such as bridges and culverts in three parts.
One part consists of losses that occur in the reach immediately downstream
from the structure where an expansion of flow takes place. The second part is
the losses at the structure itself, which can be modeled with several different
methods. The third part consists of losses that occur in the reach immediately
upstream of the structure where the flow is contracting to get through the
opemng.

The bridge routines in HEC-RAS allow the modeler to analyze a bridge with
several different methods without changing the bridge geometry. The bridge
routines have the ability to model low flow (Class A, B, and C), low flow and
weir flow (with adjustments for submergence), pressure flow (orifice and
sluice gate equations), pressure and weir flow, and high flows with the energy
equation only. The model allows for multiple bridge and/or culvert openings
at a single location.
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The bridge and culvert routines utilize four user defined cross sections in the
computations of energy losses due to the structure. A plan view of the basic
cross section layout is shown in Figure 6.10.

The culvert hydraulics in HEC-RAS are based on the Federal Highway
Administrations (FHWA) standard equations from the publication Hydraulic
Design of Highway Culverts (FHWA, 1985). The culvert routines include the
ability to model circular, box, elliptical, arch, pipe arch, low profile arch, high
profile arch, and semi circular culverts. The HEC-RAS program has the
ability to model multiple culverts at a single location. The culverts can have
different shapes, sizes, elevations, and loss coefficients. The user can also
specify the number of identical barrels for each culvert type.

Figure 6.10 Cross Section Locations at a Bridge or Culvert

Lc
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Chapter 6 Entering and Editing Geometric Data

Cross section 1 is located sufficiently downstream from the structure so that
the flow is not affected by the structure (i.e., the flow has fully expanded).
This distance should generally be detennined by field investigation during
high flows. If field investigation is not possible, then there are two sets of
criteria for locating the downstream section. The USGS has established a
criterion of locating cross section I a distance downstream from the bridge as
equal to one times the bridge opening width. Traditionally the Corps of
Engineers criterion has been to locate the downstream cross section about four
times the average length of the side constriction caused by the structure
abutments. In practical applications this expansion distance will vary
depending upon the degree of constriction, the shape of the constriction, the
magnitude of the flow, and the velocity of the flow. Recently a detailed study
was completed by the Hydrologic Engineering Center entitled "Flow
Transitions in Bridge Backwater Analysis" (HEC, 1995). The purpose of this
study was to provide better guidance to hydraulic engineers performing water
surface profile computations through bridges. Specifically the study focused
on detennining the expansion reach length, Le; the contraction reach length,
Lc; the expansion energy loss coefficient, Ce; and the contraction energy loss
coefficient, Cc' A summary of this research, and the final recommendations,
can be found in Appendix B of the HEC-RAS Hydraulic Reference manual.
The user should not allow the distance between cross section I and 2 to
become so great that friction losses will not be adequately modeled. If the
modeler feels that the expansion reach will require a long distance, then
intermediate cross sections should be placed within the expansion reach in
order to adequately model friction losses.

Cross section 2 is located immediately downstream from the bridge (i.e.,
within a few feet). This cross section should represent the effective flow just
outside the bridge.

Cross section 3 should be located just upstream from the bridge. The
distance between cross section 3 and the bridge should be relatively short.
This distance should only reflect the length required for the abrupt
acceleration and contraction of the flow that occurs in the immediate area of
the opening. Cross section 3 represents the effective flow area just upstream
of the bridge.

Both cross sections 2 and 3 will have ineffective flow areas to either side of
the bridge opening during low flow and pressure flow profiles. In order to
model only the effective flow areas at these two sections, the modeler should
use the ineffective flow area option. This option is selected from the cross
section data editor. For a detailed discussion of how to set the ineffective
flow area stations and elevations, see Chapter 5 of the HEC-RAS Hydraulic
Reference manual.
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Cross section 4 is an upstream cross section where the flow lines are
approximately parallel and the cross section is fully effective. In general,
flow contractions occur over a shorter distance than flow expansions. The
distance between cross section 3 and 4 (the contraction reach length, Lc)

should generally be determined by field investigation during high flows. The
USGS has established a criterion for locating cross section 4 a distance
upstream from the bridge equal to one times the bridge opening width (the
distance between points Band C on Figure 6.10). Traditionally, the Corps of
Engineers used a criterion to locate the upstream cross section one times the
average length of the side constriction caused by the structure abutments. The
contraction distance will vary depending upon the degree of constriction, the
shape of the constriction, the magnitude of the flow, and the velocity of the
flow. As mentioned previously, the detailed study "Flow Transitions in
Bridge Backwater Analysis" (RD-42, HEC, 1995) was performed to provide
better guidance to hydraulic engineers performing water surface profile
computations through bridges. A summary of this research, and the final
recommendations, can be found in Appendix B of the HEC-RAS Hydraulic
Reference manual.

When the user adds a bridge at a particular river station, the program .
automatically formulates two additional cross sections inside of the bridge
structure. The geometry inside of the bridge is a combination of the bounding
cross sections (2 and 3) and the bridge geometry. The bridge geometry
consists of the bridge deck, abutments if necessary, and any piers that may
exist. The user can specify different bridge geometry for the upstream and
downstream sides of the structure if necessary. Cross section 2 and the
structure information on the downstream side are used as the geometry just
inside the structure at the downstream end. Cross section 3 and the upstream
structure information are used as the bridge geometry just inside the structure
at the upstream end.

Contraction and Expansion Losses

Losses due to the contraction and expansion of flow between cross sections
are determined during the standard step profile calculations. Contraction and
Expansion losses are described in terms of coefficient times the absolute value
ofthe change in velocity head between adjacent cross sections. When the
velocity head increases in the downstream direction a contraction coefficient
is used; and when the velocity head decreases in the downstream direction, an
expansion coefficient is used.
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Chapter 6 Entering and Editing Geometric Data

Bridge Hydraulic Computations

Low Flow Computations. For low flow computations the program first uses
the momentum equation to identify the class of flow. This is accomplished
by first calculating the momentum at critical depth inside the bridge at the
upstream and downstream ends. The end with the higher momentum
(therefore most constricted section) will be the controlling section in the
bridge. The momentum at critical depth in the controlling section is then
compared to the momentum of the flow downstream of the bridge when
performing a subcritical profile (upstream of the bridge for a supercritical
profile). If the momentum downstream is greater than the critical depth
momentum inside the bridge, the class of flow is considered to be completely
subcritical (i.e., class A low flow). If the momentum downstream is less than
the momentum at critical depth in the bridge, then it is assumed that the
constriction will cause the flow to pass through critical depth and a hydraulic
jump will occur at some distance downstream (i.e., class B low flow). If the
profile is completely supercritical through the bridge then this is considered
class C low flow. Depending on the class of flow the program will do the
following:

Class A low flow. Class A low flow exists when the water surface through the
bridge is completely subcritical (i.e., above critical depth). Energy losses
through the expansion (sections 2 to 1) are calculated as friction losses and
expansion losses. Friction losses are based on a weighted friction slope times
a weighted reach length between sections 1 and 2. The average friction slope
is based on one of the four available alternatives in HEC-RAS, with the
average-conveyance method being the default. This option is user selectable.
The average length used in the calculation is based on a discharge-weighted
reach length.

There are four methods available for computing losses through the bridge
(sections 2 to 3):

- Energy equation (standard step method)

- Momentum balance

- Yarnell equation

- FHWA WSPRO method

The user can select any or all of these methods in the computations. If more
than one method is selected, the user must choose either a single method as
the final solution or tell the program to use the method that computes the
greatest energy loss through the bridge as the answer at section 3. This allows
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the modeler to compare the answers from several techniques all in a single
execution of the program. Minimal results are available for all the methods
computed, but detailed results are available for the method that is selected as
the final answer.

Energy losses through the contraction (sections 3 to 4) are calculated as
friction losses and contraction losses. Friction and contraction losses between
sections 3 and 4 are calculated the same as friction and expansion losses
between sections land 2.

Class B low flow. Class B low flow can exist for either subcritical or
supercritical profiles. For either profile, class B flow occurs when the profile
passes through critical depth in the bridge constriction. For a subcritical
profile, the momentum equation is used to compute an upstream water
surface above critical depth and a downstream water surface below critical
depth, using a momentum balance through the bridge. For a supercritical
profile, the bridge is acting as a control and is causing the upstream water
surface elevation to be above critical depth. Momentum is used again to
calculate an upstream water surface above critical depth and a downstream
water surface below critical depth. The program will proceed with forewater
calculations downstream from the bridge.

Class C low flow. Class C low flow exists when the water surface through the
bridge is completely supercritical. The program can use either the energy
equation or the momentum equation to compute the water surface through the
bridge.

Pressure Flow Computations. Pressure flow occurs when the flow comes
into contact with the low chord of the bridge. Once the flow comes into
contact with the upstream side of the bridge, a backwater occurs and orifice
flow is established. The program will handle two cases of orifice flow: the
first is when only the upstream side of the bridge is in contact with the water;
and the second is when the bridge constriction is flowing completely full. For
the first case, a sluice gate type of equation is used, as described in
"Hydraulics of Bridge Waterways" (FHWA, 1978). In the second case, the
standard full flowing orifice equation is used. The program will begin
checking for the possibility of pressure flow when the energy grade line goes
above the maximum low chord elevation. Once pressure flow is computed,
the pressure flow answer is compared to the low flow answer and the higher
of the two is used. The user has the option to tell the program to use the water
surface, instead of energy, to trigger the pressure flow calculation.

Weir Flow Computations. Flow over the bridge and the roadway
approaching the bridge will be calculated using the standard weir equation.
For high tailwater elevations the program will automatically reduce the
amount of weir flow to account for submergence on the weir. This is
accomplished by reducing the weir coefficient based on the amount of
submergence. When the weir becomes highly submerged, the program will
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Chapter 6 Entering and Editing Geometric Data

automatically switch to calculating losses based on the energy equation
(standard step backwater). The criteria for when the program switches to
energy based calculations is user controllable.

Combination Flow. Sometimes combinations of low flow or pressure flow
occur with weir flow. In these cases an iterative procedure is used to
determine the amount of each type of flow.

Entering and Editing Bridge Data

To enter bridge data the user presses the Bridge/Culvert button on the
geometric data window (Figure 6.1). Once the bridge/culvert button is
pressed, the Bridge/Culvert Data Editor will appear as shown in Figure 6.11.
To add a bridge to the model the user must do the following:

1. Select the river and reach that you would like to place the bridge in.
This is accomplished by pressing the down arrow on the river and
reach box, and then selecting the river and reach of choice.

2. Go to the Options menu and select Add a Bridge and/or Culvert
from the list. An input box will appear prompting you to enter a river
station identifier for the new bridge.

3. Enter all of the required data for the new bridge. This includes:
- Bridge Deck
- Sloping Abutments (optional)
- Piers (optional)
- Bridge modeling approach information

4. Enter any desired optional information. Optional bridge information
is found under the Options menu at the top of the window.

5. Press the Apply Data button for the interface to accept the data.

The required information for a bridge consists of: the river, reach, and river
station identifiers; a short description of the bridge; the bridge deck; bridge
abutments (if they exist); bridge piers (if the bridge has piers); and specifying
the bridge modeling approach. A description of this information follows:

River, Reach and River Station. The River and Reach boxes allow the user
to select a river and reach from the available reaches that are defined in the
schematic diagram. The reach label defines which reach the bridge will be
located in. The River Station tag defines where the bridge will be located
within the specified reach. The river station tag does not have to be the actual
river station of the bridge, but it must be a numeric value. The river station
tag for the bridge should be numerically between the two cross sections that
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Figure 6.11 Bridge/Culvert Data Editor.
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bound the bridge. Once the user selects Add a Bridge and/or Culvert from
the options menu, an input box will appear prompting you to enter a river
station tag for the new bridge. Mter the river station tag is entered f the two
cross sections that bound the bridge will be displayed on the editor.

Description. The description box is used to describe the bridge location in
more detail than just the reach and river station. This box has a limit of 256
characters. Only the first line of information is displayed, unless the button to
the right of the box is pressed. Also, the first 40 characters of the description
are used as a label for bridge plots and tables.

Bridge DeckIRoadway. The bridge deck editor is used to describe the area
that will be blocked out due to the bridge deck, road embankment and vertical
abutments. To enter bridge deck information the user presses the Deck button
on the Bridge/Culvert Data Editor. Once the deck button is pressed, the Deck
Editor will appear as in Figure 6.12 (except yours will be blank). The
information entered in the deck editor consists of the following:
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Chapter 6 Entering and Editing Geometric Data

Figure 6.12 Bridge DeckIRoadway Data Editor

Distance - The distance field is used to enter the distance between the
upstream side of the bridge deck and the cross section immediately upstream
of the bridge. This distance is entered in feet (or meters for metric).

Width - The width field is used to enter the width of the bridge deck along the
stream. The distance between the bridge deck and the downstream bounding
cross section will equal the main channel reach length minus the sum of the
bridge "width" and the "distance" between the bridge and the upstream
section. The width of the bridge deck should be entered in feet (meters for
metric).

Weir Coefficient - Coefficient that will be used for weir flow over the bridge
deck in the standard weir equation.

Skew Angle - Angle that the bridge deck is skewed from a line perpendicular
to the flow lines passing through the bridge.
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Geometric Data

Upstream Stationing, High Chord, and Low Chord - This table is used to
define the geometry of the bridge deck on the upstream side of the bridge.
The information is entered from left to right in cross section stationing. The
deck is the area between the high and low chord elevation information. The
stationing of the deck does not have to equal the stations in the bounding
cross section, but it must be based on the same origin. The Del Rowand Ins
Row buttons allow the user to delete and insert rows.

Downstream Stationing, High Chord, and Low Chord - This portion of the
table is used to define the geometry of the bridge deck on the downstream
side of the bridge. If the geometry of the downstream side is the same as the
upstream side, then the user only needs to press the Copy Up to Down
button. When this button is pressed, all of the upstream bridge deck
information is copied to the downstream side. If the bridge deck information
on the downstream side is different than the upstream side, then the user must
enter the information into the table.

U.S. Embankment SS - This field is used to enter the slope of the road
embankment on the upstream side of the bridge. The slope should be entered
as the horizontal to vertical distance ratio of the embankment. This variable is
generally not used in the computations, but is used for display purposes in the
profile plot. However, if the user has selected the FHWA WSPRO bridge
method for low flow, this field will be used in the computation of the bridge
discharge coefficient.

D.S. Embankment SS - This field is used to enter the slope of the road
embankment on the downstream side of the bridge. The slope should be
entered as the horizontal to vertical distance ratio of the embankment. This
variable is generally not used in the computations, but is used for display
purposes in the profile plot. However, if the user has selected the FHWA
WSPRO bridge method for low flow, this field will be used in the
computation of the bridge discharge coefficient.

Max Allowable Submergence - The maximum allowable submergence ratio
that can occur during weir flow calculations over the bridge deck. If this ratio
is exceeded, the program automatically switches to energy based calculations
rather than pressure and weir flow.

Submergence Criteria - When submergence occurs there are two choices
available to figure out how much the weir coefficient should be reduced due
to the submergence. The first II\ethod is based on work that was done on a
trapezoidal shaped broad crested weir (FHWA, 1978). The second criterion
was developed for an Ogee spillway shape (COE,1965). The user should pick
the criterion that best matches their problem.
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Chapter 6 Entering and Editing Geometric Data

Min Weir Flow EI- This field is used to set the minimum elevation for which
weir flow will begin to be evaluated. Once the computed upstream energy
becomes higher than this elevation, the program begins to calculate weir flow.
However, the weir flow calculations are still based on the actual geometry of
the deck/roadway, and are not effected by this elevation. If this field is left
blank, the elevation that triggers weir flow is based on the lowest high chord
elevation on the upstream side of the bridge deck. Also, weir flow is based on
the elevation of the energy grade line and not the water surface.

Once all of the bridge deck information is entered, the user should press the
OK button at the bottom of the window. Pressing the OK button tells the
interface to accept the data and close the window. Once the deck editor
closes, the graphic of the bridge deck will appear on the Bridge/Culvert Data
window. An example of this is shown in Figure 6.13. Note! The data are
not saved to the hard disk at this point. Geometric data can only be saved
to the hard disk from the File menu of the Geometric Data window.
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Figure 6.13 Example Bridge Deck Plotted on Bounding Cross Sections
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Sloping Bridge Abutments. The sloping bridge abutments editor is used to
supplement the bridge deck information. Whenever bridge abutments are
protruding towards the main channel (sloping inward abutments), it will be
necessary to block out additional area that cannot be accounted for in the
bridge deck/roadway editor. If the bridge has vertical wall abutments, then it
is not necessary to use this editor. Vertical wall abutments can be included as
part of the bridge deck/roadway data. To add sloping abutments, the user
presses the Sloping Abutment button on the Bridge/Culvert Data editor.
Once this button is pressed the Abutment data editor will appear as in Figure
6.14.

Sloping abutments are entered in a similar manner to the bridge
deck/roadway. When the editor is open, it has already established an
abutment # of 1. Generally a left and right abutment are entered for each
bridge opening. Sloping abutment data are entered from left to right, looking
in the downstream direction. In general it is usually only necessary to enter
two points to describe each abutment.

Figure 6.14 Abutment Data editor

The data for each abutment consist of a skew angle (this is optional) and the
station and elevation information. The station and elevation information
represents the high chord information of the abutment. The low chord
information of the abutment is assumed to be below the ground, and it is
therefore not necessary to enter it. The geometric information for each
abutment can vary from upstream to downstream. If this information is the
same, then the user only needs to enter the upstream geometry and then press
the Copy Up to Down button.

I
I,
I
I
I
I
I
I
'I
I
I
I
I
I
I
I
I
I



I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I

I

Chapter 6 Enterins and Editins Geometric Data

To add additional sloping abutments, the user can either press the ADD or the
Copy button. To delete an ab\]tment, press the Delete button. Once all of the
abutment data are entered, the user should press the OK button. When the
OK button is pressed, the abutment information is accepted and the editor is
closed. The abutments are then added to the bridge graphic on the
Bridge/Culvert Data editor. An example of a sloping bridge abutment is
shown in Figure 6.15. This graphic is zoomed in on the left abutment of the
bridge.

Ground
A

Ineff

'"Bank Sta

2470 2480 2490

Figure 6.15 Example of a Sloping Abutment
. . .

Bridge Piers. The bridge pier editor is used to describe any piers that exist in
the bridge opening. Note! All piers must be entered through the Pier
Editor, they should not be included as part of the ground or bridge deck.
Several of the low flow bridge computations require that the piers be defined
separately in order to determine that amount of area under the water surface
that is blocked by the piers. If the piers are included with the ground or the
bridge deck, several of the methods will not compute the correct amount of
energy loss for the piers.
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Figure 6.18 Bridge Modeling Approach Editor

When the Bridge Modeling Approach editor comes up it will be ready to enter
data for the first bridge opening (coefficient set # 1). If there is more than one
bridge opening at the current location, the user can either use a single set of
modeling approaches and coefficients, or establish a different set for each
bridge opening.

Establishing a bridge modeling approach consists of defining which methods
the program will use for low flow computations and high flow (flow at or
above the maximum low chord) computations. The user can instruct the
program to use any or all of the low flow methods during the computations by
clicking the buttons under the Compute column. If either the Momentum or
YamelI method are selected, the user must enter a value for the pier loss
coefficient that corresponds to that method. If the WSPRO method is
selected, the user must press the "WSPRO Variables" button and enter
additional information that is required for the method~ Once the WSPRO
Variables button is pressed, a data editor as shown in Figure 6.19 will appear.
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Chapter 6 Entering and Editing Geometric Data

Figure 6.19 WSPRO Data Editor

As shown in Figure 6.19, there are several variables that must be entered as
well as some options that are available to the user. All of the required
variables shown on the WSPRO data editor are used in the computation of the
discharge coefficient, C, which is used in the WSPRO expansion loss
equation. A detailed discussion of how the discharge coefficient is computed
can be found in appendix D of the HEC-RAS Hydraulic Reference manual.
The following is a description of each of the variables on the WSPRO Data
Editor:

El-of the top ofthe Embankment - These fields are used for entering the
elevation of the top of the embankment (top of road) at the edges of the bridge
opening. An elevation must be entered for both the left and right side of the
bridge opening.

El ofthe toe of the Abutment - These fields are used for entering the elevation
of the abutment toe (elevation at the station in which the abutment toe
intersects with the natural ground inside the bridge opening) on both the left
and right side of the bridge opening.

Abutment Type - This field is used for selecting the type of abutments. There
are four abutment types available from this selection box.
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Slope ofthe Abutments - This field is used for entering the slope of the
abutments. This slope is taken as the horizontal distance divided by the
vertical distance. If the abutments are vertical walls, then this field should be
left blank or set to zero. If the left and right abutments do not have the same
slope, take an average of the two and enter that into this field.

Top Width ofEmbankment - This field is used for entering the width of the
top of the road embankment, in the area of the bridge opening. If the
topwidth of the embankment varies from one end of the bridge opening to the
other, use an average of the two widths.

Centroid stationing ofthe projected bridge opening at the approach cross
section - For the WSPRO bridge method, it is necessary to calculate the water
surface topwidth inside of the bridge opening, and then project that width onto
the approach cross section. The program calculates the conveyance within
this projected width at the approach cross section. This conveyance is used in
calculating a channel contraction ratio, which is an integral part in the
calculation of the discharge coefficient. If this field is left blank, the program
will automatically center the computed topwidth, such that the center of the
topwidth will be at the center of conveyance at the approach cross section.
The user can override this by entering their own centroid stationing value for
the approach cross section.

Wing Walls - This field is used for selecting the type of wing walls. There are
three choices available in the selection box: No wing walls present; Angular
wing walls; and Rounded wing walls. If the user selects "Angular wing
walls", then the fields labeled "Angle of Wing Wall" and "Length of Wing
Wall" become active and must be filled out. If the user selects "Rounded
wing walls", then the fields "Length of wing walls" and "Radius of entrance
rounding" become active and must be filled out. If the user selects "No wing
walls present" then no other infonnation on wing walls is necessary. For
more infonnation on wing walls see appendix D of the HEC-RAS Hydraulic
Reference manual.

Guide Banks Type - This field is used for selecting the type of guide banks if
any exist. There are three choices available from the selection box: No guide
bank present; Straight; and Elliptical. If the user selects "Straight" then the
fields labeled "Length of guide banks", "Offset of Guide Banks", and "Skew
of Guide Banks" become active and must be filled out. If the use selects
"Elliptical" then only the fields "Length of Guide Banks" and "Offset of
Guide Banks" become active. If the user selects "No Guide Bank present"
then no other infonnation about guide banks is necessary. For more
infonnation on Guide Banks see appendix D of the HEC-RAS Hydraulic
Reference manual.
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Chapter 6 Entering and Editing Geometric Data

Optional Contraction and Expansion Losses - This box allows the user to tum
on contraction and expansion losses at locations that are traditionally not in
the WSPRO methodology. The basic WSPRO bridge method only computes
expansion losses in the expansion reach (between the exit cross section and
the section just downstream of the bridge). This option allows the user to tum
on contraction and expansion losses individually at the following locations:
downstream inside of the bridge; upstream inside of the bridge; upstream
outside of the bridge; at the end of a guide bank (if guide banks exist); and at
the approach cross section. The default for the WSPRO method is that
contraction and expansion losses will not be calculated at these locations.
User's should not tum these options on unless they feel that the standard
WSPRO bridge approach is not producing enough energy loss through the
bridge.

Two other options that the user has control over are: specifying that the piers
are continuous the whole way through the bridge or not, and using the
Geometric Mean friction slope averaging technique through the bridge
computations (from exit to approach section). The default for the WSPRO
methodology is to assume that the piers are continuous through the bridge,
and to use the Geometric Mean friction slope method.

After all of the variables have been entered, the user must press the OK
button for the WSPRO variables to be accepted. For more information about
the computation of the discharge coefficient, and these data variable, see
appendix D of the HEC-RAS Hydraulic Reference manual.

Once the user has selected which low flow bridge methods will be computed,
they must also specify which of those methods will be used as the final
answer to continue the computations on upstream with. Only one of the
methods can be selected as the answer to "Use" in order to continue the
computations upstream. An alternative to selecting a single method to use is
to instruct the program to use the answer with the highest computed upstream
energy elevation. This is accomplished by pressing the button under the
"Use" column that corresponds to the Highest Energy Answer text field.

For high flows, the modeler can choose between Energy based calculations or
pressure and weir flow calculations. If pressure and weir flow is the selected
high flow method, the user must enter coefficients for the pressure flow
equations. The first coefficient applies to the equation that is used when only
the upstream side (inlet) of the bridge is submerged. If this coefficient is left
blank, the program selects a coefficient based on the amount of submergence.
If the user enters a coefficient, then that value is used for all degrees of
submergence. The second coefficient applies to the equation that is used
when both the upstream and downstream end of the bridge is submerged.
Generally this coefficient is around 0.8. For more information on pressure
flow coefficients see Hydraulics of Bridge Waterways (FHWA, 1978).
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Max Low Chord - This field is used to set the maximum elevation of the deck
low chord, and therefore the elevation at which pressure flow begins to be
calculated. If this field is left blank, then the elevation that triggers pressure
flow calculations is based on the highest low chord elevation on the upstream
side of the bridge deck. If the user enters a value in this field, then the value
set will be used to trigger when pressure flow calculations begin. Pressure
flow is triggered when the energy elevation exceeds the maximum low chord.
When pressure flow is calculated, the answer is compared to the low flow
answer and the higher of the two is selected. Alternatively, the user can tell
the program to use the water surface instead of the energy elevation to trigger
pressure flow calculations. This option can be found under the Bridge and
Culvert Options section of this manual.

Once all of the bridge modeling approach information is entered, the user
should press the OK button. When the OK button is pressed the information
will be accepted and the editor will close. Remember! The data are not
saved to disk at this point, it is only accepted as being valid. To save the
geometric data, use the File menu from the Geometric Data Editor window.

Bridge Design Editor

The bridge design editor allows the user to enter or modify bridge data
quickly and conveniently. With this editor the user can enter the
deck/roadway data, sloping abutments, and pier information. To put together
a bridge with this editor, the user would do the following:

1. From the Geometric Data window, open the Bridge/Culvert data
editor. Select the River and Reach in which you would like to place
the bridge.

2. Go to the Options menu and select Add a Bridge and/or Culvert
from the list. An input box will appear prompting you to enter a river
station identifier for the new bridge.

3. Open the Bridge Design editor by pressing the Bridge Design button
on the lower left side of the Bridge/Culvert Data editor.

4. Enter the required data for the bridge deck/roadway, sloping
abutments (optional), and piers (optional).

When the Bridge Design buttori- is pressed, a window will appear as shown in
Figure 6.20. The user only has to enter a minimal amount of information to
build or edit the bridge. To create the bridge deck/roadway, the user must
enter a high cord elevation (top of road) and a low cord elevation (maximum
elevation inside of the bridge opening).
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Chapter 6 Entering and Editing Geometric Data

Figure 6.20 Bridge Design Editor

The user has the option to limit the width of the bridge opening by selecting
the Add Vertical Walls in Deck option. When this option is selected, the
bridge opening will be limited to either the main channel bank stations (this is
the default) or a user specified width (this is optional). Everything left and
right of the bridge opening will be completely filled in all the way to the
ground elevations. If the user enters a bridge opening width, the opening will
be centered between the main channel bank stations.

The user also has the option to enter sloping abutments. Sloping abutments
should only be entered after selecting to limit the width of the bridge opening
with the vertical walls option. To enter sloping abutments, the user only has
to enter a slope in units of horizontal to vertical. The program will
automatically build a left and right sloping abutment that starts in the upper
left and right comers of the bridge opening.

Once all of the bridge deck/roadway infonnation is entered, the user can have
the program build the deck/roadway by pressing the Make DeckIRoadway
button.
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The last option available in the Bridge Design editor is to enter pier
infonnation. The user enters the number of piers, the upstream and
downstream stationing of the left most pier, the spacing between the
centerline of the piers, and the width of the piers. The user then presses the
Make Piers button to have the interface build the piers.

After all of the bridge data are entered, the user presses the Close button to
get out of the editor. The bridge data can be changed at any time by either
going back into the Bridge Design editor and entering new values, or by going
to the more detailed editors for the bridge deck/roadway, sloping abutments,
and piers.

Culvert Hydraulic Computations

The culvert hydraulic computations in HEC-RAS are similar to the bridge
hydraulic computations, except the Federal Highway Administration's
(FHWA) standard equations for culvert hydraulics under inlet control are used
to compute the losses through the structure. Because of the similarities
between culverts and other types of bridges, the cross section layout, the use
of ineffective areas, the selection of contraction and expansion coefficients,
and many other aspects of bridge analysis apply to culverts as well.

The culvert routines in HEC-RAS have the ability to model eight different
types of culvert shapes. These shapes include box (rectangular), circular,
elliptical, arch, pipe arch, semi circular, low-profile arch, and high-profile
arch culverts.

The analysis of flow in culverts is complicated. It is common to use the
concepts of "Inlet" control and "Outlet" control to simplify the analysis. Inlet
control flow occurs when the flow carrying capacity of the culvert entrance is
less than the flow capacity of the culvert barrel. Outlet control flow occurs
when the culvert carrying capacity is limited by downstream conditions or by
the flow capacity of the culvert barrel. The HEC-RAS culvert routines
compute the headwater required to produce a given flow rate through the
culvert for inlet control conditions and for outlet control conditions. In
general, the higher headwater "controls," and an upstream water surface is
computed to correspond to that energy elevation.

Inlet Control Computations. For inlet control, the required headwater is
computed by assuming that the culvert inlet acts as an orifice or a weir.
Therefore, the inlet control capacity depends primarily on the geometry of the
culvert entrance. Extensive laboratory tests by the National Bureau of
Standards, and the Bureau of Public Roads (now, FHWA), and other entities
resulted in a series of equations which describe the inlet control headwater
under various conditions. These equations are used by HEC-RAS in
computing the headwater associated with inlet control.
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Chapter 6 Entering and Editing Geometric Data

Outlet Control Computations. For outlet control flow, the required
headwater mustbecomputed considering several conditions within the culvert
and the downstream tailwater. For culverts flowing full, the total energy loss
through the culvert is computed as the sum of friction losses, entrance losses,
and exit losses. Friction losses are basedon Manning's equation. Entrance
losses are computed as a coefficient times the velocity head in the culvert at
the upstream end. Exit losses are computed as a coefficient times the change
in velocity head from just inside the culvert (at the downstream end} to
outside the culvert. . .

When the culvert is not flowing full, the direct step backwater procedure is
used to calculate the profile through the culvert up to the culvert inlet. An
entrance loss is then computed and added to the energy inside the culvert (at
the upstream end) to obtain the upstream energy (headwater). For more
information on the hydraulics of culverts, the reader is referred to Chapter 6
of the HEC-RAS Hydraulics Reference manual.

Entering and Editing Culvert Data

Culvert data are entered in the same manner as bridge data. To enter culvert
data the user presses the Bridge/Culvert button on the Geometric Data
window (Figure 6.1). Once this button is pressed, the Bridge/Culvert Data
Editor will appear (Figure 6.11). To add a culvert group to the model the user
must then do the following:

1. Select the river and reach that you would like to place the culvert in.
This is accomplished by pressing the down arrow on the river and
reach boxes, and then selecting the river and reach or"choice.

2. Go to the Options menu of the Bridge/Culvert editor and select Add
a Bridge and/or Culvert from the list. An input box will appear
prompting you to enter a river station identifier for the new culvert
group. After entering the river station, press the OK button and the
cross sections that bound the new culvert group will appear in the
editor.

3. - . Enter all of the required data for the culvert group. This includes the
road embankment information and the culvert specific data. The
roadway information is entered in the same manner as abridge (using
the deck/roadway editor). To enter culvert specific data, press the
Culvert button on the Bridge/Culvert Data editor.
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4. Once all of the culvert data are entered, press the OK button in order
for the interface to accept the infonnation.

River, Reach and River Station. The River and Reach boxes allow the user
to select a river and reach from the available reaches that were put together in
the schematic diagram. The reach label defines which reach the culvert will
be located in. The River Station tag defines where the culvert will be located
within the specified reach. The River Station tag does not have to be the
actual river station of the culvert, but it must be a numeric value. The River
Station tag for the culvert should be numerically between the two cross
sections that bound the culvert. Once the user selects Add a Bridge and/or
Culvert from the options menu, an input box will appear prompting you to
enter a River Station tag for the new culvert. Mter the River Station tag is
entered, the two cross sections that bound the culvert will be displayed on the
editor.

Description. The description box is used to describe the culvert location in
more detail than just the river, reach and river station. This box has a limit of
256 characters. Only the first line of infonnation is displayed, unless the
button to the right of the box is pressed. Also, the first 40 characters of the
description are used as a label for culvert plots and tables.

Culvert Road Embankment. The culvert road embankment is virtually the
same as the bridge deck/roadway infonnation. The road embankment is used
to describe the area blocking the stream and the roadway profile. The only
difference in the infonnation for culverts is that the low chord elevations
should be left blank or set to elevations below the ground data. This will
cause the road embankment to completely fill the channel up to the roadway
elevations (high chord data). Therefore, the only opening below the roadway
will be whatever culvert openings are entered.

To enter the culvert roadway infonnation, press the Deck/Roadway button on
the Bridge/Culvert Data Editor window. For an explanation of the deck
infonnation, please review the section entitled Bridge DeckIRoadway found
earlier in this chapter.

CUlvert Data. To enter culvert specific infonnation, press the Culvert
button on the Bridge/Culvert Data Editor window. When this button is
pressed, the Culvert Data Editor will appear as shown in Figure 6.21 (except
yours will be blank). The infonnation entered in the Culvert Data Editor
consists of the following:
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Chapter 6 Entering and Editing Geometric Data

Figure 6.21 Culvert Data Editor

Culvert ID# - The culvert identifier (ID#) is aut9matically assigned to
"Culvert #1 " the first time you open the editor. The user can enter up to ten
culvert types if they are working on a multiple culvert opening problem. If
all of the culvert barrels are exactly the same, then only one culvert type
(Culvert 10#) should be entered. The number of barrels is an input parameter
in the culvert data. If the user has culverts that are different in shape, size,
elevation, or loss coefficients, then additional culverts types (Culvert IO#'s)
must be added for each culvert type. To add an additional culvert type you
can either use the Add or Copy buttons. The Add button increments the
culvert ID# and clears the culvert editor. The Copy button increments the
culvert ID# and makes a copy of the original culvert data. Once a copy is
made of a culvert, the user can change any of the existing culvert information.
Culverts can be deleted by pressing the Delete button.

Solution Criteria - This option allows the user to select between taking the
higher of the inlet control and oQtlet control answers (Highest U.S. EO), or
specifically selecting the Inlet control or Outlet control answer. The default is
to let the program compute both and take the higher of the two. In general
this should be left this way. The only time a user should specifically select
Inlet control or Outlet control, is when they feel the program is in error by
selecting the higher of the two answers.
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Rename - This button allows the user to put in their own identifier for each of
the culvert types. By default the culvert types will be labeled "Culvert #1,"
"Culvert #2," and so on. The user can enter up to twelve characters for each
culvert type.

Shape - The shape selection box allows the user to select from one of the eight
available shapes. This is accomplished by pressing the down arrow on the
side of the box, and then selecting one of the eight available shapes.

Span - The span field is used to define the maximum width inside of the
culvert. The span is left blank for circular culverts.

Rise - The rise field describes the maximum height inside of the culvert.

Chart #. - This field is used to select the Federal Highway Administration
Chart number that corresponds to the type and shape of culvert being
modeled. Once the user has selected a culvert shape, the corresponding
FHWA chart numbers will show up in the chart # selection box. More
information on FHWA chart numbers can be found in the Hydraulics
Reference manual.

Scale. - This field is used to select the Federal Highway Administration Scale
number that corresponds to the type of culvert entrance. Once the user has
selected a culvert shape and chart #, the corresponding FHWA scale numbers
will show up in the scale selection box. More information on FHWA scale
numbers can be found in the Hydraulics Reference manual.

Distance to Upstream XS - This field is usedto locate the culvert in space,
relative to the two cross sections that bound the culvert crossing. The user
should enter the distance between the upstream cross section and the upstream
end of the culvert barrel.

Culvert Length - The culvert length field describes the length of the culvert
along the centerline of the barrel.

Entrance Loss Coefficient - The coefficient entered in this field will be
multiplied by the velocity head inside the culvert at the upstream end. This
value represents the amount of energy loss that occurs as flow transitions
from the upstream cross section to inside the culvert barrel.

Exit Loss Coefficient - The coefficient entered in this field will be multiplied
by the change in velocity head from inside the culvert to outside the culvert at
the downstream end. This value represents the energy loss that occurs as
water exits the culvert.

n-value - The n-value field is used for entering the Manning's n value of the
culvert barrel.
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Chapter 6 Entering and Editing Geometric Data

Upstream Invert Elevation - This field is used to describe the elevation of the
culvert invert at the upstream end.

Downstream Invert Elevation - This field is used to describe the elevation of
the culvert invert at the downstream end.

# Identical Barrels - This field is used to display the number of identical
barrels. The number of identical barrels is limited to 25. To enter more than
one identical barrel, the user must provide different centerline stationing
information for each barrel. As the centerline stationing information is added,
the number of identical barrels will automatically change to reflect the number
of centerline stations.

Centerline Stations - This table is used to enter the stationing of each culvert
barrel. Centerline stations must be provided for both the upstream and
downstream side of each culvert barrel.

Once all of the culvert information is entered, the user should press the OK
button at the bottom of the window. Pressing the OK button tells the
interface to accept the data and close the window. Once the culvert editor is
closed, the graphic of the culvert will appear on the Bridge/Culvert Data
editor window. An example culvert with two .culvert types and two identical
barrels for each culvert type is shown in Figure 6.22. Note! The data are
not saved to the hard disk at this point. Geometric data can only be saved
from the File menu on the Geometric Data window.

Legend

•
Ground

.........."' .

Ineff•Bank Sta

Figure 6.22 Bridge/Culvert Data Editor with example culvert
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Bridge and Culvert Options

Some additional options that are available, but not required, are found under
the Options menu from the Bridge/Culvert Data Editor. These include the
following:

Add a Bridge and/or Culvert. This option initiates the process of adding a
bridge or culvert to the data set. The user is prompted to enter a river station
tag for the new bridge or culvert. The river station tag locates the bridge or
culvert within the selected reach. Once the river station is entered, the
Bridge/Culvert Data editor is cleared and the user can begin entering the data
for that new bridge or culvert.

Copy Bridge and/or Culvert. This option allows the user to make a copy of
the bridge and/or culvert crossing and place it in another reach and/or river
station within the current project.

Rename River Station. This option allows the user to change the river
station of the currently opened Bridge and/or Culvert crossing.

Delete Bridge and/or Culvert. This option will delete the currently
displayed bridge or culvert. The user is prompted with a ~essage stating
specifically which bridge or culvert is going to be deleted, and requesting
them to press the OK button or the Cancel button.

Internal Bridge Cross Sections. This option allows the userto edit the two
cross sections inside of a bridge. These two cross sections are a copy of the
cross sections just upstream and downstream of the bridge. If the ground
elevations inside of the bridge are different than just outside of the bridge,
then the internal bridge cross sections should be modified to reflect the
changing elevations. This option allows the user to change the station and
elevation data, roughness coefficients, and main channel bank stations for
each of the two internal bridge cross sections.

Momentum Equation. This option allows the user to change the
components of the momentum equation. The momentum equation is one of
the optional low flow methods in the bridge routines. The default momentum
equation includes terms in the equation to account for friction losses and the
weight of water component. The user can turn either or both of these
components off from this option.

Momentum Class B Defaults. If the program computes that the flow must
pass through critical depth inside the bridge (Class B flow), critical depth will
automatically be located inside the bridge at the most constricted cross
section. If both cross sections are identical, the program will locate critical
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Chapter6 Entering and Editing Geometric Data

depth at the upstream inside cross section. This option allows the user to
control where the program sets critical depth for class B flow. If the user
feels that it would be better to set critical depth inside the bridge at the
downstream end, then this can be selected.

Pressure Flow Criteria. This option allows the user to select either the
energy grade line or the water surface, to be used as the criterion for when the
program begins checking for the possibility of pressure flow. By default the
program uses the energy grade line. This does not change how pressure flow
is calculated, only when the program will begin checking for pressure flow.

Bridge and Culvert View Features

Several options are available for viewing the bridge/culvert geometric data.
These options include: Zoom In; Zoom Out; Display Upstream XS; Display
Downstream XS; Display Both; Highlight Weir, Opening Lid and Ground;
Highlight Piers; and Grid. These options are available from the View menu
on the bridge/culvert data editor.

Zoom In: This option allows the user to zoom in on a piece of the bridge or
culvert. This is accomplished by selecting Zoom Infrom the View menu,
then specifying the area to zoom in on with the mouse. Defining the zoom
area is accomplished by placing the mouse pointer in the upper left corner of
the desired area. Then press down on the left mouse button and drag the
mouse to define a box containing the desired zoom area. Finally, release the
left mouse button and the viewing area will display the zoomed in area of the
bridge or culvert.

Zoom Out: This option re-displays the bridge or culvert back into its original
size before you zoomed in. Zooming out is accomplished by selecting Zoom
Out from the View menu bar on the bridge/culvert data editor.

Display Upstream XS. When this option is selected, only the upstream side
of the bridge or culvert will be displayed.

Display Downstream XS. When this option is selected, only the
downstream side of the bridge or culvert will be displayed.

Display Both. When this option is selected, both the downstream and
upstream sides of the bridge will be displayed in the viewing area.

HigWight Weir, Opening Lid and Ground. When this option is selected,
various portions of the bridge/culvert graphic will be highlighted. The
program will highlight in red the combination of the deck/roadway high cord
and any ground to the left and right of this data. The red color shows what the
program will use for weir flow if the Pressure and Weir option is selected for
high flows.
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The program will also highlight any bridge openings. Within the bridge
opening, the ground information will be highlighted in blue and the lid of the
opening (deck/roadway low cord data) will be highlighted in green. If the any
of these three colors show up in an area where they should not be, then there
must be a geometric mistake in the data. This option is very useful for
detecting any data entry errors that may otherwise go unnoticed.

Highlight Piers. When this option is turned on the interface will highlight
what it thinks is the extent of the pier information. This option allows the
user to see exactly what the program thinks are piers and to see how the pier
information has been clipped. Piers are clipped below the ground and above
the low chord of the bridge.

Grid. This option allows the user to have a grid overlaid on top of the bridge
or culvert graphic.

Multiple Bridge and/or Culvert Openings

HEC-RAS has the ability to model multiple bridge and/or culvert openings at
any individual river crossing. Types of openings can consist of bridges,
culvert groups (a group of culverts is considered to be a single opening), and
conveyance areas (an area where water will flow as open channel flow, other
than a bridge or culvert opening). Up to seven openings can be modeled at a
given location, and any combination of bridges and culvert groups can be
used. Conveyance type openings can range from zero to a maximum of two,
and the conveyance areas must be located on the far left and far right of the
river crossing.

An example multiple opening is shown in Figure 6.23. As shown in this
example, there are three types of openings: a conveyance area (left side,
labeled as opening #1), a bridge (labeled as opening #2), and a culvert group
(labeled as opening #3). During low flow conditions, flow will be limited to
the bridge opening. As flow increases, the culverts will begin to take some of
the flow away from the bridge opening. The conveyance area was defined as
ineffective flow (no conveyance) until the water surface goes above the top of
the bridge. This was accomplished by setting blocked ineffective flow areas.
In this example, three blocked ineffective flow areas were established: one to
the left of the bridge (which encompasses the whole conveyance area), one
between the bridge and the culvert group, and one to the right of the culvert
group.
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1. Press the Bridge/Culvert button on the Geometric Data window.

Chapter 6 Entering and Editing Geometric Data
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3. Select Add a Bridge and/or Culvert from the Options menu of the
bridge and culvert editor. Enter the river station at which you want to
place the multiple opening crossing. Once you have done this, the
two cross sections that bound this river station will appear in the
window.

2. Select the river and reach in which you would like to place the
multiple opening river crossing. This is accomplished from the River
and Reach boxes near the top of the window.

Multiple opening data are entered in the same manner as any other bridge or
culvert crossing. In general, the user should perform the following steps to
enter multiple opening data:

Entering Multiple Opening Data

535

530 ...

2'-c:
0

~ 525

~
W

520

Station (ft)

Figure 6.23 Example Multiple Opening River Crossing
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These two cross sections, along with the bridge and culvert
information, will be used to formulate the two cross sections inside
the multiple opening river crossing.

4. Enter the deck and road embankment data by using the
DeckIRoadway editor.

5. Enter any piers or sloping abutments that are required.

6. Select the Bridge Modeling Approach button and enter a set of
coefficients and modeling approaches for each bridge opening.

7. Enter Culvert data for any culvert openings.

8. Select the Multiple Opening Analysis button on the bridge and
culvert editor. Enter the types of openings and their station limits.
Start at the left most station of the crossing and work your way to the
right end. This is explained in greater detail under the section entitled
"Defining the Openings".

Deck/Road Embankment Data. There can only be one deck and road
embankment entered for any bridge and/or culvert crossing. The deck editor
is used to describe the area that will be blocked out due to the bridge deck and
road embankment. As shown by the grey shaded area in Figure 6.23, the deck
and roadway data are used to block out area around the bridge as well as
around the culverts. In the area of the bridge, high and low chord information
is entered in order to define the top of road as well as the bridge opening. In
the area of the culverts, the high chord information is entered to define the rest
of the top of the road embankment. However, the low chord information can
be left blank, or set to elevations below the ground, because the culvert data
define the culvert openings.

Piers and abutments. All piers are entered from the pier editor, which was
described previously under bridge data. The number of bridge openings has
no impact on how pier data are entered. Piers are treated as separate
information. Once the user establishes that there is morethan one bridge
opening, the program is smart enough to figure out which piers go with which
opening. If any sloping abutment data are required for a bridge opening, it
can be entered as described previously under the bridge data section.

Bridge Modeling Approach. A bridge modeling approach and coefficient
set must be established for at least one bridge opening. If there is more than
one bridge opening, and the user has only established a single coefficient set
and bridge modeling approach, those data will be used for all of the bridge
openings. The user can establish a different set of coefficients and modeling
approaches for each bridge opening.
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Figure 6.24 Bridge Modeling Approach Editor

As shown in Figure 6.24, the user must enter information under tile Bridge
Modeling Approach editor for at least one bridge Opening. Bridge openings
are referred to as Bridge # 1, Bridge # 2, etc.., up to the number of bridge
openings. Bridge # 1 represents the left most bridge opening.while looking in
the downstream direction. Bridge # 2 represents the next bridge opening to
the right of Bridge # 1, and so on. The user can enter additional coefficient
sets and modeling approaches by selecting either the add or copy button. If
either of these buttons is selected, the Bridge # will automatically be
incremented by one. The user can then enter or change any of the information
on the editor for the second bridge opening. Any bridge opening that does not
have a corresponding coefficient set and modeling approach, will
automatically default to what is set for Bridge # 1.

ctiIvert Data. Culvert information is added in the same manner as described
in the previous section called "Entering and Editing Culvert Data." Culverts
will automatically be grouped based on their stationing.
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Defining The Openings

Once all of the bridge and/or culvert data are entered for a multiple opening
river crossing, the last step is to define the number and type of openings that
are being modeled. This is accomplished by pressing the Multiple Opening
Analysis button on the Bridge/Culvert Data editor. Once this button is
pressed, an editor will appear as shown in Figure 6.25 (except yours will be
blank the first time you bring it up).

~..... 'jl!!!i •••••••
::::~;~(t f}

.................................................................................................................................................................................................................: 1m:!!

Figure 6.25 Multiple Opening Analysis window

The user selects from the three available opening types: Conveyance; Culvert
Group; and Bridge. Openings must be established in order from left to right,
while looking in the downstream direction. In addition to establishing the
number and types of openings, the user must also enter a Station Left and a
Station Right for each opening. These stations are used to establish limits for
each opening as well as stagnation points. Stagnation points are the locations
at which flow separates (on the upstream side) from one opening to the next
adjacent opening. Stagnation points can either be set to fixed locations or
they can be allowed to migrate within limits.

As shown in Figure 6.25 (numerical representation) and Figure 6.23
(graphical representation), there are three openings established in this
example. The fIrst opening is defined as a conveyance area, and it ranges
from station 98 (the left most station of the section) to station 260. That
means that any waterin this area will be treated as normal open channel flow,
and the water surface through this area will be solved by performing standard
step calculations with the energy equation. The second opening is the bridge
opening. This opening has a left station of 260 and a right station of 740.
This bridge will be modeled by using the cross section data, bridge deck, and
pier information that lie within these two stations (260 and 740). The bridge
coefficients and modeling approach for this opening will be based on the data
entered for bridge opening #1, since it is the first bridge opening. The third
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Chapter 6 Entering and Editing Geometric Data

opening is a culvert group. This opening has a left station of 650 and a right
station of 940.,AIlYCl;llverts .that lie within these stations will be considered
as being in the same culvert group.

Notice that the right station of the bridge opening overlaps with the left station
of the culvert group. This is done on purpose. By overlapping these stations,
the user is allowing the program to calculate the location· of the stagnation
point between these two openings. This allows the stagnation point to vary
from one profile to the next. In the current version of the HEC-RAS
software, stagnation points are allowed to migrate between any bridge and
culvert group openings. However, stagnation points must be set to a fixed
location for any conveyance opening type. A more detailed explanation of
stagnation points, and how the program uses them, can be found in the HEC­
RAS Hydraulics Reference manual, under the section on Multiple Openings
(Chapter 7).

Once the user has entered all of the information into the Multiple Opening
Analysis window, simply press the OK button to accept the data.

Multiple Opening Calculations

Multiple opening calculations are computationally intensive. An iterative
solution approach is used, by which the amount of flow through each opening
is adjusted until the computed upstream energies of each opening are balanced
within a predefined tolerance. The general approach of the solution scheme is
as follows:

1. The program makes a first guess at the upstream water surface by
setting it to the computed energy of the cross section just downstream
of the bridge.

2. The program sets an initial flow distribution. This is accomplished by
first calculating the amount of active flow area in each opening, based
on the water surface from step one. The program then apportions the
flow by using an area weighting (i.e., if an opening has 40 perc~nt of
the active flow area, then it will receive 40 percent of the flow).

3. Once a flow distribution is established, the program then calculates
the water surface and energy profiles for each opening, using the
estimated flow.

4. Once the program has computed the upstream energy for each
opening, a comparison is made between the energies to see if a
balance has been achieved (i.e., all energies are within the predefined
tolerance). Ifthe energies are not within the set tolerance, theprogram
re-distributes the flow based on the computed energies.
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5. The program continues this process until either the computed energies
are within the tolerance or the number of iterations reaches a pre­
defined maximum. The energy balance tolerance is set as 3 times the
user entered water surface calculation tolerance (The default is 0.03
feet or 0.009 meters). The maximum number of iterations for multiple
opening analysis is set to 1.5 times the user entered maximum number
of iterations from the normal water surface calculations (the default is
30 for multiple openings).

A more detailed discussion of how the program performs the multiple
opening analysis can be found in Chapter 7 of the HEC-RAS Hydraulic
Reference manual.

Weirs and Gated Spillways

The current version of HEC-RAS allows the user to model inline (across the
main stream) weirs and gated spillways. Lateral weirs and gated spillways are
not available in this version, but will be added to a future version of the
software. HEC-RAS has the ability to model radial gates (often called tainter
gates) or vertical lift gates (sluice gates). The spillway crest of the gates can
be modeled as either an ogee shape or a broad crested weir shape. In addition
to the gate openings, the user can also define a separate uncontrolled overflow
weir.

This section of the User's manual will describe how to enter the data for
inline weirs and gated spillways. For information on general modeling
guidelines and the hydraulic computations of inline weirs and gated spillways,
please see Chapter 8 of the HEC-RAS Hydraulic Reference manual. To find
out how to view specific results for an inline weir and gated SpillWilY, see
Chapter 8 of this User's manual.

Entering and Editing Inline Weir and Gated Spillway
Data

Inline weir and gated spillway data are entered in a similar manner as bridge
and culvert data. To enter an inline weir and/or gated spillway press the
Inline Weir/Spillway button from the Geometric Data window. Once this
button is pressed, the Inline Weir and Gated Spillway Data editor will appear
as shown in Figure 6.26 (except-yours will be blank until you have entered
some data).
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Inline Welf and Gated Spillay - Ex 12 Gated Spil""'ay
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Figure 6.26 Inline Weir and Gated Spillway Data Editor

To add an inline weir and/or gated spillway to a model, the user must do the
following:

1. Select the river and reach that you would like to place this inline weir
and/or spillway into. This is accomplished by first selecting a River,
then selecting a specific reach withinthat river. The River and Reach
selection buttons are at the top of the Inline Weir and/or Gated
Spillway Data editor.

2. Go to the Options menu at the top of the window and select Add an
Inline Weir and/or Gated Spillway from the list. An input box will
appear asking you to enter a river station identifier for locating this
structure within the reach. After entering the river station, press the
OK button and a copy of the cross section just upstream of this river
station will appear on the screen. This cross section is used in
formulating the inline weir and/or gated spillway crossing.

3. Enter all of the data for the Inline Weir and/or Gated Spillway. This
data will include a WeirlEmbankment profile, and any gated spillways
that you may be modeling. Gated spillways are optional. If the user
does not enter any gated spillways, then the program assumes that
there is only an inline weir.
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4. Once all of the Inline Weir and/or Gated Spillway data are entered,
press the Apply Data button in order for the interface to accept the
data. The editor can then be closed by selecting Exit from the File
menu at the top of the window.

River, Reach, and River Station. The River and Reach boxes allow the user
to select a river and reach from the available reaches that were put together in
the schematic diagram. The river and reach labels define which river and
reach the inline weir and/or gate spillway will be located in. The River
Station tag defines where the structure will be located within the specified
reach. The River Station tag does not have to be the actual river station of the
structure, but it must be a numeric value. The River Station tag for the inline
weir and/or gated spillway should be numerically between the two cross
sections that bound the structure. Once the user selects Add an InUne Weir
and/or Gated Spillway from the options menu, an input box will appear
prompting you to enter a River Station tag for the new structure. After the
River Station tag is entered, the cross section just upstream of the Inline Weir
and/or Gated Spillway will be displayed on the editor.

Description. The description box is used to describe the Inline Weir and/or
Gated Spillway location in more detail than just the river, reach and river
station. This box has a limit of 256 characters. Only the fIrst line of
information is displayed, unless the button to the right of the box is pressed.
Also, the first 40 characters of the description are used as a label for the Inline
Weir and/or Gated Spillway plots and tables.

WeirlEmbankment. The Embankment and Weir data are entered together,
and are used to describe the embankment blocking the stream as well as any
uncontrolled weirs. To enter the weir and embankment data, press the
WeirlEmbankment button and the editor will appear as shown in Figure 6­
27.

The Weir/Embankment Data editor is similar to the Deck/Roadway editor for
bridges and culverts. The data on the WeirlEmbankment editor is the
following:

Distance - The distance field is used to enterthe distance between the
upstream side ofthe WeirlEmbankment (the top of the embankment) and the
cross section immediately upstream of the structure. This distance is entered
in feet (or meters for metric).
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Chapter 6 Entering and Editing Geometric Data

Figure 6.27 Weir and Embankment Data Editor

Width - The width field is used to enter the width of the top of the
embankment along the stream. The distance between the top of the
embankment and the downstream bounding cross section will equal the main
channel reach length of the upstream cross section minus the sum of the
weir/embankment "width" and the "distance" between the embankment and
th~ upstream section. The width of the embankment should be entered in feet
(meters for metric).

Weir Coefficient - Coefficient that will be used for weir flow over the
embankment in the standard weir equation.

Skew Angle - Angle that the weir/embankment is skewed from a line
perpendicular to the flow lines.
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Station and Elevation Coordinates - This table is used to define the geometry
of the Weir and the Embankment. The information is entered from left to
right in cross section stationing. The user enters stations and elevations of the
top of the embankment and weir. The stationing does not have to equal the
stations in the bounding cross section, but it must be based on the same origin.
Everything below these elevations will be filled in down to the ground. The
Del Rowand Ins Row buttons allow the user to delete and insert rows.

U.S. Embankment SS - This field is used to enter the slope of the road
embankment on the upstream side of the structure. The slope should be
entered as the horizontal to vertical distance ratio of the embankment.

D.S. Embankment SS - This field is used to enter the slope of the road
embankment on the downstream side of the structure. The slope should be
entered as the horizontal to vertical distance ratio of the embankment.

Min Weir Flow El- This field is used to set the minimum elevation for which
weir flow will begin to be evaluated. Once the computed upstream energy
becomes higher than this elevation, the program begins to calculate weir flow.
However, the weir flow calculations are still based on the actual georrietry of
the weir/embankment, and are not effected by this elevation. If this field is
left blank, the elevation that triggers weir flow is based on the lowest
elevation of the station and elevation coordinates.

Weir Crest Shape - When submergence occurs over the weir there "are two
choices available to figure out how much the weir coefficient should be
reduced due to the submergence. These two criteria are based on the shape of
the weir. The first method is based on work that was done on a trapezoidal
shaped broad crested weir (FHWA, 1978). The second criterion was
developed for an agee spillway shape (COE,1965). The user should pick the
criterion that best matches their problem. If the user selects the agee
Spillway shape, then some additional information is require. For an agee
shaped weir the user must enter the "Spillway Approach Height" and the
"Design Energy Head". The spillway approach height is equal to the
elevation of the spillway crest minus the mean elevation of the ground just
upstream of the spillway. The design energy head is equal to the energy grade
line.elevation (at the design discharge) minus the elevation of the spillway
crest. In addition to these two parameters, the user has the option to have the
program calculate the weir coefficient at the design discharge. This is
accomplished by pressing the Cd button. Once this button is pressed, the
program will compute a weir coefficient for the agee spillway based on the
design head. During the weir calculations, this coefficient will fluctuate based
on the actual head going over the spillway. The curves used for calculating
the agee spillway coefficient at design head, and discharges other than design
head, were taken from the Bureau of Reclamation publication "Design of
Small Dams", Figures 249 and 250 on page 378 (Bureau of Reclamation,
1977).
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Chapter 6 Entering and Editing Geometric Data

Gated Spillway Data. In addition to uncontrolled overflow weirs, the user
can add gated spillways (this is optional). To add gated spillways to the
structure, press the Gate button on the Inline Weir and Gated Spillway data
editor. Once this button is pressed, the gated editor will appear as shown in
Figure 6.28 (except yours will be blank until you have entered some data).

Figure 6.28 Gated Spillway Editor

The Gated Spillway editor is similar to the Culvert editor in concept. The
user enters the physical description of the gates, as well as the required
co~fficients, in the Gated Spillway editor. The functionality of the gates is
defined as part of the Steady Flow data, on a per profile basis. The following
is a list of the data contained on this editor:

Gate Group - The Gate Group is automatically assigned to "Gate #1" the first
time you open the editor. The user can enter up to 10 different Gate Groups at
each particular river crossing, and each gate group can have up to 25 identical
gate openings. If all of the gate openings are exactly the same, then only one
gate group needs to be entered. If the user has gate openings that are different
in shape, size, elevation, or have different coefficients, then additional Gate
Groups must be added for each Gate type. To add an additional gate group
you can either use the Add or Copy buttons. The Add button increments the
Gate # and clears the culvert editor. The Copy button increments the Gate #
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and makes a copy of the original Gate group data. Once a copy is made of a
gate data, the user can change any of the existing gate information. Gate
groups can be deleted by pressing the Delete button. Also, if the gates are
identical, but the user wants to be able to open the gates to different
elevations, then the user must have a separate gate group for each set of gates
that will be opened to different elevations.

Height - This field is used to enter the maximum possible height that the gate
can be opened in feet (meters for metric).

Width - This field is used for entering the width of the gate in feet (meters for
metric).

Invert - This field is used for entering the elevation of the gate invert (sill
elevation of the spillway inside of the gate) in feet (meters for metric).

Discharge Coefficient - This field is used for entering the coefficient of
discharge for the gate opening. This coefficient ranges from 0.6 to 0.8 for
Radial gates and 0.5 to 0.7 for sluice gates.

Gate Type - This field is used for selecting the type of gate. Two gate types
are available, radial (tainter gate) or sluice (vertical lift gate).

Trunnion Exponent - This field is used to enter the trunnion height exponent
which is used in the radial gate equation. A typical value for a radial gate is
0.16. If you have selected a gate type of sluice gate, this value will be set to
0.0 and should not be changed.

Opening Exponent - This field is used to enter the gate opening exponent,
which is used in the radial gate equation. A typical value for a radial gate is
0.72. If you have selected a gate type of sluice gate, this value will be set to
1.0 and should not be changed.

Head Exponent - This field is used to enter the upstream energy head
exponent, which is used in the radial gate equation. A typical value for a
radial gate is 0.62. If you have selected a gate type of sluice gate, this value
will be set to 0.5, which is a normal value for a sluice gate.

Trunnion Height - This field is used for entering the height from the spillway
crest to the trunnion pivot point. See Chapter 8 oithe Hydraulic Reference
manual for more details on this variable.

Orifice Coefficient - This field is used to enter an orifice coefficient, which
will be used for the gate opening when the gate becomes more than 80 percent
submerged. Between 67 percent and 80 percent submerged, the program uses
a transition between the fully submerged orifice equation and the free flow
equations. When the flow is less than 67 percent submerged, the program
uses the free flow gate equations.
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Chapter 6 Entering and Editing Geometric Data

Centerline Stations - This table is used for entering the centerline stationing of
the identical gate openings. The user should enter a different centerline
stationing for each gate opening that is part of the current gate group. All gate
openings within the same gate group are exactly identical in every way,
except their centerline stationing. As a user adds new centerline stationing
values, the number of identical gates in the group is automatically
incremented and displayed in the field labeled "# Openings".

Weir Coefficient - This field is used for entering a weir coefficient that will be
used for the gate opening. This coefficient will only be used when the gate is
opened to an elevation higher than the upstream water surface elevation.
When this occurs, the flow through the gate is calculated as weir flow.

Weir Crest Shape - This parameter allows the user to select between a Broad
Crested shape weir and an agee shaped weir. Depending on which shape is
selected, the program will use a different submergence criteria during the
calculation. In addition to the submergence criteria, if the user selects the
agee shape, the program will bring up two additional data entry fields that
must be entered by the user. These fields are the Spillway Approach Height
and the Design Energy Head, both are explained below. Once these fields are
entered, the user should press the button labeled Cd. When this button is
pressed, the program will compute a weir coefficient for the agee spillway
based on the design head. During the weir calculations, this coefficient will
fluctuate based on the actual head going over the gated spillway. The curves
used for calculating the agee spillway coefficient at design head, and
discharges other than design head, work taken from the Bureau of
Reclamation publication "Design of Small Dams", Figures 249 and 250 on
page 378 (Bureau of Reclamation, 1977).

Spillway Approach Height - The spillway approach height is equal to the
elevation of the spillway crest minus the mean elevation of the ground just
upstream of the spillway.

Design Energy Head - The design energy head is equal to the energy grade
line elevation (at the design discharge) minus the elevation of the spillway.

Once all of the data for the gates has been entered, the user needs to press the
OK button for the data to be accepted. If the user does not want to use the
new data, and would like to go back to the original data they had before
entering the Gate Editor, press the Cancel button. If the user presses the OK
button, this does not mean that tbe data is saved to the hard disk, it is only
stored in memory and accepted as being good data. This data is part of the
geometry data, and is stored in the geometric data file. The data can be stored
to the hard disk by selecting one of the save options from the File menu of the
Geometric Data window.
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Occasionally it is necessary to supplement surveyed cross section data by
interpolating cross sections in between two surveyed sections. Interpolated
cross sections are often required when the change in velocity head is too large
to accurately detennine the energy gradient. An adequate depiction of the
change in energy gradient is necessary to accurately model friction losses as
well as contraction and expansion losses.

Cross section interpolation can be accomplished in three ways from within the
HEC-RAS interface. The first method is to simply copy one of the bounding
cross sections and then adjust the station and elevation data. The cross
section editor allows the user to raise or lower elevations and to shrink or
expand various portions of any cross section.

The second and third options allow for automatic interpolation of cross
section data. From the Geometric Data editor, automatic interpolation options
are found under the Options menu bar as shown in Figure 6.29.

Figure 6.29 Automatic Cross Section Interpolation Options
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Chapter 6 Entering and Editing Geometric Data

The first cross section interpolation option, Within a Reach, allows for
automatic interpolation over a specified range of cross sections within a single
reach. When this option is selected, a window will pop up as shown in Figure
6.30. The user must first select the River and Reach that they would like to
perform the interpolation in. Next the user must select a starting River Station
and an ending River Station for which interpolation will be performed. The
user must also provide the maximum allowable distance between cross
sections. If the main channel distance between two sections is greater than the
user defined maximum allowable, then the program will interpolate cross
sections between these two sections. The program will interpolate as many
cross sections as necessary in order to get the distance between cross sections
below the maximum allowable.

Figure 6.30 Automatic Cross Section Interpolating Within a Reach

Once the user has selected the cross section range and entered the maximum
allowable distance, cross section interpolation is performed by pressing the
Interpolate XS's button. When the program has finished interpolating the
cross sections, the user can close the window by pressing the Close button.
Once this window is closed, the interpolated cross sections will show up on
the river schematic as light green tic marks. The lighter color is used to
distinguish interpolated cross sections from user entered data. Interpolated
cross sections can be plotted and edited like any other cross section. The only
difference between interpolated sections and user defined sections is that
interpolated sections will have an asterisk (*) attached to the end of their river
station identifier. This asterisk will show up on all input and output forms,
enabling the user to easily recognize which cross sections are interpolated and
which are user defined.



The second type of automatic cross section interpolation, Between 2 XS's,
allows the user to have much greater control over how the interpolation is
performed. When this option is selected, a Cross Section Interpolation
window will appear as shown in Figure 6.31.

Figure 6.31 Detailed Cross Section Interpolation Window

This cross section interpolation window displays only two cross sections at a
time. The user can get to any two cross sections from the River, Reach and
River Station boxes at the top of the window. Interpolated cross section
geometry is based on a string model as graphically depicted in Figure 6.31.
The string model consists of chords that connect the coordinates of the
upstream and downstream cross sections. The cords are classified as master
and minor cords. As shown in Figure 6.31, five master cords are
automatically attached between the two cross sections. These master cords
are attached at the ends of the cross sections, the main channel bank stations,
and the main channel inverts. Minor cords are generated automatically by the
interpolation routines. A minor cord is generated by taking an existing
coordinate in either the upstream or downstream section and establishing a
corresponding coordinate at the opposite cross section by either matching an
existing coordinate or interpolating one. The station value at the opposite
cross section is determined by computing the decimal percent that the known
coordinate represents of the distance between master cords and then applying
that percentage to the opposite cross section master cords. The number of
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minor cords will be equal to the sum of all the coordinates of the upstream
and downstream sections minus the number of master cords. Interpolation at
any point in between the two sections is then based on linear interpolation of
the elevations at the ends of the master and minor cords. Interpolated cross
sections will have station and elevation points equal to the number of major
and minor cords.

This interpolation scheme is used in both of the automated interpolation
options ("Within a Reach" and "Between 2 XS's"). The difference is that the
Between 2 XS's option allows the user to define additional master cords.
This can provide for a better interpolation, especially when the default of five
major cords produces an inadequate interpolation. An example of an
inadequate interpolation when using the default cords is shown in Figure 6.32.

Figure 6.32 Cross Section Interpolation Based on Default Master Cords

As shown in Figure 6.32, the interpolation was adequate for the main channel
and the left overbank area. The interpolation in the right overbank area failed
to connect two geometric features that could be representing a levee or some
other type of high ground. If it is known that these two areas of high ground
should be connected, then the interpolation between these two sections should
be deleted, and additional master cords can be added to connect the two
features. To delete the interpolated sections, press the Del Interp button.
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Master cords are added by pressing the Master Cord button that is located to
the right of the Maximum Distance field above the graphic. Once this button
is pressed, any number of master cords can be drawn in. Master cords are
drawn by placing the mouse pointer over the desired location on the top cross
section. Then while holding the left mouse button down, drag the mouse
pointer to the desired location of the lower cross section. When the left
mouse button is released, a cord is automatically attached to the closest point
near the pointer. An example of how to connect master cords is shown in
Figure 6.33.

Figure 6.33 Adding Additional Master Cords for 'Interpolation

User defined master cords can also be deleted. To delete user defined master
cords, press the scissors button to the right of the master cords button. When
this button is pressed, simply move the mouse pointer over a user defined
cord and click the left mouse button to delete the cord.

Once you have drawn in all the master cords that you feel are required, and
entered the maximum distance desired between sections, press the interpolate
button. When the interpolation has finished, the interpolated cross sections
will automatically be drawn onto the graphic for visual inspection. An
example of this is shown in Figure 6.34.
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Figure 6.34 Final Interpolation With Additional Master Cords

As shown in Figure 6.34, the interpolation with the addition of user defined
master cords is very reasonable.

In general, the best approach for cross section interpolation is to first
interpolate sections using the "Within a Reach" method. This provides for
fast interpolation at all locations within a reach. The "Within a Reach"
method uses the five default master cords, and is usually very reasonable for
most cross sections. Once this is accomplished, all of the interpolated
sections should be viewed to ensure that a reasonable interpolation was
accomplished in between each of the cross sections. This can be done from
the "Between 2 XS's" window. Whenever the user finds interpolated cross
sections that are not adequate, they should be deleted. A new set of
interpolated sections can then be developed by adding additional master cords
in order to improve the interpolation.

CAUTION: Automatic geometric cross section interpolation should not be
used as a replacement for required cross section data. If water surface profile
information is required at a specific location, surveyed cross section data
should be provided at that location. It is very easy to use the automatic cross
section interpolation to generate cross sections. But if these cross sections are
not an adequate depiction of the actual geometry, you may be introducing
error into the calculation of the water surface profile. Whenever possible, use
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topographic maps to assist you in evaluating whether or not the interpolated
cross sections are adequate. Also, once the cross sections are interpolated,
they can be modified just like any other cross section.

If the geometry between two surveyed cross sections does not change linearly,
then the interpolated cross sections will not adequately depict what is in the
field. When this occurs, the modeler should either get additional surveyed
cross sections, or adjust the interpolated sections to better depict the
information from the topographic map.

River Ice

The current version of HEC-RAS allows the user to model ice-covered
channels. This section of the users manual will describe how to enter the data
describing the ice cover and the ice cover properties. If the ice cover geometry
is known, that is, if the ice cover thickness and roughness are known
throughout the reaches of interest, the user can supply these data and describe
the ice cover directly. If the ice cover results from a wide-river type jam,
HEC-RAS will estimate the jam thickness in reaches where the ice jam
occurs. In this case, the user can supply the material properties of the jam or
use the default values. To find out how to view specific results for a channel
with an ice cover, see Chapter 8 of this User's manual.

Entering and Editing Ice Data

River ice data can be entered in two ways: by using the Add Ice Cover option
under the Options Menu found at the top of the Cross Section Data Editor
(Figure 6.2), or by using Tables Menu found at the top of the Geometric Data
window (Figure 6.1). Both ways of entering data will be described below. It is
important to remember that at least two cross sections are required to define
the ice cover. A cross section should be placed at the upstream and
downstream ends of each ice-covered reach.

Entering Ice Data at a Cross Section

To enter river ice data the user presses the Cross Section button on the
Geometric Data window (Figure 6.1). Once the cross section button is pressed
the Cross Section Data Editor will appear as shown in Figure 6.2. See the
CROSS SECTION DATA section of the User's Manual, for information on
selecting the appropriate river, reach, and cross section in the Cross Section
Data Editor. Once a cross section with an ice cover has been selected, choose
the "Add ice cover..." option under the Options Menu found at the top of the
Cross Section Data Editor (Figure 6.2). This will open the Ice Cover Editor
(Figure 6.35). All ice data for this cross section can be entered with this
editor.
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Chapter 6 Entering and Editins Geometric Data

Ice Cover Editor

Figure 6.35 Ice Cover Editor

Ice Cover Thickness. The ice cover thickness in the left overbank (LOB),
main channel (Channel), and right overbank (ROB), are entered here. If there
is no ice in any of these areas, a thickness of zero should be entered_

Ice Cover Manning's n Values. The Manning's n value of the ice cover in
the left overbank (LOB), main channel (Channel), and right overbank (ROB),
are entered here. If any part of a cross section has a non-zero ice thickness, a
Manning's n value must be supplied.

Ice Cover Specific Gravity. The default value is 0.916. The user can supply
an-alternative value here.
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Wide River Ice Jam. The boxes under this option are checked if this section
is to be treated as a wide river ice jam. In this case, HEC-RAS will estimate
the jam thickness using the complete ice jam force balance as described in the
Hydraulic Reference Manual. The user can confine the jam to the main
channel or allow the jam to be in the channel and overbank areas by checking
the proper boxes. If the ice cover is confined to the channel, the overbanks
can have a known ice thickness (including an ice thickness of zero) assigned
to them in the Ice Cover Thickness option. If the Wide River Ice Jam option is
selected, an ice cover thickness must be supplied for the main channel using
the Ice Cover Thickness Option or through the Ice Tables (see below). This
ice cover thickness will be used as the initial estimate of the ice jam thickness
and will also serve as the minimum thickness allowed for the ice jam at that
section. If the jam is allowed in the overbank areas, the channel and
overbanks hydraulic properties will be combined to calculate a single jam
thickness for the channel and overbanks. NOTE: A wide river jam cannot be
selected for an entire river channel. A cross section with fixed ice cover
geometry must be included at the upstream end and the downstream end of
the wide river ice jam to serve as the boundary conditions for the jam. There
is no limit to the number of separate wide river jams that can exist in a river
network. However, every ice jam must have a cross section with fixed ice
geometry at its upstream and downstream limit. Ice jams can extend through
any number of junctions. However, the jam will only be extended between
reaches that have identical reach names.

Internal Friction Angle of the Jam (degrees). This describes the "strength"
of the ice jam as a granular material. The default value is 45_degrees.

Ice Jam Porosity (fraction water filled). This describes the fraction of the
ice jam that is filled with liquid water. The default value is 0.4.

Coefficient Kl (longitudinal to lateral stress in jam). This describes the
ratio of the lateral stress and the longitudinal stress in the jam. It is the
efficiency of the jam in transferring longitudinal stress into lateral stress
against the channel banks. The default value is 0.33

Maximum mean velocity under ice cover. This option limits the maximum
mean velocity under a wide river ice jam. The default value is 5 fps. If the
maximum mean velocity is greater than this, the ice cover will be thinned until
the maximum velocity is attained, or the minimum ice thickness supplied by
the user is reached. In any case, the jam thickness will not be allowed to be
thinner than the user supplied thickness. This option prevents the jam from
thickening to such an extent that the entire cross sectional area of the channel
would become blocked.

Ice Cohesion. At present, the ice jam cohesion is set to the default value of
zero. This cannot be changed by the user. A value of zero is appropriate for
breakup ice jams.
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Chapter 6 Entering and Editing Geometric Data

Fixed Manning's n Value (or Nezhikovsky's data will be used). The
Manning's n value of the ice jam can be specified by the user or estimated
using the empirical relationships developed from Nezhikovsky's data (1964).
The empirical relationships estimate the Manning's n value on the basis of the
jam thickness and the total water depth. The default is the user supplied
Manning's n value.

Once all the ice data have been entered and edited, click the OK button. At
the bottom of the Cross Section Data Editor, in the space entitled "List of
special notes for cross section," the words "Ice cover" will now appear. The
user can now click on the words "Ice cover" to return to the ice cover editor
for that cross section.

Entering Ice Data Through a Table

Ice cover information can also be entered using the Tables Menu found at the
top of the Geometric Data Window (Figure 6.1). To enter data the user selects
the Ice Cover Option under the Tables Menu. All the information that can be
entered under the Ice Cover Editor can also be entered using the Ice Cover
table. It is often very convenient to enter and view data for more than one
cross section at a time (Figure 6.36).

Figure 6.36 Entering ice information using a Table
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The user has the option of entering the ice thickness in the left overbank
(LOB ice Thickness), the main channel (Chan ice Thickness), and the right
overbank (ROB ice Thickness); the Manning's n value of the left overbank
ice cover (LOB ice Mann n), the main channel ice cover (Chan ice Mann n),
and the right overbank ice cover (ROB ice Mann n); and the specific gravity
of the ice cover (Ice gravity). The user can also choose if the ice cover in the
main channel is the result of a wide river ice jam (Ice Jam Chan. Note: only y
or n can be entered here), and choose if the overbanks are also included in
the wide river ice jam (Ice Jam OB. Note: only y or n can be entered here).
The user can further select the internal friction angle of the ice jam (Friction
Angle); the porosity of the ice jam (Porosity); the longitudinal to lateral stress
ratio of the ice jam (Stress Kl ratio); the maximum allowable under ice flow
velocity (Max Velocity); and if the Manning's n value of the ice jam is fixed,
that is selected by the user, or if the Manning's n value will be determined by
HEC-RAS (Note: only y or n can be entered here).

As in all instances where a Table is used to enter data, in each column the user
has the option of entering one or more values, adding a constant to one or
more of the values, multiplying a group of values by a factor, or changing a
group of values to a specific value. Additionally, cut, copy, and paste buttons
are provided to pass data to and from the Windows Clipboard.

Entering Ice Data at Bridges

The influence of ice on the hydraulics of bridges is a relatively unstudied area.
Little is known about the ways in which a wide river ice jam interacts with the
various components of a bridge. The important components of a bridge that
may interact with an ice jam include the piers, low chord, approaches, and
deck. Previous investigations of ice jams in rivers with bridges have largely
ignored their presence, arguing that observed ice jams did not cont~ct the low
steel significantly. Removing the bridge information for an ice jam study still
remains an option. However to allow a user to efficiently use HEC-RAS with
ice and with bridges, three separate options are provided. These options allow
the user to selectively decide at each bridge whether or not the ice cover can
interact with the structure. When modeling ice at bridges, users should
carefully evaluate the results for consistency and accuracy.

Ice information at bridges is entered using the Bridge/Culvert editor found
under the Geometry editor. Use the options menu in the Bridge/Culvert editor
to select the ice option. This will open a window as shown in Figure 6.37.
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HEC-RAS
:.:-;"'::"::":::::-:::::-::;-;':-:::~:::

Figure 6.37 Entering ice information at bridges

No ice computed in the bridge. In this case no ice calculations will be
prefonned at the bridge itself and the ice thickness at the bridge will be
assumed to be zero.

Ice remains constant through the bridge. In this case, the ice thickness at
the cross section immediately upstream of the bridge will be used. If the ice
thickness is calculated as a wide river jam, this thickness will be used.

Dynamic ice jam computed through the bridge. In this case, the wide river
ice jam calculations will be prefonned at the bridge cross section. The user
must check for inconsistent results, especially if any part of the ice jam is
above the low chord of the bridge.

Setting Tolerances for the Ice Jam Calculations

The user can override the default settings for the ice j am calculation tolerances
which are used in the solution of the ice jam force balance equation. The
tolerances are set as multiples of the water surface calculation tolerance used
in the solution of the energy equation, described in the Simulation Options
sec;tion of Chapter 7. The user can change the values of these tolerances by
changing the water surface calculation tolerance. The tolerances are as
follows:

Ice thickness calculation tolerance. This tolerance is compared with the
difference between the computed and assumed ice thickness at a cross section.
It is set to ten times the water surface calculation tolerance. Its default value
isO.lft.
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Global ice thickness calculation tolerance. This tolerance is compared with
the difference between the computed ice thickness at each cross section
between successive solutions of the ice jam force balance equation and the
energy equation.. It is set to ten times the water surface calculation tolerance.
Its default value is 0.1 ft.

Global water level calculation tolerance. This tolerance is compared with
the difference between the computed water surface elevations at each cross
section between successive solutions of the ice jam force balance equation
and the energy equation. It is set to six times the water surface calculation
tolerance. Its default value is 0.06 ft.

Maximum number of ice jam iterations. This variable defines the
maximum number of times for successive solutions of the ice jam force
balance equation and the energy equation. It is set to 2.5 times the maximum
number of iterations. Its default value is 50.

Viewing and Editing Data Through Tables

Once cross section data are entered, the user can view and edit certain types of
data in a tabular format. The current version of HEC-RAS· allows the user to
view and edit Manning's n or k values, cross section reach lengths, contract
and expansion coefficients, and the cross section river stationing. These
options are available from the Tables menu option on the Geometric Data
editor. The following is a description of each option.

Manning's n or k values

It is often desirable to view and edit the Manning's n values or roughness
heights (k values) for several cross sections all at the same time. From the
Geometric Data editor, the user can select Manning's n or k values from
the Tables menu item. Once this option is selected, a window will appear as
shown in Figure 6.38.

As shown in Figure 6.38, the user has the options of selecting either n or k
values to be used as the roughness coefficient, add a constant to one or more
of the n or k values, multiply a group of n or k values by a factor, or change a
group of nor k values to a specific value. Additionally, cut, copy, and paste
buttons are provided to pass data to and from the Windows Clipboard.

To add a constant to a group of n or k values, the user must first highlight the
values that they would like to change. Highlighting is accomplished by
placing the mouse in the upper left cell of the desired cells to highlight, then
press the left mouse button and drag the cursor to the lower left corner of the
desired cells to highlight. When the left mouse button is released, the cells
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tdit Manning's n Values
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Figure 6.38 Manning's n Data View and Editing Table

that are selected will be highlighted (except the first cell). Once the user has
highlighted the desired cells to be modified, press the Add Constant button.
This will bring up a pop up window, which will allow the user to enter a
constant value that will be added to all cells that are highlighted.

To multiply a group of n or k values by a factor, the user first highlights the
desired cells. Once the cells are highlighted, pressing the Multiply by a
Factor button will bring up a pop up window. This window allows the user
to enter a value that will be multiplied by each of the highlighted cells.

To set a group of n or k values to the same number, the user must first
highlight the values that they would like to change. Once the cells are
highlighted, pressing the Set Values button will bring up a pop up window.
This window will allow the user to enter a specific n or k value which will
replace all of the highlighted values.

The user can also go directly into the table and change any individual values.
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Reach Lengths

The user has the ability to view and edit cross section reach lengths in a
tabular format. This is accomplished by selecting Reach Lengths from the
Tables menu of the Geometric Data editor. Once this option is selected, a
window will appear as shown in Figure 6.39. The user has the same editing
features as described previously for the n values table. See the discussion
under Manning's n or k values, in the previous section, for details on how to
edit the data.

===~,_...._._--.._-_.._._------_.._-_._-_._...
Edit Downstream Reach Lengths

;::.::;:::
:.::::::':

;;: :~:.

,..~:.~L"" ,..""" " "',...L?3.6340.37
1489 14729 :152 72
192.87 199.9209.~b

19539 191 .28 . .J1B8. 07

208.04 .?~gJ~W.,,, ...............• ?Q~;,~.§ ..
203.23 197.54193.52

•••·~II~II~i20495 20275 ···199.45
... ~ 21323 201.57201.77

19629 201 .98204.19................ - .. '.
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Figure 6.39 Reach Lengths View and Editing Table

Contraction and Expansion Coefficients

The user has the ability to view and edit contraction and expansion
coefficients in a tabular format. This is accomplished by selecting
Coefficients from the Tables menu of the Geometric Data editor. Once this
option is selected, a window will appear as shown in Figure 6.40. The user
has the same editing features as described previously for the n values table.
See the discussion under Manning's n values, in the previous section, for
details on how to edit the data.
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t:dit Contraction/t:xpansion Coefficients

Figure 6.40 Contraction and Expansion Coefficients Table

River Stationing

This option allows the user to view and edit the cross section river stationing
in a tabular form. This is accomplished by selecting River Stations from the
Tables menu of the Geometric Data editor. Once this option is selected, a
window will appear as shown in Figure 6.41. This table allows the user to
change the river stationing of individual cross sections, add a constant value
to the river stationing of selected cross sections (those cross sections
highlighted by the user), multiply the selected cross sections river stationing
by a factor, or to renumber the cross section river stationing based on the main
channel reach lengths.
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RenamE! River Stfihons

Figure 6.41 Cross Section River Stationing View and Editing Table

Importing Geometric Data

HEC-RAS has the ability to import geometric data in several different
formats. These fonnats include: a GIS fonnat (developed at HEC); the
USACE Standard Surveyor fonnat; the HEC-2 data fonnat, and the HEC­
RAS data fonnat. Data can be imported into an existing HEC-RAS geometry
file or for a completely new geometry file (one that has no data at all).
Multiple data files can be imported into the same geometric data file on a
reach by reach basis.
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Chapter 6 Entering and Editing Geometric Data

To import data into an HEC-RAS geometric data file, the user selects the
Import Geometric Data option from the File menu of the Geometric Data
window. Once this option is selected, the user then selects one of the three
available formats from the list. After a format is selected, the user will be
asked if they want to add the data to the current geometry file, or if they want
to clear the current geometry file before importing the data. Once this choice
is made, the user will be prompted to enter the name of the file containing the
data. The following is a discussion of each of the three file formats.

GIS Format

A file format for interfacing HEC-RAS with GIS/CADD systems has been
developed at HEC. A detailed description of the file format is contained in
Appendix B of this manual. Chapter 13 of this manual provides detailed
discussions on how to import GIS/CADD data into HEC-RAS, as well as
how to export computed water surface profiles back to GIS/CADD systems.

USACE Survey Data Format

The U.S. Army Corps of Engineers (USACE) has developed a standard file
format for survey data. This format is documented in Chapter 6 of
Engineering Manual (EM) 1110-1-1005. The USACE survey format
encompasses a wide range of data types. The current version of HEC-RAS
has the capability to read this file format, but only cross section data are
extracted from the file. At this time all other data are ignored.

HEC-2 Data Format

The HEC-2 program was the predecessor to the HEC-RAS software package.
The HEC-2 program was used for many years to compute steady flow water
surface profiles. Consequently, thousands of data sets exist in the HEC-2 data
format. HEC-RAS has two ways of importing HEC-2 data. The first way is
accomplished through the use of the Import HEC-2 Data option from the
File menu on the main HEC-RAS window. When this method is used, it is
assumed that the user has started a new project, and therefore all of the HEC-2
data is imported (geometric data, flow data, and plan information). A second
way of importing HEC-2 data is provided from the geometric data editor.
This way of importing HEC-2 data allows the user to bring the data into
existing HEC-RAS geometric data files. This method. also allows the user to
import multiple HEC-2 data files into the same HEC-RAS geometric data file.
However, when importing HEC-2 data from the geometric data window, only
the geometric data contained in the HEC-2 files will be imported. All of the
other data (flow data and plan information) will be ignored.
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HEC-RAS Data Format
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This option allows the user to combine several HEC-RAS geometry files into
a single geometry file. For example, if several pieces of a river system were
developed as separate HEC-RAS models, this option could be used to put
them together into one model.
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Gra9hical Cross Section Editor

A graphical cross section editor is available from the Options menu of the
Geometric Data Editor window. When this option is selected, a window will
appear as shown in Figure 6.42.
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The user has the option to move objects (objects are ground points, main
channel bank stations, ineffective flow areas, levees, and blocked
obstructions), delete objects, or add new objects. To move an object, the user
first selects Move Objects from the Options menu. Then move the mouse
pointer over the object that you want to move, press down the left mouse
button, and then move the object. When you are finished moving the object,
simply release the left mouse button and the object will be moved. To delete
an object, first select Delete Objects from the Options menu. Next, move the
mouse pointer over the object that you would like to delete and click the left
mouse button. Whatever object is closest to the mouse pointer will be
deleted. To add an abject to the cross section, first select the type of object
you want to add from the available list under the Options menu. Once you
have selected an object type to add, move the mouse pointer to the location
where you would like to add it and click the left mouse button. If the object
that you are adding requires more than one point, such as blocked ineffective
flow areas and blocked obstructions, then continue to move the mouse pointer
and click the left mouse button to add the additional points.

Other available options from the Graphical Cross Section editor are the ability
to zoom in and zoom out, to overlay a grid onto the cross section plot, and to
undo all of the graphical editing. When the Undo Edits option is selected, the
cross section is automatically returned to its original state ~efore this
particular editing session began. However, once this editor is closed, or if the
user selects a different cross section from the editor, it is assumed that the user
is happy with the changes that were made and they are saved in memory. The
data is not saved to the hard disk, so it is still possible to get the original data
back if needed.

Attaching and Viewing Pictures

The user can attach a picture to any cross section or hydraulic structure
(bridge, culvert, etc.). Once pictures are attached, they can be viewed from a
picture viewer within the HEC-RAS geometric data editor. The picture
viewer supports the following graphics formats: bit map (*.bmp); icon (*.ico);
windows metafile (*.wmf); GIF (*.gif); and JPEG (*.jpg).

Pictures are attached to cross sections or hydraulic structures from within the
picture viewer. To bring up the picture viewer, go to the geometric data editor
and click on the View Picture button with the left mouse button. An editor
will appear as shown in Figure 6.43. To attach a picture to a particular river
station, first select the River, Reach, and River Station in which you would
like to attach the picture. ext select the Add Picture button, and a file
selection box will appear allowing you to select a graphics file to attach to the
selected location. If the picture file is not in the same location as your data
files, you can select the drive and path of the picture from within the file
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Figure 6.43 HEC-RAS Picture Viewer

selection box. Once a graphic file is located and selected, press the Open
button to attach it to the selected location. The picture should automatically
show up inside of the picture viewer. An example picture is shown in Figure
6.44. Additional pictures can be added by selecting a different location and
selecting the Add Picture button to attach the picture. Only one picture can be
attached to a model object.

Once pictures are attached to the viewer, the user can move to different
pictures by using the up and down arrow buttons, or selecting a specific river
stationing that has a picture attached to it. Options are available to zoom in,
zoom out, remove pictures, and to resize the picture to fit within the size of
the picture viewer window. The user can resize the picture viewer·to
whatever size they want. However, if you are viewing a bitmap picture, and
you make the window larger than the actual picture resolution, the photo will
begin to distort.

Once pictures are attached to the geometry file, a small red square will be
displayed on the river system schematic at each location where a picture
exists. When the user clicks the left mouse button over a cross section, a pop
up menu will appear. If that particular cross section has a picture attached to
it, one of the menu options will be to view the picture. Selecting the View
Picture option from the pop up menu will bring up the picture viewer and
automatically load that particular picture.

The pictures are stored as part of the geometry data (not the actual picture, but
its location on the hard disk). In general, it is a good idea to keep the picture
files in the same directory as your project data files. This will make it easier
to keep track of all the files associated with a particular project.
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1!!'1 Picture Viewer Il!lIiJEJ

Figure 6.44 Picture Viewer with Example Bit Map Photo

Saving the Geometric Data

To save the geometric data, use the Save Geometry Data As option from the
File menu of the Geometric Data window. When this option is selected, the
user is prompted to enter a title for the geometric data. Once you have entered
the title, press the OK button and the data will be saved to the hard disk. If
the geometric data have been saved before (and therefore a title has already
been entered), then it is only necessary to select the Save Geometry Data
option. When this option is selected, the geometry data are saved with the
previously defined title.

In general, it is a good idea to periodically save your data as you are entering
them. This will prevent the loss of large amounts of information in the event
of a power failure, or if a program error occurs in the HEC-RAS user
interface.
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CHAPTER 7

Performing a Steady Flow Analysis

This chapter discusses how to calculate steady flow water surface profiles.
The chapter is divided into two parts. The first part discusses how to enter
steady flow data and boundary conditions. The second part discusses how to
develop a plan and perform the calculations.

Contents

• Entering and Editing Steady Flow Data

• Performing Steady Flow Calculations

Entering and Editing Steady Flow Data

Once all of the geometric data are entered, the modeler can then enter any
steady flow data that are required. To bring up the steady flow data editor,
select Steady Flow Data from the Edit menu on the HEC-RAS main
window. The steady flow data editor should appear as shown in Figure 7.1

Steady Flow Data

The user is required to enter the following infonnation: the number of profiles
to be calculated; the peak flow data (at least one flow for every river reach and
every profile); and any required boundary conditions. The user should enter
the number of profiles first. The next step is to enter the flow data. Flow data
are entered directly into the table. Use the mouse pointer to select the box in
which to enter the flow, then type in the desired flow value.

Flow data are entered from upstream to downstream for each reach. At least
one' flow value must be entered for each reach in the river system. Once a
flow value is entered at the upstream end of a reach, it is assumed that the
flow remains constant until another flow value is encountered within the
reach. The flow data can be changed at any cross section within a reach. To
add a flow change location to the table, first select the reach in which you
would like to change the flow (from the river and reach boxes above the
table). Next, select the River Station location for which you want to enter a
flow change. Then press the Add Flow Change Location button. The new
flow change location will appear in the table.
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Figure 7.1 Steady Flow Data Editor

Each profile is automatically assigned a title based on the profile number,
such as profile #1 is assigned a title of "Prof #1," profile #2 is assigned a title
of "Prof #2," etc. The user can rename the title for each profile by simply
going into the options menu and selecting Edit Profile Names. Once this
option is selected, a dialog will appear allowing you to rename each of the
profile titles.

Boundary Conditions

After all of the flow data have been entered into the table, the next step is to
enter any boundary conditions that may be required. To enter boundary
conditions data, press the Boundary Conditions button at the top right of the
steady flow data editor. The boundary conditions editor should appear as
shown in Figure 7.2.

Boundary conditions are necessary to establish the starting water surface at
the ends of the river system (upstream and downstream). A starting water
surface is necessary in order for the program to begin the calculations. In a
subcritical flow regime, boundary conditions are only necessary at the
downstream ends of the river system. If a supercritical flow regime is going
to be calculated, boundary conditions are only necessary at the upstream ends
of the river system. If a mixed flow regime calculation is going to be made,
then boundary conditions must be entered at all ends of the river system.
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Chapter 7 Peltorming a Steady Flow Analysis

Steady Flow Boundary Conditions

Figure 7.2 Steady Flow Boundary Conditions Editor

The boundary conditions editor contains a table listing every reach. Each
reach has an upstream and a downstream boundary condition. Connections to
junctions are considered internal boundary conditions. Internal boundary
conditions are automatically listed in the table, based on how the river system
was defined in the geometric data editor. The user is only required to enter
the necessary external boundary conditions.

To enter a boundary condition, first use the mouse pointer to select the cell
location in which you would like to enter a boundary condition. Then select
the type of boundary condition from the four available types listed above the
table. The four types of boundary conditions consist of:

Known Water Surface Elevations - For this boundary condition the user
must enter a known water surface for each of the profiles to be computed.

Critical Depth - When this type of boundary condition is selected, the user is
not required to enter any further information. The program will calculate
critical depth for each of the profiles and use that as the boundary condition.

Normal Depth - For this type of boundary condition, the user is required to
enter an energy slope that will be used in calculating normal depth (Manning's
equation) at that location. A normal depth will be calculated for each profile
based on the user entered slope. If the energy slope is unknown, the user
could approximate it by entering either the slope of the water surface of the
slope of the channel bottom.

Rating Curve - When this type of boundary condition is selected, a pop up
window appears allowing the user to enter an elevation versus flow rating
curve. For each profile, the elevation is interpolated from the rating curve
given the flow.
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An additional feature of the boundary condition data, is that the user can
specify a different type of boundary condition for each profile at the same
location. This is accomplished by first selecting the option that says "Set
boundary for one profile at a time" at the top of the window. When this
option is selected, the table will expand out to provide a row for each profile,
at every location. The user can then select the location and profile for which
they would like to change the boundary condition type.

Once all the boundary conditions data are entered, press the OK button to
return to the steady flow data editor. Press the Apply Data button to have the
data accepted.

Steady Flow Data Options

Several options are available from the steady flow data editor to assist users in
entering the data. These features can be found under the Options menu at the
top of the window. The following options are available:

Undo Editing. This option allows the user to retrieve the data back to the
form that it was in the last time the Apply Data button was pressed. Each
time the Apply Data button is pressed, the Undo Editing feature is reset to the
current information.

Delete Row From Table. This option allows the user to delete a row from
the flow data table. To use this option, first select the row to be deleted with
the mouse pointer. Then select Delete Row From Table from the options
menu. The row will be deleted and all rows below it will move up one.

Ratio Selected Flows. This option allows the user to multiply selected values
in the table by a factor. Using the mouse pointer, hold down the left mouse
button and highlight the cells that you would like to change by a factor. Next,
select Ratio Selected Flows from the options menu. A pop up window will
appear allowing you to enter a factor to multiply the flows by. Once you
press the OK button, the highlighted cells will be updated with the new
values.

Edit Profile Names. This option allows the user to change the profile names
from the defaults of PF#l, PF#2, etc.

Set Changes in WS and EG. This option allows the user to set specific
changes in the water surface and energy between any two cross sections in the
model. The changes in water surface and energy can be set for a specific
profile in a multiple profile model. When this option is selected, a window
will appear as shown in Figure 7.3. As shown, there are four options that the
user can select from: Additional EG, Change in EG, Known WS, and
Change in WS. The Additional EG option allows the user to add an
additional energy loss between two cross sections. This energy loss will be
used in the energy balance equation in addition to the normal friction and
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Chapter 7 Performing a Steady Flow Analysis

contraction and expansion losses. The Change in EG option allows the user
to set a specific amount of energy loss between two cross sections. When this
option is selected, the program does not perform an energy balance, it simply
adds the specified energy loss to the energy of the downstream section and
computes a corresponding water surface. The Known WS option allows the
user to set a water surface at a specific cross section for a specific profile.
During the computations, the program will not compute a water surface
elevation for any cross section where a known water surface elevation has
been entered. The program will use the known water surface elevation and
then move to the next section. The Change in WS option allows the user to
force a specific change in the water surface elevation between two cross
sections. When this option is selected, the program adds the user specified
change in water surface to the downstream cross section, and then calculates a
corresponding energy to match the new water surface.

Set Internal Changes in WS and EG

Figure 7.3 Setting Changes in Water Surface and Energy

As shown in Figure 7.3, to use the "Set Internal Changes in WS and EG"
option, the user first selects the river, reach, river station, and profile that they
would like to add an internal change too. Once the user has established a
location and profile, the next step is to select one of the four available options
by pressing the appropriate button. Once one of the four buttons are pressed,
a row will be added to the table at the bottom, and the user can then enter a
number in the value column, which represents the magnitude of the internal
change.
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Observed WS. This option allows the user to enter observed water surfaces
at any cross section for any of the computed profiles. The observed water
surfaces can be displayed on the profile plots and in the summary output
tables.

Inline Spillway Gate Openings. This option allows the user to control gate
openings for any inline gated spillways that have been added to the geometric
data. When this option is selected, a window will appear as shown in
Figure 7.4.

Figure 7.4 Inline Spillway Gated Openings Editor

As shown in Figure 7.4, for each profile the user can specify how many gates
are opened per gate group, and at what elevation they are opened too. For the
example shown in Figure 7.4, there are three gate groups labeled "Left
Group," "Center Group," and "Right Group." Each gate group has five
identical gate openings. All of the gate openings have a maximum opening
height of ten feet. For profile number I, only the middle gate group is
opened, with all five gates opened to a height of five feet. For the second
profile, all three gate groups are opened. The Left gate group has two gates
opened to seven feet, the Center gate group has five gates opened to four feet,
and the Right gate group has two gates opened for seven feet. This type of
information must be entered for all of the profiles being computed.

Saving The Steady Flow Data

The last step in developing the steady flow data is to save the information to a
file. To save the data, select the Save Flow Data As from the File menu on
the steady flow data editor. A pop up window will appear prompting you to
enter a title for the data.
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Chapter 7 Performing a Steady Flow Analysis

Importing Data From The HEC Data Storage System
(HEC-DSS)

HEC-DSS is a data base system that was specifically designed to store data
for applications in water resources. The HEC-DSS system can store almost
any type of data, but it is most efficient at storing large blocks of data (e.g.,
time-series data). These blocks of data are stored as records in HEC-DSS,
and each record is given a unique name called a "pathname." A pathname can
be up to 80 characters long and, by convention, is separated into six parts.
The parts are referenced by the letters A, B, C, D, E, and F, and are delimited
by a slash "/" as follows:

/NB/CIDIE/F/

The pathname is used to describe the data in enough detail, that various

application programs can write to and read data from HEC-DSS by simply
knowing the pathname. For more information about HEC-DSS, the user is
referred to the "HEC-DSS, User's Guide and Utility Manuals" (HEC, 1995).

Many of the HEC application programs have the ability to read from and
write to the HEC-DSS. This capability facilitates the use of observed data as
well as passing information between software programs. The ability to read
data from HEC-DSS has been added to HEC-RAS in order to extract flow
and stage data for use in water surface profile calculations. It is a common
practice to use a hydrologic model (i.e., HEC-HMS) to compute the runoff
from a watershed and then use HEC-RAS to compute the resulting water
surface profiles.

Reading data from HEC-DSS into HEC-RAS is a two step process. First, the
user must establish connections between HEC-RAS cross-section .locations
and pathnames contained in the HEC-DSS file. These connections are
established by selecting the "Set Locations for DSS Connections" option
from the File menu of the Steady Flow Data editor. When this option is
selected, a window will appear as shown in Figure 7.5. The user selects
cross-section locations for DSS connections by selecting a River, Reach, and
River Station, then pressing the "Add selected location to table" button.
When this button is pressed, a new row will be added to the table at the top of
the window. The user should do this for all the locations where they want to
establish connections to HEC-DSS data.

The next step is to open a particular HEC-DSS file. The user has the option
of either typing the filename in directly, or using the open button which is
right next to the filename field. Once a DSS file is selected, a listing of the
pathnames for all of the data contained in that file will appear in the table at
the bottom of the window. The user can establish connections to more than
one DSS file if desired.
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....... J

Editor for setting connections to HEC-DSS pathnames.

To establish the connection between an HEC-RAS cross section and a
particular pathname in the DSS file, the user selects the row in the upper table
that contains the river station that they want to connect data to. Next, they
select the pathname that they want to connect to that river station from the
lower table. Finally, they press the button labeled "Select DSS Pathname,"
and .the pathname is added to the table at the top of the window.

To make it easier to find the desired pathnames, a set of pathname part filters
were added to the window. These filters contain a list of all the DSS
pathnarne parts contained within the currently opened DSS file. If the user
selects a particular item within the list of one of the pathname parts, then only
the pathnames that contain that particular pathnarne part will be displayed.
These filters can be used in combination to further reduce the list of
pathnames displayed in the table. When a particular filter is left blank, that
means that pathname part is not being filtered.
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Chapler 7 Performing a Sleady Flow Analysis

Another feature on the editor to assist in selecting the appropriate pathnames
is the "Plot Selected Pathname" button. This button allows the user to get a
plot of the data contained within any record in the DSS file. The user simply
selects a DSS pathname, and then presses the Plot Selected Pathname
button, and a new window will appear with a graphic of the data contained
within that record.

Once all of the pathnarne connections are set, the user presses the OK button
to close the editor. The next step is to import the data. This is accomplished
by selecting "DSS Import" from the File menu of the Steady Flow Data
editor. When this option is selected, a window will appear as shown in
Figure 7.6

First the user sets a time window, which consists of a starting date and time
and an ending date and time. When data are extracted from DSS, the program
will only look at the data that is contained within the user specified time
window.

Below the time window there are two options for selecting flow data to be
extracted from the DSS file. The first option allows the user to pick off flow
data at a specified time interval, starting with the beginning of the time
window for the first profile. The second and subsequent profiles would be
based on adding the user specified time interval to the start time of the time
window. Flow data is extracted from the hydrographs at each of the locations
being read from DSS. The second option listed on the window allows the
user to get an overall peak flow for a profile computation. When this option
is selected, the peak flow will be extracted from each hydrograph, within the
time window specified. These peak flows will be made into the final profile
in the flow data editor.
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The bottom portion of the window contains options for interpolating flow data
at locations that do not have hydrographs in the DSS file. After the flow data
are read in, it will be necessary to interpolate flow data at all of the locations
listed in the flow data editor that do not have values in the DSS file. Three
options are available: no interpolation, linear interpolation, or using the flow
data from an existing profile to calculated ratios for interpolating between
points that have data. Once all the options are set, the user presses the
"Import Data" button to have the data imported and fill out the flow data
editor.

Performing Steady Flow Calculations

Once all of the geometry and steady flow data have been entered, the user can
begin calculating the steady flow water surface profiles. To perform the
simulations, go to the HEC-RAS main window and select Steady Flow
Analysis from the Simulate menu. The Steady Flow Analysis window will
appear as in Figure 7.7 (except yours may not have a Plan title and short TD).

Figure 7.7 Steady Flow Analysis window

Defining A Plan

The first step in performing a simulation is to put together a Plan. The Plan
defines which geometry and flow data are to be used, as well as provide a
description and short identifier for the run. Also included in the plan
information are the selected flow regime and the simulation options.
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Chapter 7 PertfJrlning a Steady Flow Analysis

Before a Plan is defined, the user should select which geometry and flow data
will be used in the plan. To select a geometry or flow file, press the down
arrow button next to the desired data type. When this button is pressed, a list
will appear displaying all of the available files of that type that are currently
available for the project. Select the geometry and flow files that you want to
use for the current plan.

To establish a Plan, select New Plan from the File menu on the steady flow
analysis window. When New Plan is selected, a window will appear
prompting you to enter a title for the plan. After you enter the title, press the
OK button to close the window and accept the title. The user will also be
prompted to enter a short identifier for the plan. The short identifier is limited
to 12 characters. It is very important to enter a short identifier that is
descriptive of the plan. When viewing multiple plan output from the graphics
and tables, the Short ID will be used to identify each plan.

The last step is to select the desired flow regime for which the model will
perform calculations. The user can select between subcritical, supercritical, or
mixed flow regime calculations.

Saving The Plan Information

To save the Plan information to the hard disk, select Save Plan from the File
menu of the simulation window. Whenever any option is changed or
modified on the Steady Flow Analysis window, the user should Save the Plan.

Simulation Options

The following is a list of the available simulation options under the Options
menu of the Steady Flow Analysis window:

Encroachments. This option allows the user to perform a floodway
encroachment analysis. For a detailed description of how to use the floodway
encroachment capabilities of HEC-RAS, see Chapter 9 of the User's Manual
(this manual). For a description of how the encroachment calculations are
performed for the various encroachment methods, see Chapter 9 of the
Hydraulic Reference Manual.

Flow Distribution Locations. This option allows the user to specify
locations in which they would like the program to calculate flow distribution
output. The flow distribution option allows the user to subdivide the left
overbank, main channel, and right overbank, for the purpose of computing
additional hydraulic information.
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As shown in Figure 7.8, the user can specify to compute flow distribution
information for all the cross sections (this is done by using the Global option)
or at specific locations in the model. The number of slices for the flow
distribution computations must be defined for the left overbank, main channel,
and the right overbank. The user can define up to 45 total slices. Each flow
element (left overbank, main channel, and right overbank) must have at least
one slice. The flow distribution output will be calculated for all profiles in the
plan during the computations.

Figure 7.8 Window for Specifying the Locations of Flow Distribution.

To set the flow distribution option for all the cross sections, simply select the
number of slices for the left overbank, main channel, and right overbank from
the Set Global Subsections portion of the window. To set flow distribution
output at specific locations, use the Set Specific Location Subsection
Distribution option.

During the normal profile computations, at each cross section where flow
distribution is requested, the program will calculate the flow, area, wetted
perimeter, percentage of conveyance, and average velocity for each of the user
defined slices. For details on how the flow distribution output is actually
calculated, see Chapter 4 of the HEC-RAS Hydraulic Reference Manual. For
information on viewing the flow distribution output, see Chapter 8 of the
User's Manual (this manual).
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Chapter 7 Performing a Steady Flow Analysis

Conveyance Calculations. This option allows the user to tell the program
how to calculate conveyance in the overbanks. Two options are available.
The first option, At breaks in n values only, instructs the program to sum
wetted perimeter and area between breaks in n values, and then to calculate
conveyance at these locations. If n varies in the overbank the conveyance
values are then summed to get the total overbank conveyance. The second
option, Between every coordinate point (HEC-2 style), calculates wetted
perimeter, area, and conveyance between every coordinate point in the
overbanks. The conveyance values are then summed to get the total left
overbank and right overbank conveyance. These two methods can provide
different answers for conveyance, and therefore different computed water
surfaces. The At breaks in n values only method is the default.

Friction Slope Methods. This option allows the user to select one of four
available friction slope equations, or to allow the program to select the method
based on the flow regime and profile type. The four equations are:

- Average Conveyance (Default)

- Average Friction Slope

- Geometric Mean Friction Slope

- Harmonic Mean Friction Slope

Set Calculation Tolerances. This option allows the user to override the
default settings for the calculation tolerances. These tolerances are used in the
solution of the energy equation. Warning I!! - Increasing the default
calculation tolerances could result in computational errors in the water surface
profile. The tolerances are as follows:

Water surface calculation tolerance: This tolerance is used to compare
against the difference between the computed and assumed water surface
elevations. When the difference is less than the tolerance, the program
assumes that it has a valid numerical solution.

Critical depth calculation tolerance: This tolerance is used during the critical
depth solution algorithm.

Maximum number of iterations: This variable defines the maximum number
of guesses that the program will.make when attempting to balance a water
surface.

Maximum difference tolerance: This tolerance is used during the balance of
the energy equation. As the program attempts to balance the energy equation,
the solution with the minimum error (assumed minus computed water surface)
is saved. If the program goes to the maximum number of iterations without
meeting the specified calculation tolerance, the minimum error solution is
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checked against the maximum difference tolerance. If the solution at
minimum error is less than this value, then the program uses the minimum
error solution as the answer, issues a warning statement, and then proceeds
with the calculations. If the solution at minimum error is greater than the
maximum difference tolerance, then the program issues a warning and
defaults the solution to critical depth. The computations then proceed from
there.

Flow Tolerance Factor: This factor is only used in the bridge and culvert
routines. The factor is used when the program is attempting to balance
between weir flow and flow through the structure. The factor is multiplied by
the total flow. The resultant is then used as a flow tolerance for the balance of
weir flow and flow through the structure.

Each of these variables has an allowable range and a default value. The user
is not allowed to enter a value outside of the allowable range.

Critical Depth Output Option. This option allows the user to instruct the
computational program to calculate critical depth at all locations.

Critical Depth Computation Method. This option allows the user to select
between two methods for calculating critical depth. The default method is the
Parabolic Method. This method utilizes a parabolic searching technique to
find the minimum specific energy. This method is very fast, but it is only
capable of finding a single minimum on the energy curve. A second method,
Multiple Critical Depth Search, is capable of finding up to three minimums
on the energy curve. If more than one minimum is found the program selects
the answer with the lowest energy. Very often the program will find
minimum energies at levee breaks and breaks due to ineffective flow settings.
When this occurs, the program will not select these answers as valid critical
depth solutions, unless there is no other answer available. The Multiple
Critical Depth Search routine takes a lot of computation time. Since critical
depth is calculated often, using this method will slow down the computations.
This method should only be used when you feel the program is finding an
incorrect answer for critical depth.

Check Data Before Execution. This option provides for comprehensive data
input checking. When this option is turned on, data input checking will be
performed when the user presses the compute button. If all of the data are
complete, then the program allows the steady flow computations to proceed.
If the data are not complete, or some other problem is detected, the program
will not perform the steady flow analysis, and a list of all the problems in the
data will be displayed on the screen. If this option is turned off, data checking
is not performed before the steady flow execution. The default is that the data
checking is turned on.

Set Log File Output Level. This option allows the user to set the level of the
Log file. The Log file is a file that is created by the computational program.
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Chapter 7 Performing a Steady Flow Analysis

This file contains infonnation tracing the program process. Log levels can
range between 0 and 10, with 0 resulting in no Log output and 10 resulting in
the maximum Log output. In general, the Log file output level should not be
set unless the user gets an error during the computations. If an error occurs in
the computations, set the log file level to an appropriate value. Re-run the
computations and then review the log output, try to detennine why the
program got an error.

When the user selects Set Log File Output Level, a window will appear as
shown in Figure 7.9. The user can set a "Global Log Level," which will be
used for all cross sections and every profile. The user can also set log levels
at specific locations for specific profiles. In general, it is better to only set the
log level at the locations where problems are occurring in the computations.
To set the specific location log level, first select the desired reach and river
station. Next select the log level and the profile number (the log level can be
turned on for all profiles). Once you have everything set, press the Set button
and the log level will show up in the window below. Log levels can be set at
several locations individually. Once all of the Log Levels are set, press the
OK button to close the window.

Figure 7.9 Log File Output Level window
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Warning!!! - setting the log output level to 4 or 5 can result in very large log
file output. Log level values of 6 or larger can result in extremely large log
files.

View Log File. This option allows the user to view the contents of the log
file. The interface uses the Windows Write program to accomplish this. It is
up to the user to set an appropriate font in the Write program. If the user sets
a font that uses proportional spacing, the information in the log file will not
line up correctly. Some fonts that work well are: Line Printer; Courier (8 pt.);
and Helvetica (8 pt.). Consult your Windows user's manual for information
on how to use the Write program.

Starting the Computations

Once all of the data have been entered, and a Plan has been defined, the
steady flow computations can be performed by pressing the Compute button
at the bottom of the steady flow simulation window. Once the compute
button is pressed, a separate window will appear showing you the progress of
the computations. The information that appears in the window is anI)' there
as an indicator of the programs progress during the computations. This
window is not intended to be used for viewing any output. When the
computations have been completed, the user can close the computations
window by double clicking the upper left corner of the window. If the
computations ended with a message stating "PROGRAM TERMINATED
NORMALLY," the user can then begin to review the output.
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Chapter 8 Viewing Results

CHAPTER 8

Viewing Results

After the model has fInished the steady flow profIle computations, you can
begin to view the output. Output is available in a graphical and tabular format.
The current version of the program allows the user to view cross sections,
profIles, rating curves, X-Y-Z perspective plots, detailed tabular output at a
single cross section, and limited tabular output at many cross sections. Users
also have the ability to develop their own output tables.

Contents

• Cross Sections, ProfIles, and Rating Curves

• X-Y-Z Perspective Plots

• Tabular Output

• View Results from the River System Schematic

• Viewing Flow Distribution Output

Cross Sections, Profiles, and Rating Curves

Graphical displays are often the most effective method of presenting input
data and computed results. Graphics allow the user to easily spot errors in the
input data, as well as providing an overview of the results in a way that tables
of numbers cannot.

Viewing Graphics on the Screen

To view a graphic on the screen, select either Cross Sections, Profiles, or
Rating Curves from the View menu on the HEC-RAS main window. Once
you have selected one of these options, a window will appear with the graphic
plotted in the viewing area. An example cross section plot is shown in Figure
8.1. The user can plot any cross section by simply selecting the appropriate
reach and river station from the list boxes at the top of the plot. The user can
also step through the cross section plots by using the up and down arrow
buttons next to the river station box.
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Figure 8.1 Example Cross Section Plot
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I
An example profIle plot is shown in Figure 8.2. The profIle plot displays the
water surface profIle for the fIrst reach in the river system. If there is more
than one reach, additional reaches can be selected from the Options menu on
the plot.

An example rating curve plot is shown in Figure 8.3. The rating curve is a plot
of the water surface elevation versus flow rate for the profiles that were
computed. A rating curve can be plotted at any location by selecting the
appropriate reach and river station from the list boxes at the top of the plot.

I
I
I
I
I
I

8-2
I
I



..Profile Plot RI!lEl
......0]

i f.

,.---,------;---, I '
Legend !

1-..-....-.. -.......;:.....- ..-....-.-.--i !
EG 100 yr I

'-_W_S_l_
0

_

0

_

y

_

r

--' 'II.Ground .

40003000

Main Channel Distance (ft)

20001000

Chapter 8 Viewing Results

Critical Creek - Example 1 Existing Conditions
Geom: Base Geometry Data Flow: 100 Year Profile
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Figure 8.2 Example Profile Plot
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Graphical Plot Options

Several plotting features are available from the Options menu on all of the
graphical plots. These options include: zoom in; zoom out; selecting which
plans, profIles, reaches and variables to plot; and control over labels, lines,
symbols, scaling, grid options, zoom window location, font sizes, and land
marks. In addition to using the options menu at the top of each graphic
window, if a user presses the right mouse button while the cursor is over a
graphic, the options menu will appear right at the cursor location. In general,
the options are about the same on all of the graphics.

Zoom In: This option allows the user to zoom in on a portion of the graphic.
This is accomplished by selecting Zoom In from the Options menu, then
specifying the area to zoom in on with the mouse. DefIning the zoom area is
accomplished by placing the mouse pointer at a comer of the desired zoom
area. Then press down on the left mouse button and drag the mouse to defIne a
box containing the desired zoom area. Finally, release the left mouse button
and the viewing area will display the zoomed-in graphic. A small window
showing the entire graphic will be placed in one of the comers of the gIaphic.
This window is called the Zoom Window. The Zoom Window shows the
entire graphic with a box around the zoomed in area. The user can move the
zoom box or resize it in order to change the viewing area.

Zoom Out: This option doubles the size of the currently zoomed in graphic.

Full Plot: This option re-displays the graphic back into its original size before
you zoomed in. Using the Full Plot option is accomplished by selecting Full
Plot from the Options menu.

Plans. This option allows the user to select from the available Plans for
plotting. The default plan is the currently opened plan. The user can select
additional plans to view for comparison of results graphically.

Profiles. This option allows the user to select which profIles they would like to
have displayed on the graphic. This option does not apply to the rating curve, it
automatically plots all of the profIles.

Reaches. This option allows the user to select which river reaches they would
like to have displayed. This option only applies to the profIle plot. .

Variables. This option allows the user to select what ever variables are
available for plotting. The number and type of variables depends on what type
of graphic is being displayed. The following is a list of variables that can be
found on the profIle plot: water surface, energy, critical water surface, observed
water surfaces, reach labels, and left and right main channel bank stations. The
cross section plot is limited to the following four variables: water surface,
energy, critical water surface, and Manning's n values.
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Labels. This option allows the user to change the labels at the top of the plot.
The user can select any or all of the following items to be added to the caption:
project title, plan title, run date, run time, geometry title, flow title, river and
reach names, cross section descriptions, cross section river stationing, and any
user defmed additional text.

I
I

Lines and Symbols. This option allows the user to change the line types, line
colors, line widths, symbol types, symbol sizes, symbol colors, fill patterns, and
the line labels. When the user selects this option, a window will appear as
shown in Figure 8.4.

8-5

Figure 8.4 Line and Symbol Options Window

When the Line and Symbol Options window comes up, it will list only the
information from the current plot. When this window is in the "Current Pict
Line Styles" mode, the user can only change the information for the current
plot. If the user wants to change the default line and symbol options for all of
the plots, they must select Default Line Styles at the top of the window.
When this option is selected, the user will be able to change the label, line, and
symbol options for every variable that is plotted in the program. To use this
option, the user finds the variable that they want to change from the list on the
left side of the window. Select that variable by clicking the left mouse button
while over top of the variable. Once a variable is selected, the options that are
set for that variable will be highlighted with a red box around each option. The
user can change whatever option they want, as well as changing the label for
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Chapter 8 Viewing Results

that variable. If a variable does not have a default label, you can not enter one
for that variable. Once the user has made all of the changes that they want to
all of the desired variables, they should press the OK button. The changes will
be saved permanently, and any plot that is displayed within HEC-RAS will
reflect the user entered changes.

Scaling. This option allows the user to defme the scaling used for the plot.
Users are allowed to set the minimum, maximum, and labeling increment for
the X and Y axis. Scaling can be set temporarily, or scaling can be set to be
persistent (scaling stays constant for all cross sections). Persistent scaling is
only available for the cross section and rating curve plots.

Grid. This option allows the user to overlay a grid on top of the graphic.
Users have the option to have both major and minor tics displayed, as well as a
border around the plot.

Zoom Window Location. This option allows the user to control which comer
of the plot that the zoom window will be placed, and the size of the zoom
window. The zoom window appears whenever the user has selected the Zoom
In option.

Font Sizes. This option allows the user to control the size of all of the text
displayed on the graphic.

Land Marks. This option is specific to profile plots. With this option the user
can tum on additional labels that will be displayed as land marks below the
invert of the channel. Two types of land marks can be displayed, cross section
river stations or cross section descriptions. In addition to these two variables,
once one of the two are displayed, the user can select to edit the land mark
labels.

Plotting Velocity Distribution Output

The user has the option of plotting velocity distribution output from the cross
section viewer. Velocity distributions can only be plotted at locations in
which the user has specified that flow distribution output be calculated during
the computations. To view the velocity distribution plot, first bring up a cross
section plot (select "Cross Sections" from the view menu of the main HEC­
RAS window). Next, select the cross section in which you would like to see
the velocity distribution output. Select Velocity Distribution from the
Options menu of the cross section window. This will bring up a pop up
window (Figure 8.5) that will allow you to set the minimum velocity,
maximum velocity, and velocity increment for plotting. In general, it is better
to let the program use the maximum velocity range for plotting. Next, the
user selects Plot Velocity Distribution, then press the "OK" button and the
velocity distribution plot will appear as shown in Figure 8.6.
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Chapter 8 Viewing Results

For details on how to select the locations for computing the velocity
distribution, see Chapter 7 of the User's Manual. For infonnation on how the
velocity distribution is actually calculated, see Chapter 4 of the Hydraulic
Reference Manual.
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Plotting Other Variables in Profile
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The profile plotting window has the ability to plot other variables, besides
water surface and energy, in profile. Any variable that is computed at a cross
section can be displayed in profile. An example would be to plot velocity
versus distance. To plot other variables in profile, the user must first select
the General Profile option from the Options menu of the Profile plot. Once
this option is turned on, the plot automatically switches to a plot of channel
velocity versus distance. Other variables can be selected from the Variables
option under the Options menu. The user can plot several different variable
types at one time ( e.g., velocity and area versus distance), but the scaling
may not be appropriate when this is done. An example of plotting other
variables in profile is shown in Figure 8.7.

The rating curve plotting window has the ability to plot other variables besides
discharge versus water surface elevation. Any variable that is computed at a
cross section can be displayed against another computed variable (or
variables). An example of this capability is shown in Figure 8.8. In this
example, Discharge (x-axis) is being plotted against total flow area and main
channel flow area (y-axis).

Plotting One Variable Versus Another

1000

Critical Creek - Example 1 Modified Geometry Conditions
Geom: Base Geometry Data + Interpolated Flow: 100 Year Profile - Up and Down Bndry.
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2. Using the available graphics options (scaling, labels, grid, etc.), modify
the plot to be exactly what you would like printed.

3. Select Print Current (or just Print on the proftle plot) from the File
menu of the displayed graphic. When this option is selected, a pop up
window will appear allowing you to modify the default print options.
Change any desired options and press the Print button. The

1. Display the graphic of interest (cross section, proftle, rating curve, X­
Y-Z, or river system schematic) onto the screen.

To plot other variables, the user selects theX Axis Variable and Y Axis
Variable from the Options menu of the rating curve plotting window. When
selected variables to plot, keep in mind that all variables selected for a
particular axis should have a similar range in magnitude.

All of the graphical plots in HEC-RAS can be sent directly to a printer or
plotter. The printer or plotter used depends on what you currently have set as
the default printer or plotter in the Windows Print Manager. To send a graphic
to the printer or plotter, do the following:

Sending Graphics to the Printer or Plotter
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Figure 8.8 Example of Plotting One Variable Against Other Variables
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Results

graphic will be sent to the Windows Print Manager. The print manager will
then send the plot to the default printer or plotter.

Note: The user can print multiple cross sections at one time by using the Print
Multiple option from the File Menu of the cross section and rating curve plots.
This option also allows the user to establish how many cross sections or rating
curves they would like to have printed on each page.

Sending Graphics to the Windows Clipboard

All of the HEC-RAS graphics can be sent to the Windows Clipboard. Passing
a graphic to the clipboard allows that graphic to then be pasted into another
piece of software (i.e., a word processor or another graphics program). To
pass a graphic to the windows clipboard, and then to another program, do the
following:

I. Display the graphic of interest on the screen.

2. Using the options menu, modify the plot to be exactly what you want.

3. Select Copy to Clipboard from the File menu of the displayed
graphic. The plot will automatically be sent to the Windows Clipboard.

4. Bring up the program that you want to paste the graphic into. Select
Paste from the Edit menu of the receiving program. Once the graphic
is pasted in, it can be re-sized to the desired dimensions.

HEC-RAS sends and displays all graphics in a Window's Meta fIle format.
Since Meta fIles are vector based graphics, the graphic can be resized without
causing the image to distort.

X-Y-Z Perspective Plots
I

~other type of graphic available to the user is the X-Y-Z Perspective Plot.
The" X-Y-Z plot is a 3-dimensional plot of multiple cross sections within a
reach. An example X-Y-Z Perspective plot is shown in Figure 8.9.
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The user has the ability to select which reaches to be plotted, the range of the
river stations, and which plans and profiles to be displayed. The plot can be
rotated left and right, as well as up and down, in order to get different
perspectives of the river system. Zoom in and zoom out features are available,
as well as the ability to move around with scroll bars. The user can choose to
ov~rlay the water surface or not. The user has the ability to overlay a grid on
the plot, as well as a legend and labels at the top. The graphic can be sent to

the printer/plotter or the clipboard just like any other plot. Sending the graphic
to the printer or clipboard is accomplished by selecting the Print or Clipboard
options from the File menu. The user also has the option to reverse the order
in which the water surface profiles are displayed. This option allows the user
to display the higher water surfaces first, such that the lower profiles are not
covered up.

Critical Creek - Example 1 Modified Geometry Conditions
Geom: Base Geometry Data + Interpolated Flow: 100 Year Profile - Up and Down Bndry.

,----'",----;--,
Legend
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Figure 8.9 Example X-Y-Z Perspective Plot
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Summary tables of the detailed water surface proftle computations are often
necessary to analyze and document simulation results. Tabular output allows
the user to display large amounts of detailed information in a concise format.
HEC-RAS has two basic types of tabular output, cross section tables and
proftle tables.

Cross Section Tables

Cross section tables show detailed hydraulic information at a single location,
for a single proftle. To display a cross section table on the screen, select Cross
Section Table from the View menu of the main HEC-RAS window. An
example cross section table is shown in Figure 8.10.

0.100 0.040 0.100

9167 8833 7500
750.66 510.34 5.10
75066 51034 510

2666.59 6830.26 3.15
......... -.,- ... .>., .• " .., ..

232.64 7900 20.70
3.55 13.38 0.62

3.23 6.46 0.25
25256.3 64692.0 29.8
23341· 80.96 2071

224 4.39 0.17
7.95 58.71 0.11

100.59 18.47 1.50
32.00 300 1.42

Figure 8.10 Example Cross Section Table
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Chapter 8 Viewing Results

Any cross section can be displayed in the table by selecting the appropriate
river, reach and river station from the list boxes at the top of the table. Also,
any of the computed profiles can be displayed by selecting the desired profile
from the profIle list box.

Users can also view detailed hydraulic information for other types of cross
section specifIc tables. Other table types are selected from the Type menu on
the cross section table window. The following types are available in addition to
the normal cross section table (which is the default):

Culvert. The culvert table type brings up detailed culvert information. This
table can be selected for normal culverts, or for culverts that are part of a
multiple opening river crossing. An example culvert specifIc table is shown in
Figure 8.11.

~ Culvert Output I!!!lIIifEi

Figure 8.11 Example Culvert Type of Cross Section Table

Bridge. The bridge table type brings up detailed output for the cross sections
inside the bridge as well as just upstream of the bridge. The bridge table type
can be selected for normal bridge crossings, or for bridges that are part of a
multiple opening river crossing. An example of the bridge specifIc cross
section table is shown in Figure 8.12.
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Inline Weir/Spillway. The Inline Weir/Spillway type of table can be used to
view detailed output for any inline weirs and/or gated spillways that have been
entered by the user.
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Conveyance. The conveyance type of table is the same as a normal cross
section table. The only difference is that a conveyance type of table is used to
view the hydraulic results of a portion of a multiple opening river crossing.
That is, if the user has defmed an open channel flow type of opening (i.e.,
conveyance area), at a multiple opening crossing, then this table can be used to
vi~w the hydraulic results for that specific opening.

Figure 8.12 Example Bridge Type of Cross Section Table

Flow Distribution. The Flow Distribution table type can be used to view the
computed flow distribution output at any cross section where this type of
output was requested. An example of the flow distribution table output is
shown in Figure 8.13.

8-14

I
I
I
I



I
I
I
I
I
I
I
I
I
I
I
I
I
I,
I
I
I
I
I

Chapter 8 Viewing Results

......,.._,. ..??§.:~~.! 125.23 50.40 3.07 2.21
925.60 298.40 72.08 10.28 ... 3.10

...

803.82 274.13 72.05 893 2.93

278.:66 145.92 72.97 3.10 1.91
560.07 222.03 73.14 6.22 252
748.93 262.71 72.03 6.32 3.65 2.85
578.88: 225.07 72.01 6.43 3.13 2.57..... .; .. , • .........d. " •• , ... ~. d •• _ , •

463.56: 196.97 72.00 5.15 27~ . 2.35
. .;.

527.69 212.91 72.01. 5.B6 2.96 2.4B
36140 169.74 7210 4.02 2.36 213
4057 10.24 5.67 045 228 396

190.26 26.28 5.89 2.11 5.84 7.24
448.27 41.88 522. 4.98 9.31 : 10.70

Figure 8.13 Example of the Flow Distribution Type of Table

At the bottom of eacb of the cross section tables are two text boxes for
displaying messages. The bottom text box is used to display the defInition of
the variables listed in the table. When the user presses the left mouse button
over any data fIeld, the description for that fIeld is displayed in the bottom text
box. The other text box is used to display any Errors, Warnings, and Notes
that may bave occurred during the computations for the displayed cross
section.

Cross Section Table Options

Under the Options menu of the cross section table window, the user bas tbe
following options:

Plans. This option allows the user to select wbicb plan, and therefore output
file, tbey would like to view.
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Include Interpolated XS's. This option allows the user to either view
interpolated cross section output or not. Turning the "include interpolated
XS's" option on (which is the default), allows interpolated sections to be
selected from the river station box. Turning this option off gets rid of all the
interpolated sections from the river station selection box, and only the user
entered cross sections are displayed.

Units System For Viewing. This option allows the user to view the output in
either English or Metric units. It does not matter whether the input data is in
English or Metric, the output can be viewed in either system.

Profile Tables

Profile tables are used to show a limited number of hydraulic variables for
several cross sections. To display a profile table on the screen, select Profile
Table from the View menu of the main HEC-RAS window. An example
profile table is shown in Figure 8.14.

Figure 8.4 Example Profile Table
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Chapter 8 Viewing Results

There are several standard table (Std. Tables) types available to the user.
Some of the tables are designed to provide specific information at hydraulic
structures (e.g., bridges and culverts), while others provide generic information
at all cross sections. The standard table types available to the user are:

Standard Table 1. The is the default profIle type of table. This table gives
you a summary of some of the key output variables.

Standard Table 2. This is the second of the standard summary tables. This
table provides information on the distribution of flow between the left
overbank, main channel, and right overbank:. This table also shows the friction
losses, as well as contraction and expansion losses that occurred between each
section. Energy losses displayed at a particular cross section are for the losses
that occurred between that section and the next section downstream.

Four XS Culvert. This standard table provides summary results for the four
cross sections around each of the culverts in the model. The four cross sections
are the two immediately downstream and the two immediately upstream of the
culvert. This table will list all of the culverts in the model for the seleqed
reaches.

Culvert Only. This standard table provides hydraulic information about the
culvert, as well as the inlet control and outlet control computations that were
performed.

Six XS Bridge. This table provides summary results for the six cross sections
that make up the transition of flow around a bridge. The six cross sections
include the two cross sections just downstream of the bridge; the two cross
sections inside of the bridge; and the two cross sections just upstream of the
bridge. The program will display results for all the bridges in the model within
the selected reaches. When viewing this table, on occasion there will be no
displayed results for the cross sections inside of the bridge. This occurs only
when the user has selected a bridge modeling approach that does not compute
results inside of the bridge. This includes: Yarnell's method; both pressure
flow equations; and pressure and weir flow solutions.

Bridge Only. The bridge only table shows summary information specilically
for bridges.

Bridge Comparison. The bridge comparison table shows the results for all of
the user selected bridge modeling approaches that were computed during the
computations. For example, the program can calculate low flow bridge
hydraulics by four different methods. The resulting upstream energy for the
user selected methods will be displayed in this table.
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Multiple Opening. This table shows a limited number of output variables for
each opening of a mUltiple opening river crossing.

Four XS Inline Weir. This table displays summary results of the four cross
sections immediately around an inline weir and/or gated spillway. The four
cross sections are the two immediately upstream and the two immediately
downstream of the inline weir and/or gated spillway.

Inline Weir Only. This table shows the fmal computed water surface and
energy just upstream of each of the inline weir and/or gated spillways. In
addition to these elevations, the table displays the total flow, the flow over the
weir, and the total flow through all of the gates.

Encroachment 1, 2, and 3. These three standard tables provide various types
of output for the computations of floodway encroachments.

HEC-FDA. This table provides information that can be exported to the HEC
Flood Damage Analysis (FDA) program. The table displays total flow,
channel invert elevation, and water surface elevation.

To view one of the types of tables, select the desired table type from the Std.
Tables menu on the profIle table. In addition to the various types of profIle
tables, the user can specify which plans, profiles and reaches to include in the
table. The plans, profIles and reaches options are available from the Options
menu on the profile plot.

The user also has the ability to tum the viewing of interpolated, cross sections
on or off. The default is to view all cross sections, including the interpolated
ones. To prevent the interpolated sections from showing up in the table, de­
select Include Interpolated XS's from the Options menu.

Another feature available to users is the ability to set the number of decimal
places that will be displayed for any variable of the pre-defmed tables. Once a
pre-defmed table is selected from the Tables menu, select Standard Table #
Dec Places from the Options menu. A window will appear displaying the
current number of decimal places for each variable. The user can change the
number of decimal places to what ever they wish.

User's also have the ability to view profile output tables in either English or
metric units. This is available from the Options menu on the profIle tables. It
does not matter whether the input data is in English or metric, the output can
be viewed in either system.

User Defined Output Tables

A special feature of the profIle tables is the ability for users to define their own
output tables. User defined output tables are available by selecting Define
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Chapter 8 Viewing Results

Table from the Options menu of the profIle table. When this option is
selected, a window will appear, as shown in Figure 8.15. At the top of the
window is a table for the user selected variable headings (Table Column
Headings), the units, and the number of decimal places to be displayed for each
variable. Below this table is a table containing all of the available variables that
can be included in your user defined table. The variables are listed in
alphabetical order. Below the list of variables is a message box that is used to
display the definition of the selected variable.

To get a defInition of a particular variable, simply click the left mouse button
once while the mouse pointer is over the desired variable. The description of
the variable will show up at the bottom of the window. To add variables to the
column headings, simply double click the left mouse button while the mouse
pointer is over the desired variable. The variable will be placed in the active
field of the table column headings. To select a specifIc column to place a
variable in, click the left mouse button once while the mouse pointer is over the
desired table column field. To delete a variable from the table headings,
double click the left mouse button while the mouse pointer is over the variable
that you want to delete. The number of decimal places for each variable can be
changed by simply typing in a new value.

User defined tables are limited to 15 variables. Once you have selected all of
the variables that you want, press the OK button at the bottom of the window.
The profile table will automatically be updated to display the new table.

...................................................................
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Figure 8.15 User Defined Tables Window
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Once you have the table displayed in the profIle table window, you can save the
table headings for future use. To save a table heading, select Save Table from
the Options menu on the profIle table window. When this option is selected, a
pop up window will appear, prompting you to enter a name for the table. Once
you enter the name, press the OK button at the bottom of the pop up window.
The table name will then be added to a list of tables included under the User
Tables menu on the profIle table window. To delete a table from the list of
user defmed tables, select Remove Table from the Options menu of the
profIle table window. When this option is selected, a pop up window will
appear displaying a list of all the user defmed tables. Click the left mouse
button over the tables that you want to delete, then press the OK button. The
selected tables will then be deleted from the User Tables menu list.

Sending Tables to the Printer

To send a table to the printer do the following:

1. Bring up the desired table from the tabular output (cross section or
profIle tables) section of the program.

2. Select Print from the File menu of the displayed table. When this
option is selected, a pop up window will appear allowing you to modify
the default print options. Once you have set the printer with the desired
options, press the Print button. The table will be sent to the Windows
Print Manager. The Windows Print Manager will control the printing
of the table.

The profIle type of tables allow you to print a specifIc portion of the table,
rather than the entire table. If you desire to only print a portion of the table, do
the following:

1. Display the desired profIle type table on the screen.

2. Using the mouse, press down on the left mouse button and highlight
the area of the table that you would like to print. To get an entire row
or column, press down on the left mouse button while moving the
pointer across the desired row or column headings.

3. Select Printer from the File menu of the displayed table. Only the
highlighted portion of the table and the row and column headings will
be sent to the Windows Print Manager.
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Chapter 8 Viewing Results

Sending Tables to the Windows Clipboard

To pass a table to the Windows Clipboard, and then to another program, do the
following:

1. Display the desired table on the screen.

2. Select Copy to Clipboard from the File menu of the displayed table.

3. Bring up the program that you want to pass the table into. Select Paste
from the Edit menu of the receiving program.

Portions of the profIle tables can be sent to the Clipboard in the same manner
as sending them to the printer.

Viewing Results From the River System Schematic

The user has the option of either bringing up graphics and tables from the View
menu on the main HEC-RAS window (as discussed above), or from the river
system schematic (found under geometric data). Once data have been entered,
and a successful simulation has been made, the user can interact with the river
system schematic. When the left mouse button is pressed over the river system
schematic, a pop up menu will appear listing options that are relevant to the
area of the schematic that is located under the mouse pointer. An example of
this is shown in Figure 8.16.

In Figure 8.16, the pop up menu shown comes up whenever the user presses
the left mouse button over a cross section. In this particular example, the
mouse button was pressed over the cross section located at river station 10.0 of
the Upper reach of Fall river. As shown in the menu, the user has the choice of
editing the cross section data; plotting the cross section; plotting the profIle for
the reach containing this cross section; bringing up the XYZ plot for that reach;
viewing tabular output; plotting the computed rating curve at this cross
se~tion; or viewing a picture of the location. Other pop up menus are available
for bridges; culverts; junctions; and reach data.
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Geometric Data - base geo data gfifEJ

Lower Reach

I
Figure 8.16 Geometric Data Window With Pop up Menu

I

Viewing Ice Information

River ice information can be viewed both in a graphical and tabular format.

Viewing Graphical Ice Information on the Screen

To view graphical ice information on the screen, select either Cross Sections,
Pr.ofiles, or X-Y-Z Perspective Plot from the View menu on the HEC-RAS
mam window.

Cross Section Plot. Figure 8.17 is an example cross section plot displaying
ice. The ice cover is displayed by selecting Variables under the Options
menu, then selecting the Ice Cover option. The ice thicknesses in the right
overbank, main channel, and left overbank are displayed. The default color and
fill pattern can be changed by the user by selecting Lines and Symbols under
the Options menu. Note that multiple profiles and multiple plans can be
displayed on the same plot.
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Profiles Plot. An example of a profIle plot with ice is shown in Figure 8.18. In
this case, the WS-EG Profile was selected. As with the Cross Section plot, the
ice cover is displayed by selecting Variables under the Options menu, then
selecting the Ice Cover option. The ice thicknesses in the right overbank, main
channel, and left overbank are displayed. The default color and fill p!lttem can
be changed by the user by selecting Lines and Symbols under the Options
menu. Note that multiple profiles and multiple plans can be displayed on the
same plot.
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Ice information can also be displayed in profIle plots by selecting the General
Profile option and then selecting Variables under the Options menu. This
provides a number of ice variables, including ice volume in the channel, left,
and right overbanks; ice thickness in the channel, left, and right over~anks; top
of ice elevation in the channel, left, and right overbanks; and bottom of ice
elevations in the channel, left, and right overbanks. These plots can all be
viewed in different widow sizes and printed.

X-Y-Z Perspective Plot. As with the Cross Section plot, the ice cover is
displayed by selecting Variables under the Options menu, then selecting the
Ice Cover option. The ice thicknesses in the right overbank, main channel, and
left overbank are displayed. The default color and fill pattern can be changed
by the user by selecting Lines and Symbols under the Options menu.
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Fi~ure 8.18 Profile plot with ice cover.
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Chapter 8 Viewing Results

Viewing Tabular Ice Information

Tabular information describing the results of the ice calculations can be
displayed by selecting Profile Table under the View menu on the HEC­
RAS main window. Ice information is available directly by selecting the Ice
Cover option under the Std. Tables menu of the ProfIle Table window.
The Ice Cover option provides a table that includes the ice volume, ice
thickness, and composite Manning's n value for the main channel, left
overbank, and right overbank. In addition, the Ice Cover Table includes the
water surface elevation and the cumulative ice volume starting from the
downstream end of the channel. An example table of ice information is
shown in Figure 8.19. Tables of ice information can also be created using
the Define Table option under the Options menu of the ProfIle Table
window.
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Chapter 9 Peiforming a Floodway Encroachment Analysis

CHAPTER 9

Performing a Floodplain Encroachment
Analysis

The evaluation of the impact of floodplain encroachments on water surface
profiles can be of substantial interest to planners, land developers, and
engineers. Floodplain and floodway evaluations are the basis for floodplain
management programs. Most of the studies are conducted under the National
Flood Insurance Program and follow the procedures in the "Flood Insurance
Study Guidelines and Specifications for Study Contractors," FEMA 37
(Federal Emergency Management Agency, 1985).

FEMA 37 defines a floodway "...as the channel of a river or other watercourse
and the adjacent land areas that must be reserved in order to discharge the
base flood without cumulatively increasing the water-surface elevation by
more than a designated height." Normally, the base flood is the one-p"ercent
chance event (IOO-year recurrence interval), and the designated height is one
foot, unless the state has established a more stringent regulation for maximum
rise. The floodway is usually determined by an encroachment analysis, using
an equal loss of conveyance on opposite sides of the stream. For purposes of
floodway analysis, the floodplain fringe removed by the encroachments is
assumed to be completely blocked.

HEC-RAS contains five optional methods for specifying floodplain
encroachments. For information on the computational details of each of the
five encroachment methods, as well as special considerations for
encroachments at bridges, culverts, and multiple openings, see Chapter 9 of
the HEC-RAS hydraulics reference manual. This chapter describes how to
enter floodplain encroachment data, how to perform the encroachment
calculations, and viewing the floodplain encroachment results.

Contents

• General

• Entering Floodplain Encroachment Data

• Performing the Floodplain Encroachment Analysis

• Viewing the Floodplain Encroachment Results
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Currently, the HEC-RAS program has 5 methods to determine floodplain
encroachments. These methods are:

For a detailed discussion on each of these methods, the user is referred to
Chapter 9 of the Hydraulic Reference Manual.

Chap''' 9 ~.1om'in~ a Flaodwal En.cma'hm<n' Anall,i,

Gen ral

The HEC-RAS floodplain encroachment procedure is based on calculating a
natural profile (existing conditions geometry) as the first profile in a multiple
profile run. Other profiles, in a run, are calculated using various
encroachment options, as desired. Before performing an encroachment
analysis, the user should have developed a model of the existing river system.
This model should be calibrated to the fullest extent that is possible.
Verification that the model is adequately modeling the river system is an
extremely important step before attempting to perform an encroachment
analysis.
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User enters right and left encroachment stations
User enters fIxed top width
User specifIes the percent reduction in conveyance
User specifIes a target water surface increase
User specifIes a target water surface increase and
maximum change in energy

Method 1 ­
Method 2­
Method 3­
Method 4­
Method 5 -

The goal of performing a floodplain encroachment analysis is to determine the
limits of encroachment that will cause a specifIed change in water surface
elevation. To determine the change in water surface elevation, the program
must fIrst determine a natural profile with no encroachments. This base profile
is typically computed using the one percent chance discharge. The computed
profile will defme the floodplain, as shown in Figure 6.1. Then, by using one
of the 5 encroachment methods, the floodplain will be divided into two zones:
the floodway fringe and the floodway. The floodway fringe is the area blocked
by the encroachment. The floodway is the remaining portion of the floodplain in
which the one-percent chance event must flow without raising the water
surface more than the target amount.
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Chapter 9 Peiforming a Floodway Encroachment Analysis

Within HEC-RAS, the data for performing a floodplain encroachment
analysis are entered from the Steady Flow Analysis Window. Encroachment
infonnation is not considered as pennanent geometry or flow data, and is
therefore not entered as such. The encroachment infonnation is saved as part
of the existing Plan data.

Plan View

Cross Section
View
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Figure 9.1 Floodway Definition Sketch

Entering Floodplain Encroachment Data
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To bring up the floodplain encroachment data window, select the
Encroachments option from the Options menu of the Steady Flow Analysis
window. When this option is selected an Encroachment window will appear
as·shown in Figure 9.2 (except yours will be blank when you first open it).

As shown in Figure 9.2, There are several pieces of data that the user must
supply for an encroachment analysis. The encroachment analysis can only be
perfonned for profiles 2 through 15 (or what ever number has been set by the
user in the flow data editor). Encroachments are not perfonned on profile one
because most of the encroachment methods rely on having a base profile for
comparison.

I
I
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Encroachments

Figure 9.2 Floodplain Encroachment Data Editor

The data for an encroachment analysis should be entered in the following
manner:

Global Information. Global information are data that will be applied at
every cross section for every profile computed. The first piece of global
information is the Equal Conveyance Reduction selection box at the top of
the Encroachment data editor window. Equal conveyance reduction applies to
encroachment methods 3, 4, and 5. When this is turned on, the program will
attempt to encroach, such that an equal loss of conveyance is provided on
both sides of the stream. If this option is turned off, the program will
encroach by trying to maintain a loss in conveyance in proportion to the
distribution of natural overbank conveyance. The default is to have equal
conveyance reduction turned on.

The second item under global information, is the Left bank offset and the
Right bank offset. The left and right offsets are used to establish a buffer
zone around the main channel for further limiting the amount of the
encroachments. For example, if a user established a right offset of 5 feet and
a left offset of 10 feet, the model will limit all encroachments to 5 feet from
the right bank station and 10 feet from the left bank station. The default is to
have no right or left offset, this will allow the encroachments to go up to the
main channel bank stations, if necessary.
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I
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River, Reach and River Station Selection Boxes. The next piece of data for
the user to select, is the river and reach in which to enter encroachment data.
The user is limited to seeing one reach at a time on the encroachment data
editor. Once a reach is selected, the user can then enter a Starting and
Ending River Station to work on. By default, the program selects all the
sections in the reach. The user can change this to any range of cross sections
within the reach.

9-5

Profile. Next, the user should select a profile number to work on. Profiles
are limited to 2 through the maximum number set in the currently opened
flow data (e.g., 2 through 4, if the user has set 4 profiles in the flow data
editor). The user can not set encroachments for profile 1.

At this point the user should repeat these tasks until all of the encroachment
data are entered (i.e., for all the reaches and locations in the model, as well as
all of the profiles for which the user wants to perform the encroachment
analysis). Once all of the encroachment data are entered, the user presses the
OK button and the data will be applied and the window will close. The user
can return to the encroachment window and edit the data at any time. The
encroachment data are not saved to the hard disk at this time, they are only

Method and Target Values. The next step is to enter the desired
encroachment method to be used .for the currently selected profile. Once a
method is selected, the data entry boxes that corresponds to that method will
show up below the method selection box. Some of the methods require only
one piece of data, while others require two. The user should then enter the
required information that corresponds to the method that they have selected.
For example, if the user selects encroachment method 4, only one piece of
information is required, the target change in water surface elevation. The
available encroachment methods in HEC-RAS are:

User enters right and left encroachment station
User enters a fixed topwidth
User specifies the percent reduction in conveyance
User specifies a target water surface increase
User specifies target water surface increase and
maximum change in energy

Method 1 ­
Method 2­
Method 3­
Method 4­
Method 5 -

Set Selected Range. Once the encroachment method is selected, and its
corresponding data are entered, the user should press the Set Selected Range
button. Pressing this button will fill in the table below with the selected range
of river stations; the selected method; and the corresponding data for the
method. Note that, if the selected method only has one data item, that
method's data will go under the Value 1 column of the table. If the selected
method has two data items, the first goes into the Value 1 column and the
second goes into the Value 2 column. Once the data is put into the table, the
user can change the method and corresponding data values directly from the
table.
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Chapter 9 Pert"ormins a Floodway Encroachment Analysis

saved in memory. To save the data to the hard disk, the user should either
select Save Project from the File menu of the main HEC-RAS window, or
select Save Plan from the File menu of the Steady Flow Analysis window.

The Import Method 1 option, allows the user to transfer the computed
encroachment stations from a previous run (output file) to the input data for a
future run. For example, if the user performs a preliminary encroachment
analysis using any of the methods 2 through 5, they may want to convert tile
results from one of the runs to a method 1 encroachment method. This will
allow the user to further define the floodway, using method 1, without having
to enter all of the encroachment stations. The import of encroachment
stations, in this manner, is limited to the results of a single encroachment
profile for each reach.

Performing The Floodplain Encroachment Analysis

The HEC-RAS floodway procedure is based on calculating a natural profile
(no encroachments) as the first profile of a multiple profile run. Subsequent
profiles are calculated with the various encroachment options available in the
program.

In general, when performing a floodway analysis, encroachment methods 4
and 5 are normally used to get a first cut at the encroachment stations.
Recognizing that the initial floodway computations may provide changes in
water surface elevations greater, or less, than the "target" increase, initial
computer runs are usually made with several "target" values.. The initial
computer results should then be analyzed for increases in water surface
elevations, changes in velocities, changes in top width, and other parameters.
Also, plotting the results with the X-Y-Z perspective plot, or onto a topo map,
is recommended. From these initial results, new estimates can be made and
tested.

After a few initial runs, the encroachment stations should become more
defined. Because portions of several computed profiles may be used, the final
computer runs are usually made with encroachment Method 1 defining the
speCific encroachment stations at each cross section. Additional runs are
often made with Method 1, allowing the user to adjust encroachment stations
at specific cross sections to further define the floodway.

While the floodway analysis gerierally focuses on the change in water surface
elevation, it is important to remember that the floodway must be consistent
with local development plans and provide reasonable hydraulic transitions
through the study reach. Sometimes the computed floodway solution, that
provides computed water surfaces at or near the target maximum, may be
unreasonable when transferred to the map of the actual study reach. If this
occurs, the user may need to change some of the encroachment stations, based
on the visual inspection of the topo map. The floodway computations should
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Viewing the Floodplain Encroachment Results
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Chapter 9 Peiforming a Floodway Encroachment Analysis

be re-run with the new encroachment stations to ensure that the target
maximum is not exceeded.

Floodplain encroachment results can be viewed in both graphical and tabular
modes. Graphically, the encroachment results show up on the cross section
plots as well as the X-Y-Z Perspective plot. An example cross section plot is
shown in Figure 9.3.

Floodway Determination - Example 6
Geom: Existing Conditions Flow: Base + 1 fl Target Depth

River =Beaver Creek Reach =Kentwood Upstream Boundary Cross Section
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Figure 9.3 Example Cross Section Plot With Encroachments

As shown in Figure 9.3, the encroachments are plotted as outlined blocks. In
this example, the water surface profile for the base run (first profile) is plotted
along with one of the encroached profiles. The user can plot as many profiles
as they wish, but it may become a little confusing with several sets of
encroachments plotted at they same time.

I
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Chapter 19 Performing a Floodway Encroachment Analysis I
Another type of graphic that can be used to view the encroachments is the X- I
Y-Z perspective plot, an example is shown in Figure 9.4. In this example, the
base profile (profile 1) as well as one of the encroached profiles is plotted at
the same time over a range of cross sections. This type of plot allows the user I
to get a reach view of the floodplain encroachment. The user can quickly see
if the encroachments transition smoothly or if they are erratic. In general, the
final encroachments should have a consistent and smooth transition from one I
cross section to the next. With the assistance of this type of plot, the user may
want to further refine the final encroachment stations and re-run the model.

I

9-8

Figure 9.4 Example X-Y-Z Perspective Plot with Base and Encroached Profiles

Encroachment results can also be viewed in a tabular mode from the Profile
Output Tables. Select Profile Table from the View menu of the main HEC­
RAS window. When the table comes up, the user can select from three
different pre-defined encroachment tables. To bring up one of the
encroachment tables, select Encroachment 1 from the Std. Tables menu on
the Profile table window. An example of Encroachment 1 table is shown in
Figure 9.5. The table shows the basic encroachment results of: computed
water surface elevation; change in water surface from the base profile; the
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Chapter 9 Performing a Floodway Encroachment Analysis

computed energy; top width of the active flow area; the flow in the left
overbank, main channel, and right overbank; the left encroachment station;
the station of the left bank of the main channel; the station of the right bank of
the main channel; and the right encroachment station.
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Figure 9.S Example of the Encroachment 1 Standard Table
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Encroachment 2 table provides some additional information that is often used
whe.n plotting the encroachments onto a map. This table includes: the change
in water surface elevations from the first profile; the top width of the active
flow area; the percentage of conveyance reduction in the left overbank; the
left encroachment station; the distance from the center of the main channel to
the left encroachment station; th~ station of the center of the main channel; the
distance from the center of the main channel to the right encroachment station;
the right encroachment station; and the percentage of conveyance reduction in
the right overbank. An example of the Encroachment 2 standard table is
shown in Figure 9.6.
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Figur~ 9.6 Example of the Encroachment 2 Standard Table
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The last encroachment table, Encroachment 3, provides the minimum
floodway data for reporting. This table includes: the active flow top width;
the flow area (including any ineffective flow area); the average velocity of the
entire cross section; the computed water surface elevation; the base water
surface elevation (profile 1); and the change in water surface from the first
profile. An example of this table is shown in Figure 9.7
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220.00
220.00

1797.30 7058.81 1.98 218.99 218.99
928.58 5276.33 2.65 219.97 218.99

1764.76 908001 1.54 218.45 218.45
84798 5912.37 2.37 219.32 218.45.........""........-.-

1872.46 9233.37 1.52 218.22 218.22..-,...-"- .....................
789.38 5529.23 2.53 218.94 218.22

1987.63 9481.46 1.48 218.09 218.09
70761 5351.25 2.62 218.71 218.09

1910.01 9428.42 1.48 217.90 217.90
752.77 5178.39 2.70 218.33 217.90

1846.93 8960.55 1.56 217.42 217.42
617.70 4042.22 3.46 217.54 217.42

............. " ..." ....".__..•.u"........." .••. .-.

1846.93 2508.57 5.58 217.42 217.42
..........................................................

617.70 1978.13 7.08 217.54 217.42

Figure 9.7 Example of the Encroachment 3 Standard Table
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Chapter 10 Troubleshooting With HEC-RAS

CHAPTER 10

Troubleshooting With HEC-RAS

The HEC-RAS software is designed to continue its computations all the way
through completion, even when the user has entered poor data. Because of
this, the fact that the program executes a complete run does not necessarily
mean that the results are good. The user must carefully review the results to
ensure that they adequately represent the study reach and that they are
reasonable and consistent. The HEC-RAS software is an engineering tool, it is
by no means a replacement for sound engineering.

The HEC-RAS software contains several features to assist the user in the
development of a model; debugging problems; and the review of results.
These features include: built in data checking; an Errors, Warnings, and Notes
system; and a computational Log Output fIle. In addition to these features, the
user can use the graphical and tabular output to review the results and check
the data for reasonableness and consistency.

Built in Data Checking

The HEC-RAS user interface has two types of built in data checking. The ftrst
type of data checking is performed as the user enters the data. Each data fteld
of the data entry editors has some form of data checking. The second type of
data checking occurs when the user starts the steady flow computations. When
the user presses the compute button, on the steady flow analysis window, the
entire data set is processed through several data checks before the
computations are processed. A detailed discussion of each of these two data
checking features is described below.

Checking the Data as it is Entered

This type of data checking occurs whenever the user enters data into a single
data field or table. Once the user leaves a particular data entry field or table,
the program will automatically check that data for reasonableness. The
following is a list of some of the types of data checks that are performed:

1. Minimum and maximum range checking for variables.

2. Alpha and numeric data checks. This is done to ensure that the right
type of data is entered in each field.

10-1
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3. Increasing order of station for cross sections, bridge deck/roadway, and
abutments.

4. Data consistency checks (Le., when the main channel bank stations are
entered, the program checks to see if they exist in the cross section
station and elevation data).

5. Data deletion warnings. When you delete data the software will give
you a warning before it is deleted.

6. File management warnings (i.e., program will give you a chance to
save the data to the hard disk before the program is closed, or a
different data set is opened).

7. Data geometry checks (i.e., when a bridge deck/roadway is entered, the
program checks to ensure that the deck/roadway intersects with the
ground data).

Data Checking Before Computations are Performed

The second type of data checking is performed to evaluate the completeness
and consistency of the data. This type of data checking occurs before the
computations take place. When the user presses the Compute button on the
Steady Flow Analysis window, the program will perform a series of data
checks before the computations are allowed to proceed. If any data errors are
found, the program will not perform the computations. The following is a list
of some of the types of checks that are made during this time:

1. Data completeness. These data checks insure that all of the required
data exists for the entire data set. If any missing data are found, a
complete list of all the missing data and their specific locations is
displayed on the screen. An example of this is shown in Figure 10.1.

2. Data consistency. This type of data checking is performed to ensure
that the data is consistent with the computations that are being
requested. For example, if the user asks to perform a mixed flow
regime computation, the program checks to ensure that upstream as
well as downstream boundary conditions have been specified.
Likewise, if an encroachment analysis is requested, the program checks
to ensure that the number of profiles lines up with the number specified
in the encroachment data. There are several other checks of this type.

10-2

I
I
I
I
I
I
I
I
I
I
I
,I
I
I
I
I
I
I
I



The user can request a summary of all the errors, warnings, and notes that
occurred during the computations. This is accomplished by selecting
Summary Errors, Warnings, and Notes from the View menu on the main
HEC-RAS window. Once this is selected, a window will pop up displaying all
of the messages. The user can select a specifIc River and Reach, as well as
which Proftle and Plan to view. The user has the options of expanding the
window; printing the messages; or sending them to the windows clipboard. An
example of the Errors, Warnings, and Notes window is shown in Figure 10.2.

.....

Chapter 10 Troubleshooting With HEC-RAS

The HEC-RAS software has a system of Errors, Warnings, and Notes that are
passed from the steady flow computation program to the user interface.
During the computations, the steady flow computation program will set flags
for at a particular node (nodes are cross sections, bridges, culverts, or multiple
openings) whenever it is necessary. These message flags are written to the
standard output fIle, along with the computed results for that node. When the
user interface reads the computed results from the output fIle, if any errors,
warnings, or notes exist, they are interpreted and displayed in various locations
from the interface.

~.I~~~.~pll3~.E!~l:l.~~..l:I '.IF.3:I:!~.r:.~ ..~~...~..'.'~! ..'3.i:-'..I:!.r....!::l.t.l:l.t~g~:.l.?
- Channel Manning's n value not set

- Incomplete dBtB 0 n ReBch " 1" at River StBtion: 11
- Coefficient of Expansion not set

- Incomple~e dBtB 0 n ReBch " 1" al River SIBtion: 10
- Main channel length not set

Zero or Undefined Flow Vlllues on Rellch : 1 Prof # 2

Figure 10.1 Data Completeness Checking Window

Chapter 10 Troubleshooting With HEC-RAS

Errors, Warnings, and Notes
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Besides the summary window, messages will automatically appear on the cross
section specific tables. When a cross section or hydraulic structure is being
displayed, any errors, warnings, or notes for that location and profile will show
up in the Errors, Warnings, and Notes message box at the bottom of the table.
An example of this table is shown in Figure 10.3.

In general, the errors, warnings, and notes messages should be self
explanatory. The three categories of messages are the following:

ERRORS: Error messages are only sent when there are problems that prevent
the program from being able to complete the run.

WARNINGS: Warning messages provide information to the user that mayor
may not require action on the user's part. In general, whenever a warning is set
at a location, the user should review the hydraulic results at that location to
ensure that the results are reasonable. If the hydraulic results are found to be
reasonable, then the message can be ignored. However, in many instances, a
warning level message may require the user to take some action that will cause
the message to disappear on future runs. Many of the warning messages are
caused by either inadequate or bad data. Some common problems that cause
wariring messages to occur are the following:

Cross sections spaced to far apart. This can cause several warning
messages to be set.

Cross sections starting and ending stations not high enough. If a
computed water surface is higher than either end point of the cross section, a
warning message will appear.

Bad Starting Water Surface Elevation. If the user specifies a boundary
condition that is not possible for the specified flow regime, the program will
take action an set an appropriate warning message.
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Figure 10.3 Cross Section Table with Errors, Warnings, and Notes

Setting Log File Output Level
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NOTES: Note level messages are set to provide information to the user about
how the program is performing the computations.

Bad Cross Section Data. This can cause several problems, but most often the
program will not be able to balance the energy equation and will default to
critical depth.

This option allows the user to set the level of the Log file. The Log fIle is a fIle
that is created by the computational program. This file contains information
tracing the program process. Log levels can range between 0 and 10, with 0
resulting in no Log output and 10 resulting in the maximum Log output. In
general, the Log fIle output level should not be set unless the user gets an error
during the computations. If an error occurs in the computations, set the log fIle

.• 'l
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Chapter 0 Troubleshooting With HEC-RAS

level to an appropriate value. Re-run the computations and then review the log
output, try to determine why the program got an error.

When the user selects Set Log File Output Level, a window will appear as
shown in Figure IDA. The user can set a "Global Log Level," which will be
used for all cross sections and every profIle. The user can also set log levels at
specific locations for specific profIles. In general, it is better to only set the log
level at the locations where problems are occurring in the computations. To set
the specific location log level, first select the desired reach and river station.
Next select the log level and the profIle number (the log level can be turned on
for all profIles). Once you have everything set, press the Set button and the log
level will show up in the window below. Log levels can be set at several
locations individually. Once all of the Log Levels are set, press the OK button
to close the window.

Warning !!! - setting the global log output level to 4 or 5 can result in very
large log fIle output. Global log level values of 6 or larger can result in
extremely large log fIles.

Reach=UpperReech
Reach=Upper Reach P.S=11
Reach=Upper Reach P.S=10

Figure 10.4 Log File Output Level window
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Viewing Graphics

Viewing Tabular Output

Reviewing and Debugging- the Normal Output

Chapter 10 Troubleshooting With HEC-RAS

Viewi ng The Log Fi Ie

After the user has successfully completed a run, and reviewed all the errors,
warnings, and notes, the normal output should be reviewed for consistency and
reasonableness.

In general, the graphical output should be used as much as possible to get a
quick view of the results. The user should look at all of the ·cross sections with
the cross section plotting capability. The cross section plots will assist the user
in fmding data mistakes, as well as possible modeling mistakes (mistakes in
ineffective flow areas, levees, n values, etc.).

This option allows the user to view the contents of the log fIle. The interface
uses the Windows Write program to accomplish this. It is up to the user to set
an appropriate font in the Write program. If the user sets a font that uses
proportional spacing, the information in the log fIle will not line up correctly.
Some fonts that work well are: Line Printer; Courier (8 pt.); and Helvetica (8
pt.). Consult your Windows user's manual for information on how to use the
Write program.

The profile plotting capability is a good way to get a quick overview of the
entire study area. The user should look for sudden changes to the energy grade
line and the water surface. In general, these two variables should transition
smoothly along the channel. If the user fmds rapid changes in the energy or the
water surface, the results at those locations should be reviewed closely to
ensure that they are correct.

The X-Y-Z Perspective Plot can also be used to get a quick view of an entire
reach. This plot is very helpful for viewing the top width of the flow area. If
the user finds dramatic changes in the top width from one cross section to the
next, then the results at those locations should be reviewed closely. Dramatic
changes in top width may indicate the need for additional cross sections.

There are several types of tabular output. The user should try to make use of
all of them when viewing tabular results. In general, the profIle types of tables
should be used to get an overview of some of the key variables at several
locations. If any problems are found, or any results that seem suspect, the user
should use the cross section specifIc tables to get detailed results at a single
location.

Chapter 10 Troubleshooting With HEC-RASI
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Chapter 0 Troubleshooting With HEC-RAS

The Occurrence of Critical Depth

During the water surface profIle calculations, the program may default to
critical depth at a cross section in order to continue the calculations. Critical
depth can occur for the following reasons:

1. Bad cross section data: If the energy equation can not balance because
of bad cross section data, the program defaults to critical depth.

2. Cross sections spaced too far apart: If the cross sections are spaced to
far apart, the program may not be able to calculate enough energy
losses to obtain a subcritical water surface at the upstream section.

3. Wrong flow regime: When calculating a subcritical profIle, and the
program comes to a reach that is truly supercritical, the program will
default to critical depth. Likewise, when calculating a supercritical
profIle, if the reach is truly subcritical, the program will default to
critical depth.

4. Program can not balance the energy equation above or below the top of
a levee or ineffective flow area: On occasion, when the program is
balancing a water surface that is very close to the top of a levee, or an
ineffective flow area, the program may go back and forth (above and
below the levee) without being able to balance the energy equation.
When this occurs, the program will default to critical depth.

Computational Program Does Not Run To Completion

While running the computational part of the software, when the program is
fInished you should get the message "PROGRAM TERMINATED
NORMALLY." If the user has entered bad data, the computational program
may not be able to run to completion. When this happens the program will stop
and write an error message to the screen, as shown in Figure 10.5.

This is a Fortran error message that is put out by the Fortran compiler that was
used to develop the computational program. The message basically says that a
math error occurred and therefore the program could not continue. When this
type of error occurs, it is almost always a data input problem. There is a
"small" possibility that it could be a bug in the program, but the user should
exhaust all the possible data input errors before assuming that the program has
a "Bug."
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Figure 10.5 Steady Flow Analysis Computation Window

The first step in finding the problem is to realize where the error is occurring.
From the information in the computation window, shown in Figure 10.5, the
program was on the fIrst profIle and had fmished computing the water surface
and energy for cross section 93.4. This means that the error occurred at the
next computational point upstream of section 93.4. Go to the Geometric Data
editor and review the input data closely at the problem location.

Computational errors, such as the one shown in Figure 10.5, often occur at
bridges. Check your data closely for any inconsistencies in the bridge
geometry. Many of the problems that occur at bridges are due to bad
Deck/Roadway data. Go to the Bridge/Culvert Data editor and turn on the
option HigWight Weir, Opening Lid and Ground from the View menu.
This option will assist you in fmding any geometric mistakes in the bridge data.

Chapter 10 Troubleshooting With HEC-RASChapter 10 Troubleshooting With HEC-RAS
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Chapter 1J Computing Scour at Bridges

CHAPTER 11

Computing Scour at Bridges

The computation of scour at bridges within HEC-RAS is based upon the
methods outlined in Hydraulic Engineering Circular No. 18 (FHWA, 1995).
Before performing a scour analysis with the HEC-RAS software, the engineer
should thoroughly review the procedures outlined in the Hydraulic
Engineering Circular No. 18 (HEC 18) report. This chapter presents the data
input required for computing contraction scour and local scour at piers and
abutments.

For information on the bridge scour equations, please see Chapter 10 of the
HEC-RAS Hydraulic Reference Manual.

Contents

• General Modeling Guidelines

• Entering Bridge Scour Data

• Computing Total Bridge Scour
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Gen ,ral Modeling Guidelines

In order to perform a bridge scour analysis, the user must first develop a
hydraulic model of the river reach containing the bridge to be analyzed. This
model should include several cross sections downstream from the bridge,
such that any user defined downstream boundary condition does not affect the
hydraulic results inside and just upstream of the bridge. The model should
also include several cross sections upstream of the bridge, in order to evaluate
the long term effects of the bridge on the water surface profile upstream.

The hydraulic modeling of the bridge should be based on the procedures
outlined in Chapter 5 of the Hydraulic Reference Manual. If observed data
are available, the model should be calibrated to the fullest extent possible.
Once the hydraulic model has been calibrated (if observed data are available),
the modeler can enter the design events to be used for the scour analysis. In
general, the design event for a scour analysis is usually the 100 year (l
percent chance) event. In addition to this event, it is recommended that a 500
year (0.2 percent chance) event also be used in order to evaluate the bridge
foundation under a super-flood condition.

The next step is to turn on the flow distribution option in the HEC-RAS
software. This option allows for additional output showing the distribution of
flow for multiple subdivisions of the left and right overbanks, as well as the
main channel. The output of the flow distribution option includes the
following items for each flow slice: percentage of flow; flow area; wetted
perimeter; conveyance; hydraulic depth; and average velocity. The user can
control the number of slices in each flow element (left overbank, main
channel, and right overbank), up to a maximum of 45 total slices. The flow
distribution output is controlled from the Options menu of the Steady Flow
Analysis window (see Chapter 7, Simulation Options).

The user must request the flow distribution output for the cross sections inside
the bridge, the cross section just upstream of the bridge, and the approach
section ( cross section upstream of the bridge at a distance such that the flow
lines are parallel and the flow has not yet begun to contract due to the bridge
constriction). Flow distribution output can be requested at additional cross
sections, but these are the only cross sections that will be used in the bridge
scour computations. The flow distribution option must be turned on in order
to get more detailed estimates of the depth and velocity at various locations
within the cross section. Once the user has turned this option on, the profile
computations must be performed again in order for the flow distribution
output to be computed and included in the output file.

After performing the water surface profile calculations for the design events,
and computing the flow distribution output, the bridge scour can then be
evaluated. The total scour at a highway crossing is comprised of three
components: long-term aggradation and degradation; contraction scour; and
local scour at piers and abutments. The scour computations in the HEC-RAS

11-2
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Chapter 11 Computing Scour at Bridges

software allow the user to compute contraction scour and local scour at piers
and abutments. The current version of the HEC-RAS software does not allow
the user to evaluate long-term aggradation and degradation. Long term
aggradation and degradation should be evaluated before performing the bridge
scour analysis. Procedures for performing this type of analyses are outlined
in the HEC No. 18 report.

Entering Bridge Scour Data

The bridge scour computations are performed by opening the Hydraulic
Design Functions window and selecting the Scour at Bridges function. Once
this option is selected the program will automatically go to the output me and
get the computed output for the approach section, the section just upstream of
the bridge, and the sections inside of the bridge. The Hydraulic Design
window for Scour at Bridges will appear as shown in Figure 11-1.

Legend

W8 PF#1--20 GrO~nd

Ineff•
15 Bank 8ta

o~.......,~..."...~...,.....~,.............-rr~.,..,

o 500 1000 1500 2000 2500 3000

Stiltion (ft)

Figure 11-1. Hydraulic Design Window For Scour at Bridges
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As shown in Figure 11-1, the Scour at Bridges window contains the input data,
a graphic, and a window for summary results. Input data tabs are available for
contraction scour, pier scour, and abutment scour. The user is required to enter
only a minimal amount of input and the computations can be performed. If the
user does not agree with any of the data that the program has selected from the
output fIle, the user can override it by entering their own values. This provides
maximum flexibility in using the software.

Entering Contraction Scour Data

Contraction scour can be computed in HEC-RAS by either Laursen's clear­
water (Laursen, 1963) or live-bed (Laursen, 1960) contraction scour equations.
Figure 11-2 shows all of the data for the contraction scour computations. All
of the variables except K1 and D50 are obtained automatically from the HEC­
RAS output fIle. The user can change any variable to whatever value they
think is appropriate. To compute contraction scour, the user is only required to
enter the DSO (mean size fraction of the bed material) and a water temperature
to compute the K1 factor.
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Figtrre 11-2. Example Contraction Scour Calculation
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Chapter II Computing Scour at Bridges

Each of the variables that are used in the computation of contraction scour are
defIned below, as well as a description of where each variable is obtained from
the output fIle.

YI: The average depth (hydraulic depth) in the left overbank, main channel,
and the right overbank, at the approach cross section.

VI: The average velocity of flow in the left overbank, main channel, and right
overbank, at the approach section.

YO: The average depth in the left overbank, main channel, and right overbank,
at the contracted section. The contracted section is taken as the cross section
inside the bridge at the upstream end of the bridge (section BU).

Q2: The flow in the left overbank, main channel, and right overbank, at the
contracted section (section BU).

W2: The top width of the active flow area (not including ineffective flow area),
taken at the contracted section (section BU).

050: The bed material particle size of which 50% are smaller, for the left
overbank, main channel, and the right overbank. These values must be entered
by the user.

Equation: The user has the option to allow the program to decide whether to
use the live-bed or clear-water contraction scour equations, or to select a
specifIc equation. If the user selects the Default option (program selects which
equation is most appropriate), the program must compute Ve, the critical
velocity that will transport bed material fIner than D50. If the average velocity
at the approach cross section is greater than Ve, the program uses the live-bed
contraction scour equation. Otherwise, the clear-water contraction scour
equation will be used.

QI: The flow in the left overbank, main channel, and right overbank at the
approach cross section.

WI: The top width of the active flow area (not including ineffective flow
area), taken at the approach cross section.

K I: An exponent for the live-bed contraction scour equation that accounts for
the mode of bed material transport. The program can compute a value for K1
or the user can enter one. To have the program compute a value, the Kl button
must be pressed. Figure 11-3 shows the window that comes up when the Kl
button is pressed. Once a water temperature is entered, and the user presses
the OK button, the Kl factor will be displayed on the main contraction scour
window. Kl is a function of the energy slope (Sl) at the approach section, the
shear velocity (V·) at the approach section, water temperature, and the fall
velocity (w) of the D50 bed material.
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compute Kl for Contraction Scour

Figure 11-3. Computation of the Kl Factor.

Approach XS River Sta.: The river station of what is being used as the
approach cross section. The approach cross section should be located at a
point upstream of the bridge just before the flow begins to contract do to the
constriction of the bridge opening. The program assumes that the second cross
section upstream of the bridge is the approach cross section. If this is not the
case, the user can select a different river station to be used as the approach
cross section.

As shown in Figure 11-2, the computation of contraction scour is performed
separately for the left overbank, main channel, and right overbank. For this
example, since there is no right overbank flow inside of the bridge, there is no
contraction scour for the right overbank. The summary results show that the
computed contraction scour, Ys' was 2.26 feet (0.69 m) for the left overbank,
and 6.67 feet (2.03 m) for the main channel. Also note that the graphic was
updated to show how far the bed would be scoured due to the contraction
scour.

Entering Pier Scour Data

Pier scour can be computed by either the Colorado State University (CSU)
equation (Richardson, et aI, 1990) or the Froehlich (1988) equation (the
Froehlich equation is not included in the HEC No.18 report). The CSU
equation is the default. As shown in Figure 11-4, the user is only required to
enter the pier nose shape (K1), the angle of attack for flow hitting the piers, the
condition of the bed (K3), and a D90 size fraction for the bed material. All
other values are automatically obtained from the HEC-RAS output file.
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Chapter 11 Computing Scour at Bridges

As shown in Figure 11-4, the user has the option to use the maximum velocity
and depth in the main channel, or the local velocity and depth at each pier for
the calculation of the pier scour. In general, the maximum velocity and depth
are used in order to account for the potential of the main channel thalweg to
migrate back and forth within the bridge opening. The migration of the main
channel thalweg could cause the maximum potential scour to occur at anyone
of the bridge piers.

Each of the variables that are used in the computation of pier scour are defined
below, as well as a description of where each variable is obtained from the
output fIle.

Maximum VI YI: If the user selects this option, the program will fmd the
maximum velocity and depth located in the cross section just upstream and
outside of the bridge. The program uses the flow distribution output to obtain
these values. The maximum VI and Yl will then be used for all of the piers.

Figure 11-4. Example Pier Scour Computation.

Legend

Groxnd

In~f

Bank Sta

WS PFNI
•

Total Scour

Con1r Scour

~

;;:1 ":::1

fl\ ,/
;~:::J:::

":::::j'
,1 111 ',.11"...~.
,I'""n,.:::
n'

5

o

-5

20

15

10

Bridge Scour RS = 10.36
25

-10

-15 -t->---........,................,--~.,.,.-~ .............,.,~..,..,

:~~~~
!Pier Scour

.: All Piers:

I
I
I

I

I
I

I
I
I
I
I
I

11-7



Chapter 1 COII/puting Scour at Bridges

Local VI YI: If the user selects this option, the program will find the velocity
(V I) and depth (Y I) at the cross section just upstream and outside of the
bridge that corresponds to the centerline stationing of each of the piers.

Method: The method option allows the user to choose between the CSU
equation and the Froehlich equation for the computation of local scour at bridge
piers. The CSU equation is the default method.

Pier #: This selection box controls how the data can be entered. When the
option "Apply to All Piers" is selected, any of the pier data entered by the user
will be applied to all of the piers. The user does not have to enter all of the data
in tills mode, only the portion of the data that should be applied to all of the
piers. Optionally, the user can select a specific pier from tills selection box.
When a specific pier is selected, any data that has already been entered, or is
applicable to that pier, will show up in each of the data fields. The user can
then enter any missing information for that pier, or change any data that was
already set.

Shape: This selection box is used to establish the pier nose (upstream end)
shape. The user can select between square nose, round nose, circular cylinder,
group of cylinders, or sharp nose (triangular) pier shapes. When the user
selects a shape, the KI factor for the CSU equation and the Pm factor for the
Froehlich equation are automatically set. The user can set the pier nose shape
for all piers, or a different shape can be entered for each pier.

a: This field is used to enter the width of the pier. The program automatically
puts a value in tills field based on the bridge input data. The user can change
the value.

D50: Median diameter of the bed material of which 50 percent are smaller.
This value is automatically filled in for each pier, based on what was entered
for the left overbank, main channel, and right overbank, under the contraction
scour data. The user can change the value for all piers or any individual pier.

YI: This field is used to display the depth of water just upstream of each pier.
The. value is taken from the flow distribution output at the cross section just
upstream and outside of the bridge. If the user has selected to use the
maximum YI and VI for the pier scour calculations, then tills field will show
the maximum depth of water in the cross section for each pier. The user can
change tills value directly for eac.h or all piers.

VI: This field is used to display the average velocity just upstream of each
individual pier. The value is taken from the flow distribution output at the
cross section just upstream and outside of the bridge. If the user has selected
to use the maximum YI and VI for the pier scour calculations, then tills field
will show the maximum velocity of water in the cross section for all piers. The
user can change tills value directly for each or all piers.
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Chapter 11 Computing Scour at Bridges

Angle: This field is used to enter the angle of attack of the flow approaching
the pier. If the flow direction upstream of the pier is perpendicular to the pier
nose, then the angle would be entered as zero. If the flow is approaching the
pier nose at an angle, then that angle should be entered as a positive value in
degrees. When an angle is entered, the program automatically sets a value for
the K2 coefficient. When the angle is > 5 degrees, K1 is set to 1.0.

L: This field represents the length of the pier through the bridge. The field is
automatically set by the program to equal the width of the bridge. The user can
change the length for all piers or each individual pier. This length is used in
determining the magnitude of the K2 factor.

Kl: Correction factor for pier nose shape, used in the CSU equation. This
factor is automatically set when the user selects a pier nose shape. The user
can override the selected value and enter their own value.

K2: Correction factor for angle of attack of the flow on the pier, used in the
CSU equation. This factor is automatically calculated once the user enters the
pier width (a), the pier length (L), and the angle of attack (angle).

K3: Correction factor for bed condition, used in the CSU equation. The user
can select from: clear-water scour; plane bed and antidune flow; small dunes;
medium dunes; and large dunes.

D90: The median size of the bed material of which 90 percent is finer. The
D90 size fraction is used in the computation of the K4 factor, and must be
entered directly by the user.

K4: The K4 factor is used to decrease scour depths in order to account for
arrnoring of the scour hole. This factor is only applied when the D50 of the bed
material is greater than 0.2 feet (0.06 m). This factor is automatically
calculated by the program, and is a function of 050; 090; a; and the depth of
water just upstream of the pier. The K4 factor is used in the CSU equation.

a': The projected pier width with respect to the direction of the flow. This
factor should be calculated by the user and is based on the pier width, shape,
angle, and length. This factor is specific to Froehlich's equation.

Phi: Correction factor for pier nose shape, used in the Froehlich equation. This
factor is automatically set when the user selects a pier nose shape. The user
can override the selected value and enter their own value.

For the example shown in Figure 11-4 the CSU equation was used, resulting in
a computed pier scour of 10.85 feet (3.31 m) at each pier (shown under
summary results in Figure 11-4). Also shown in Figure 11-4 is an updated
graphic with both contraction and pier scour shown.
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Entering Abutment Scour Data

Abutment scour can be computed by either the HIRE equation (Richardson,
1990) or Froehlich's equation (Froehlich, 1989). The input data and results for
abutment scour computations are shown in Figure 11-5.
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As shown in Figure 11-5, abutment scour is computed separately for the left
and right abutment. The user is only required to enter the abutment type (spill­
through, vertical, vertical with wing walls). The program automatically selects
values for all of the other variables based on the hydraulic output and default
settings. However, the user can change any variable. The location of the toe of
the abutment is based on where the roadway embankment intersects the natural
ground. This stationing is very important because the hydraulic variables used
in the abutment scour computations will be obtained from the flow distribution
output at this cross section stationing. If the user does not like the stationing
that the model picks, they can override it by entering their own value.
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Chapter 11 Computing Scour at Bridges

Each of the variables that are used in the computation of abutment scour are
defmed below, as well as a description of where each variable is obtained from
the output file.

Toe Sta at Bridge: This field is used to defme the stationing in the upstream
bridge cross section (section BU), where the toe of the abutment intersects the
natural ground. The program automatically selects a value for this stationing at
the point where the road embankment and/or abutment data intersects the
natural ground cross-section data. The location for the abutment toe stationing
can be changed directly in this field.

Toe Sta at App.: This field is used to define the stationing in the approach
cross section (section 4), based on projecting the abutment toe station onto the
approach cross section. The location for this stationing can be changed directly
in this field.

Length: Length of the abutment and road embankment that is obstructing the
flow. The program automatically computes this value for both the left and right
embankments. The left embankment length is computed as the stationing of
the left abutment toe minus the station of the left extent of the water surface in
the cross section just upstream of the bridge (including ineffective flow area).
The right embankment length is computed as the stationing of the right extent
of the water surface minus the stationing of the toe of the right abutment, at the
cross section just upstream of the bridge. These lengths can be changed
directly.

YI: This value is the computed depth of water at the station of the toe of the
embankment, at the cross section just upstream of the bridge. The value is
computed by the program as the elevation of the water surface minus the
elevation of the ground at the abutment toe stationing. This value can also be
changed by the user. This value is used in the HIRE equation.

KI: This value represents a correction factor accounting for abutment shape.
The user can choose among: vertical abutments; vertical with wing walls; and
spill-through abutments.

Skew: This field is used to enter the angle of attack of the flow against the
abutment. A value of 90 degrees should be entered for abutments that are
perpendicular to the flow (normal situation). A value less than 90 degrees
should be entered if the abutment is pointing in the downstream direction. A
value greater than 90 degrees should be entered if the abutments are pointing in
the upstream direction. The skew angle is used in computing the K2 factor.
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K2: Correction factor for angle of attack of the flow on the abutments. This
factor is automatically computed by the program. As the skew angle becomes
greater than 90 degrees, this factor increases from a value of one. As the skew
angle becomes less than 90 degrees, this value becomes less than one.

Equation: This field allows the user to select a specific equation (either the
HIRE or Froehlich equation), or select the default mode. When the default
mode is selected, the program will choose the equation that is the most
applicable to the situation. The selection is based on computing a factor of the
embankment length divided by the approach depth. If this factor is greater that
25, the program will automatically use the HIRE equation. If the factor is
equal to or less than 25, the program will automatically use the Froehlich
equation.

L'; The length of the abutment (embankment) projected normal to the flow.
This value is automatically computed by the program once the user enters an
abutment length and a skew angle. This value can be changed by the user
directly.

Va: The average depth of flow (hydraulic depth) that is blocked by the
embankment at the approach cross section. This value is computed by
projecting the stationing of the abutment toe's up to the approach cross section.
From the flow distribution output, the program calculates the area and top
width left of the left abutment toe and right of the right abutment toe. Ya is
then computed as the area divided by the top width. This value can be changed
by the user directly.

Qe: The flow obstructed by the abutment and embankment at the approach
cross section. This value is computed by projecting the stationing of the
abutment toes onto the approach cross section. From the flow distri.bution
output, the program calculates the percentage of flow left of the left abutment
toe and right of the right abutment toe. These percentages are multiplied by the
total flow to obtain the discharge blocked by each embankment. These values
can be changed by the user directly.

Ae:. The flow area that is obstructed by the abutment and embankment at the
approach cross section. This value is computed by projecting the stationing of
the abutment toes onto the approach cross section. From the flow distribution
output, the program calculates the area left of the left abutment toe and right of
the right abutment toe. These values can be changed by the user directly.

VI: The velocity at the toe of the abutment, taken from the cross section just
upstream and outside of the bridge. This velocity is obtained by fmding the
velocity in the flow distribution output at the corresponding cross section
stationing of the abutment toe. These values can be changed by the user
directly.

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I

I
I



Chapter 11 Computing Scour at Bridges

Computing Total Bridge Scour

The total scour is a combination of the contraction scour and the individual pier
and abutment scour at each location. Table 11.1 shows a summary of the
computed results, including the total scour.

In addition to the abutment input data, once the compute button is pressed, the
bridge scour graphic is updated to include the abutment scour and the
summary results window displays the computed abutment results. For the
example shown in Figure 11-5, the program selected the HIRE equation and
computed 10.63 feet (3.24 m) of local scour for the left abutment and 14.90
feet (4.54 m) of local scour for the right abutment.

Right O.B.
0.00 ft (0.0 m)

12.89 ft (3.93 m)
21.57 ft (6.58 m)
13.11 ft (4.00 m)
17.52 ft (5.34 m)

Pier Scour
Ys = 10.85 ft (3.31 m)
Eqn. = CSU equation

Contraction Scour
Main Channel
6.67 ft (2.03 m)
Live-Bed

Abutment Scour
Left Right
10.63 ft (3.24 m) 14.90 ft (4.54 m)
HIRE equation HIRE equation

Left O.B.
Ys = 2.26 ft (0.69 m)
Eqn = Clear-Water

Table 11.1
Summary of Scour Computations

Ys=
Eqn=

Total Scour
Left Abutment =
Right abutment =
Piers 1-2 (left O.B.) =
Piers 3-6 (main ch.) =

Piers 1-6

Once all three types of scour data are entered, and the compute button is
pressed, the bridge scour graphic is updated to reflect the total computed
scour. Shown in Figure 11-6 is the graphic of the final results (the graphic
has been zoomed in to see more detail). The graphic and the tabular results
can be sent directly to the default printer, or they can be sent to the Windows
Clipboard in order to be pasted into a report. A detailed report can be
generated, which shows all of the input data, computations, and final results.
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The bridge scour input data can be saved by selecting Save Hydraulic Design
Data As from the File menu of the Hydraulic Design Function window. The
user is only required to enter a title for the data. The computed bridge scour
results are never saved to the hard disk, The computations can be performed
in a fraction of a second by simply pressing the compute button. Therefore,
when the Hydraulic Design Function window is closed, and later re-opened,
the user must press the compute button to get the results.
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Bridge Scour RS = 10.36

Figure 11-6. Total Scour Depicted in Graphical Form
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Chapter 12 Performing Channel Modifications

CHAPTER 12

Performing Channel Modifications

The channel modification option in HEC-RAS allows the user to perform a
series of trapezoidal cuts into the existing channel geometry. In general, this
option is used for planning studies, but it can also be used for hydraulic
design of flood control channels.

This chapter does not cover the concepts of stable channel design. This
software is designed to evaluate the hydraulics of various channel
modifications. It is up to the user to ensure that any channel modification will
not cause further scour of the channel bed and banks. Discussions on stable
channel design can be found in many hydraulic text books, as well the Corps
Engineering Manual "Hydraulic Design of Flood Control Channels"
(USACE, 1991).

This chapter discusses: general modeling guidelines for using the channel
modification option; how to enter the necessary input data; performing the
channel modifications; and how to compare existing condition and modified
condition results.

Contents

• General Modeling Guidelines

• Entering Channel Modification Data

• Performing The Channel Modifications

• Comparing Existing and Modified Conditions

12-1



General Modeling Guidelines

In order to perform a channel modification analysis, the user should first
develop a hydraulic model of the existing river reach containing the area in
which the channel modification will be analyzed. This model should include
several cross sections downstream from the study reach, such that any user
defined downstream boundary condition does not affect the hydraulic results
inside the channel modification region. The model should also include
several cross sections upstream of the study reach, in order to evaluate the
effects of the channel modification on the water surface profile upstream.

Once a model of the existing river system is completed, the user can use the
Channel Modification option to perform trapezoidal cuts and fills into the
existing geometry. Once the user has performed all of the desired channel
modifications, then the modified geometry data is saved into a new geometry
file. The user can then create a new plan, which contains the modified
geometry and the original flow data that was used under the existing
conditions plan. Computations can then be performed for the modified
condition, and the user can compare the water surface profiles for both
existing and modified conditions.

The channel modification option in HEC-RAS allows for:.
• Multiple trapezoidal cuts (up to three)
• Independent specification of left and right trapezoidal side slopes
• Ability to change the Manning's n value for the trapezoidal cut
• Separate bottom widths for each trapezoidal cut
• Ability to set new channel reach lengths
• Multiple ways of locating the main channel centerline
• User can explicitly define the elevation of the new channel invert, or it

can be based on the original channel invert, or it can be based on
projecting a slope from a downstream cross section or an upstream
cross section

• The centerline of the trapezoidal cut can be entered directly, or it can
be located midway between the original main channel bank stations

• Option to fill the existing channel before performing cuts
• Cut and fill areas and volumes are computed

Ent ring Channel Modification Data

Within HEC-RAS, the data for performing a channel modification analysis are
entered from the Geometric Data window. The channel modification data are
stored within the geometry file of the base geometric data ( the geometric data
set in which the channel modification is being perfonned on).

12-2
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To bring up the Channel Modification Data window, select Channel
Modification from the Options menu of the Geometric Data window. When
this option is selected, a Channel Modification window will appear as shown in
Figure 12.1 (except yours will not have any data in it the fIrst time you bring it
up).
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Figure 12.1 Channel Modification Data Editor
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As shown in Figure 12.1, there are several pieces of data that the user must
enter in order to perform a channel modification analysis. The editor is divided
into three separate areas. The top portion of the window contains selection
boxes for the River and Reach; titles for the base geometry fIle and the
modified geometry fIle; buttons for performing the cuts and viewing cut and fIll
volumes; and controls for rotating the graphic. The middle portion of the
window contains a data input area for entering channel modifIcation
information over a range of cross sections, as well as a graphic of the cross
sections that are being modifIed. The bottom portion of the window contains a
table that lists the channel modifIcation data for all of the cross sections in the
selected Reach of a particular River.
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The fIrst step in performing a channel modification is to select the River and
Reach in which you want to perform the analysis. This is accomplished from
the River and Reach selection boxes in the upper left comer of the window.
The next step is to select a range of cross sections in which you would like to
perform a channel modification. This is accomplished by first selecting a cross
section from the Starting Riv Sta box and then from the Ending Riv Sta box.
Once this is done, all of the cross sections within the range of the specified
starting and ending river stations will appear in the graphic on the right. The
next step is to specify the channel modification data that you would like to
apply to this range of cross sections. This is accomplished by entering
information into the table contained in the "Set Range of Values" area of the
window. This table allows the user to enter information for up to three cuts,
which can then be applied to the selected range of cross sections. The
information contained in this table is as follows:

Center Cuts (yin): This column in the table is used to defme how the
trapezoidal cuts will be centered within the existing cross section data. If the
user enters a "y" in this column, then that particular cut will be centered
between the existing cross-section main channel bank stations. When all of the
cut information is entered, and the Apply Cuts to Selected Range button is
pressed, the program will automatically fIll in the center stationing of the
trapezoidal cuts in the lower table. If an "n" is entered, then it is up to the user
to specify the center stationing for each cross section, and each cut, in the table
at the bottom of the window.

Bottom Width: This column is used for entering the bottom width of the
trapezoidal cuts. If this column is left blank, it is assumed that the bottom
width will be zero. The user always has the option of directly entering the
bottom width for each cross section in the table at the bottom of the window.

Invert Elevation: This column is used to specify the invert elevation of the
trapezoidal cuts. If this column is left blank for a particular cut, then it is
assumed that the invert elevation of that trapezoidal cut will be set equal to the
invert elevation of the existing channel. If the user wants to have invert
elevations that are not equal to the existing channel inverts, then they must
enter elevations into this column and select one of the slope projection options
below this table. The user has the option to use the specified invert elevations
for each of the cross sections in the selected range; or they can enter elevations
for the most upstream cross section and have the other invert elevations
computed by projecting the cuts on a constant slope; or the elevations entered
can be applied to the most downstream cross section of the range, and all
others will be computed by projecting a user specified slope upstream.
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Chapter 12 Perl"orming Channel Modifications

Left Slope: This column is used to specify the slope of the left bank for each of
the trapezoidal cuts. The slope is entered in units of horizontal distance to one
unit in the vertical. (e.g., a value of 2 means the left bank slope will project 2
feet horizontally for every 1 foot vertically).

Right Slope: This column is used to specify the slope of the right bank for each
of the trapezoidal cuts. The slope is entered in units of horizontal distance to
one unit in the vertical. (e.g., a value of 2 means the right bank slope will
project 2 feet horizontally for every 1 foot vertically).

Cut n Val: This column is used to specify the new Manning's n value to be
applied to each of the trapezoidal cuts. If this column is left blank for any cut,
then the existing n values will be used for that cut.

Once this table has been filled out, the user must select one of the three slope
projection options listed below the table. The three options are:

Same Cut to all sections: If this option is selected, then the channel
modification data entered into the table will be applied to all of the cross
sections in the selected range.

Project cut from upper RS at slope: When this option is selected, the invert
elevations that were entered into the table will be applied to the most upstream
cross section in the selected range. The invert elevation of all of the other cross
sections will be based on projecting a user entered slope from the most
upstream cross section to each cross section downstream. The user must enter
a slope when this option is selected. The elevations of each cross sections
trapezoidal cuts are based on the user entered slope times the distance that each
cross section is from the most upstream cross section. The distance is the
cumulative main channel reach length for each of the individual cross sections.

Project cut from lower RS at slope: When this option is selected, the invert
elevations that were entered into the table will be applied to the most
downstream cross section in the selected range. The invert elevation of all of
the other cross sections will be based on projecting a user entered slope from
the most downstream cross section to each cross section upstream. The user
must enter a slope when this option is selected. The elevations of each cross
section's trapezoidal cuts are based on the user entered slope times the distance
that each cross section is from the most downstream cross section. The
distance is the cumulative main channel reach length for each of the individual
cross sections.

A fmal option that can be applied to the selected range of cross sections is the
Fill Channel option. When this option is turned on, the main channel of the
base cross-section data will be filled before any of the trapezoidal cuts are
applied. The main channel is filled to an elevation equal to the elevation of the
lower of the two main channel bank stations.
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Once the user has filled in all of the desired data in the "Set Range of Values"
data area, then the Apply Cuts to Selected Range button should be pressed.
When this button is pressed, the lower table is filled with the specific
infonnation that will be applied to each of the cross sections in the selected
range. The cut infonnation is then applied to each of the cross sections, and the
graphic is updated to show both the existing cross section and the modified
cross sections.

The user has the option of entering and modifying the channel modification
data directly in the table at the bottom of the window, or they can use the "Set
Range of Values" data area to apply a set of channel cut properties to a range
of cross sections (this can be done several times for different ranges of cross
sections within the reach).

A fmal option available to the user is Cut cross section until cut daylights
once. This is a global option that will be applied to all of the channel
modification data. When this option is selected, as the program performs the
cutting of the trapezoidal channel, the left and right banks of the channel will
start at the bottom of the trapezoid and cut through the ground until they reach
open air, then the cutting will stop. If this option is turned off, the left and right
banks of the trapezoid will be projected to infmity, continually cutting any
ground that lies above them.

Perf rming the Channel Modifications

Once all of the desired channel modification data are entered for a reach, the
user should press the Compute Cuts button at the top of the graphic. When
this button is pressed, all of the channel modification data from the lower table
is applied and the graphic is updated to reflect the new cut information. The
user can continue to modify the data and press the Compute Cuts button as
many times as is necessary to get the desired cuts. The cut infonnation is
always applied to the base geometry data.

Once the user has completed the desired channel modifications for the reach,
they can view the cut and fill quantities by pressing the Cut and Fill Areas
button. When this button is pressed, a window will appear as shown in Figure
12.2.
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Chapter 12 Performing Channel Modifications

Channel Modification - Cut and Fill Data

o
o
o

23837
o

23837

·ctijid):'
172<15 31216

o 0
172<15 31216

4398
o

<1398

<1338:

o
<1338

o
o
o

773<1
o

773<1

223 1053 1681
0 0 0

223 1053 1681

2<13 1629 2301

0 0 0
2<13 1629 2301

429

o
<129

<106
o

<106

CuI

Fill
Net

CuI
Fill
Net

3

Figure 12.2 Channel Modification Cut and Fill Quantities
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The cut and fill quantities table shows the cut, fill, and net areas and volumes
for each of the individual cross sections, as well as the totals for the reach. The
table shows the cut and fill quantities that were necessary in order to transform
the existing cross-section data into the modified cross-section data. The areas
and volumes are provided in the categories of left overbank, main channel,
right overbank, and total. These categories are based on the main channel bank
stations of the base geometry data. The volumes listed at a particular cross
section, represent the volume between that cross section and the next
downstream cross section. The total volume and area at a particular cross
section is the sum of the left overbank, main channel, and right overbank
quantities for that individual cross section only. Total volumes for the entire
reach are listed at the bottom of the table. The Cut and Fill Quantities table can
be. printed, sent to a file, or copied to the clipboard, by pressing the desired
button at the bottom of the window.

The channel modification option has been set up to work with one Reach of the
model at a time. If the user needs to perform channel modifications to more
than one reach of a multiple reach model, they can simply select a new reach at
any time. While the information in the tables and the graphic only show a
single reach, the channel modification information is stored for all of the
reaches.
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Chap'a ], Performing Channel Modifications

Once the user has fmished all of the desired channel modifications, for all of the
desired reaches, a new geometry fIle should be created for the modified
geometry. To create a modified geometry ftle, the user must enter a title for the
modified geometry fIle in the upper right hand side of the window. Once the
new geometry file title is entered, the ftle can be created by pressing the Create
Modified Geometry button at the bottom of the window. When this button is
pressed, a Save Geometry Data As window will appear. The user has the
options to change the directory in which the geometry fIle will be stored,
change the name of the geometry fIle title, or select an existing geometry fIle to
over write. Once the user has decided on a title and a directory, the OK button
can be pressed to save the modified geometry to the hard disk. However, the
original geometry ftle is still the one that is in memory. If the user wants to
work with the new modified geometry ftle, they will need to open it from the
Geometric Data Editor window.

Note: the data entered into the channel modification editor is saved as part of
the base geometry ftle (i.e., it is not saved with the modified geometry file).
This allows the user to open the base geometry ftle and recreate the modified
geometry. In order for this data to be saved, the user must select Save
Geometry Data from the file menu of the geometric data editor, after they
have entered the channel modification data.

I
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Com aring Existing and Modified Conditions

Once a modified geometry ftle is created, the user can create a new plan that
will incorporate the modified geometry and the previously defined flow data.
This is accomplished by first opening the modified geometry ftle from the
Geometric Data window. The next step is to open the Steady Flow Analysis
window and create a new Plan. This is accomplished by selecting New Plan
from the File menu of the Steady Flow Analysis window. Once a new plan is
created, the computations can be performed.

After the water surface proftle computations have been performed for the
modified channel conditions, the user can compare the results of the existing
and' modified conditions on any of the graphics and tables. An example cross
section plot of the two plans is shown in Figure 12.3. Figure 12.3 shows the
geometry of the modified channel condition, along with the computed water
surface elevations from both the existing and modified plans. To display the
results from more than one plan on a graphic, the user can select Plan from the
Options menu on any of the graphics.

In addition to graphical output, the user can review the computed results from
both plans in a tabular form. Figure 12.4 shows the computed results for both
plans in Standard Table 1 of the Proftle Output table.
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Chapter 13 Using CIS Data With HEC-RAS

CHAPTER 13

Using GIS Data With HEC-RAS

HEC-RAS has the ability to import three-dimensional (3D) river schematic
and cross section data created in a GIS or CADD system. While the HEC­
RAS software only utilizes two-dimensional data during the computations, the
three-dimensional information is used in the program for display purposes.
After the user has completed a hydraulic analysis, the computed water surface
profiles can be exported back to the GIS or CADD system for development
and display of a floodplain map.

The importing and exporting of GIS or CADD data is accomplished through
the use of formatted ASCII text files. The text files provide a generic way of
exchanging data between GIS/CADD systems and HEC-RAS, without
adopting any single GIS/CADD system. Appendix B of this manual
provides a detailed description and examples of the file formats used for
importing and exporting GIS or CADD data.

The HEC has developed a set of macros for Arc Info (using Arc Macro
Language, AML) that will allow a user to write the geometric data in the
required format, as well as read the HEC-RAS results and perform the
floodplain mapping. These macros are not part of the HEC-RAS package.
The macros and a user's manual will be provided on an as needed basis.
Also, the Intergraph Corporation will be adding the capability to exchange
data with HEC-RAS in their Inroads Software package, as well as a new
program called Storm Works (Intergraph, 1997)

This chapter discusses how to import GIS or CADD data into HEC-RAS;
what additional information will need to be added to complete the data; and
how to export the results back to the GIS or CADD system.

Contents

• General Modeling Guidelines

• Importing GIS or CADD Data Into HEC-RAS

• Completing The Data and Performing The Computations

• Exporting Computed Results To The GIS or CADD
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Gen4ral Modeling Guidelines

The current version of HEC-RAS has the ability to import the following
geometric data from a GIS/CADD system:

River System Schematic. The structure of the stream network as represented
by a series of interconnected reaches. Each reach is represented as a multi­
point line, which is assumed to follow the invert of the main channel. The
River and Reach labels, as well as the Junction labels, are also imported from
the GIS/CADD.

Cross Section Data. The following cross section data can be imported from
aGIS/CADD:

1. River, Reach, and River Station identifiers.

2. Cross Section Cut Lines (X and Y coordinates of the plan-view line
that represents the cross section). This is a multi-point line that can
have two or more points.

3. The cross section surface line. This line is sent to HEC-RAS as a
series of X, Y, Z coordinates for each point in the cross section.
HEC-RAS transforms these coordinates into station and elevation
points (X and Y) for computational purposes. The first station of the
cross section is always set to zero. The true (real world) coordinates
of the cross section are recomputed from the cross section cut line for
the purposes of displaying the data (3D plot).

4. Cross section main channel bank stations.

5. Downstream reach lengths for the left overbank, main channel, and
right overbank.

At this time, Manning's n values, contraction and expansion coefficients,
optional cross section properties (ineffective flow areas, levees, etc.), and
hy.draulic structure data (bridges, culverts, etc..) are not imported from a
GIS/CADD system. Many of these variables will be added in future versions
of the software.

The general procedure for utilizing GIS/CADD data with HEC-RAS is the
following:

1. The first step is to start a New Project. This is accomplished from the
File menu of the main HEC-RAS window.
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Chapter i3 Using GiS Data With HEC-RAS

The next step is to go to the Geometric Data editor and import the
GIS/CADD data into HEC-RAS. GIS/CADD data are imported by
selecting the Import GIS Data option from the File menu on the
Geometric Data window. This is assuming that you have already used
a GIS system to write the required geometry data into a text file, using
the required HEC-RAS format. The format of this file is described in
Appendix B of this manual.

After the GIS data are imported, the user will need to add any
additional geometric data that is needed to represent the physical
system.

The next step is to perform the water surlace profile calculations for
the desired flow rates.

I
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5. Once the water surlace profiles are calculated, the user can then
output the results to a text file using the Export GIS Data option
from the File menu of the main HEC-RAS window.

6. The last step is to import the HEC-RAS results file into the
GIS/CADD system and develop the floodplain maps for each of the
profiles.

Once the user has a project that is utilizing GIS data, then additional data can
be imported directly into an existing HEC-RAS geometry file without starting
a new project. This allows the user to go back to the GIS and extract
additional cross sections on an as-needed basis. The HEC-RAS program will
automatically place the new cross sections into the appropriate River and
Reach, based on the identifiers defined for each cross section in the GIS
import file.

After the user has perlormed the hydraulic analyses, the computed water
surlace profiles information can be written to a text file, which can then be
imported into the GIS for development and display of floodplain maps. HEC­
RAS exports the cross section Cut Line coordinates (X and Y), as well as the
water surlace elevation for each profile. This is done for every cross section
in the model. Additionally, the program exports a series of bounding
polygons (one per river reach) for each computed profile. For information on
the HEC-RAS GIS export file format, review the detailed write up found in
Appendix B of this manual.
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Impo ting GIS or CADD Data Into HEC-RAS

Within HEC-RAS, GIS data are imported from the Geometric Data Window.
To import geometric data from a GIS/CADD system into HEC-RAS, the
following steps should be followed:

1. The first step is to extract the necessary geometric information from a
GIS/CADD system and write it to a text fIle in the required HEC-RAS
format. As mentioned previously, HEC is working on a set of macros
written in AML, to be used with Arc Info. Likewise, the Intergraph
Corporation is adding this capability to their Inroads software package,
as well as a program called Storm Works. You have the option of
obtaining the AML macros from HEC (for use in Arc Info); using
Inroads or Storm Works from Intergraph; or developing your own
routines to extract this data from the GIS/CADD system of your
choice. The fJ..1e formats for the required text fJ..1e are outlined in
Appendix B of this manual.

2. The next step is to start a new project in HEC-RAS. This is
accomplished by selecting the New Project option from the File menu
of the main HEC-RAS window. This option will allow the user to
enter a project title and fIlename.

3. After a new project is started, the user should open the Geometric Data
Editor. Once the editor is opened, the user can import GIS/CADD data
into HEC-RAS by selecting the Import Geometry Data/GIS Format
option from the File menu of the Geometric Data window. When this
option is selected, a window will appear (Figure 13.1) in which the
user can select the fIle that contains the geometry data from the GIS.

test of im orf .

BEGIN HEADER

Existing Conditions Run
Wailupe River with GIS data -Example 15

Figure 13.1 Window for Selecting GIS Data File To Import
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Chapter 13 Usins CIS Data With HEC-RAS

Once the user selects the ftle containing the GIS data, and then presses
the OK button, the data will be imported and a schematic of the river
system will show up in the Geometric Data window (Figure 13.2).
Once the importing of the data is completed, the user should save the
geometric data by selecting Save Geometry Data As from the File
menu of the Geometric Data window.
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Figure 13.2 River System Schematic of Imported GIS Data
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Completing The Data and Performing The
Computations

Completing The Geometric Data

Once the user has imported the geometric data from a GIS/CADD system, the
next step is to add any additional data required to perform the analyses. At a
minimum, the user is currently required to enter Manning's n values for all of
the cross sections, and junction reach lengths if there are any junctions in the
data set. Manning's n values can be entered directly from the cross section
data editor (on a cross section by cross section basis) or through the
Manning's n-values table (this is the preferred way because the n values can
be entered more efficiently). The Manning's n value table is available from the
Tables menu on the Geometric Data window.

In addition to the Manning's n values, the user may need to enter the following
data to complete the geometry fIle: additional user entered cross-section data;
interpolated cross sections; optional cross section properties (ineffective flow
areas, levees, blocked obstructions, etc.); and hydraulic structures (bridges,
culverts, weirs and spillways).

Importing Additional Geometry From The GIS

The user also has the option of getting additional cross-section data from the
GIS. Additional cross sections can be extracted from the GIS and written to
the GIS text fIle for import into HEC-RAS. When this is done, if the original
cross section data as well as the new cross sections are contained in the GIS
fIle, the HEC-RAS software will ask the user if they want to completely clear
the existing geometry fIle and start a new one or if they want to update
currently opened geometry data. If the user chooses to update the currently
opened geometry data and if the GIS import fIle contains cross sections that are
already in the geometry fIle, the program will ask the user to select one of the
following three options pertaining to the duplicate cross sections only:

Clear existing XS and replace with new data. This option completely
eliminates the existing cross sections and replaces it with the new data found in
the GIS import fIle.

Update existing cross section with new data only. This option does not
clear the existing cross section, but it does update the cross section with any of
the data found in the GIS import fIle. Information like the ground points, main
channel bank stations, and downstream reach lengths will be updated.
Manning's n values, and optional cross section properties will not be changed
from the original data.
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Chapter 13 Using GIS Data With HEC-RAS

Do not modify existing cross section data. This option tells the
program not to modify anything about the existing cross section data,
and to only add any new cross sections that are found in the GIS import
ftle.

Entering Additional Cross Section Data

If additional cross sections are entered by the user from the cross section editor
(or through the HEC-2 import feature), the user will need to enter the
coordinates of the cross section strike line in order to maintain a geospatially
correct schematic and XYZ plot. The cross section strike line coordinates can
be entered by selecting XS Schematic Lines from the Edit menu on the
Geometric Data window. When this option is selected a window will appear as
show in Figure 13.3.

:::::::::::::::,::::::;:;::::::::::::::::::::::::: ••........... :... :.•:.::::::::::::::::::::::::::: ::':::';::::::::::::':::::: :::::::::.;'::':::::0::::: .. :: :::::::::::::::::.;:::";:;;;::;;:::";

~

FigUre 13.3 Cross Section Schematic Line X and Y Coordinates

The coordinates that are entered for the cross section schematic lines must be
consistent with the previously enrered GIS data (i.e., if the GIS data is in state
plane coordinates, then the user entered data must also be in state plane
coordinates). Once all of the cross section schematic lines have consistent
coordinates, the schematic and XYZ plot will provide a geospatially correct
display of the cross sections.
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Performing The Computations and Viewing Results

Once the user has completed the geometric data file, flow data can be entered
and the computations can be performed. When utilizing GIS data, there are no
special requirements for entering flow data or performing the computations.
Once the hydraulic computations are completed, the user can begin to review
the output. When GIS data are utilized, the HEC-RAS XYZ perspective plot
has the ability to plot a true three dimensional perspective of the river system
and the water surface profiles. An example XYZ plot with GIS data is shown
in Figure 13.4.

Figure 13.4 XYZ Perspective Plot With GIS Data
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Chapter 13 Using CIS Data With HEC-RAS

Exporting Computed Results To The GIS or CADD

Once the user has completed all of the hydraulic calculations, the computed
water surface profiles can be exported to the GIS/CADD in order to develop
floodplain maps. The HEC-RAS results are exported to an ASCII text file,
which can then be imported by the GIS/CADD system. The format of the
HEC-RAS results file is documented in Appendix B of this manual.

Exporting the HEC-RAS computed water surface profiles to a GIS/CADD
system is accomplished by selecting Export GIS Data from the File menu on
the main HEC-RAS window. Once this option is selected, a window will
appear as shown in Figure 13.5.

GIS Export

:\HEC\RAS\OATA\wailupe,gis

Figure 13.5 Window to Enter a Filename For Exporting
Results to GIS

As shown in Figure 13.5, the user ftrst enters a filename for the HEC-RAS
Export file. Next, the user can select what they would like to export. Normally
the user would select "Export Water Surfaces," and then select which proftles
to export by using the Select Profiles to Export button. Once these options
are selected, the information can be exported by pressing the Export Data
button.

Additional options are available t-o export geometry data from HEC-RAS to the
GIS/CADD system. This option can be very useful for supplementing terrain
data with additional surveyed cross sections. It is a common occurrence for
terrain models to have good information in the overbank areas, but not as good,
if at all, in the main channel. HEC-RAS allows the user to export the entire
cross section, or just the main channel portion only. Also, the user can send all
cross sections, including interpolated sections, or they can turn off the
interpolated cross sections.
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In order to use the feature of sending terrain data from HEC-RAS to the GIS,
the user must enter geospatial coordinates for all of the cross sections, and the
stream centerline before exporting the data. These coordinates are required in
order to correctly locate the data spatially within the terrain model.
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Appendix B - HEC-RAS ImportlExport Files (or Ceospatial Data

Appendix B

HEC-RAS Import/Export Files for
Geospatial Data

At version 2.0, HEC-RAS has introduced three-dimensional (3D) geometry for
the description of river networks and cross-sections. This capability makes it
possible to import channel geometry from CADD or GIS programs without
conversion from real-world coordinates to station-elevation descriptions for the
cross-sections, as HEC-2 required. Similarly, water-swface elevations
calculated at cross-sections can be exported to CADD or GIS programs, where
they can be used to create model water surfaces for inundation mapping.

Supported HEC-RAS Data Exchange

Using a formatted ASCII text file, HEC-RAS will import a basic description of
the channel geometry including:

The structure of the stream network, as represented by interconnected
reaches.
The location and description of cross-sections.

Using the same file format, HEC-RAS can write a file exporting the results of
a hydraulic model run to a CADD or GIS program. At a minimum, reported
results include the locations of cross-sections and the calculated water-surface
elevations at those cross-sections.

The Import/Export Data File Structure

This section gives general rules for the construction of an HEC-RAS geometric
data import or export file. It is not necessary to understand all these rules to
build an import file, but they may be useful when debugging failed imports.
The rules given here are a portion of the definition of a general-purpose
geometric data exchange format being developed at HEC for its NexGen
model programs. Note: These me fonnats are evolving, in that additional
data types will be added, and some of the existing ones may be modified
for future versions. Ifyou are writing software to read and write these
me fonnats, please keep in mind that you may need to modify your
software to stay compatible with future versions of HEC-RAS.
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Records and Keywords

The HEC-RAS geometric data import file is composed of records, which in
tum are composed of keywords and values. All records must contain one
keyword, and all keywords end with a colon (:). A record can also contain a
value or a set of values following the keyword, i.e., after the colon. Spaces,
tabs, or line ends can be placed between a keyword and values within a record.

A record that contains a keyword and no value marks the beginning or the end
of a group of related records (for example, the record "BEGIN HEADER:"
marks the beginning of the header section of a data file). A record that contains
a keyword and a value assigns that value to the part of the model named by the
keyword.

When a keyword is read, all spaces up to the colon are removed and all letters
are capitalized. The keywords "Begin Header:", "Begin header:", and " Be
GiNH eadEr:" are all equivalent to "BEGINHEADER:". For readability,
keywords named in this manual will contain internal spaces.

Values

A record can assign a single value to a single variable, or multiple values to an
array. Values can be integers, floating point numbers, text strings, or locations
(X,Y,Z, label). A single value in an array of values is called an "element" of
that array.

A numerical value (integer or floating point) cannot contain internal blanks.
A floating point number can contain a decimal point; an integer cannot.
Elements in an array of numerical values can be separated by commas, blanks,
tabs, or line ends.

A text string can contain internal blanks, tabs, and commas, but cannot contain
intemalline ends. Elements in an array of text strings must be separated by
line ends.

A location consists of three coordinate values and a label (X, Y, Z, label). The
first two coordinates are planar, the third gives elevation. The coordinate
values are floating point numbers, and the label can be any type of value
(although the label can be restricted to a particular data type in a particular
context). In certain contexts, the elevation value or the label may not be
required. If a label is used, all three coordinate values must be given; the value
"NULL" is valid for the elevation coordinate only. The coordinate values and
the label can be separated by commas, blanks, or tabs, but a location cannot
contain internal line ends. Elements in an array of locations must be separated
by line ends.
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Data Groups

Records in the data file can be collected in two types of groups: objects and file
sections. An object is a group of records that combine to describe an entity
within the model, a cross-section for example. A file section is a logical or
functional grouping of data, the file header, for example, is a section that
contains a description of the whole file.

Objects and file sections begin and end with records that contain keywords, but
no values. A file section starts with a record containing a keyword composed
of the word "BEGIN" followed by the section name and a colon, and ends with
a keyword composed of the word "END" followed by the section name and a
colon. For example, records containing only the keywords "BEGIN
HEADER" and "END HEADER:" are used to start and end the header section
of a file. An object starts with a record containing a keyword naming the object
type and ends with a record containing the keyword "END:" only. For
example, a cross-section object begins and ends with records containing the
keywords "CROSS-SECTION:" and "END:" only.

Comments

Hash characters (#) are used to identify comments. When a hash character is
encountered in the file, all data from the hash to the next line end are ignored.
A line that begins with a hash is equivalent to a blank line.

HEC-RAS Channel Geometry Import File

HEC-RAS reads channel geometry from a text file composed of three data
sections:

1. A header, containing descriptions that apply to all data in the file.
2. A description of the stream network, containing reach locations and

connectivity.
3. A descriptions of the model cross-sections, containing their location on

the stream network and data required to support the HEC-RAS model.

An example HEC-RAS Channel Geometry Import file and HEC-RAS model
results export file is shown at the end of this appendix.

Header

The header is bounded by the records "BEGIN HEADER:" and "END
HEADER" and must contain a record to identify the units system used in the
imported data set. The units system can be E GUSH or "METRIC.
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BEGIN HEADER:
UNITS: ENGLISH

END HEADER:

minimum import file header

Records that may be included in the header are listed in the Table B.l:

Table B.l

KeywO~d Value Type Value

UNITS string ENGLISH or rviETRIC
I

string array List of profiles exported from HEC-RAS.PROFILES:
Not used on import.

DTM1]YPE: string type (e.g., TIN or raster)

DTM: I string name of digital terrain model

STREAiM LAYER: string name of stream layer in CADD or GIS

NUMBfR OF REACHES integer number of hydraulic reaches contained in the
file.

CROSS!-SECTION LAYER: string name of cross-section layer in CADD or GIS

NUMBkR OF CROSS- integer number of cross sections in the file
SECTIO S:

MAP PROJECTION: string projection (coordinate) system used (e.g.,

I
STATEPLANE)

PROJE~TIONZONE: string proj ection zone (if applicable, e.g., 5101)

DATUM: string reference datum for planar coordinates

VERTHCAL DATUM: string reference datum for vertical coordinates
I

Stream Network

The stream network section is bounded by the records "BEGIN STREAM
NETWORK:" and "END STREAM NETWORK:" and contains records
describing reaches and reach endpoints. At a minimum, the stream network
section must contain at least two endpoints and one reach. The minimum
requirements for a stream network are shown below.
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BEGIN STREAM NETWORK:
ENDPOINT: 476132.66, 65291.86, 155.28, 1
ENDPOINT: 478144.53, 64296.61, 123.72, 2

REACH:
STREAM ID: Below Springfield
REACH ID: Blue River
FROM POINT: 1
TO POINT: 2
CENTERLINE:

476132.66, 65291.86, 155.28, 23.13
476196.08,65196.61,154.47

lines omitted
478144.53, 64296.61, 123.72, 22.41

END:
END STREAM NETWORK:

minimum import stream network section

A reach endpoint is represented by a record containing the keyword
"ENDPOINT" followed by four comma-delimited fields containing the
endpoint's X,Y,Z coordinates and an integer ID.

A reach is represented by a multi-record object that begins with a record
containing only the keyword "REACH" and ends with a record containing only
the keyword "END:" At a minimum, a reach object must contain records
setting values for a stream ID, a reach ID, a FROM point, and a TO point. A
reach's FROM and TO point IDs must match IDs for endpoints listed before
the reach object in the file. The reach object must also contain an array of
locations defining the stream centerline. This array begins with a record
containing only the keyword "CENTERLINE:" and ends when any keyword is
encountered. A location element in the array contains the X, Y, and Z
coordinates of a point on the stream centerline, and the point's river station. In
HEC-RAS, elevation and stationing are optional in the stream network
definition. If a location element includes a station value, it must occupy the
fourth field in the element. If the elevation is not known, the word "null" must
take its place.

Station values are assumed to be in miles for data sets in English units, and in
kilometers for data sets in metric units. Stationing is used for indexing
locations along reaches, and is not used to precisely locate objects in the model.

Records that may be included in a stream network section are listed in Table
B.2:
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Table B.2

Keywo~d Value Type Value
I

location coordinates and integer illENDPqINT:

REACB: none marks beginning of reach object

END: none marks end of reach object

The following records are required for a reach object.

STREAMID: string identifies reach's membership in stream
I

string unique ID fo r reach within streamREACli ID:

FROM POINT: string integer reference to upstream endpoint
I

TO POINT: string integer reference to downstream endpoint

CENTERLINE: location array array elements contain coordinates and
(optionally) floating point station value.

Cross-Sections

The cross-section file section begins with a record containing the only the
keyword "BEGIN CROSS-SECTIONS:" and ends with a record containing the
only the keyword "END CROSS-SECTIONS:." A cross-section is represented
by multi-record object beginning with a record containing only the keyword
"CROSS-SECTION:" and ending with a record containing only the keyword
"END:."

A cross-section object must include records identifying the stream, reach, and
station value of the cross-section, a 2D cut line, and a series oDD locations on
the cross-section. Stationing is given in miles for data sets with plane units of
feet and in kilometers for data sets with plane units of meters. A cut line is
co~posed of the label "CUT LINE:" followed by an array of2D locations. A
cross-section polyline consists of the label "SURFACE LINE:" plus 3D
coordinates written as comma-delimited X,Y,Z real-number triples, one triple
to a line.

Records that may be included in the cross-section file section are listed in Table
B.3:
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Table B.3

Keyword Value Type Value

CROSS-SECTION: none marks beginning of cross-section object

END: none marks end of cross-section object

The following records are required for a cross-section object.

STREAMID: string identifiers for stream and reach where cross-
section is located (must refer to existing streams

REACHID: string and reaches in the model)

STATION: floating point relative position of cross-section on stream

CUT LINE: location array array elements contain 2D coordinates of cross
sectione stike line

SURFACE LINE: location array array elements contain 3D coordinates of cross
section points

The following records are optional for a cross-section object.

BANK POSITIONS: floating point Fraction of length along cut line where main
(2 elements) channel bank stations are located. (values 0.0 -

1.0)

REACH LENGTHS: floating point Distance along left overbank, center channel,
(3 elements) and right overbank flow paths to next cross-

section downstream (units are feet or meters).

WATER ELEVATION: floating point Water surface elevation values. Used for export
array of model results. Not read on import.

HEC-RAS Model Results Export File

HEC-RAS exports model results to a text file using the same format as the data
import file. The contents of the files, however, are not identical. The stream
network section is not required for data export, and the surface line may be
omitted from the cross-section objects. An example HEC-RAS model export
file is shown at the end of this discussion. Model results are reported with the
following elements (Table B.4), which are not required (and are not read) in
the import file.
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Value

Marks end of boundaries file section.

Marks start of boundaries file section.

A series of 2D locations marking the limits of a
water surface. A single profile limit can be
merged from multiple polygons.

Marks start of an object defining the limits of a
single water surface profile.

Elevation of water surface at the cross-section.
The array must contain one val ue for each
profile.

Name of profile. This must match a name in the
Profile Names record in the header.

Value Type

none

none

none

floating point
array

location array

string

1. Profile names can contain up to 16 characters. They must begin with a
letter, and must not contain blanks.

2. If no profile name is provided, only one water elevation will be written
for each cross section.

WATEk ELEVATIONS:

PRoFIlE NAl\1ES: string array name(s) of water surface profiles reported in the
file. This record is required if more than one
profile is reported.

Water Surface Bounding Polygon

In addition to a water surface elevation at each cross section (one for each
profile), the HEC-RAS program sends a bounding polygon for each hydraulic
reach in the model (the program outputs a new set of bounding polygons for
each profile computed). The bounding polygon is used as an additional tool in
assisting the GIS (or CADD) software to figure out the boundary of the water
surface on top of the terrain.

BEGni BOUNDARIES:

The fol owing record is optional in the Header section of the export file.

I
POLY<IJON

The fol owing record is required for each cross-section object.
I

The fol owing records make up a section defming a bounding polygon of the water surface limits.
I

Appendix B - HEC-RAS ImportlExport Files [or Ceospatial Data
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In most cases, the bounding polygon will represent the outer limits of the cross
section data, and the actual intersection of the water surface with the terrain
will be inside of the polygon. In this case, the GIS software will use the water
surface elevations at each cross section and create a surface that extends out to
the edges of the bounding polygon. That surface is then intersected with the
terrain data, and the actual water limits are found as the location where the
water depth is zero.

However, is some cases, the bounding polygon may not represent the extents
of the cross-section data. For example, if there are levees represented in the
HEC-RAS model, which limit the flow of water, then the bounding polygon
will only extend out to the levees at each cross section. By doing this, when the
information is sent to the GIS, the bounding polygon will prevent the GIS
system from allowing water to show up on both sides of the levees.

In addition to levees, the bounding polygon is also used at hydraulic structures
such as bridges, culverts, weirs, and spillways. For example, if all of the flow
is going under a bridge, the bounding polygon is brought into the edges of the
bridge opening along the road embankment on the upstream side, and then
back out to the extent of the cross-section data on the downstream side. By
doing this, the GIS will be able to show the contraction and expansion of the
flow through the hydrualic structures, even ifthe hydraulic structures are not
geometricaly represented in the GIS.

Another application of the bounding polygon is in FEMA floodway studies.
When a floodway study is done, the first profile represents the existing
conditions of the flood plain. The second and susequent profiles are run by
encroaching on the floodplain until some target increase in water surface
elevation is met. When the encroached profile is sent to the GIS, the bounding
polygon is set to the limits of the encroachment for each cross section. This
will allow the GIS to display the encroached water surface (floodway) over the
terrrain, even though the water surface does not intersect the ground.

Import/Export Guidelines

The following rules apply to channel and cross-section import/export data.

DefIning The Stream Network

1. The stream network is represented by a set of interconnected reaches.
A stream is a set of one or more connected reaches that share a
common stream ID.

2. A stream is composed of one or more reaches with the same stream ID,
and each reach in a stream must have a unique reach ID. Every reach
must be identified by a unique combination of stream and reach IDs.
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3. Stream IDs and Reach IDs are alphanumeric strings up to 16
characters long. Reach endpoint IDs are integers.

4. Streams cannot contain parallel flow paths. (If three reaches connect at
a node, only two can have the same stream ID.) This prevents
ambiguity in stationing along a stream.

5. A reach is represented by an ordered series of 3D coordinates, and
identified by a stream ID, a reach ID, and IDs for its endpoints

6. A reach endpoint is represented by its 3D coordinates and identified by
an integer ID.

7. Reaches are not allowed to cross, but can be connected at their
endpoints (junctions) to form a network.

8. The normal direction offlow on a reach is indicated by the order of its
endpoints. One point marks the upstream or "from" end of the reach,
the other marks the downstream or "to" end of the reach.

Defining Cross-Sections

I. Each cross-section is defined by a series of 3D coordinates, and
identified by a stream name and reach name (which must refer to an
existing stream and reach) and a station, indicating the distance from
the cross-section to the downstream end of the stream.

2. Stationing is given in miles for projects using English units and in
kilometers for projects using metric units.

3. A cross-section line can cross a reach line exactly once, and cannot
cross another cross-section line.

Res).l1ts of a water surface calculation are exported in a file that contains cross­
section locations in plane (2D) coordinates, water-surface elevations for the
cross-sections, and boundary polygons for the reaches.

The Following Rules Apply to Water-Surface Export Data

1. A cross-section is represented by a water surface elevation and a series
of 2D coordinates on the cross-section cut line. The full width of the
cross-section is included.

2. One bounding polygon is created for each reach in the stream network,

8-10

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I



I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I

3.

4.
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and for each profile.

A reach's bounding polygon is made up of the most upstream cross­
section on the reach, the endpoints of all cross-sections on the reach,
and the most upstream cross-sections of reaches downstream of the
reach.

For purposes of defining bounding polygons only, the endpoints of a
cross-section are adjusted to the edge of the water surface at the cross­
section if the cross-section is part of a fl00dway, a leveed section of the
reach, or the water extent is controlled by a hydraulic structure. This
allows calculated water surfaces that are higher than the land surface to
be reported back to the CADD or GIS program.
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Sam~le HEC-RAS Geometry Import File
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DTM TYPE: TIN
DTM: /HEC63/USR1/EVANS/WAILUPE/WAI TIN (TIN)
STRE~ LAYER: /HEC63/USR1/EVANS/WAILUPE/WAI_STR
NUMB~R OF REACHES: 3
CRosIS-SECTION LAYER: /HEC63/USR1 /EVANS/WAILUPE/WAI_ XS
MAP PROJECTION: STATEPLANE
PROJECTION ZONE: 5101
DATI: NAD27
UNITS: ENGLISH

END HEiADER:

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
II

1. 19112.84,

REACH:
STREAM ID: Wailupe
REACH ID: Lower
FROM POINT: 3
TO POINT: 4
CENTERLINE:

582307.31, 46985.66,
33 lin s omitted

BEGIN STREAM NETWORK:

ENDPeINT: 582090.19, 49360.46, 220.17, 1
ENDPOINT: 583638.69, 47559.38, 266.80, 2
ENDPOINT: 582307.31, 46985.66, 112.84, 3
ENDPOINT: 584128.44, 41274.97, -3.41, 4

REACIH:
ST1REAM ID: Kulai Gorge
REACH ID: Headwaters
F OM POINT: 2
T POINT: 3
CE TERLINE:

583638.69, 47559.38, 266.80, 0.33
11 lines omitted

582307.31, 46985.66, 112.84, 0.00
END:

REAC
STREAM ID: Wailupe
REiACH ID: Upper
F~OM POINT: 1
TO POINT: 3
CEJNTERLINE:

582090.19, 49360.46, 220.17, 1. 65
14 linfs omitted

582307.31, 46985.66, 112.84, 1. 19
END:
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6 Cross-Sections omitted

CROSS-SECTION:
STREAM ID: Wailupe
REACH ID: Upper
STATION: 1.629
BANK POSITIONS: 0.4781, 0.5615
REACH LENGTHS: 55.965, 53.626, 40.370
CUT LINE:

582159.78, 49259.60
582013.48, 49223.76

SURFACE LINE:
582159.78, 49259.60, 235.49

29 lines omitted

0.00-3.41,

169.89

167.62

Appendix B - HEC-RAS Import/Export Files [or Ceospatial Data

46950.81
46978.64
47224.45

41274.97,

47224.45,

46950.81,

CROSS-SECTION:
STREAM ID: Kulai
REACH ID: Headwaters
STATION: 0.019
BANK POSITIONS: 0.4454, 0.4799
REACH LENGTHS: 187.942, 193.195, 163.246
CUT LINE:

582769.62,
582598.07,
581981.41,

SURFACE LINE:
582769.62,

78 lines omitted
581981.41,

END:

CROSS-SECTION:
STREAM ID: Kulai
REACH ID: Headwaters
STATION: 0.312
BANK POSITIONS: 0.5562, 0.6294
REACH LENGTHS: 84.541, 89.110, 82.013
CUT LINE:

583613.16, 47441.98
583567.80, 47529.68
583558.73, 47575.04
583567.80, 47638.55

SURFACE LINE:
583613.16, 47441.98, 309.69

29 lines omitted
583567.80, 47638.55, 278.10

END:

584128.44,
END:

END STREAM NETWORK:

BEGIN CROSS-SECTIONS:

I
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FILE OMPLETE: 28 -October 1996, 17: 17
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4.01

6.39

161. 92

165.01

0.5155
192.982, 137.742

46846.45
46878.92

46846.45,

47082.99,81953.51,

STREAMID: Wailupe
I

REiCH ID: Lower

B.Af'JK POSITIONS: 0.5236, 0.5686
REACH LENGTHS: 171.000, 164.796, 159.249

b82723.17,
f82426.44,

SURFACE LINE:
82723.17,

END:

CROS -SECTION:
STREAM ID: Wailupe
REACH ID: Lower
STATION: 0.037
BANK POSITIONS: 0.5034,
RE~CH LENGTHS: 82.365,
CU~ LINE:

1586214.12, 42127.92
581980.99, 40806.06

SURFACE LINE:
~86214.12, 42127.92,

71 lines omitted
581980.99, 40806.06,

END:

AppendJ B - HEC-RAS lmportlExport Files for CeospatiaJ Data

END~
7 Cross-Sections omitted

END CROSS-SECTIONS:



42188.21
41483.75
40961. 43

47429.88
47529.68
47568.99
47662.74

47441.98
47529.68
47575.04
47638.55

BEGIN HEADER:

257.7377, 270.6435

265.8189, 268.7436

5.964032, 6.43543

CROSS-SECTION:
WATER ELEVATIONS:
CUT LINE:

583613.16,
583567.80,
583558.73,
583567.80,

END:

CROSS-SECTION:
WATER ELEVATIONS:
CUT LINE:

586202.53,
583941. 76,
581932.30,

END:

CROSS-SECTION:
WATER ELEVATIONS:
CUT LINE:

583537.56,
583474.05,
583474.05,
583492.20,

END:

CROSS-SECTION:
WATER ELEVATIONS: 5.662289, 6.12576
CUT LINE:

586214.12, 42127.92

Appendix B - HEC-RAS ImportlExport Files for Ceospatia1 Data
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119 cross-sections omitted_

BEGIN CROSS-SECTIONS:

END HEADER:

# RAS output file created 29 Oct 96 16:36:41 Tuesday
# by HEC-RAS

NUMBER OF REACHES: 3
NUMBER OF CROSS-SECTIONS: 46
NUMBER OF PROFILES: 2
MAP PROJECTION: STATEPLANE
PROJECTION ZONE: 5876
DATUM: NAD27
PLANE UNITS: FEET
ELEVATION UNITS: FEET
STATION UNITS: MILES
PROFILE NAMES: PF#l, PF#2

Sample HEC-RAS Geographic Data Export File

I
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BEGIN 'OUNDS:

PROFILE LIMITS:
PROFILE ID:PF#l
POn,YGON:

i82013.48 , 49223.76
63 {ines omitted

581819.14 , 49209.56

POtYGON:
581953.51 , 47082.99

141 lines omitted
581934.965 , 47008.78

I
PO~YGON:

583567.8 , 47638.55
43 lines omitted

583530 , 47650.645
END: I

PROFILE LIMITS:
PR?FILE ID:PF#2
POLYGON

582013.48 49223.76
63 lines omitted

581819.14 49209.56

I
POLYGON:

581953.51 , 47082.99
141 lines omitted

f81934.965 , 47008.78

POLYGON:
583567.8 , 47638.55

43[ lines omitted
5 8 35 30 , 4 7 650 . 64 5

END:

END BO NDS:

#FILE COMPLETE: 17 Jan 97 16:38:04 Friday
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Appendix C

HEC-RAS Output Variables
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Variable Name

# Barrels
Alpha
Area

Area Channel
Area Left
Area Right
Base WS

Beta
BR Open Area
BR Open Vel

Br Sel Mthd
C & E Loss
Center Station
Ch Sta L
Ch Sta R
Clv EGNo Wr

CoefofQ
Conv. Chnl
Conv. Left
Conv. Ratio

Conv. Right
Conv. Total
Crit Depth
Crit E.G.

Crit Enrgy 1
Crit Enrgy 2
Crit Enrgy 3
Crit Num
Crit W.S.

Units

#

sq ft

sq ft
sq ft
sq ft
ft

sq ft
ft/s

ft
ft
ft
ft
ft

cfs
cfs

cfs
cfs'
ft
ft

ft
ft
ft
#
ft

Description

umber of barrels in a culvert.
Alpha - energy weighting coefficient.
Flow area of the entire cross section including ineffective
flow.
Flow area of the main channel including ineffective flow
Flow area of the left overbank including ineffective flow.
Flow area of the right overbank including ineffective flow.
Water surface for first profile (used in comparison to
encroachment profiles).
Beta - momentum weighting coefficient.
Total area of the entire bridge opening.
Average velocity inside the bridge opening (Maximum of
BD and BD).
Selected bridge hydraulic modeling method.
Contraction or expansion loss between two cross sections.
Stationing of the center of the main channel.
Left station of main channel.
Right station of main channel.
Energy grade elevation at the culvert when calculated
without the weir.
WSPRO bridge method coefficient of discharge..
Conveyance of main channel.
Conveyance of left overbank.
Ratio of the conveyance of the current cross section to the
conveyance of the downstream cross section.
Conveyance of right overbank.
Conveyance of total cross section.
Critical depth. Corresponds to critical water surface.
Critical energy elevation. Minimum energy on the energy
versus depth curve.
Energy associated with first critical depth.
Energy associated with second critical depth.
Energy associated with third critical depth.
Number of critical depths found.
Critical water surface elevation. Water surface
corresponding to the minimum energy on the energy versus
depth curve.
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A endix l- HEC-RAS Out ul Variables I
Crit W.S . 1 ft Water surface elevation of first critical depth. ICrit W.S .2 ft Water surface elevation of second critical depth.
Crit W.S

..,
ft Water surface elevation of third critical depth..-'

ICulv Crt Depth ft Critical depth inside the culvert.

Culv EGlin ft Energy gradeline inside the culvert at the inlet.
Culv EG Out· ft Energy gradeline inside the culvert at the outlet.

ICulv Ent Lss ft Culvert entrance loss (energy loss due only to entrance).
Culv Ext Lss ft Culvert exit loss (energy loss due to exit).
Culv Frc n Ls ft Friction loss through the culvert barrel.

ICulv Ful Lngh ft The length that the culvert flows full.
Culv Inv EIDn ft Culvert inside invert elevation downstream.
Culv Inv EIUp ft Culvert inside invert elevation upstream.

ICulvN I Depth ft Nonnal depth for this culvert (and flow).
Culv Q cfs Flow through all barrels in a culvert group.
Culv Vel In ft/s Velocity inside of culvert at inlet. ICulv Vel Out ft/s Velocity inside of culvert at outlet.
Cuiv WS In ft Water surface elevation inside the culvert at the inlet.
CuIv W lOut ft Water surface elevation inside the culvert at the outlet. ICum Ch I en ft Cumulative Channel Length.
Deck Witlth ft Width of bridge/culvert Deck (top of embankment), in

direction of flow. IDelta E ft Change in energy grade line through culvert(s) and
bridge(s).

IDelta WS ft Change in water surface through culvert(s) and bridge(s).
Dist Cen er L ft Distance from center of channel to left encroachment.
Dist Cen er R ft Distance from center of channel to right encroachment.

IE.G. Ele ft Energy gradeline for calculated WS Elev.
E.G.IC ft Upstream energy gradeline at culvert based on inlet control.
E.G.OC ft Upstream energy gradeline at culvert based on outlet ,Icontrol.

E.G. Sior ft/ft Slope of the energy grade line.
E.G. US. ft Energy grade elevation at upstream end of bridge or culvert

I(final answer).

Enc Metlod Encroachment method used at this cross section.
Enc Sta I ft_ Left station of encroachment. IEnc Sta ' ft Right station of encroachment.
Enc Val I ft Target for encroachment analysis.
Enc Val '2 ft Second target for encroachment analysis. IEncrWD ft Top width between encroachments.

Energy 1G ft Energy grade elevation upstream of bridge for energy only
method. IEnergy S ft Water surface elevation upstream of bridge for energy only
method.

Energy rEG ft Energy grade elevation upstream of bridge for low energy Iand weir method.
Energy/Wr WS ft Water surface elevation upstream of bridge for low flow

I
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I Appendix C - HEC-RAS Output Variables

I energy method and weir flow.
Flow Area sq ft Total area of cross section active flow.

I
Flow Area Ch sq ft Area of main channel active flow.
Flow Area L sq ft Area of left overbank active flow.
Flow AreaR sq ft Area of right overbank active flow.

I
Frctn Loss ft Friction loss between two cross sections.
Frctn Slope ftJft Representative friction slope between two cross sections.
Frctn SIp Md Friction slope averaging method used.

I
Froude # ChI Froude number for the main channel.
Froude # XS Froude number for the entire cross section.
Gate #Open # The number of gates opened in the current group.

I Gate Area sq ft The flow area in an opened gate.
Gate Invert ft Gate spillway invert elevation.
Gate Open Ht ft Height of gate opening.

I Gate Q Total cfs Flow through all gate openings in a gate group.
Gate Submerg Degree of gate submergence. The ratio of the downstream

depth above the gate to the upstream depth above the gate.

I Headloss ft Total energy loss between two cross sections.
Hydr Depth ft Hydraulic depth for cross section (AreafTopwidth of active

flow).

I Hydr Depth C ft Hydraulic depth in channel (channel flow area/topwidth of
channel flow).

Hydr Depth L ft Hydraulic depth in left overbank (left overbank flow

I area/topwidth of left overbank flow).
Hydr Depth R ft Hydraulic depth for right over bank (right overbank flow

I
area/topwidth of right overbank flow).

Ice Btm Chan ft The bottom elevation of ice in the main channel.
Ice Btm LOB ft The bottom elevation of ice in the left overbank.

I
Ice Btm ROB ft The bottom elevation of ice in the right overbank.
Ice Thick Chan ft Ice thickness in the main channel.
Ice Thick LOB ft Ice thickness in the left overbank.

I
Ice Thick ROB ft Ice thickness in the right overbank.
Ice Top Chan ft The top elevation of ice in the main channel.
Ice Top LOB ft The top elevation of ice in the left overbank.

I Ice Top ROB ft- The top elevation of ice in the right overbank.
Ice Vol Total cu ft Cumulative volume of ice in an ice jam.
Ice Vol. Chan cu ft Cumulative volume of ice in the main channel for an ice jam.

I Ice Vol. LOB cu ft Cumulative volume of ice in the left overbank for an ice
Jam.

Ice Vol. ROB cu ft Cumulative volume of ice in the right overbank for an ice

I Jam.
Ineff EI Left ft The elevation of the left ineffective area.
Ineff EI Right ft The elevation of the right ineffective area.

I Invert Slope ftJft The slope from the invert of this cross section to the next
cross section downstream.

IW Gate Flow cfs Total flow through all of the gate groups of an inline

I
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I

Appendix

weir/spillway. I
K Perc ft Conveyance reduction from left encroachment.

I

K Perc I ft Conveyance reduction from right encroachment.

IL. FreelJoard ft The freeboard in the main channel at the left bank (left bank
elevation minus water surface elevation).

L. Levee Frbrd ft The freeboard before the left levee is over-topped. ILeft Sta IEff ft Furthest left station where there is effective flow.
Length <Chnl ft Downstream reach length of the main channel.
Length I eft ft Downstream reach length of the left overbank. ILength ~ght ft Downstream reach length of the right overbank.

Length ~td ft Weighted cross section reach length, based on flow
distribution, in left bank, channel, and right bank. ILevee E Left ft The elevation of the left levee.

Levee E

t
Rjght ft The elevation of the right levee.

LOB El ,v ft The ground elevation at the left bank of the main channel. IMann C mp Composite Manning's n value for main channel.
Max ChI Dpth ft Maximum main channel depth.
Min Ch El ft Minimum main channel elevation. IMinEI I ft Minimum overall section elevation.
Min El ~rs ft Elevation at the bridge when pressure flow begins.

IMin Error ft The minimum error, between the calculated and assumed

Min ToJ Rd
water surfaces when balancing the energy equation.

ft Elevation where weir flow begins.

IMomen. EG ft Energy grade elevation upstream of bridge for momentum
method.

Momen. WS ft Water surface elevation upstream of bridge. for momentum

Imethod.
# Current number (or final number) of trials attempted before

the energy equation is balanced. Ift Observed water surface elevation.
lb/ft s Total stream power in main channel (main channel shear

stress times main channel average velocity). Used in IYang's and other sediment transport equations.
Power L

1

B lb/ft s Total stream power in left overbank (left overbank shear
stress times left overbank average velocity). Used in I

Power JOB
Yang's and other sediment transport equations.

lb/ft s Total stream power in right overbank (right overbank shear
stress times right overbank average velocity). Used in IYang's and other sediment transport equations.

Power "!ptal lb/ft s Total stream power (total cross section shear stress times
total cross section average velocity). Used in Yang's and I

ProfDe16 EG
other sediment transport equations.

ft Difference in EG between current profile and EG for first

II
profile.

Prof Del WS ft Difference in WS between current profile and WS for first
profile.

I
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I Profile # Profile number.
Prs a EG ft Energy grade elevation upstream of bridge for pressure only

I
method.

Prs a WS ft Water surface elevation upstream of bridge for pressure
only method.

I
Prs/Wr EG ft Energy grade elevation upstream of bridge for pressure

and/or weir method.
Prs/Wr WS ft Water surface elevation upstream of bridge for pressure

I and/or weir method.
Q Barrel cfs Flow through one barrel in a culvert group.
Q Bridge cfs Flow through the bridge opening.

I Q Channel cfs Flow in main channel.
Q Left cfs Flow in left overbank.
Q Perc Chan ft Percent of flow in main overbank.

I Q Perc L ft Percent of flow in left overbank.
Q Perc R ft Percent of flow in right overbank.
Q Right cfs Flow in right overbank.

I Q Total cfs Total flow in cross section.
QWeir cfs Flow over the weir.
R. Freeboard ft The freeboard in the. main channel at the right bank (right

I bank elevation minus water surface elevation).
R. Levee Frbrd ft The freeboard before the right levee is over-topped.
Rght Sta Eff ft Furthest right station that still has effective flow.

I ROB Elev ft The ground elevation at the right bank of the main channel.
SA Chan acres Cumulative surface area for main channel from the bottom

I
of the reach.

SA Left acres Cumulative surface area for left overbank from the bottom
of the reach.

I
SA Right acres Cumulative surface area for right overbank from the bottom

of the reach.
SA Total acres Cumulative surface area for entire cross section from the

I bottom of the reach.
Shear Chan Ib/sq ft Shear stress in main channel (y RcH Sf)'
Shear LOB Ib/sq ft Shear stress in left overbank (y RLOB Sf)'

I Shear ROB Ib.Lsq ft Shear stress in right overbank (y RROB Sf)'
Shear Total Ib/sq ft Shear stress in total section (y RT Sd.
Spc Force PR cu ft Specific force prime. For mixed flow, the specific force at

I this cross section for the flow regime that does not control.
SpecifForce cu ft The specific force for this cross section at the computed

water surface elevation. SF = ATYcent + (Q2p)/(gAacl)

I Sta W.S. Lft ft Left station where water intersects the ground.
Sta W.S. Rgt ft Right station where water intersects the ground.
Std Stp Case # Standard step method used to determine WSEL (1 =

I successful convergence, 2 = minimum error, 3 = resorted to
critical depth).

I
Top W ehnl ft Top width of the main channel. Does not include 'islands',

C-5
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Appendix C - HEC-RAS Output Variables I
but it does include ineffective flow. ITop W lieft ft Top width of the left overbank. Does not include 'islands',

I. h
but it does include ineffective flow.

ITop W Rig t ft Top width of the right overbank. Does not include 'islands',

Top Wdfh Act

but it does include ineffective flow.
ft Top width of the wetted cross section, not including

Iineffective flow.
Top Width ft Top width of the wetted cross section.

I hrs Cumulative travel time based on the average velocity of theTrvl Tmr Avg Ientire cross section, per reach.
Trvl Tme Chi hrs Cumulative travel time based on the average velocity of the

velC~
main channel, per reach. Iftls Average velocity of flow in main channel.

Vel Head ft Velocity head.

Vel Lef~ ft/s Average velocity of flow in left overbank. IVel Rig t ft/s Average velocity of flow in right overbank.
Vel TotJl ftls Average velocity of flow in total cross section.
Vol Cha acre-ft Cumulative volume of water in the channel (including Iineffective flow).

acre-ft Cumulative volume of water in the left overbank (including
ineffective flow). IVol Rig t acre-ft Cumulative volume of water in the right overbank
(including ineffective flow).

IVolume acre-ft Cumulative volume of water in the direction of
computations (including ineffective flow).

W.P. Channel ft Wetted perimeter of main channel.

II
W.P. Left ft Wetted perimeter of left overbank.
W.P. Right ft Wetted perimeter of right overbank.
W.P. TOlal ft Wetted perimeter of total cross section.

IW.S. El9v ft Calculated water surface from energy equation.

WS. Prir ft Water surface prime. For mixed flow, the water surface of
the flow regime that does not control.

IW.S. US. ft Water surface elevation upstream of bridge or culvert.
Weir Avg Depth ft The average depth offlow over the weir.

Weir M~ Depth ft- The maximum depth of flow over the weir. IWeir St Lft ft Station where flow starts on the left side of weir.
Weir St Rgt ft Station where flow ends on the right side of weir.
Weir Su I merg The ratio of the downstream depth above the weir to the I

I
upstream depth above the weir.

Wr Flw {\rea sq ft Area of the flow going over the weir.
Wr Top tydth ft Top width of water over the weir. IWS Air Entr. ft Water surface elevation accounting for air entrainment.
WSPRO EG ft Energy grade elevation upstream of bridge for the WSPRO

method. IWSPRO WS ft Water surface elevation upstream of bridge for the WSPRO
method.

I
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I
I Wtd. n Chnl

Wtd. n Left

I
Wtd. n Right
XS Delta EG ft

I
XS Delta WS' ft

Yarnell EG ft

I Yarnell WS ft

I
I
I
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I
I
I
I
I
I
I
I
I

Appendix C - HEC-RAS Output Variables

Conveyance weighted Manning's n for the main channel.
Conveyance weighted Manning's n for the left overbank.
Conveyance weighted Manning's n for the right overbank.
Change in energy gradeline between current section and
next one downstream.
Change in water surface between current section and next
one downstream.
Energy grade elevation upstream of bridge for Yarnell
method.
Water surface elevation upstream of bridge for Yarnell
method.
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New Features and Modifications

Since the last release of the HEC-RAS software (Version 2.1, October 1997) we have found and
fixed several bugs. Additionally, a few new features have been added to this version.

3. An option to view data contained in an HEC-DSS file was also added. This option allows
the user to graphically plot or tabulate data contained in DSS. This option is available from
the View menu on the main HEC-RAS window.

1. HEC-RAS now has the ability to model floating ice as well as dynamic ice jams. This
option is available from the geometric data editor and is documented in all three of the HEC­
RAS manuals.

10f6HEC-RAS Version 2.2 Release Notes

HEC-RAS
Version 2.2, September 1998

Release Notes

4. Internal Rating Curves. The user can now put a rating curve at any cross section. During
the computations, the program will take the water surface from the rating curve instead of
computing a value. Internal Rating curves are added from the Steady Flow Data editor.

Important Note: Version 2.2 ofHEC-RAS will only run on computers using Windows 95, 98 or
Windows NT 4.0. This version of HEC-RAS will not run under the Windows 3.1 or 3.11
operating systems. This is due to the fact that Microsoft no longer supports Windows 3.1 or
3.11. All of the Microsoft software development products that we use no longer allow us to
develop a version of HEC-RAS that will run under Windows 3.1 or 3.11. If you are using
Windows 3.1 or 3.11, you must either upgrade your operating system to Windows 95, 98 or NT
4.0, or you can continue to use HEC-RAS 2.0, noting the bugs in that version.

2. Reading data from and writing results to HEC-DSS (HEC Data Storage System). The user
can read flow and stage data from HEC-DSS and use it for computing water surface profiles.
Reading Data from HEC-DSS is accomplished from the Steady Flow Data editor. The user
must first establish connections between HEC-RAS cross section locations and the DSS file
pathnames. This is accomplished by using the "Set Locations for DSS Connections" option
from the File menu of the Steady Flow Data editor. Once these connections are established,
the user can import data by using the "DSS Import" option, also from the file menu of the
Steady Flow Data ·editor. Additionally, user's can write computed water surface profiles to
HEC-DSS. The export of results to DSS is accomplished under the File menu of the main
HEC-RAS window.
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1. Error plotting critical depth in profile plots with metric data sets.

13. Inte al bridge cross section editor has added options to insert a row and to delete a row.

User I terface Bugs Found in Version 2.1 and Fixed for Version 2.2

2. The simulation option of computing critical depth using the secant method to search for
mul iple critical depths option was not being saved in the data file.

I
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Pictme viewer now shows the picture filename in the window title and a copy to clipboard
butt I n was added.

The umber of profiles allowed has been increased from 15 to 100.

Boundary Condition Editor - When a boundary condition in the table is double clicked, the
apptPriate dialog editor is opened

Gra~hics - Zooming out has changed meaning. The "Zoom Out" option now doubles the
zoorp view in height and width. A new option called "Full Plot" was added. When this
option is selected, the entire plot is displayed. Also, a "Pan" option was added for moving
the ~raphic around when zoomed in.

GIS Export now allows users to export the cross section surface lines to the GIS file.
Add tionally, the user can specify to send just the main channel only or the entire cross
sectmn. This feature was added to allow users to supplement their terrain data with
survl y d cross section information.

HEC-RAS ersion 2.2 Release Notes

9.

5.

6.

8.

7.

10. The user can now rotate the three dimensional graphic while zoomed in on a piece of the
river system. The old version would automatically zoom out when attempting this.

11. In pi evious versions, the path to the RAS data directory could not have any spaces in it.
Thi restriction has been removed. Also, the path length had a set limit. This problem has
also been fixed.

12. Tw I new methods of specifying the distance for cross section interpolation were added. A
con tant distance interval from the upstream cross-section and a set specific location from
the pstream section.

14. An option was added to the schematic editor to reverse the stationing data of the cross
sectIOn geometry. This was added for those data sets that have the cross sections entered
fro I right to left looking downstream, instead of from left to right.



13. Bridge Scour with SI units.

14. The abutment scout using FroeWich's equation with SI units produced incorrect scour
results.

4. Report Generator - The reporting of the bridge computation options of Momentum Class B
defaults and Pressure Criteria were incorrect.

6. The filename and path to an HEC-RAS project could not contain any spaces in earlier
versions. This limitation has been removed.

30f6

3. Printing XS tables - The column widths were not set correctly, this made the text from one
column run over into the next cell.

5. Manually adding GIS reach lines would not move a junction. Now the junction and the first
point in all reaches move with the new reach location.

7. Error renaming river stations. In 2.1 there is an error renaming the river stations from the
cross section editor. The work around is to copy the station to the desired river station, then
delete the old location, or use the River Station table from the geometric editor.

HEC-RAS Version 2.2 Release Notes

10. Cross Section plot (and Rating curve) would show" 12312" in the mouse tracking box. This
would stay there until you moved the mouse over the plot. This box is now empty when you
open the plot window.

9. Channel Modification. The graphic on the Channel Modification window did not show that
the blocked obstructions will still be in place after the cuts. The graphic was modified so
that the blocked obstructions show they still reach down to the cut.

8. Rating curves were not correctly converted from Metric to English. This will affect running
Metric data as well, since all computations are in English units. The flow was converted as
if it was a length, not a volume per time.

15. If the pier size fraction D50 and D90 were not entered the program would crash when
computing scour depths.

16. GIS exporting water surface. If you use encroachments on your data set, then the bounding
polygon for the first profile (Base) was incorrectly computed. This will affect the ability to
generate the inundated area in the GIS package. The encroached profiles worked fine. This
is a problem for data sets with encroachments only.

12. Removing junctions from the geometry caused some problems if the lower reach of the
junction to be deleted had a junction on its downstream end.

11. The misspelled word in the tool tip for the cross section button on the geometric data editor
has been corrected.
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21. Pipe arch culverts. In SI units, the span was not computed when a rise was entered.

24. Use defined tables were not printed by the report generator.

23. Geo etric Schematic did not print at a specified scale when it was set by the user.
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e Weir Gate Editor. When the broad crested weIr option was selected, the weIr
lcient text field disappeared.

Con erting project units back and forth caused some of the plan files to have an incorrect
geometry file selected.

Replrt Generator - Rating curve boundary conditions were not being printed as part of the
flo I data.

When increasing the number of profiles, the boundary condition for the last profile, was
sup~osed to be used for subsequent profiles. There was an error in that it would use the first
profiles, not the last.

A feL bridge clipping problems were fixed.

HEC-RAS rsion 2.2 Release Notes

18. The title on Geometry Schematic window did not change when the user changed the
geometry file on the steady flow analysis window.

19. SI lata Sets. Bridges with internal cross sections specified were not converted correctly
befo e SNET computations.

30. Met ic problem - General profile plot (i.e. plotting velocity in profile) was not converting all
I

the data to metric correctly. This was fixed.

20.

17. GIS cross section cut lines. If the GIS cut lines were edited when bridges, culverts, or inline
weir were present in the geometry, a message would always display that told users that the
GIS cross section cut lines would not be displayed unless all XS's had GIS cut lines. This
mes. age was display even if all XS had GIS cut line data.

25. Gen rating River Stations from the geometric table option to rename river stations returns an
inco ect message when bridges and culverts are present.

22. Brid e Culvert Editor. If a bridge culvert picture was zoomed in and the user edited the data
on sub editor (such as the pier editor) the bridge picture would update and show the new
data but the scaling would be missing or incomplete on the plot.

28.

29.

26.

27.



6. A levee at a bridge node could occasionally cause the program to crash.

Bugs Found in Version 2.1 of Computation Program SNET

Solutions to some graphics problems

1. A user reported that he was having errors in zooming in on graphics. He found that when he
downloaded a new device driver for his ATI3DRage2Plus video card that it worked.

50f6HEC-RAS Version 2.2 Release Notes

4. If a culvert crossing had weir flow and the culvert inlet control answer was higher than the
outlet control answer, but both the culvert inlet and outlet are submerged (hence this causes
the inlet answer to be discarded), the final result was not being reported correctly (a work
around was to set the culvert to "outlet only"). This has been fixed.

2. The program cannot calculate a supercritical profile through two or more nonidentical
culverts. When this is attempted, the program is supposed to skip the culvert computations.
This check was not being performed correctly and the program was occasionally crashing.

1. If a hydraulic jump occurred in the cross section downstream of a bridge, then the reach
length was not being calculated correctly. This caused the profile plot to be displayed
incorrectly.

9. Several modifications have been made to the momentum solution that may cause differences
in the final water surface solution. The force from the weight of water and the force from
the road embankment have been changed and should be more hydraulically correct. The
static force exerted by the upstream pier was being calculated from the wrong water surface.
The downstream pier was using the wrong internal bridge section. Both of these have been
corrected.

3. The program was sometimes reporting the pressure/weir solution as the final answer even
when it didn't converge (it did, however, report a warning). When the pressure/weir solution
does not converge, the program now defaults to the energy method answer.

5. Encroachments at a cross section just upstream of a junction were not being' performed
correctly if the junction was being modeled with the momentum method.

7. An encroachment th.at stopped at a vertical wall that was going up (from outside to inside)
would cause the program to crash.

8. For the class B momentum solution, the program was not always correctly deciding which
interior bridge cross section to set to critical depth.

I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I
I



11. A si gle opening bridge that is completely outside of the channel stations could, on rare
occa ion, cause the program to crash.

12. Lo and high arch culverts had a bug that could sometimes result in an incorrect answer
bein reported and it could, at other times, cause SNET to crash.

15. The e was a problem in the WSPRO bridge methodology. Occasionally the program was
havi g trouble computing the discharge coefficient.

10. A b g was found that was keeping the pressure/weir flow solution from converging in
cert in cases. This has been corrected and the pressure/weir solution should now be more
stab
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13. The fYarnell bridge method is not considered valid if the water hits the low chord or overtops
the _pad. However, the program was not always disregarding the Yarnell method when this
haprlened.

14. The program was having a problem performing encroachments at multiple opening river
eros: ings. If the encroachment would block out the entire opening, the program would
blo -up. This has been fixed. Now if the encroachment blocks the entire opening, that
ope ing is automatically turned off.

HEC-RAS ersion 2.2 Release Notes

16. An i line weir that has gates but no weir flow would sometimes fail to converge. This has
been fixed.

17. occLiOnallY bridges with pier debris were getting incorrect calculations of area and wetted
peri I eter inside of the bridge at the upstream end.

18. Thelie was a problem with cross sections that had more than 5 blocked ineffective flow
areak. The problem was in the calculation of critical depth.

19. TheL was a problem with encroachments at inline weirs and gated spillways. The program
was Imaking the correct calculations, but was outputting the wrong surcharge just upstream
oftlle weir/spillway.

occLionailYa cUlve-~ that was under inlet control and had weir flow, was not balancing to a
fina solution within the specified tolerance.

20.




